How to debug evince's inability to set custom keyboard accelerators?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

How to debug evince's inability to set custom keyboard accelerators?

Sophoklis Goumas-2
Hello,

I've been trying to debug Evince's inability to set
custom keyboard shortcuts, more specifically I would like to set
View Options -> Continuous to be toggled by 'c'.

My DE is XFCE and I have appropriately made this possible
by Settings -> Settings Editor -> xsettings -> Gtk -> CanChangeAccels
(or Settings -> Appearance -> Settings -> Enable editable accelerators).

When after that I've tried to set the keyboard accelerator by hovering
the mouse over that option and pressing another key combination, say
'ctrl-[', as 'c' it's already set to toggle continuous when the
View Options menu is down and that I could change that by locating
the accels file later on and edit, it didn't went as expected.

So, the next step was to launch evince from CLI to see if any output at
all would have been generated there. Nothing.

Then I thought about locating that accels file by:
$ find ~ -iname "*evince*" -iname "*accel*"
which yielded nothing.

So then I've decided into looking a little bit on it and I found out
some promising instructions on how to generate debuggable output here:
https://wiki.gnome.org/Apps/Evince/Debugging

I then downloaded debian's source and tried to pass --enable-debug to
the build process by adding it under the DEB_CONFIGURE_EXTRA_FLAGS of
debian/rules file. The package would then not build leading reporting
some inconsistencies between libevdocument3-4 symbol files, for which
I've created a bug report here:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=780317

Following the tip passed on the bug report:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=780317#20
I've removed the -c4 from debian/rules' DEB_DH_MAKESHLIBS_ARGS part.

The package would eventually now build but even after that version was
installed no debuggable output was being produced when trying to launch
evince as follows:
$ EV_DEBUG=1 evince qux.djvu
nothing on the console.

So then I've decided to try to see why there were no evince accels file
and following what I've read in the source I have decided to do:
$ mkdir ~/.config/evince
after a usual evince launch I've noticed that it would now contain an
accels file which it's contents are shown here:
http://paste.debian.net/plain/161215

Since this is not the first time I'm having trouble with evince, I had
an accels file backed-up to a remote machine from which I've pulled it
and replaced the created accels, which would now contain:
http://paste.debian.net/plain/161191

But then after launching evince it would return to the same state again.

So, please, help me debug this situation.

Sophoklis


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/CAC2zJ1sEdtEbFdnyfb7=-6bQoNQ2jS-6ahVD2zO-nO9sMcEagA@...