Icedove crashes after recent update

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

Icedove crashes after recent update

Emile Antonios
Hello,

I've noticed that over the last few weeks Icedove is crashing. I've
never had a problem with that before. It typically happens when clicking
on or deleting an email. I don't get any error, it just closes.

I'm running Jessie KDE

same as:

http://forums.debian.net/viewtopic.php?f=10&t=128931

Thanks and regards

Emile

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Peter Hillier-Brook
On 04/08/16 08:18, Emile Antonios wrote:

> Hello,
>
> I've noticed that over the last few weeks Icedove is crashing. I've
> never had a problem with that before. It typically happens when clicking
> on or deleting an email. I don't get any error, it just closes.
>
> I'm running Jessie KDE
>
> same as:
>
> http://forums.debian.net/viewtopic.php?f=10&t=128931
>
> Thanks and regards
>
> Emile
>
>
Ditto here, same environment.

Peter HB

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Tony van der Hoff
On 04/08/16 09:53, Peter Hillier-Brook wrote:

> On 04/08/16 08:18, Emile Antonios wrote:
>> Hello,
>>
>> I've noticed that over the last few weeks Icedove is crashing. I've
>> never had a problem with that before. It typically happens when clicking
>> on or deleting an email. I don't get any error, it just closes.
>>
>> I'm running Jessie KDE
>>
>> same as:
>>
>> http://forums.debian.net/viewtopic.php?f=10&t=128931
>>
>> Thanks and regards
>>
>> Emile
>>
>>
> Ditto here, same environment.

Yep, I see that too; sometimes it just disappears without my touching it.

Same environment.


--
Tony van der Hoff        | mailto:[hidden email]
Buckinghamshire, England |

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Mike McGinn
In reply to this post by Emile Antonios


On 08/04/2016 03:18 AM, Emile Antonios wrote:

> Hello,
>
> I've noticed that over the last few weeks Icedove is crashing. I've
> never had a problem with that before. It typically happens when clicking
> on or deleting an email. I don't get any error, it just closes.
>
> I'm running Jessie KDE
>
> same as:
>
> http://forums.debian.net/viewtopic.php?f=10&t=128931
>
> Thanks and regards
>
> Emile
>
>
I had the same problem. So I installed Thunderbird, typed "ln -s
.icedove .thunderbird" in my home directory and stopped worrying about it.

Mike

--
Mike McGinn KD2CNU
President, UU Congregation at Rock Tavern * www.uucrt.org
Laziness is what separates us from the beavers.
More kidneys than eyes ** Registered Linux User 377849

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Daniel Bareiro
In reply to this post by Emile Antonios

On 04/08/16 04:18, Emile Antonios wrote:

> Hello,

Hello, Emile.

> I've noticed that over the last few weeks Icedove is crashing. I've
> never had a problem with that before. It typically happens when clicking
> on or deleting an email. I don't get any error, it just closes.
>
> I'm running Jessie KDE
>
> same as:
>
> http://forums.debian.net/viewtopic.php?f=10&t=128931

It seems that several of us are experiencing this issue. Here I am using
the same environment that you (KDE + Icedove in Debian Jessie, all
updated to the latest versions). Although on the references you mention
seems not to be something related to the desktop environment, because
there was also someone with XFCE who had the same problem.

I'm not sure if I began to see this after the last update or before, but
I can say that quite some time and became something a little annoying.

Doing some tests running Icedove from a console, it seems that a
segmentation fault occurs.

Doing some debug based on this document [1], I found several reasons for
this:

* A file not found:

---------------------------------------------------------------------
Program received signal SIGSEGV, Segmentation fault.
nsHTMLCSSStyleSheet::~nsHTMLCSSStyleSheet
(this=this@entry=0x7fffc75fd380, __in_chrg=<optimized out>)
    at
/build/icedove-tNL3mB/icedove-45.1.0/mozilla/layout/style/nsHTMLCSSStyleSheet.cpp:42
42
/build/icedove-tNL3mB/icedove-45.1.0/mozilla/layout/style/nsHTMLCSSStyleSheet.cpp:
No such file or directory.
---------------------------------------------------------------------

* Some kind of problem related to libxul:

---------------------------------------------------------------------
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4a2f550 in vtable for nsDisplayXULImage () from
/usr/lib/icedove/libxul.so
---------------------------------------------------------------------
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4a09fd0 in vtable for nsDisplayBackgroundImage () from
/usr/lib/icedove/libxul.so
---------------------------------------------------------------------

* I'm not sure what happened here:

---------------------------------------------------------------------
Program received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
---------------------------------------------------------------------


Unfortunately I had the head working on other things and left this issue
a little aside for the moment.

Have you installed some add-on? Here I'm using Enigmail, Iceowl, Inverse
SOGO Connector and Provider for Google Calendar (I do not remember to
have installed the the Google Calendar add-on so maybe it was some
automatic dependency).

Kind regards,
Daniel

[1] https://wiki.debian.org/Icedove#Debugging


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Jörg-Volker Peetz-3
In reply to this post by Emile Antonios
Does it work better with a fresh profile?

If yes, maybe cleaning up your profile helps. Here's a survey of the files in
the profile folder:
http://kb.mozillazine.org/Files_and_folders_in_the_profile_-_Thunderbird

Regards,
jvp.


Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Weaver-5
In reply to this post by Emile Antonios
On 2016-08-04 17:18, Emile Antonios wrote:
> Hello,
>
> I've noticed that over the last few weeks Icedove is crashing. I've
> never had a problem with that before. It typically happens when
> clicking on or deleting an email. I don't get any error, it just
> closes.
>
I'm getting exactly the same experience, with seemingly nothing
initiating continuous crashes after last nights update.
Never had a problem before.
Running a mix of Gnome, KDE apps with Enlightenment over the top on an
Unstable system.
Anybody else seeing this?
Cheers!

Weaver.
--
"It is the duty of the patriot to protect his country from its  
government."
  -- Thomas Paine

Registered Linux User: 554515

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

D. R. Evans
In reply to this post by Emile Antonios
Emile Antonios wrote on 08/04/2016 01:18 AM:

> I've noticed that over the last few weeks Icedove is crashing. I've
> never had a problem with that before. It typically happens when clicking
> on or deleting an email. I don't get any error, it just closes.
>
> I'm running Jessie KDE
>
> same as:
>
> http://forums.debian.net/viewtopic.php?f=10&t=128931
>
Add me to the set of people seeing this. Very vanilla KDE-based jessie system,
except that I do have ZFS support added (but I'm sure that's nothing to do
with the problem); otherwise, there are no unofficial packages on the machine.

  Doc

--
Web:  http://www.sff.net/people/N7DR


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Ralph Katz
In reply to this post by Emile Antonios
On 08/04/2016 03:18 AM, Emile Antonios wrote:

> Hello,
>
> I've noticed that over the last few weeks Icedove is crashing. I've
> never had a problem with that before. It typically happens when clicking
> on or deleting an email. I don't get any error, it just closes.
>
> I'm running Jessie KDE
>
> same as:
>
> http://forums.debian.net/viewtopic.php?f=10&t=128931
>
> Thanks and regards
>
> Emile
Add me as well.  Icedove dies silently maybe once a week.  Sometimes
dies clicking on next message or delete message, sometimes dies by
itself with no user action while using firefox or anything else.
Nothing in .xsession-errors nor syslog.

System is up-to-date jessie.  Icedove debian package add-ons: enigmail,
iceowl-extension, calendar-google-provider.

Regards,
Ralph




signature.asc (546 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Ralph Katz
In reply to this post by Emile Antonios
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

On 08/04/2016 03:18 AM, Emile Antonios wrote:

> Hello,
>
> I've noticed that over the last few weeks Icedove is crashing.
> I've never had a problem with that before. It typically happens
> when clicking on or deleting an email. I don't get any error, it
> just closes.
>
> I'm running Jessie KDE
>
> same as:
>
> http://forums.debian.net/viewtopic.php?f=10&t=128931
>
> Thanks and regards
>
> Emile

This may be bug 828069  icedove: random crashes after latest security
update

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=828069

Ralph

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
Comment: Using GnuPG with Icedove - http://www.enigmail.net/

iQEcBAEBCgAGBQJXp1dDAAoJECe2FpioHXO6W9wIAJbWWFlPJrWwbbBQB94d51Oo
4sRcJqRQrLGkveg86WA052WxJMXHVemi9nmgA73zhC8zj+c9iAis7EQ/6NkylYf7
QgdI++Gt1U4s/RtBDkrPER2QzZTEIdCR3hamTEvQI5ZdCNeFewrtb6xjen8kOOVr
ccarEmqntTsVe2oVUboayKXU+5eCLPRoxAov5ZlC7jm4Y/xQnbZ47XCKIEBn9qvv
KO7NC+0GRRt724736fqFyLu3yH0rdrxBZDr3kT/xjC9li3yj2kxxvJQCDhW2l8s6
iFSKYrFZbeNi5hY7qgpno7I23ELCuYzHm4C/76zfmf6cjw1Q+2yyG93gjAVR0us=
=YXvr
-----END PGP SIGNATURE-----

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Weaver-5
On 2016-08-08 01:44, Ralph Katz wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA512
>
> On 08/04/2016 03:18 AM, Emile Antonios wrote:
>> Hello,
>>
>> I've noticed that over the last few weeks Icedove is crashing.
>> I've never had a problem with that before. It typically happens
>> when clicking on or deleting an email. I don't get any error, it
>> just closes.
>>
>> I'm running Jessie KDE
>>
>> same as:
>>
>> http://forums.debian.net/viewtopic.php?f=10&t=128931
>>
>> Thanks and regards
>>
>> Emile
>
> This may be bug 828069  icedove: random crashes after latest security
> update
>
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=828069

Not applicable to my situation.
I've never had a problem of any sort before, over an install period on
this machine of over a year, until this last update.
Now it crashes often.
It's flat out staying up for half an hour.
Sometimes it'll crash before it opens, at other times it will appear to
coincide with a mouse event, but nothing consistent.
I'm trying to discover something reproducible to report, but aside from
the inevitable crashes, there's nothing.
Cheers!

Weaver

--
"It is the duty of the patriot to protect his country from its  
government."
  -- Thomas Paine

Registered Linux User: 554515

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Daniel Bareiro
In reply to this post by Weaver-5

On 07/08/16 09:33, Weaver wrote:

>> I've noticed that over the last few weeks Icedove is crashing. I've
>> never had a problem with that before. It typically happens when
>> clicking on or deleting an email. I don't get any error, it just
>> closes.
>>
> I'm getting exactly the same experience, with seemingly nothing
> initiating continuous crashes after last nights update.
> Never had a problem before.
> Running a mix of Gnome, KDE apps with Enlightenment over the top on an
> Unstable system.
Moritz Muehlenhoff few minutes ago announced a new Icedove update (DSA)
for Debian Jessie. Maybe it doesn't correct this, but worth trying.


Kind regards,
Daniel


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Re: Icedove crashes after recent update

Mario Pereyra
In reply to this post by Weaver-5
I'm also having the same problem for about the same mentioned time, but
I use Debian wheezy & gnome

No report of error, no log, ... no information, only the application
disappear.

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

tony baldwin-4


On 10/12/2016 08:55 AM, Mario Pereyra wrote:
> I'm also having the same problem for about the same mentioned time, but
> I use Debian wheezy & gnome
>
> No report of error, no log, ... no information, only the application
> disappear.
>

similar experience.
Seems to occur randomly here, like when I delete something or mark it
read/unread, or move something to another folder, and other  generally
trivial operations.

tony
--
http://tonybaldwin.me
all tony, all the time

Reply | Threaded
Open this post in threaded view
|

Re: Icedove crashes after recent update

Ben Caradoc-Davies-3
On 13/10/16 03:43, Tony Baldwin wrote:
> On 10/12/2016 08:55 AM, Mario Pereyra wrote:
>> I'm also having the same problem for about the same mentioned time, but
>> I use Debian wheezy & gnome
>> No report of error, no log, ... no information, only the application
>> disappear.
> similar experience.
> Seems to occur randomly here, like when I delete something or mark it
> read/unread, or move something to another folder, and other  generally
> trivial operations.

Setting layers.offmainthreadcomposition.enabled to false helped me:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=829188
https://bugzilla.mozilla.org/show_bug.cgi?id=619621
https://bugzilla.mozilla.org/show_bug.cgi?id=1198710

Kind regards,

--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand