Interdire une version précise d’un paquet.

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Interdire une version précise d’un paquet.

nicolas.patrois
Bonjour,

J’ai ce bogue de gravité critical sur libdns-export1110 (→ 1:9.11.17+dfsg-4) <En attente de traitement>
 b1 - #954736 - Upgrade to 9.16.1-1 causes dhcpd to die with SIGABRT
Quand je réponds non, il arrête tout. J’aimerais juste que les mises à jour se fassent mais que ce paquet (et les paquets qui dépendent de lui) ne le soit pas.
Je suis obligé de mettre à jour avec aptitude d’autres paquets mais c’est pénible.
Je sais qu’on peut punaiser un paquet mais ça bloque toute mise à jour, pas la mise à jour vers une version précise (ou j’ai raté un truc).
Quelqu’un sait comment bloquer juste une version d’un paquet dans une mise à jour ?

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

Reply | Threaded
Open this post in threaded view
|

Re: Interdire une version précise d’un paquet.

François LE GAD
Le 25/03/2020 à 11:03, [hidden email] a écrit :
> Je suis obligé de mettre à jour avec aptitude d’autres paquets mais c’est pénible.

Bonjour,

aptitude forbid-version [paquet]

Tu peux alors mettre le reste à jour avec aptitude. La mise à jour de
[paquet] est ignorée jusqu'à la publication d'une autre version.

--
François

Reply | Threaded
Open this post in threaded view
|

Re: Interdire une version précise d’un paquet.

Belaïd MOUNSI
In reply to this post by nicolas.patrois
Bonjour,

Tu peux fixer la priorité du paquet que tu veux fixer avec le système de preferences d'apt. Par exemple si tu veux garder absolument la version 2 de l'application "appli", tu peux mettre dans /etc/apt/preferences (faut peut être ajuster un peu selon l'application):

Package: appli
Pin: version 2
Pin-Priority: 1001

Le mer. 25 mars 2020 à 11:03, <[hidden email]> a écrit :
Bonjour,

J’ai ce bogue de gravité critical sur libdns-export1110 (→ 1:9.11.17+dfsg-4) <En attente de traitement>
 b1 - #954736 - Upgrade to 9.16.1-1 causes dhcpd to die with SIGABRT
Quand je réponds non, il arrête tout. J’aimerais juste que les mises à jour se fassent mais que ce paquet (et les paquets qui dépendent de lui) ne le soit pas.
Je suis obligé de mettre à jour avec aptitude d’autres paquets mais c’est pénible.
Je sais qu’on peut punaiser un paquet mais ça bloque toute mise à jour, pas la mise à jour vers une version précise (ou j’ai raté un truc).
Quelqu’un sait comment bloquer juste une version d’un paquet dans une mise à jour ?

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...



--
< Belaid >
Reply | Threaded
Open this post in threaded view
|

Re: Interdire une version précise d’un paquet.

Cyrille BIOT-2
In reply to this post by nicolas.patrois
Même soucis

aptitude hold libdns-export1110

ne fait rien, le paquet n'est pas gelé

aptitude search "~ahold"
ihA libglx-mesa0                    - free implementation of the  
OpenGL API -- G
ThA libreoffice-common              - suite de productivité  
bureautique -- fichi


Il n'apparait pas dans cette liste

Donc j'attends pour l'instant la résolution de ce bug...





[hidden email] a écrit :

> Bonjour,
>
> J’ai ce bogue de gravité critical sur libdns-export1110 (→  
> 1:9.11.17+dfsg-4) <En attente de traitement>
>  b1 - #954736 - Upgrade to 9.16.1-1 causes dhcpd to die with SIGABRT
> Quand je réponds non, il arrête tout. J’aimerais juste que les mises  
> à jour se fassent mais que ce paquet (et les paquets qui dépendent  
> de lui) ne le soit pas.
> Je suis obligé de mettre à jour avec aptitude d’autres paquets mais  
> c’est pénible.
> Je sais qu’on peut punaiser un paquet mais ça bloque toute mise à  
> jour, pas la mise à jour vers une version précise (ou j’ai raté un  
> truc).
> Quelqu’un sait comment bloquer juste une version d’un paquet dans  
> une mise à jour ?
>
> nicolas patrois : pts noir asocial
> --
> RÉALISME
>
> M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme  
> des humains ? Un cerveau plus gros ?
> P : Non... Une carte bleue suffirait...



Reply | Threaded
Open this post in threaded view
|

Re: Interdire une version précise d’un paquet.

Cyrille BIOT-2
Oups désolé j'avais pas vu la réponse

aptitude forbid-version

Désolé, je ne connaissais pas cette option

merci en tout cas

Reply | Threaded
Open this post in threaded view
|

Re : Interdire une version précise d’un paquet.

nicolas.patrois
In reply to this post by François LE GAD
Le 25/03/2020 11:09:41, François LE GAD a écrit :

> Bonjour,
> aptitude forbid-version [paquet]
> Tu peux alors mettre le reste à jour avec aptitude. La mise à jour de
> [paquet] est ignorée jusqu'à la publication d'une autre version.

Merci, je ne connaissais pas.
Manque de bol, le paquet n’est pas installé donc ça ne marche pas.
# aptitude forbid-version libdns-export1110
Le paquet libdns-export1110 n'est pas installé, l'interdiction de mise à jour n'est pas possible.

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

Reply | Threaded
Open this post in threaded view
|

Re: Interdire une version précise d’un paquet.

Cyrille BIOT-2
Oui et le hold n'est pas fonctionnel, donc retour cas départ ;)



[hidden email] a écrit :

> # aptitude forbid-version libdns-export1110
> Le paquet libdns-export1110 n'est pas installé, l'interdiction de  
> mise à jour n'est pas possible.



Reply | Threaded
Open this post in threaded view
|

Re: Re : Interdire une version précise d’un paquet.

Gaëtan PERRIER-3
In reply to this post by nicolas.patrois
Je vais sûrement dire une bêtise, mais pourquoi vouloir bloquer une version d'un paquet qui n'est pas installé ?

Le 25 mars 2020 12:33:03 GMT+01:00, [hidden email] a écrit :
Le 25/03/2020 11:09:41, François LE GAD a écrit :

Bonjour,
aptitude forbid-version [paquet]
Tu peux alors mettre le reste à jour avec aptitude. La mise à jour de
[paquet] est ignorée jusqu'à la publication d'une autre version.

Merci, je ne connaissais pas.
Manque de bol, le paquet n’est pas installé donc ça ne marche pas.
# aptitude forbid-version libdns-export1110
Le paquet libdns-export1110 n'est pas installé, l'interdiction de mise à jour n'est pas possible.

nicolas patrois : pts noir asocial

--
Envoyé de mon appareil Android avec Courriel K-9 Mail. Veuillez excuser ma brièveté.
Reply | Threaded
Open this post in threaded view
|

Re : Re : Interdire une version précise d’un paquet.

nicolas.patrois
Le 25/03/2020 12:52:37, Gaëtan Perrier a écrit :

> Je vais sûrement dire une bêtise, mais pourquoi vouloir bloquer une
> version d'un paquet qui n'est pas installé ?

Il est imposé par la mise à jour d’un autre paquet.

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

Reply | Threaded
Open this post in threaded view
|

Re: Re : Re : Interdire une version précise d’un paquet.

Gaëtan PERRIER-3
Dans ce cas tu bloques la mise à jour de l'autre paquet.

Gaëtan

Le 25 mars 2020 13:13:31 GMT+01:00, [hidden email] a écrit :
Le 25/03/2020 12:52:37, Gaëtan Perrier a écrit :

Je vais sûrement dire une bêtise, mais pourquoi vouloir bloquer une
version d'un paquet qui n'est pas installé ?

Il est imposé par la mise à jour d’un autre paquet.

nicolas patrois : pts noir asocial

--
Envoyé de mon appareil Android avec Courriel K-9 Mail. Veuillez excuser ma brièveté.
Reply | Threaded
Open this post in threaded view
|

Re: Interdire une version précise d’un paquet.

Cyrille BIOT-2

Gaëtan Perrier <[hidden email]> a écrit :

> Dans ce cas tu bloques la mise à jour de l'autre paquet.
>

Effectivement, il faut geler ces paquets et ça passe
# aptitude search "~ahold"
ih  isc-dhcp-client                 - client DHCP pour l'obtention  
automatique d
ih  isc-dhcp-common                 - toutes les pages de manuel  
concernant tous


par contre gros soucis dans la mise  à jour de la libc6 mais c'est un  
autre problème ;)