Jeg skulle aldrig have opdateret til Stretch ...

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Jeg skulle aldrig have opdateret til Stretch ...

Flemming Bjerke-3
Jeg har et stykke tid kørt Jessie på en af mine desktoppe, og det har
fungeret rigtig fortræffeligt. Men suk, så var jeg så letsindig at
opdatere til Stretch .... Først var kdm forsvundet og xdm virkede ikke.
Jeg fandt ud af at lightdm så måtte bruges. Men viste det sig at hverken
kde eller xfce4 fungerede. Gnome classic fungerer dog nogenlunde, selvom
Gnome lige synes at det skal gå i stå fra tid til anden. Og så virker
lyden heller ikke. Det er bare træls ... for det er ret vanskeligt at
installere noget andet idet jeg ikke kan bruge skærmen på den bærbare
som debian kører på. Dvs. det er ikke nemt at boote med en ubuntu usb.
Måske jeg skal prøve mate og cinnamon?

Øv.

Flemming

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Flemming Bjerke-3
Nåeh, men xfce4 virker alligevel. Problemet var bare at xfce synes at
det skulle dele billedet med den defekte skærm, og så var det som om en
masse programmer ikke virkede ... men det var bare fordi jeg ikke kunne
se dem. Det lykkedes at pille lidt i settingfilen og slukke for den
defekte skærm ... og vupti. Og lyden, jeg skulle bare starte pulseaudio
(pulseaudio -D). Så nu har jeg da en så vidt jeg kan se en fuldt
fungibel debian9 selvom kde trods apt-get purge kde* og reinstallation
er absolut uvillig til at virke. Og gnome var som sagt heller ikke for
godt.

Glæder mig til at bruge debian9.

flem


On 06-08-2017 21:39, Flem wrote:

> Jeg har et stykke tid kørt Jessie på en af mine desktoppe, og det har
> fungeret rigtig fortræffeligt. Men suk, så var jeg så letsindig at
> opdatere til Stretch .... Først var kdm forsvundet og xdm virkede ikke.
> Jeg fandt ud af at lightdm så måtte bruges. Men viste det sig at hverken
> kde eller xfce4 fungerede. Gnome classic fungerer dog nogenlunde, selvom
> Gnome lige synes at det skal gå i stå fra tid til anden. Og så virker
> lyden heller ikke. Det er bare træls ... for det er ret vanskeligt at
> installere noget andet idet jeg ikke kan bruge skærmen på den bærbare
> som debian kører på. Dvs. det er ikke nemt at boote med en ubuntu usb.
> Måske jeg skal prøve mate og cinnamon?
>
> Øv.
>
> Flemming
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Geert Heldager Nielsen
KDE/Plasma bruger sddm som displaymanager i stretch.


--
                Geert Heldager Nielsen
                Søborg Hovedgade 139 A 1. tv.
                2860 Søborg

                Tlf. 39660766
               



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Flemming Bjerke-3
Ja, ssdm har jeg også prøvet, men den virker slet ikke, Lightdm kan godt
starte kde ... og der sker da også et eller andet, dvs, den starter med
sort skærm og et hvidt k-logo. Men den dør efter et stykke tid. Det
samme sker ved når jeg kører startkde. Se nedenfor. Det er åbenbart her
det går galt

kf5.kcoreaddons.kaboutdata: Could not initialize the equivalent
properties of Q*Application: no instance (yet) existing.

Så vidt jeg kan se, er jeg ikke den eneste der har problemer med kde på
debian9.

Flem

startkde: Starting up...
kdeinit5: Shutting down running client.
kdeinit5: preparing to launch
'/usr/lib/i386-linux-gnu/libexec/kf5/klauncher'
kdeinit5: Launched KLauncher, pid = 10551, result = 0
Connecting to deprecated signal
QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kdeinit5: opened connection to :0
kdeinit5: preparing to launch 'libkdeinit5_kded5'
kdeinit5: Launched KDED, pid = 10556 result = 0
kdeinit5: preparing to launch 'libkdeinit5_kcminit_startup'
kdeinit5: Launched 'kcminit_startup', pid = 10557 result = 0
kdeinit5: Got SETENV 'KDE_MULTIHEAD=false' from launcher.
Initializing  "kded_touchpad" :  "kcminit_touchpad"
Width:  1127  height:  612
Approx. resX:  12  resY:  12
Touchpad resolution: x:  12  y:  12
Final resolution x: 12  y: 12
kdeinit5: PID 10556
terminated.                                                                                                    

Initializing  "kcm_access" :
"kcminit_access"                                                                                    

kdeinit5: Got EXEC_NEW '/usr/bin/kaccess' from
launcher.                                                                          

kdeinit5: preparing to launch
'/usr/bin/kaccess'                                                                                  

Initializing  "kcm_style" :  "kcminit_style"
kf5.kcoreaddons.kaboutdata: Could not initialize the equivalent
properties of Q*Application: no instance (yet) existing.
kdeinit5: PID 10564 terminated.
kdeinit5: Got SETENV
'GTK_RC_FILES=/etc/gtk/gtkrc:/home/jytte/.gtkrc:/home/jytte/.config/gtkrc'
from launcher.
kdeinit5: Got SETENV
'GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/jytte/.gtkrc-2.0:/home/jytte/.config/gtkrc-2.0'
from launcher.
Initializing  "kcm_input" :  "kcminit_mouse"
Initializing  "kcm_kgamma" :  "kcminit_kgamma"
kdeinit5: PID 10557 terminated.
kdeinit5: Got KWRAPPER '/usr/bin/ksmserver' from wrapper.
kdeinit5: preparing to launch '/usr/bin/ksmserver'
Qt: Session management error: networkIdsList argument is NULL
Configuring Lock Action
ksmserver: "/run/user/1000/KSMserver"
ksmserver: KSMServer: SetAProc_loc: conn  0 , prot= local , file=
@/tmp/.ICE-unix/10580
ksmserver: KSMServer: SetAProc_loc: conn  1 , prot= unix , file=
/tmp/.ICE-unix/10580
kdeinit5: Got SETENV
'SESSION_MANAGER=local/gule:@/tmp/.ICE-unix/10580,unix/gule:/tmp/.ICE-unix/10580'
from launcher.
ksmserver: KSMServer::restoreSession  "saved at previous logout"
ksmserver: Starting autostart service
"/etc/xdg/autostart/baloo_file.desktop"
ksmserver: Starting autostart service  "/etc/xdg/autostart/krunner.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/plasmashell.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/xembedsniproxy.desktop"
ksmserver: Autostart 0 done
Session path: "/org/freedesktop/login1/session/_32"
ksmserver: Kcminit phase 1 done
ksmserver: Starting autostart service
"/etc/xdg/autostart/pulseaudio.desktop"
ksmserver: Autostart 1 done
kwin: kunne ikke overtage håndteringsvalget, kører en anden
vindueshåndtering? (prøv at bruge --replace)
ksmserver: Starting notification thread
ksmserver: Kcminit phase 2 done
ksmserver: autostart service "/usr/bin/baloo_file" finished with exit
code  0
ksmserver: Starting autostart service
"/home/jytte/.config/autostart/fluxgui.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/at-spi-dbus-bus.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/hplip-systray.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/light-locker.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/org.kde.korgac.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/powerdevil.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/tracker-extract.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/tracker-miner-apps.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/tracker-miner-fs.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/tracker-miner-user-guides.desktop"
ksmserver: Starting autostart service
"/etc/xdg/autostart/tracker-store.desktop"
ksmserver: Autostart 2 done
ksmserver: autostart service "/usr/lib/at-spi2-core/at-spi-bus-launcher"
finished with exit code  0
ksmserver: autostart service "/usr/bin/start-pulseaudio-x11" finished
with exit code  0
ksmserver: autostart service "/usr/bin/xembedsniproxy" finished with
exit code  255
ksmserver: autostart service "/usr/bin/gdbus" finished with exit code  0
ksmserver: autostart service "/usr/bin/light-locker" finished with exit
code  1
ksmserver: autostart service "/usr/bin/hp-systray" finished with exit
code  1
ksmserver: autostart service "/usr/lib/tracker/tracker-miner-apps"
finished with exit code  1
ksmserver: autostart service
"/usr/lib/tracker/tracker-miner-user-guides" finished with exit code  1
ksmserver: autostart service "/usr/lib/tracker/tracker-miner-fs"
finished with exit code  1
ksmserver: autostart service "/usr/lib/tracker/tracker-extract" finished
with exit code  1




On 07-08-2017 07:11, Geert Heldager Nielsen wrote:
> KDE/Plasma bruger sddm som displaymanager i stretch.
>
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Flemming Bjerke-3
Der er for meget der ikke fungerer på desktoppen på stretch efter
dist-upgrade. Ud over allerede nævnte problemer:

Man kan godt få den til at mounte et usb-stik, men brugeren kan ikke
skrive til den længere. Jo, det kan man godt fixe ... men hvordan er det
nu lige man gør det?

Og så vil man gerne have vist et link i en mail (Thunderbird). Man
trykker på linket med musen ... og en pop-up meddeler at firefox
allerede kører. Og hvordan fixer man lige det ...?

Som server fungerer debian super, men det her giver alt for meget bøvl.
Sidst jeg opdaterede et par maskiner til ubuntu 16.04 LTS, behøvede jeg
bare hovedet under armen. Alt fungerede uden problemer.

I min verden tegner det ikke godt for debians desktop. Måske skulle man
tage konsekvensen og gøre debian til et serverstyresystem og overlade
ansvaret for desktoppen til f.eks. ubuntu? For på desktoppen slår
debians test-system åbenbart ikke til.

flem

On 07-08-2017 21:53, Flem wrote:

> Ja, ssdm har jeg også prøvet, men den virker slet ikke, Lightdm kan godt
> starte kde ... og der sker da også et eller andet, dvs, den starter med
> sort skærm og et hvidt k-logo. Men den dør efter et stykke tid. Det
> samme sker ved når jeg kører startkde. Se nedenfor. Det er åbenbart her
> det går galt
>
> kf5.kcoreaddons.kaboutdata: Could not initialize the equivalent
> properties of Q*Application: no instance (yet) existing.
>
> Så vidt jeg kan se, er jeg ikke den eneste der har problemer med kde på
> debian9.
>
> Flem
>
> startkde: Starting up...
> kdeinit5: Shutting down running client.
> kdeinit5: preparing to launch
> '/usr/lib/i386-linux-gnu/libexec/kf5/klauncher'
> kdeinit5: Launched KLauncher, pid = 10551, result = 0
> Connecting to deprecated signal
> QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
> kdeinit5: opened connection to :0
> kdeinit5: preparing to launch 'libkdeinit5_kded5'
> kdeinit5: Launched KDED, pid = 10556 result = 0
> kdeinit5: preparing to launch 'libkdeinit5_kcminit_startup'
> kdeinit5: Launched 'kcminit_startup', pid = 10557 result = 0
> kdeinit5: Got SETENV 'KDE_MULTIHEAD=false' from launcher.
> Initializing  "kded_touchpad" :  "kcminit_touchpad"
> Width:  1127  height:  612
> Approx. resX:  12  resY:  12
> Touchpad resolution: x:  12  y:  12
> Final resolution x: 12  y: 12
> kdeinit5: PID 10556
> terminated.                                                                                                    
>
> Initializing  "kcm_access" :
> "kcminit_access"                                                                                    
>
> kdeinit5: Got EXEC_NEW '/usr/bin/kaccess' from
> launcher.                                                                          
>
> kdeinit5: preparing to launch
> '/usr/bin/kaccess'                                                                                  
>
> Initializing  "kcm_style" :  "kcminit_style"
> kf5.kcoreaddons.kaboutdata: Could not initialize the equivalent
> properties of Q*Application: no instance (yet) existing.
> kdeinit5: PID 10564 terminated.
> kdeinit5: Got SETENV
> 'GTK_RC_FILES=/etc/gtk/gtkrc:/home/jytte/.gtkrc:/home/jytte/.config/gtkrc'
> from launcher.
> kdeinit5: Got SETENV
> 'GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/jytte/.gtkrc-2.0:/home/jytte/.config/gtkrc-2.0'
> from launcher.
> Initializing  "kcm_input" :  "kcminit_mouse"
> Initializing  "kcm_kgamma" :  "kcminit_kgamma"
> kdeinit5: PID 10557 terminated.
> kdeinit5: Got KWRAPPER '/usr/bin/ksmserver' from wrapper.
> kdeinit5: preparing to launch '/usr/bin/ksmserver'
> Qt: Session management error: networkIdsList argument is NULL
> Configuring Lock Action
> ksmserver: "/run/user/1000/KSMserver"
> ksmserver: KSMServer: SetAProc_loc: conn  0 , prot= local , file=
> @/tmp/.ICE-unix/10580
> ksmserver: KSMServer: SetAProc_loc: conn  1 , prot= unix , file=
> /tmp/.ICE-unix/10580
> kdeinit5: Got SETENV
> 'SESSION_MANAGER=local/gule:@/tmp/.ICE-unix/10580,unix/gule:/tmp/.ICE-unix/10580'
> from launcher.
> ksmserver: KSMServer::restoreSession  "saved at previous logout"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/baloo_file.desktop"
> ksmserver: Starting autostart service  "/etc/xdg/autostart/krunner.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/plasmashell.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/xembedsniproxy.desktop"
> ksmserver: Autostart 0 done
> Session path: "/org/freedesktop/login1/session/_32"
> ksmserver: Kcminit phase 1 done
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/pulseaudio.desktop"
> ksmserver: Autostart 1 done
> kwin: kunne ikke overtage håndteringsvalget, kører en anden
> vindueshåndtering? (prøv at bruge --replace)
> ksmserver: Starting notification thread
> ksmserver: Kcminit phase 2 done
> ksmserver: autostart service "/usr/bin/baloo_file" finished with exit
> code  0
> ksmserver: Starting autostart service
> "/home/jytte/.config/autostart/fluxgui.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/at-spi-dbus-bus.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/hplip-systray.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/light-locker.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/org.kde.korgac.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/powerdevil.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/tracker-extract.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/tracker-miner-apps.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/tracker-miner-fs.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/tracker-miner-user-guides.desktop"
> ksmserver: Starting autostart service
> "/etc/xdg/autostart/tracker-store.desktop"
> ksmserver: Autostart 2 done
> ksmserver: autostart service "/usr/lib/at-spi2-core/at-spi-bus-launcher"
> finished with exit code  0
> ksmserver: autostart service "/usr/bin/start-pulseaudio-x11" finished
> with exit code  0
> ksmserver: autostart service "/usr/bin/xembedsniproxy" finished with
> exit code  255
> ksmserver: autostart service "/usr/bin/gdbus" finished with exit code  0
> ksmserver: autostart service "/usr/bin/light-locker" finished with exit
> code  1
> ksmserver: autostart service "/usr/bin/hp-systray" finished with exit
> code  1
> ksmserver: autostart service "/usr/lib/tracker/tracker-miner-apps"
> finished with exit code  1
> ksmserver: autostart service
> "/usr/lib/tracker/tracker-miner-user-guides" finished with exit code  1
> ksmserver: autostart service "/usr/lib/tracker/tracker-miner-fs"
> finished with exit code  1
> ksmserver: autostart service "/usr/lib/tracker/tracker-extract" finished
> with exit code  1
>
>
>
>
> On 07-08-2017 07:11, Geert Heldager Nielsen wrote:
>> KDE/Plasma bruger sddm som displaymanager i stretch.
>>
>>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Adam Sjøgren
Flem writes:

> I min verden tegner det ikke godt for debians desktop. Måske skulle man
> tage konsekvensen og gøre debian til et serverstyresystem og overlade
> ansvaret for desktoppen til f.eks. ubuntu? For på desktoppen slår
> debians test-system åbenbart ikke til.

Min oplevelse er den diamentralt modsatte - hver gang jeg har opgraderet
Ubuntu på arbejdet har der altid været noget nyt i vejen, Debian
derhjemme er der sjældent noget der går i stykker på.

Så jeg ville synes det måske var lige tidligt nok at trække tæppet væk
under Ubuntu ved at fjerne alle desktop-pakker fra Debian :-)


  Mvh.

   Adam

--
 "HENCE, I think that all UNIXs should have an EMACS,         Adam Sjøgren
  and everybody should run UNIX!"                        [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Geert Heldager Nielsen

Når man opgraderer fra en udgivelse til den næste,
er der altid risiko for, at gamle konfigurations-filer
i hjemmemappen kan give problemer. En anden ting man kan
gøre, er at læse installerings-vejledningen, hvor der er
tips til hvad der kan gå galt, og hvordan det løses.

--
                Geert Heldager Nielsen



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Flemming Bjerke-3
Hvad angår konfigurationsfiler i hjemmemappe, har jeg forsøgt at oprette
ny bruger for at se om kde så ville køre ... hjalp ikke. Jeg har chekket
opgraderingsvejledningen.

Det er da glædeligt at nogle har bedre oplevelser. Jeg var nu også
virkelig godt tilfreds med Jessie. Det kan da også godt være at jeg
skulle have ventet ½ års tid til de værste bugs var luget ud af stretch.
Men nu overvejer jeg faktisk en netinstall af kubuntu 16.04. på en anden
partition (så kan jeg jo altid vende tilbage for se om stretch
fungerer). For jeg orker ikke at fluekneppe stretch for få at alle
mulige vigtige småting til at fungere.

Jeg har da også oplevet problemer med ubuntu, men ikke med opdatering af
LTS-udgaverne. Jeg har heller ikke tid til at opdatere hvert halve år
... så LTS passer mig fint, og det gør debians opdatering af stable også
...

Flem


On 08-08-2017 17:36, Geert Heldager Nielsen wrote:
> Når man opgraderer fra en udgivelse til den næste,
> er der altid risiko for, at gamle konfigurations-filer
> i hjemmemappen kan give problemer. En anden ting man kan
> gøre, er at læse installerings-vejledningen, hvor der er
> tips til hvad der kan gå galt, og hvordan det løses.
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jeg skulle aldrig have opdateret til Stretch ...

Flemming Bjerke-3
Nåh, ja-ja. Usbstick-problemet løstes ved at installere pmount, og
problemet med ikke at kunne åbne links fra thunderbird i firefox løstes
ved afstallere thunderbird og installere det igen.

Så det eneste seriøse problem der er tilbage, er kde. Jeg kan ikke
engang få dolphin til at køre fra xfce4. Hvad angår Gnome, ved jeg ikke
rigtig hvor slemme problemerne er. Men nu kører xfce4 så vidt jeg kan se
OK. ... Bortset fra jeg ikke kunne vække dyret fra dvale eller hvile.
Men nu har jeg slået begge dele fra.

Nåeh, men jeg må vel lave en bug report om kde.

flem


On 08-08-2017 18:28, Flem wrote:

> Hvad angår konfigurationsfiler i hjemmemappe, har jeg forsøgt at oprette
> ny bruger for at se om kde så ville køre ... hjalp ikke. Jeg har chekket
> opgraderingsvejledningen.
>
> Det er da glædeligt at nogle har bedre oplevelser. Jeg var nu også
> virkelig godt tilfreds med Jessie. Det kan da også godt være at jeg
> skulle have ventet ½ års tid til de værste bugs var luget ud af stretch.
> Men nu overvejer jeg faktisk en netinstall af kubuntu 16.04. på en anden
> partition (så kan jeg jo altid vende tilbage for se om stretch
> fungerer). For jeg orker ikke at fluekneppe stretch for få at alle
> mulige vigtige småting til at fungere.
>
> Jeg har da også oplevet problemer med ubuntu, men ikke med opdatering af
> LTS-udgaverne. Jeg har heller ikke tid til at opdatere hvert halve år
> ... så LTS passer mig fint, og det gør debians opdatering af stable også
> ...
>
> Flem
>
>
> On 08-08-2017 17:36, Geert Heldager Nielsen wrote:
>> Når man opgraderer fra en udgivelse til den næste,
>> er der altid risiko for, at gamle konfigurations-filer
>> i hjemmemappen kan give problemer. En anden ting man kan
>> gøre, er at læse installerings-vejledningen, hvor der er
>> tips til hvad der kan gå galt, og hvordan det løses.
>>

Loading...