KDEPIM 18.08.3 for Buster

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

KDEPIM 18.08.3 for Buster

Sandro Knauß-5
Hey,

as Debian is already in freeze, the version of KDEPIM that will shipped with
the next stable is 18.08.3. That was uploaded same days ago. There is no time
to package 18.12.X sorry for that.
So please test this version in more depth and report issues. If you also
manage to point to existing bugfixes like done in #921535 it is very likely we
can ship a that bugfix also for Buster.

hefee

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Martin Steigerwald
Hello Sandro.

Sandro Knauß - 07.02.19, 00:33:
> as Debian is already in freeze, the version of KDEPIM that will
> shipped with the next stable is 18.08.3. That was uploaded same days
> ago. There is no time to package 18.12.X sorry for that.
> So please test this version in more depth and report issues. If you
> also manage to point to existing bugfixes like done in #921535 it is
> very likely we can ship a that bugfix also for Buster.

While I had hoped for KDEPIM 18.12, I certainly accept and understand
your decision.

I probably will test whether I can get Akonadi EWS with Office 365 – not
my choice, mind you – to work for me with that version. So far I was not
able to, but by triaging upstream reports I did not yet find one that
applies to my situation. So maybe it is still a configuration issue on my
side. Evolution with EWS just works fine, including calendar.

Aside from that since KDEPIM/Akonadi 18.08 I see stalls when downloading
POP3 messages from my private Dovecot server. Often Akonadi/KMail just
sits there, according to atop apparently doing nothing, for up to a
minute, before continuing as if nothing has happened. That behavior has
been so erratic, that I did not yet invest more time to actually find out
what is going on here. Sometimes it works normally and sometimes I see
those stalls. I was disappointed cause I expected the work of Daniel¹ to
improve performance of KDEPIM/Akonadi quite a bit and did not have those
delays with earlier KDEPIM/Akonadi. According to akonadictl fsck there
are quite some issues with my setup… and I wonder whether to recreate it
once again as akonadictl fsck does not seem to fix any of those. However…
that would be something for upstream mailing list kdepim-users (where I
raised this issue quite some time ago).

I know both upstream development and packaging it can use more hands. So
I mean no offense to anybody with that.

[1] https://www.dvratil.cz/2018/04/my-kde-pim-update/

Thanks,
--
Martin


Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Libor Klepáč
Hi,
i'm using EWS without problems for some time (well - sometimes, i have to
restart akonadi or it won't sync emails ...).
I have attached my setup as screenshot. (I have autodiscovery disabled and use
"user agent"="Outlook 2016" on other tab).

You have to install package kmailtransport-akonadi to be able to send emails
thru EWS.
This package is not recommended by any other package so it is not installed by
default.

Libor


On čtvrtek 7. února 2019 11:10:21 CET you wrote:

> Hello Sandro.
>
> Sandro Knauß - 07.02.19, 00:33:
> > as Debian is already in freeze, the version of KDEPIM that will
> > shipped with the next stable is 18.08.3. That was uploaded same days
> > ago. There is no time to package 18.12.X sorry for that.
> > So please test this version in more depth and report issues. If you
> > also manage to point to existing bugfixes like done in #921535 it is
> > very likely we can ship a that bugfix also for Buster.
>
> While I had hoped for KDEPIM 18.12, I certainly accept and understand
> your decision.
>
> I probably will test whether I can get Akonadi EWS with Office 365 – not
> my choice, mind you – to work for me with that version. So far I was not
> able to, but by triaging upstream reports I did not yet find one that
> applies to my situation. So maybe it is still a configuration issue on my
> side. Evolution with EWS just works fine, including calendar.
>
> Aside from that since KDEPIM/Akonadi 18.08 I see stalls when downloading
> POP3 messages from my private Dovecot server. Often Akonadi/KMail just
> sits there, according to atop apparently doing nothing, for up to a
> minute, before continuing as if nothing has happened. That behavior has
> been so erratic, that I did not yet invest more time to actually find out
> what is going on here. Sometimes it works normally and sometimes I see
> those stalls. I was disappointed cause I expected the work of Daniel¹ to
> improve performance of KDEPIM/Akonadi quite a bit and did not have those
> delays with earlier KDEPIM/Akonadi. According to akonadictl fsck there
> are quite some issues with my setup… and I wonder whether to recreate it
> once again as akonadictl fsck does not seem to fix any of those. However…
> that would be something for upstream mailing list kdepim-users (where I
> raised this issue quite some time ago).
>
> I know both upstream development and packaging it can use more hands. So
> I mean no offense to anybody with that.
>
> [1] https://www.dvratil.cz/2018/04/my-kde-pim-update/
>
> Thanks,

--------
[1] mailto:[hidden email]
[2] tel:+420377457676
[3] http://www.bcom.cz

Screenshot_20190207_125705.png (67K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Libor Klepáč
In reply to this post by Sandro Knauß-5
Hi,
thanks for update.

Works ok, no problems. It took while to startup kontact on first run.

I still have problem with 100% CPU usage in kontact (and/or kmail).
It's using CPU even if i shutdown akonadi server.
I don't know how to debug.
According to strace, it's pooling file descriptor 5 in loop, which is [eventfd].

[pid  2317] poll([{fd=5, events=POLLIN}, {fd=8, events=POLLIN}, {fd=56, events=POLLIN}, {fd=170, events=POLLIN}, {fd=174, events=POLLIN}, {fd=175, events=POLLIN}, {fd=176, events=POLLIN}, {fd=177, events=POLLPRI}, {fd=178, events=POLLIN}], 9, 0) = 1 ([{fd=5, revents=POLLIN}])
[pid  2317] read(5, "\1\0\0\0\0\0\0\0", 16) = 8
[pid  2317] write(5, "\1\0\0\0\0\0\0\0", 8) = 8
[pid  2317] poll([{fd=5, events=POLLIN}, {fd=8, events=POLLIN}, {fd=56, events=POLLIN}, {fd=170, events=POLLIN}, {fd=174, events=POLLIN}, {fd=175, events=POLLIN}, {fd=176, events=POLLIN}, {fd=177, events=POLLPRI}, {fd=178, events=POLLIN}], 9, 0) = 1 ([{fd=5, revents=POLLIN}])
[pid  2317] read(5, "\1\0\0\0\0\0\0\0", 16) = 8
[pid  2317] write(5, "\1\0\0\0\0\0\0\0", 8) = 8


Libor



On čtvrtek 7. února 2019 0:33:38 CET Sandro Knauß wrote:

> Hey,
>
> as Debian is already in freeze, the version of KDEPIM that will shipped with
> the next stable is 18.08.3. That was uploaded same days ago. There is no
> time to package 18.12.X sorry for that.
> So please test this version in more depth and report issues. If you also
> manage to point to existing bugfixes like done in #921535 it is very likely
> we can ship a that bugfix also for Buster.
>
> hefee




Reply | Threaded
Open this post in threaded view
|

KDEPIM with Office 365 (was: Re: KDEPIM 18.08.3 for Buster)

Martin Steigerwald
In reply to this post by Libor Klepáč
Hi Libor.

Libor Klepáč - 07.02.19, 13:03:
> i'm using EWS without problems for some time (well - sometimes, i have
> to restart akonadi or it won't sync emails ...).

There is some bug report about that in upstream bug tracker. Unresolved
so far.

> I have attached my setup as screenshot. (I have autodiscovery disabled
> and use "user agent"="Outlook 2016" on other tab).

Thank you very much. AFAIR on my various attempts I had it like this at
least once. Well except for the user-agent setting. I will have a go
with that next week and report back.

> You have to install package kmailtransport-akonadi to be able to send
> emails thru EWS.

It is installed here.

> This package is not recommended by any other package so it is not
> installed by default.

Thanks for letting me know.

Ciao,
--
Martin


Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Martin Steigerwald
In reply to this post by Sandro Knauß-5
Sandro Knauß - 07.02.19, 00:33:
> Hey,
>
> as Debian is already in freeze, the version of KDEPIM that will
> shipped with the next stable is 18.08.3. That was uploaded same days
> ago. There is no time to package 18.12.X sorry for that.
> So please test this version in more depth and report issues. If you
> also manage to point to existing bugfixes like done in #921535 it is
> very likely we can ship a that bugfix also for Buster.

The other issue I have since 18.08 packages is:

Debian #921624: kmail: Crash during/after filtering inbox, probably
related to Qt WebEngine integration
https://bugs.debian.org/921624

Crash during/after filtering inbox, probably related to Qt WebEngine
integration
https://bugs.kde.org/404052

I can add more backtraces to the upstream bug report. For some reason
DrKonqi shortened the second backtrace I had it generate after fully
upgrading to 18.08.3-1.

At least this one produces a crash, instead of just stalling… for
whatever reason.

Thanks,
--
Martin


Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Sandro Knauß-5
Hey,

> Debian #921624: kmail: Crash during/after filtering inbox, probably
> related to Qt WebEngine integration
> https://bugs.debian.org/921624
>
> Crash during/after filtering inbox, probably related to Qt WebEngine
> integration
> https://bugs.kde.org/404052
>
> I can add more backtraces to the upstream bug report. For some reason
> DrKonqi shortened the second backtrace I had it generate after fully
> upgrading to 18.08.3-1.
>
> At least this one produces a crash, instead of just stalling… for
> whatever reason.
Pelase add debug symbols for
libKF5AkonadiCore.so.5abi2
KF5CoreAddons.so.5

otherwise the backtraces are not that helpful.

hefee

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Martin Steigerwald-5
In reply to this post by Libor Klepáč
Hi Libor.

Libor Klepáč - 07.02.19, 13:03:

> Hi,
> i'm using EWS without problems for some time (well - sometimes, i have to
> restart akonadi or it won't sync emails ...).
> I have attached my setup as screenshot. (I have autodiscovery disabled and
> use "user agent"="Outlook 2016" on other tab).
>
> You have to install package kmailtransport-akonadi to be able to send emails
> thru EWS.
> This package is not recommended by any other package so it is not installed
> by default.

Thanks for your help.

Akonadi EWS is working here too now, at least to some extent. There are some
interim failures at times but I am not sure whether they are Akonadi or Office
365 related.

--
Martin Steigerwald • Proact Deutschland GmbH
Trainer

Telefon: +49 911 30999 55 • Fax: +49 911 30999 99
Südwestpark 43 • 90449 Nürnberg • Germany
[hidden email] • www.proact.de

Amtsgericht Nürnberg • HRB 18320
Geschäftsführer: Oliver Kügow • Richard Müller • Jakob Høholdt • Peter Mikael
Javestad


Mit freundlichen Grüßen / With kind regards
Martin Steigerwald • 
Proact Deutschland GmbH
Trainer
Telefon: <a href="tel:+49%20911%2030999%200" target="_blank" id="LPlnk689713" style="text-decoration:none;color:#7D7D7D;">+49 911 30999 0 • 
Fax: <a href="tel:" target="_blank" id="LPlnk689713" style="text-decoration:none;color:#7D7D7D;">+49 911 30999 99
Südwestpark 43 • 
90449 Nürnberg • 
Germany
[hidden email] • 
www.proact.de
 
Amtsgericht Nürnberg
 • 
HRB 18320
Geschäftsführer: 
Oliver Kügow • 
Richard Müller • 
Jakob Høholdt
 • 
Peter Mikael Javestad
 
– Delivering Business Agility –
 
Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Christian Hilberg-2
In reply to this post by Martin Steigerwald
Hi there,

Am Donnerstag, 7. Februar 2019, 13:20:00 CET schrieb Martin Steigerwald:

> Sandro Knauß - 07.02.19, 00:33:
> > Hey,
> >
> > as Debian is already in freeze, the version of KDEPIM that will
> > shipped with the next stable is 18.08.3. That was uploaded same days
> > ago. There is no time to package 18.12.X sorry for that.
> > So please test this version in more depth and report issues. If you
> > also manage to point to existing bugfixes like done in #921535 it is
> > very likely we can ship a that bugfix also for Buster.
>
> The other issue I have since 18.08 packages is:
>
> Debian #921624: kmail: Crash during/after filtering inbox, probably
> related to Qt WebEngine integration
> https://bugs.debian.org/921624
>
> Crash during/after filtering inbox, probably related to Qt WebEngine
> integration
> https://bugs.kde.org/404052

Filed another one (since 18.08):

KMail (in Kontact) crashing upon start or shortly after
https://bugs.kde.org/405491

It might be related (or even duplicate) to #404052,
only that I do not need to have mails filtered for
KMail to crash. Looks like a QtWebEngine thing.

Just like Martin, I missed out on debug syms. Got them
installed now and trying to get another backtrace.

> I can add more backtraces to the upstream bug report. For some reason
> DrKonqi shortened the second backtrace I had it generate after fully
> upgrading to 18.08.3-1.
>
> At least this one produces a crash, instead of just stalling… for
> whatever reason.
>
> Thanks,

(Bye)²,

        Christian

--



Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Andy Wood
Hello,

I have also been suffering from infrequent kmail crashes in recent weeks.  It
is not related to filtering, nor is it specific to nouveau (I use the NVIDIA
proprietary display driver).
Not currently reproducible ... and yes I need to install debug syms in order
to provide more than a "me too".  The impact may be wider than kmail because I
have also had one okular crash too.

Andy.

On Friday, 15 March 2019 09:55:10 GMT Christian Hilberg wrote:

> Hi there,
>
> Am Donnerstag, 7. Februar 2019, 13:20:00 CET schrieb Martin Steigerwald:
> > Sandro Knauß - 07.02.19, 00:33:
> > > Hey,
> > >
> > > as Debian is already in freeze, the version of KDEPIM that will
> > > shipped with the next stable is 18.08.3. That was uploaded same days
> > > ago. There is no time to package 18.12.X sorry for that.
> > > So please test this version in more depth and report issues. If you
> > > also manage to point to existing bugfixes like done in #921535 it is
> > > very likely we can ship a that bugfix also for Buster.
> >
> > The other issue I have since 18.08 packages is:
> >
> > Debian #921624: kmail: Crash during/after filtering inbox, probably
> > related to Qt WebEngine integration
> > https://bugs.debian.org/921624
> >
> > Crash during/after filtering inbox, probably related to Qt WebEngine
> > integration
> > https://bugs.kde.org/404052
>
> Filed another one (since 18.08):
>
> KMail (in Kontact) crashing upon start or shortly after
> https://bugs.kde.org/405491
>
> It might be related (or even duplicate) to #404052,
> only that I do not need to have mails filtered for
> KMail to crash. Looks like a QtWebEngine thing.
>
> Just like Martin, I missed out on debug syms. Got them
> installed now and trying to get another backtrace.
>
> > I can add more backtraces to the upstream bug report. For some reason
> > DrKonqi shortened the second backtrace I had it generate after fully
> > upgrading to 18.08.3-1.
> >
> > At least this one produces a crash, instead of just stalling… for
> > whatever reason.
> >
> > Thanks,
> (Bye)²,
> Christian



Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Christian Hilberg-2
Hi,

Am Freitag, 15. März 2019, 12:02:42 CET schrieb Andy G Wood:
> Hello,
>
> I have also been suffering from infrequent kmail crashes in recent weeks.
> It is not related to filtering, nor is it specific to nouveau (I use the
> NVIDIA proprietary display driver).

I'm seeing the issue with both, nouveau and (legacy 390) nvidia blob.
Currently running Kontact inside a VM instead, let's see what that does.

> Not currently reproducible ... and yes I need to install debug syms in order
> to provide more than a "me too".  The impact may be wider than kmail
> because I have also had one okular crash too.

Regarding wider impact, the traces I've seen so far point towards QtWebEngine,
so any app integrating this might be affected.

> Andy.
>
> On Friday, 15 March 2019 09:55:10 GMT Christian Hilberg wrote:
> > Hi there,
> >
> > Am Donnerstag, 7. Februar 2019, 13:20:00 CET schrieb Martin Steigerwald:
> > > Sandro Knauß - 07.02.19, 00:33:
> > > > Hey,
> > > >
> > > > as Debian is already in freeze, the version of KDEPIM that will
> > > > shipped with the next stable is 18.08.3. That was uploaded same days
> > > > ago. There is no time to package 18.12.X sorry for that.
> > > > So please test this version in more depth and report issues. If you
> > > > also manage to point to existing bugfixes like done in #921535 it is
> > > > very likely we can ship a that bugfix also for Buster.
> > >
> > > The other issue I have since 18.08 packages is:
> > >
> > > Debian #921624: kmail: Crash during/after filtering inbox, probably
> > > related to Qt WebEngine integration
> > > https://bugs.debian.org/921624
> > >
> > > Crash during/after filtering inbox, probably related to Qt WebEngine
> > > integration
> > > https://bugs.kde.org/404052
> >
> > Filed another one (since 18.08):
> >
> > KMail (in Kontact) crashing upon start or shortly after
> > https://bugs.kde.org/405491
> >
> > It might be related (or even duplicate) to #404052,
> > only that I do not need to have mails filtered for
> > KMail to crash. Looks like a QtWebEngine thing.
> >
> > Just like Martin, I missed out on debug syms. Got them
> > installed now and trying to get another backtrace.
> >
> > > I can add more backtraces to the upstream bug report. For some reason
> > > DrKonqi shortened the second backtrace I had it generate after fully
> > > upgrading to 18.08.3-1.
> > >
> > > At least this one produces a crash, instead of just stalling… for
> > > whatever reason.
> > >
> > > Thanks,

(Bye)²,

        Christian

--



Reply | Threaded
Open this post in threaded view
|

Re: KDEPIM 18.08.3 for Buster

Christian Hilberg-2
Am Freitag, 15. März 2019, 12:39:55 CET schrieb Christian Hilberg:

> Hi,
>
> Am Freitag, 15. März 2019, 12:02:42 CET schrieb Andy G Wood:
> > Hello,
> >
> > I have also been suffering from infrequent kmail crashes in recent weeks.
> > It is not related to filtering, nor is it specific to nouveau (I use the
> > NVIDIA proprietary display driver).
>
> I'm seeing the issue with both, nouveau and (legacy 390) nvidia blob.
> Currently running Kontact inside a VM instead, let's see what that does.
(1) KMail in a Buster VirtualBox VM did not show the issue

(2) Using nouveau, it showed that the crash path led through Qt WebEngine,
    but ended in the nouveau DRI lib, which is a known issue [0], [1].
    Got there through the bug I filed on bugs.kde.org [2].

(3) Using NVidia 390xx legacy blob with vblank_mode=0 __GL_SYNC_TO_VBLANK=0
    relaxed the situation for me, the error does not seem to occur
    (at least after a few hours there's no crash yet)

(4) disabling vblank did _not_ resolve the issue when using the nouveau
    driver

(5) I've seen reports where building Qt against OpenGL ES instead of GLX
    resolved the issue (but made e.g. WebGL not working)

Just 2 cents.

[0] https://bugreports.qt.io/browse/QTBUG-41242
[1] https://bugreports.qt.io/browse/QTBUG-49243
[2] https://bugs.kde.org/show_bug.cgi?id=405491

> > Not currently reproducible ... and yes I need to install debug syms in
> > order to provide more than a "me too".  The impact may be wider than
> > kmail because I have also had one okular crash too.
>
> Regarding wider impact, the traces I've seen so far point towards
> QtWebEngine, so any app integrating this might be affected.
>
> > Andy.
> >
> > On Friday, 15 March 2019 09:55:10 GMT Christian Hilberg wrote:
> > > Hi there,
> > >
> > > Am Donnerstag, 7. Februar 2019, 13:20:00 CET schrieb Martin Steigerwald:
> > > > Sandro Knauß - 07.02.19, 00:33:
> > > > > Hey,
> > > > >
> > > > > as Debian is already in freeze, the version of KDEPIM that will
> > > > > shipped with the next stable is 18.08.3. That was uploaded same days
> > > > > ago. There is no time to package 18.12.X sorry for that.
> > > > > So please test this version in more depth and report issues. If you
> > > > > also manage to point to existing bugfixes like done in #921535 it is
> > > > > very likely we can ship a that bugfix also for Buster.
> > > >
> > > > The other issue I have since 18.08 packages is:
> > > >
> > > > Debian #921624: kmail: Crash during/after filtering inbox, probably
> > > > related to Qt WebEngine integration
> > > > https://bugs.debian.org/921624
> > > >
> > > > Crash during/after filtering inbox, probably related to Qt WebEngine
> > > > integration
> > > > https://bugs.kde.org/404052
> > >
> > > Filed another one (since 18.08):
> > >
> > > KMail (in Kontact) crashing upon start or shortly after
> > > https://bugs.kde.org/405491
> > >
> > > It might be related (or even duplicate) to #404052,
> > > only that I do not need to have mails filtered for
> > > KMail to crash. Looks like a QtWebEngine thing.
> > >
> > > Just like Martin, I missed out on debug syms. Got them
> > > installed now and trying to get another backtrace.
> > >
> > > > I can add more backtraces to the upstream bug report. For some reason
> > > > DrKonqi shortened the second backtrace I had it generate after fully
> > > > upgrading to 18.08.3-1.
> > > >
> > > > At least this one produces a crash, instead of just stalling… for
> > > > whatever reason.
> > > >
> > > > Thanks,
(Bye)²,

        Christian

--


signature.asc (201 bytes) Download Attachment