KEYEXPIRED

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

KEYEXPIRED

Piviul-2
Ciao a tutti, vorrei aggiornare una vecchissima wheezy a jessie; ho
sostituito nel sources.list jessie a wheezy, ho dato un apt-get update e
dopo aver aggiornato la lista dei pacchetti mi ha dato questo errore:

GPG error: http://archive.debian.org jessie Release: The following
signatures were invalid: KEYEXPIRED 1587841717 KEYEXPIRE
D 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED
1587841717

Ho cercato in internet ma non sono riuscito a risolvere...

Piviul

Reply | Threaded
Open this post in threaded view
|

Re: KEYEXPIRED

Piviul-2
Il 16/05/20 06:03, Piviul ha scritto:

> Ciao a tutti, vorrei aggiornare una vecchissima wheezy a jessie; ho
> sostituito nel sources.list jessie a wheezy, ho dato un apt-get update
> e dopo aver aggiornato la lista dei pacchetti mi ha dato questo errore:
>
> GPG error: http://archive.debian.org jessie Release: The following
> signatures were invalid: KEYEXPIRED 1587841717 KEYEXPIRE
> D 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED
> 1587841717
>
> Ho cercato in internet ma non sono riuscito a risolvere...
invece si :P. Bastava non puntare ad archive.debian.org ma a uno dei
repos dei mirror debian...

Piviul

Reply | Threaded
Open this post in threaded view
|

Re: KEYEXPIRED

Giuseppe Sacco
In reply to this post by Piviul-2
Ciao Piviul,

Il giorno sab, 16/05/2020 alle 06.03 +0200, Piviul ha scritto:
[...]
> GPG error: http://archive.debian.org jessie Release: The following
> signatures were invalid: KEYEXPIRED 1587841717 KEYEXPIRE
> D 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED
> 1587841717

credo che la stessa chiave, con data di scadenza aggiornata, sia
presente nel pacchetto debian-archive-keyring di jessie. Lo puoi
scaricare e installare a mano.

Oppure: https://linux-audit.com/how-to-solve-an-expired-key-keyexpired-with-apt/

Ciao,
Giuseppe

Reply | Threaded
Open this post in threaded view
|

Re: KEYEXPIRED

gollum1-3
In reply to this post by Piviul-2
Il giorno sab 16 mag 2020 alle ore 06:03 Piviul <[hidden email]>
ha scritto:

>
> Ciao a tutti, vorrei aggiornare una vecchissima wheezy a jessie; ho
> sostituito nel sources.list jessie a wheezy, ho dato un apt-get update e
> dopo aver aggiornato la lista dei pacchetti mi ha dato questo errore:
>
> GPG error: http://archive.debian.org jessie Release: The following
> signatures were invalid: KEYEXPIRED 1587841717 KEYEXPIRE
> D 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED 1587841717 KEYEXPIRED
> 1587841717
>

Ho visto che poi hai risolto, ma, solo per dovere di cronaca, a volte
può capitare di avere lo stesso errore per un motivo molto più
banale...
batteria tampone scarica, e quindi data completamente sballata... lo
dico per esperienza...

Byez
--
Gollum1 - http://www.gollumone.it
Tesssssoro, dov'é il mio tessssoro...