Latest NVIDIA driver (346.96) issue

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Latest NVIDIA driver (346.96) issue

Pascal Obry

Since yesterday update of NVIDIA 346.96-1 I get an error about uvm
module:

The module is compiled (dkms):

$ ls -la /lib/modules/4.3.0-1-amd64/updates/dkms/nv*
-rw-r--r-- 1 root root 11730792 Jan 20 09:08 /lib/modules/4.3.0-1-amd64/updates/dkms/nvidia-current.ko
-rw-r--r-- 1 root root   111776 Jan 20 09:08 /lib/modules/4.3.0-1-amd64/updates/dkms/nvidia-current-uvm.ko

But cannot be loaded:

$ sudo modprobe nvidia-current-uvm
modprobe: ERROR: could not insert 'nvidia_current_uvm': Invalid argument

Any idea?

Thanks,

--
  Pascal Obry /  Magny Les Hameaux (78)

  The best way to travel is by means of imagination

  http://v2p.fr.eu.org
  http://www.obry.net

  gpg --keyserver keys.gnupg.net --recv-key F949BD3B


Reply | Threaded
Open this post in threaded view
|

Re: Latest NVIDIA driver (346.96) issue

Charles Kroeger
On Wed, 20 Jan 2016 13:10:01 +0100
Pascal Obry <[hidden email]> wrote:

> Since yesterday update of NVIDIA 346.96-1 I get an error about uvm
> module:
>
> The module is compiled (dkms):
>
> $ ls -la /lib/modules/4.3.0-1-amd64/updates/dkms/nv*
> -rw-r--r-- 1 root root 11730792 Jan 20
09:08 /lib/modules/4.3.0-1-amd64/updates/dkms/nvidia-current.ko > -rw-r--r-- 1 root
root   111776 Jan 20
09:08 /lib/modules/4.3.0-1-amd64/updates/dkms/nvidia-current-uvm.ko > > But cannot
be loaded: >
> $ sudo modprobe nvidia-current-uvm
> modprobe: ERROR: could not insert 'nvidia_current_uvm': Invalid argument
>
> Any idea?
>
> Thanks,
>

Try # apt-get -f install

For some reason the headers and dkms have not been together on these upgrades.
dkms has had a problem finding the headers to compile the module.

I think # apt-get update will be good now and -f will install what you need.

pure conjecture of course

--
CK

Reply | Threaded
Open this post in threaded view
|

Re: Latest NVIDIA driver (346.96) issue

Mart van de Wege
In reply to this post by Pascal Obry
Pascal Obry <[hidden email]> writes:

> Since yesterday update of NVIDIA 346.96-1 I get an error about uvm
> module:
>
> The module is compiled (dkms):
>
> $ ls -la /lib/modules/4.3.0-1-amd64/updates/dkms/nv*
> -rw-r--r-- 1 root root 11730792 Jan 20 09:08
> /lib/modules/4.3.0-1-amd64/updates/dkms/nvidia-current.ko
> -rw-r--r-- 1 root root   111776 Jan 20 09:08
> /lib/modules/4.3.0-1-amd64/updates/dkms/nvidia-current-uvm.ko
>
> But cannot be loaded:
>
> $ sudo modprobe nvidia-current-uvm
> modprobe: ERROR: could not insert 'nvidia_current_uvm': Invalid argument
>
Check the documentation to see if your chipset is still supported. I had
this problem with the upgrade, as the Quadro in my laptop is no longer
supported by the mainline driver.

Mart

--
"We will need a longer wall when the revolution comes."
    --- AJS, quoting an uncertain source.

Reply | Threaded
Open this post in threaded view
|

Re: Latest NVIDIA driver (346.96) issue

Pascal Obry
Le jeudi 21 janvier 2016 à 10:56 +0100, Mart van de Wege a écrit :
> Check the documentation to see if your chipset is still supported. I
> had
> this problem with the upgrade, as the Quadro in my laptop is no
> longer
> supported by the mainline driver.

Yes, the K1100M is still listed as supported on Nvidia page:

http://www.nvidia.com/Download/driverResults.aspx/90913/en-us

Thanks.

--
  Pascal Obry /  Magny Les Hameaux (78)

  The best way to travel is by means of imagination

  http://v2p.fr.eu.org
  http://www.obry.net

  gpg --keyserver keys.gnupg.net --recv-key F949BD3B