Migration issue because of openvswitch...

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Migration issue because of openvswitch...

Stéphane Glondu-3
Hello,

Currently, react (19 days old), xmlm (17 days) and xen-api (11 days) are
stuck in unstable. One reason is the following: xen-api depends on xmlm
and they must go together, and xen-api depends on (a new binary package
of) openvswitch, which FTBFS (and has been for > 32 days).

Is there anyone working on fixing openvswitch? Or can the dependency in
xen-api be dropped, and reintroduced later, when openvswitch works and
has migrated to testing?


Cheers,

--
Stéphane


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: http://lists.debian.org/4F994B2E.1070901@...

Reply | Threaded
Open this post in threaded view
|

Re: [ovs-dev] Migration issue because of openvswitch...

Simon Horman
On Thu, Apr 26, 2012 at 03:18:38PM +0200, Stéphane Glondu wrote:

> Hello,
>
> Currently, react (19 days old), xmlm (17 days) and xen-api (11 days) are
> stuck in unstable. One reason is the following: xen-api depends on xmlm
> and they must go together, and xen-api depends on (a new binary package
> of) openvswitch, which FTBFS (and has been for > 32 days).
>
> Is there anyone working on fixing openvswitch? Or can the dependency in
> xen-api be dropped, and reintroduced later, when openvswitch works and
> has migrated to testing?

Sorry, I managed to miss this FTBFS situation.

Is this the right place to be looking for the build logs?
https://buildd.debian.org/status/fetch.php?pkg=openvswitch

It seems that an sparc at least there is a problem in the test suite

https://buildd.debian.org/status/fetch.php?pkg=openvswitch&arch=sparc&ver=1.4.0%2Bgit20120321-1&stamp=1332458882
395: ofproto-dpif - mirroring, select_all            FAILED (ofproto-dpif.at:423)
396: ofproto-dpif - mirroring, select_src            FAILED (ofproto-dpif.at:468)
397: ofproto-dpif - mirroring, OFPP_NONE ingress port FAILED (ofproto-dpif.at:506)
398: ofproto-dpif - mirroring, select_dst            FAILED (ofproto-dpif.at:545)
399: ofproto-dpif - mirroring, select_vlan           FAILED (ofproto-dpif.at:589)
400: ofproto-dpif - mirroring, output_port           FAILED (ofproto-dpif.at:640)
401: ofproto-dpif - mirroring, output_vlan           FAILED (ofproto-dpif.at:687)

Unfortuantely I have run out of today, but I'll take a look tomorrow
if no one else has.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: http://lists.debian.org/20120426141833.GB30298@...

Reply | Threaded
Open this post in threaded view
|

Re: [ovs-dev] Migration issue because of openvswitch...

Ben Pfaff-3
In reply to this post by Stéphane Glondu-3
On Thu, Apr 26, 2012 at 03:18:38PM +0200, Stéphane Glondu wrote:
> Is there anyone working on fixing openvswitch? Or can the dependency in
> xen-api be dropped, and reintroduced later, when openvswitch works and
> has migrated to testing?

I hadn't noticed that Open vSwitch had FTBFS (it seems that I'd failed
to subscribe to it in the PTS).

I'm looking at it now.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: http://lists.debian.org/20120426164432.GA18821@...

Reply | Threaded
Open this post in threaded view
|

Re: [ovs-dev] Migration issue because of openvswitch...

Ben Pfaff-3
On Thu, Apr 26, 2012 at 09:44:32AM -0700, Ben Pfaff wrote:
> On Thu, Apr 26, 2012 at 03:18:38PM +0200, Stéphane Glondu wrote:
> > Is there anyone working on fixing openvswitch? Or can the dependency in
> > xen-api be dropped, and reintroduced later, when openvswitch works and
> > has migrated to testing?
>
> I hadn't noticed that Open vSwitch had FTBFS (it seems that I'd failed
> to subscribe to it in the PTS).
>
> I'm looking at it now.

It's a bug in the testsuite.  I posted a fix to the OVS development
mailing list for review:
        http://openvswitch.org/pipermail/dev/2012-April/016844.html

I expect to upload a fixed package today or tomorrow.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: http://lists.debian.org/20120426180844.GD18821@...

Reply | Threaded
Open this post in threaded view
|

Re: [ovs-dev] Migration issue because of openvswitch...

Ben Pfaff-3
On Thu, Apr 26, 2012 at 11:08:44AM -0700, Ben Pfaff wrote:

> On Thu, Apr 26, 2012 at 09:44:32AM -0700, Ben Pfaff wrote:
> > On Thu, Apr 26, 2012 at 03:18:38PM +0200, Stéphane Glondu wrote:
> > > Is there anyone working on fixing openvswitch? Or can the dependency in
> > > xen-api be dropped, and reintroduced later, when openvswitch works and
> > > has migrated to testing?
> >
> > I hadn't noticed that Open vSwitch had FTBFS (it seems that I'd failed
> > to subscribe to it in the PTS).
> >
> > I'm looking at it now.
>
> It's a bug in the testsuite.  I posted a fix to the OVS development
> mailing list for review:
>         http://openvswitch.org/pipermail/dev/2012-April/016844.html
>
> I expect to upload a fixed package today or tomorrow.

The fixed version has been installed and I expect the buildds to start
work on it soon.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: http://lists.debian.org/20120426221509.GQ19990@...