Missing Firmware

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing Firmware

Roger-14
You may be interested to know that the iso's listed at
https://cdimage.debian.org/images/unofficial/non-free/images-including-firmware/10.0.0-live+nonfree/amd64/iso-hybrid/
are missing some firmware information.

I selected the debian-live-10.0.0-amd64-xfce+nonfree.iso for my Dell
Studio XPS notebook computer.  It always had complained that it needed
the B43 Broadcom firmware files of b43/ucode16_mimo.fw and
b43-open/ucode16_mimo.fw.

Whenever I would install Debian Buster it would look for those.  It
never made any difference if I added the missing files to another flash
drive in another USB port or swapped into the same port, they were never
found by the install process.

With the new iso, it did exactly the same thing.  Evidently the non-free
version does not contain the missing firmware anyway.

Please advise as to how to get the install to look for the *.deb or
other files containing the necessary firmware.

Thank you.


Reply | Threaded
Open this post in threaded view
|

Re: Missing Firmware

Andy Simpkins-5
On 19/08/19 17:00, [hidden email] wrote:

> You may be interested to know that the iso's listed at
> https://cdimage.debian.org/images/unofficial/non-free/images-including-firmware/10.0.0-live+nonfree/amd64/iso-hybrid/
>
> are missing some firmware information.
>
> I selected the debian-live-10.0.0-amd64-xfce+nonfree.iso for my Dell
> Studio XPS notebook computer.  It always had complained that it needed
> the B43 Broadcom firmware files of b43/ucode16_mimo.fw and
> b43-open/ucode16_mimo.fw.
>
> Whenever I would install Debian Buster it would look for those.  It
> never made any difference if I added the missing files to another flash
> drive in another USB port or swapped into the same port, they were never
> found by the install process.
>
> With the new iso, it did exactly the same thing.  Evidently the non-free
> version does not contain the missing firmware anyway.
>
> Please advise as to how to get the install to look for the *.deb or
> other files containing the necessary firmware.
>
> Thank you.
>
>
>
Hi there,

A quick note to acknowledge your post.

The B43 firmware resides in the following packages in the non-free
section of the repository:
  b43-fwcutter_019-4_amd64.deb
  firmware-b43-installer_019-4_all.deb
  firmware-b43legacy-installer_019-4_all.deb


*IF*

You are wanting to install onto your laptop, the firmware *IS* part of
the manifest for the non-free installation image
i.e.https://cdimage.debian.org/images/unofficial/non-free/cd-including-firmware/10.0.0+nonfree/amd64/iso-cd/

*BUT IF*

You just want to run a live image at this point in time I agree with you
that this appears to be missing.
Looking at the manifest of the 'live' images I do not see mention of the
B43 drivers...

<< Highvoltage >>  Can you confirm this please?


BR
/Andy






Reply | Threaded
Open this post in threaded view
|

Re: Missing Firmware

Steve McIntyre
Andy, it's probably more helpful if you respond to the reporter too -
they're most likely not subscribed to the mailing list...

On Tue, Aug 20, 2019 at 11:43:06AM +0100, Andy Simpkins wrote:

>On 19/08/19 17:00, [hidden email] wrote:
>> You may be interested to know that the iso's listed at
>> https://cdimage.debian.org/images/unofficial/non-free/images-including-firmware/10.0.0-live+nonfree/amd64/iso-hybrid/
>>
>> are missing some firmware information.
>>
>> I selected the debian-live-10.0.0-amd64-xfce+nonfree.iso for my Dell
>> Studio XPS notebook computer.  It always had complained that it needed
>> the B43 Broadcom firmware files of b43/ucode16_mimo.fw and
>> b43-open/ucode16_mimo.fw.
>>
>> Whenever I would install Debian Buster it would look for those.  It
>> never made any difference if I added the missing files to another flash
>> drive in another USB port or swapped into the same port, they were never
>> found by the install process.
>>
>> With the new iso, it did exactly the same thing.  Evidently the non-free
>> version does not contain the missing firmware anyway.
>>
>> Please advise as to how to get the install to look for the *.deb or
>> other files containing the necessary firmware.
>>
>> Thank you.
>>
>>
>>
>Hi there,
>
>A quick note to acknowledge your post.
>
>The B43 firmware resides in the following packages in the non-free
>section of the repository:
>  b43-fwcutter_019-4_amd64.deb
>  firmware-b43-installer_019-4_all.deb
>  firmware-b43legacy-installer_019-4_all.deb
>
>
>*IF*
>
>You are wanting to install onto your laptop, the firmware *IS* part of
>the manifest for the non-free installation image
>i.e.https://cdimage.debian.org/images/unofficial/non-free/cd-including-firmware/10.0.0+nonfree/amd64/iso-cd/
>
>*BUT IF*
>
>You just want to run a live image at this point in time I agree with you
>that this appears to be missing.
>Looking at the manifest of the 'live' images I do not see mention of the
>B43 drivers...
>
><< Highvoltage >>  Can you confirm this please?

--
Steve McIntyre, Cambridge, UK.                                [hidden email]
"I suspect most samba developers are already technically insane... Of
 course, since many of them are Australians, you can't tell." -- Linus Torvalds