Network-Manager und Fritzbox

classic Classic list List threaded Threaded
38 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Network-Manager und Fritzbox

"Jürgen Bausa"
Ich betreibe ein Laptop (Xiaomi Air 12) unter Buster AMD64 mit KDE und verwende den Network-Manager.
Das wlan wird von einer Fritzbox 7530 bereitgestellt (2,4 und 5 GHz mit gleicher ssid, wpa2).
Seit ich die fritzbox nutze (vorher war es ein TP-Link Router), habe ich folgendes Problem:

Wird die wlan Verbndung vom Laptop neu initiiert (Neustart oder Aufwachen), dann passiert es manchmal
(ca.5-10 % der Fälle), dass die Verbindung ganz kurz erstellt wird, dann aber wieder beendet wird und
auf dem Desktop des Laptops eine Meldung erscheint, das wlan Passwort sei falsch gewesen (was es definitiv
nicht ist) und ich solle doch jetzt das richtige eingeben. Gebe ich dann das richtige Passwort wieder ein,
wird die Verbindung problemlos erzeugt. Oder ich klicke das Fenster weg und starte die Verbindung mit dem
gespeicherten passwort. Auch das geht problemlos.
 
Im Log der Fritzbox finde ich dann das folgende (lina ist das Laptop):
 
20.12.19 22:57:51 WLAN-Gerät wurde abgemeldet (5 GHz), lina, IP 192.168.0.31, MAC XX:XX:XX:XX:XX:XX.
20.12.19 22:57:48 WLAN-Gerät angemeldet, WLAN wird mit voller Leistung reaktiviert (5 GHz).
 
Das ist immer so: Das Problem tritt nur auf, wenn die Fritzbox durch die Verbindung aus dem Energiesparmodus aufgeweckt wird.
 
Im Log des Laptops finde ich:
 
wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=DE
wlp1s0: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='meineSSID' freq=5220 MHz)
wlp1s0: Trying to associate with XX:XX:XX:XX:XX:XX (SSID='meineSSID' freq=5220 MHz)
wlp1s0: Associated with XX:XX:XX:XX:XX:XX
wlp1s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
wlp1s0: WPA: Key negotiation completed with XX:XX:XX:XX:XX:XX [PTK=CCMP GTK=CCMP]
wlp1s0: CTRL-EVENT-CONNECTED - Connection to XX:XX:XX:XX:XX:XX completed [id=0 id_str=]
wlp1s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-70 noise=9999 txrate=6000
Dec 20 22:57:48 lina avahi-daemon[637]: Joining mDNS multicast group on interface wlp1s0.IPv6 with address fe80::31a:e3aa:b668:28ed.
Dec 20 22:57:48 lina avahi-daemon[637]: New relevant interface wlp1s0.IPv6 for mDNS.
Dec 20 22:57:48 lina avahi-daemon[637]: Registering new address record for fe80::31a:e3aa:b668:28ed on wlp1s0.*.
Dec 20 22:57:49 lina dhclient[17036]: DHCPREQUEST for 192.168.0.31 on wlp1s0 to 255.255.255.255 port 67
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=XX:XX:XX:XX:XX:XX reason=2
wlp1s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="meineSSID" auth_failures=1 duration=10 reason=WRONG_KEY
dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/5
wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Dec 20 22:57:54 lina systemd[1]: NetworkManager-dispatcher.service: Succeeded.
Dec 20 22:58:06 lina avahi-daemon[637]: Withdrawing address record for fe80::31a:e3aa:b668:28ed on wlp1s0.
Dec 20 22:58:06 lina avahi-daemon[637]: Leaving mDNS multicast group on interface wlp1s0.IPv6 with address xxxx::xxxx:xxxx:xxxx:xxxx.
Dec 20 22:58:06 lina avahi-daemon[637]: Interface wlp1s0.IPv6 no longer relevant for mDNS.
wlp1s0: Reject scan trigger since one is already pending
 
Das Ganze tritt aber nur mit dem Buster Laptop auf. Andere wlan Clients (MacBook, Android, Win10) machen
das nicht.
 
Das gleiche Phänomen habe ich in einem anderen Haushalt auf, wo auch eine Fritzbox 7530 betrieben wird. 
Das dort genutzte Laptop hat zwar andere Hardware (Acer), ist aber vergliechbar installiert (auch Buster 
AMD64 mit KDE und Network-Manager).
 
Benutzt jemand von euch eine ähnliche Kombination? Und hat das Problem eventuell auch schon gehabt? 
Ich bin mir nicht sicher, ob es am Network-Manager oder an der Fritzbox liegt.
Gibts irgendwelche Möglichkeiten, das Ganze zu debuggen?
 
Gruß,
Jürgen
Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Marc Haber-14
On Thu, 26 Dec 2019 23:20:47 +0100, "Jürgen Bausa"
<[hidden email]> wrote:
>Ich betreibe ein Laptop (Xiaomi Air 12) unter Buster AMD64 mit KDE und verwende den Network-Manager. Das wlan wird von einer Fritzbox 7530 bereitgestellt (2,4 und 5 GHz mit gleicher ssid, wpa2). Seit ich die fritzbox nutze (vorher war es ein TP-Link Router), habe ich folgendes Problem: Wird die wlan Verbndung vom Laptop neu
initiiert (Neustart oder Aufwachen), dann passiert es manchmal (ca.5-10 % der Fälle), dass die Verbindung ganz kurz erstellt wird, dann aber wieder beendet wird und auf dem Desktop des Laptops eine Meldung erscheint, das wlan Passwort sei falsch gewesen (was es definitiv nicht ist) und ich solle doch jetzt das richtige eingeben.
Gebe ich dann das richtige Passwort wieder ein, wird die Verbindung problemlos erzeugt. Oder ich klicke das Fenster weg und starte die Verbindung mit dem gespeicherten passwort. Auch das geht problemlos.   Im Log der Fritzbox finde ich dann das folgende (lina ist das Laptop):   20.12.19 22:57:51 WLAN-Gerät wurde abgemeldet (5 GHz),
lina,
>IP 192.168.0.31, MAC XX:XX:XX:XX:XX:XX. 20.12.19 22:57:48 WLAN-Gerät angemeldet, WLAN wird mit voller Leistung reaktiviert (5 GHz).   Das ist immer so: Das Problem tritt nur auf, wenn die Fritzbox durch die Verbindung aus dem Energiesparmodus aufgeweckt wird.   Im Log des Laptops finde ich:   wlp1s0: CTRL-EVENT-REGDOM-CHANGE
init=DRIVER type=COUNTRY alpha2=DE wlp1s0: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='meineSSID' freq=5220 MHz) wlp1s0: Trying to associate with XX:XX:XX:XX:XX:XX (SSID='meineSSID' freq=5220 MHz) wlp1s0: Associated with XX:XX:XX:XX:XX:XX wlp1s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0 wlp1s0: WPA: Key negotiation
completed with XX:XX:XX:XX:XX:XX [PTK=CCMP GTK=CCMP] wlp1s0: CTRL-EVENT-CONNECTED - Connection to XX:XX:XX:XX:XX:XX completed [id=0 id_str=] wlp1s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-70 noise=9999 txrate=6000 Dec 20 22:57:48 lina avahi-daemon[637]: Joining mDNS multicast group on interface wlp1s0.IPv6 with address
>fe80::31a:e3aa:b668:28ed. Dec 20 22:57:48 lina avahi-daemon[637]: New relevant interface wlp1s0.IPv6 for mDNS. Dec 20 22:57:48 lina avahi-daemon[637]: Registering new address record for fe80::31a:e3aa:b668:28ed on wlp1s0.*. Dec 20 22:57:49 lina dhclient[17036]: DHCPREQUEST for 192.168.0.31 on wlp1s0 to 255.255.255.255 port 67
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=XX:XX:XX:XX:XX:XX reason=2 wlp1s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="meineSSID" auth_failures=1 duration=10 reason=WRONG_KEY dbus: wpa_dbus_property_changed: no property SessionLength in object
/fi/w1/wpa_supplicant1/Interfaces/5 wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD Dec 20 22:57:54 lina systemd[1]: NetworkManager-dispatcher.service: Succeeded. Dec 20 22:58:06 lina avahi-daemon[637]: Withdrawing address record for fe80::31a:e3aa:b668:28ed on wlp1s0. Dec 20 22:58:06 lina avahi-daemon[637]: Leaving mDNS
multicast group on interface
>wlp1s0.IPv6 with address xxxx::xxxx:xxxx:xxxx:xxxx. Dec 20 22:58:06 lina avahi-daemon[637]: Interface wlp1s0.IPv6 no longer relevant for mDNS. wlp1s0: Reject scan trigger since one is already pending   Das Ganze tritt aber nur mit dem Buster Laptop auf. Andere wlan Clients (MacBook, Android, Win10) machen das nicht.   Das gleiche
Phänomen habe ich in einem anderen Haushalt auf, wo auch eine Fritzbox 7530 betrieben wird.  Das dort genutzte Laptop hat zwar andere Hardware (Acer), ist aber vergliechbar installiert (auch Buster  AMD64 mit KDE und Network-Manager).   Benutzt jemand von euch eine ähnliche Kombination? Und hat das Problem eventuell auch schon
gehabt?  Ich bin mir nicht sicher, ob es am Network-Manager oder an der Fritzbox liegt. Gibts irgendwelche Möglichkeiten, das Ganze zu debuggen?   Gruß, Jürgen

Der Artikel ist völlig unlesbar. Daher keine Antwort von mir.

Bitte mit Zeilenwechseln neu posten.

Grüße
Marc
--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber         |   " Questions are the         | Mailadresse im Header
Mannheim, Germany  |     Beginning of Wisdom "     |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Sebastian Suchanek
Am 29.12.2019 um 11:50 schrieb Marc Haber:

> [...]
> Der Artikel ist völlig unlesbar. Daher keine Antwort von mir.
>
> Bitte mit Zeilenwechseln neu posten.

Der Fairness halber muss man sagen, dass die Original-E-Mail durchaus
sinnvolle Zeilenwechsel hatte.
Dass die Original-Mail allerdings HTML-only war (worüber wahrscheinlich
Dein MUA gestolpert ist) und HTML-Mails auf einer Mailingsliste meiner
Meinung nach auch pfui-bäh sind, steht auf einem anderen Blatt.


Tschüs,

Sebastian

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Robert Stephan
In reply to this post by "Jürgen Bausa"
Das Problem kenn ich von meinem T550, mit dem T500 war es auch nicht anders.
Meine Vermutung ist daß der Networkmanger, bzw. wpa_supplicant einen
Schlüßelwechsel im Ruhezustand verpennt hat oder daß der zugehörige
Paßwortmanager zu lange braucht um aus den Puschen zu kommen.
Lösung hab ich keine, bei einem Klick auf "Verbinden" steht die Verbindung ja
wieder.
Unschöner ist daß meine Ethernetschnittstelle nach dem Aufwachen ab und an nur
mit 10MBit/s erkannt und eingerichtet wird.
Allerdings könnten beide Probleme durchaus zusammenhängen, also fehlerhafte
Initialisierung beim Aufwachen.

Grüße

Robert



Schlüßel ID= 6E9BF134
Fingerprint=68C1 F1BC C3E0 EA52 0CE7  FB95 7E1B 7D60 6E9B F134
Am Donnerstag, 26. Dezember 2019, 23:20:47 CET schrieb Jürgen Bausa:

> Ich betreibe ein Laptop (Xiaomi Air 12) unter Buster AMD64 mit KDE und
> verwende den Network-Manager. Das wlan wird von einer Fritzbox 7530
> bereitgestellt (2,4 und 5 GHz mit gleicher ssid, wpa2). Seit ich die
> fritzbox nutze (vorher war es ein TP-Link Router), habe ich folgendes
> Problem:
>
> Wird die wlan Verbndung vom Laptop neu initiiert (Neustart oder Aufwachen),
> dann passiert es manchmal (ca.5-10 % der Fälle), dass die Verbindung ganz
> kurz erstellt wird, dann aber wieder beendet wird und auf dem Desktop des
> Laptops eine Meldung erscheint, das wlan Passwort sei falsch gewesen (was
> es definitiv nicht ist) und ich solle doch jetzt das richtige eingeben.
> Gebe ich dann das richtige Passwort wieder ein, wird die Verbindung
> problemlos erzeugt. Oder ich klicke das Fenster weg und starte die
> Verbindung mit dem gespeicherten passwort. Auch das geht problemlos.
>  
> Im Log der Fritzbox finde ich dann das folgende (lina ist das Laptop):
>  
> 20.12.19 22:57:51 WLAN-Gerät wurde abgemeldet (5 GHz), lina, IP
> 192.168.0.31, MAC XX:XX:XX:XX:XX:XX. 20.12.19 22:57:48 WLAN-Gerät
> angemeldet, WLAN wird mit voller Leistung reaktiviert (5 GHz).
> Das ist immer so: Das Problem tritt nur auf, wenn die Fritzbox durch die
> Verbindung aus dem Energiesparmodus aufgeweckt wird.
> Im Log des Laptops finde ich:
>  
> wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=DE
> wlp1s0: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='meineSSID'
> freq=5220 MHz) wlp1s0: Trying to associate with XX:XX:XX:XX:XX:XX
> (SSID='meineSSID' freq=5220 MHz) wlp1s0: Associated with XX:XX:XX:XX:XX:XX
> wlp1s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
> wlp1s0: WPA: Key negotiation completed with XX:XX:XX:XX:XX:XX [PTK=CCMP
> GTK=CCMP] wlp1s0: CTRL-EVENT-CONNECTED - Connection to XX:XX:XX:XX:XX:XX
> completed [id=0 id_str=] wlp1s0: CTRL-EVENT-SIGNAL-CHANGE above=1
> signal=-70 noise=9999 txrate=6000 Dec 20 22:57:48 lina avahi-daemon[637]:
> Joining mDNS multicast group on interface wlp1s0.IPv6 with address
> fe80::31a:e3aa:b668:28ed. Dec 20 22:57:48 lina avahi-daemon[637]: New
> relevant interface wlp1s0.IPv6 for mDNS. Dec 20 22:57:48 lina
> avahi-daemon[637]: Registering new address record for
> fe80::31a:e3aa:b668:28ed on wlp1s0.*. Dec 20 22:57:49 lina dhclient[17036]:
> DHCPREQUEST for 192.168.0.31 on wlp1s0 to 255.255.255.255 port 67 wlp1s0:
> CTRL-EVENT-DISCONNECTED bssid=XX:XX:XX:XX:XX:XX reason=2
> wlp1s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
> wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="meineSSID" auth_failures=1
> duration=10 reason=WRONG_KEY dbus: wpa_dbus_property_changed: no property
> SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/5 wlp1s0:
> CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
> Dec 20 22:57:54 lina systemd[1]: NetworkManager-dispatcher.service:
> Succeeded. Dec 20 22:58:06 lina avahi-daemon[637]: Withdrawing address
> record for fe80::31a:e3aa:b668:28ed on wlp1s0. Dec 20 22:58:06 lina
> avahi-daemon[637]: Leaving mDNS multicast group on interface wlp1s0.IPv6
> with address xxxx::xxxx:xxxx:xxxx:xxxx. Dec 20 22:58:06 lina
> avahi-daemon[637]: Interface wlp1s0.IPv6 no longer relevant for mDNS.
> wlp1s0: Reject scan trigger since one is already pending
>  
> Das Ganze tritt aber nur mit dem Buster Laptop auf. Andere wlan Clients
> (MacBook, Android, Win10) machen das nicht.
>  
> Das gleiche Phänomen habe ich in einem anderen Haushalt auf, wo auch eine
> Fritzbox 7530 betrieben wird.  Das dort genutzte Laptop hat zwar andere
> Hardware (Acer), ist aber vergliechbar installiert (auch Buster AMD64 mit
> KDE und Network-Manager).
>  
> Benutzt jemand von euch eine ähnliche Kombination? Und hat das Problem
> eventuell auch schon gehabt?  Ich bin mir nicht sicher, ob es am
> Network-Manager oder an der Fritzbox liegt. Gibts irgendwelche
> Möglichkeiten, das Ganze zu debuggen?
>  
> Gruß,
> Jürgen


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Robert Stephan
In reply to this post by Marc Haber-14
>
> Der Artikel ist völlig unlesbar. Daher keine Antwort von mir.
>
> Bitte mit Zeilenwechseln neu posten.
>
> Grüße
> Marc

Kommt bei mir Problemlos und lesbar an.
Verbastelt da dein Mailprogramm irgendwas?

Grüße

Robert

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Dirk Paul Finkeldey
In reply to this post by Marc Haber-14
Am 29.12.19 um 11:50 schrieb Marc Haber:
On Thu, 26 Dec 2019 23:20:47 +0100, "Jürgen Bausa"
[hidden email] wrote:

~ gekürzt
Der Artikel ist völlig unlesbar. Daher keine Antwort von mir.

Bitte mit Zeilenwechseln neu posten.


Laut Header ist die Mail Ordnungsgemäß.

Content-Type: text/html; charset=UTF-8

Grüße
Marc


Gruß

Dirk

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Rolf Muth
In reply to this post by "Jürgen Bausa"
Hallo,

da das originale Posting im Text nicht vernünftig lesbar war, antworte ich mit
Textmail auf die HTML Version und hoffe, dass alle dies vollständige Zitat
lesen können.

Am Donnerstag, 26. Dezember 2019, 23:20:47 CET schrieb Jürgen Bausa:

> Ich betreibe ein Laptop (Xiaomi Air 12) unter Buster AMD64 mit KDE und
> verwende den Network-Manager. Das wlan wird von einer Fritzbox 7530
> bereitgestellt (2,4 und 5 GHz mit gleicher ssid, wpa2). Seit ich die
> fritzbox nutze (vorher war es ein TP-Link Router), habe ich folgendes
> Problem:
>
> Wird die wlan Verbndung vom Laptop neu initiiert (Neustart oder Aufwachen),
> dann passiert es manchmal (ca.5-10 % der Fälle), dass die Verbindung ganz
> kurz erstellt wird, dann aber wieder beendet wird und auf dem Desktop des
> Laptops eine Meldung erscheint, das wlan Passwort sei falsch gewesen (was
> es definitiv nicht ist) und ich solle doch jetzt das richtige eingeben.
> Gebe ich dann das richtige Passwort wieder ein, wird die Verbindung
> problemlos erzeugt. Oder ich klicke das Fenster weg und starte die
> Verbindung mit dem gespeicherten passwort. Auch das geht problemlos.
>  
> Im Log der Fritzbox finde ich dann das folgende (lina ist das Laptop):
>  
> 20.12.19 22:57:51 WLAN-Gerät wurde abgemeldet (5 GHz), lina, IP
> 192.168.0.31, MAC XX:XX:XX:XX:XX:XX. 20.12.19 22:57:48 WLAN-Gerät
> angemeldet, WLAN wird mit voller Leistung reaktiviert (5 GHz).
> Das ist immer so: Das Problem tritt nur auf, wenn die Fritzbox durch die
> Verbindung aus dem Energiesparmodus aufgeweckt wird.
> Im Log des Laptops finde ich:
>  
> wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=DE
> wlp1s0: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='meineSSID'
> freq=5220 MHz) wlp1s0: Trying to associate with XX:XX:XX:XX:XX:XX
> (SSID='meineSSID' freq=5220 MHz) wlp1s0: Associated with XX:XX:XX:XX:XX:XX
> wlp1s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
> wlp1s0: WPA: Key negotiation completed with XX:XX:XX:XX:XX:XX [PTK=CCMP
> GTK=CCMP] wlp1s0: CTRL-EVENT-CONNECTED - Connection to XX:XX:XX:XX:XX:XX
> completed [id=0 id_str=] wlp1s0: CTRL-EVENT-SIGNAL-CHANGE above=1
> signal=-70 noise=9999 txrate=6000 Dec 20 22:57:48 lina avahi-daemon[637]:
> Joining mDNS multicast group on interface wlp1s0.IPv6 with address
> fe80::31a:e3aa:b668:28ed. Dec 20 22:57:48 lina avahi-daemon[637]: New
> relevant interface wlp1s0.IPv6 for mDNS. Dec 20 22:57:48 lina
> avahi-daemon[637]: Registering new address record for
> fe80::31a:e3aa:b668:28ed on wlp1s0.*. Dec 20 22:57:49 lina dhclient[17036]:
> DHCPREQUEST for 192.168.0.31 on wlp1s0 to 255.255.255.255 port 67 wlp1s0:
> CTRL-EVENT-DISCONNECTED bssid=XX:XX:XX:XX:XX:XX reason=2
> wlp1s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
> wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="meineSSID" auth_failures=1
> duration=10 reason=WRONG_KEY dbus: wpa_dbus_property_changed: no property
> SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/5 wlp1s0:
> CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
> Dec 20 22:57:54 lina systemd[1]: NetworkManager-dispatcher.service:
> Succeeded. Dec 20 22:58:06 lina avahi-daemon[637]: Withdrawing address
> record for fe80::31a:e3aa:b668:28ed on wlp1s0. Dec 20 22:58:06 lina
> avahi-daemon[637]: Leaving mDNS multicast group on interface wlp1s0.IPv6
> with address xxxx::xxxx:xxxx:xxxx:xxxx. Dec 20 22:58:06 lina
> avahi-daemon[637]: Interface wlp1s0.IPv6 no longer relevant for mDNS.
> wlp1s0: Reject scan trigger since one is already pending
>  
> Das Ganze tritt aber nur mit dem Buster Laptop auf. Andere wlan Clients
> (MacBook, Android, Win10) machen das nicht.
>  
> Das gleiche Phänomen habe ich in einem anderen Haushalt auf, wo auch eine
> Fritzbox 7530 betrieben wird.  Das dort genutzte Laptop hat zwar andere
> Hardware (Acer), ist aber vergliechbar installiert (auch Buster AMD64 mit
> KDE und Network-Manager).
>  
> Benutzt jemand von euch eine ähnliche Kombination? Und hat das Problem
> eventuell auch schon gehabt?  Ich bin mir nicht sicher, ob es am
> Network-Manager oder an der Fritzbox liegt. Gibts irgendwelche
> Möglichkeiten, das Ganze zu debuggen?
>  
Ich habe einen TERRA_MOBILE_1749 Laptop mit Buster, KDE und Network-Manager
ebenfalls an einer Fritzbox 7530 mit aktiviertem ipv6, auch 2,4 und 5 GHz mit
gleicher ssid, wpa2. Hier funktioniert alles ganz normal.

Allerdings wird anscheinend auch hier nach dem
systemctl status network-manager.service die Verbindung kurz unterbrochen:

/var/log/user.log

Dec 29 12:56:35 laptop NetworkManager[834]: <warn>  [1577620595.6901] dns-mgr:
could not commit DNS changes: resolvconf failed with status 256
Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6016] dhcp6
(wlp4s0):   nameserver <ipv6 Adr fritz.box>
Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6016] dhcp6
(wlp4s0): state changed unknown -> bound
Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6056] dhcp6
(wlp4s0): client pid 10675 exited with status 0
Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6056] dhcp6
(wlp4s0): state changed bound -> done
Dec 29 12:56:51 laptop NetworkManager[834]: <warn>  [1577620611.7928]
sup-iface[0x55b765fd70b0,wlp4s0]: connection disconnected (reason 33)

--
Herzliche Grüße!
Rolf Muth
Meine Adressen dürfen nicht für Werbung verwendet werden!
OpenPGP Public Key:
http://pgp.uni-mainz.de:11371/pks/lookup?op=index&search=0x5544C89A

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Aw: Re: Network-Manager und Fritzbox

"Jürgen Bausa"
In reply to this post by Marc Haber-14
> Der Artikel ist völlig unlesbar. Daher keine Antwort von mir.

Sorry, war mir nicht klar dass web.de auch bei reinem Text per default html sendet.
Ich hoffe, jetzt klappts.


Ich betreibe ein Laptop (Xiaomi Air 12) unter Buster AMD64 mit KDE und verwende den Network-Manager.
Das wlan wird von einer Fritzbox 7530 bereitgestellt (2,4 und 5 GHz mit gleicher ssid, wpa2).
Seit ich die fritzbox nutze (vorher war es ein TP-Link Router), habe ich folgendes Problem:
Wird die wlan Verbndung vom Laptop neu initiiert (Neustart oder Aufwachen), dann passiert es manchmal
(ca.5-10 % der Fälle), dass die Verbindung ganz kurz erstellt wird, dann aber wieder beendet wird und
auf dem Desktop des Laptops eine Meldung erscheint, das wlan Passwort sei falsch gewesen (was es definitiv
nicht ist) und ich solle doch jetzt das richtige eingeben. Gebe ich dann das richtige Passwort wieder ein,
wird die Verbindung problemlos erzeugt. Oder ich klicke das Fenster weg und starte die Verbindung mit dem
gespeicherten passwort. Auch das geht problemlos.

Im Log der Fritzbox finde ich dann das folgende (lina ist das Laptop):

20.12.19 22:57:51 WLAN-Gerät wurde abgemeldet (5 GHz), lina, IP 192.168.0.31, MAC XX:XX:XX:XX:XX:XX.
20.12.19 22:57:48 WLAN-Gerät angemeldet, WLAN wird mit voller Leistung reaktiviert (5 GHz).

Das ist immer so: Das Problem tritt nur auf, wenn die Fritzbox durch die Verbindung aus dem Energiesparmodus aufgeweckt wird.

Im Log des Laptops finde ich:

wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=DE
wlp1s0: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='meineSSID' freq=5220 MHz)
wlp1s0: Trying to associate with XX:XX:XX:XX:XX:XX (SSID='meineSSID' freq=5220 MHz)
wlp1s0: Associated with XX:XX:XX:XX:XX:XX
wlp1s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
wlp1s0: WPA: Key negotiation completed with XX:XX:XX:XX:XX:XX [PTK=CCMP GTK=CCMP]
wlp1s0: CTRL-EVENT-CONNECTED - Connection to XX:XX:XX:XX:XX:XX completed [id=0 id_str=]
wlp1s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-70 noise=9999 txrate=6000
Dec 20 22:57:48 lina avahi-daemon[637]: Joining mDNS multicast group on interface wlp1s0.IPv6 with address fe80::31a:e3aa:b668:28ed.
Dec 20 22:57:48 lina avahi-daemon[637]: New relevant interface wlp1s0.IPv6 for mDNS.
Dec 20 22:57:48 lina avahi-daemon[637]: Registering new address record for fe80::31a:e3aa:b668:28ed on wlp1s0.*.
Dec 20 22:57:49 lina dhclient[17036]: DHCPREQUEST for 192.168.0.31 on wlp1s0 to 255.255.255.255 port 67
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=XX:XX:XX:XX:XX:XX reason=2
wlp1s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="meineSSID" auth_failures=1 duration=10 reason=WRONG_KEY
dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/5
wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Dec 20 22:57:54 lina systemd[1]: NetworkManager-dispatcher.service: Succeeded.
Dec 20 22:58:06 lina avahi-daemon[637]: Withdrawing address record for fe80::31a:e3aa:b668:28ed on wlp1s0.
Dec 20 22:58:06 lina avahi-daemon[637]: Leaving mDNS multicast group on interface wlp1s0.IPv6 with address xxxx::xxxx:xxxx:xxxx:xxxx.
Dec 20 22:58:06 lina avahi-daemon[637]: Interface wlp1s0.IPv6 no longer relevant for mDNS.
wlp1s0: Reject scan trigger since one is already pending

Das Ganze tritt aber nur mit dem Buster Laptop auf. Andere wlan Clients (MacBook, Android, Win10) machen
das nicht.

Das gleiche Phänomen habe ich in einem anderen Haushalt auf, wo auch eine Fritzbox 7530 betrieben wird.
Das dort genutzte Laptop hat zwar andere Hardware (Acer), ist aber vergliechbar installiert (auch Buster
AMD64 mit KDE und Network-Manager).

Benutzt jemand von euch eine ähnliche Kombination? Und hat das Problem eventuell auch schon gehabt?
Ich bin mir nicht sicher, ob es am Network-Manager oder an der Fritzbox liegt.

Gibts irgendwelche Möglichkeiten, das Ganze zu debuggen?

Gruß,

Jürgen

 

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

"Jürgen Bausa"
In reply to this post by Rolf Muth

>Gesendet: Sonntag, 29. Dezember 2019 um 13:47 Uhr
>Von: "Rolf Muth" <[hidden email]>
>
>Ich habe einen TERRA_MOBILE_1749 Laptop mit Buster, KDE und Network-Manager
>ebenfalls an einer Fritzbox 7530 mit aktiviertem ipv6, auch 2,4 und 5 GHz mit
>gleicher ssid, wpa2. Hier funktioniert alles ganz normal.

Das ist interessant. ich frage mich, was der Unterschied in deiner Konfiguration ist.
Unterstützt dein Laptop auch 5 GHz?

Jürgen

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

"Jürgen Bausa"
In reply to this post by Robert Stephan

>Gesendet: Sonntag, 29. Dezember 2019 um 13:05 Uhr
>Von: "Robert Stephan" <[hidden email]>
>
>Das Problem kenn ich von meinem T550, mit dem T500 war es auch nicht anders.
>Meine Vermutung ist daß der Networkmanger, bzw. wpa_supplicant einen
>Schlüßelwechsel im Ruhezustand verpennt hat oder daß der zugehörige
>Paßwortmanager zu lange braucht um aus den Puschen zu kommen.
>Lösung hab ich keine, bei einem Klick auf "Verbinden" steht die Verbindung ja
>wieder.

Eigenartig ist aber, dass es nur in Verbindung mit einer Fritzbox passiert.
Mit anderen Routern hatte ich nie das Problem.
Der AVM Support sagt, es liegt am Client. Aber ich glaube nicht, dass
sie das im Detail geprüft haben.

Leider gibt es (noch?) keine Backports zu kernel, Network-Manager und wpa_supplicant.
Sonst könnte man die einfach mal installieren und schauen, ob das etwas ändert.

Jürgen

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Rolf Muth
In reply to this post by "Jürgen Bausa"
Am Montag, 30. Dezember 2019, 10:13:00 CET schrieb Jürgen Bausa:

> >Gesendet: Sonntag, 29. Dezember 2019 um 13:47 Uhr
> >Von: "Rolf Muth" <[hidden email]>
> >
> >Ich habe einen TERRA_MOBILE_1749 Laptop mit Buster, KDE und Network-Manager
> >ebenfalls an einer Fritzbox 7530 mit aktiviertem ipv6, auch 2,4 und 5 GHz
> >mit gleicher ssid, wpa2. Hier funktioniert alles ganz normal.
>
> Das ist interessant. ich frage mich, was der Unterschied in deiner
> Konfiguration ist. Unterstützt dein Laptop auch 5 GHz?
>
Ja (s.o.), benutze ich auch. dmesg zeigt
iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164

--
Herzliche Grüße!
Rolf Muth
Meine Adressen dürfen nicht für Werbung verwendet werden!
OpenPGP Public Key:
http://pgp.uni-mainz.de:11371/pks/lookup?op=index&search=0x5544C89A

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Manfred Gil-5
In reply to this post by "Jürgen Bausa"
Am 29.12.19 um 20:30 schrieb "Jürgen Bausa":
[..]
> Benutzt jemand von euch eine ähnliche Kombination? Und hat das Problem eventuell auch schon gehabt?
> Ich bin mir nicht sicher, ob es am Network-Manager oder an der Fritzbox liegt.
>
> Gibts irgendwelche Möglichkeiten, das Ganze zu debuggen?

Ein Schuss ins Blaue...

Versuch doch mal den Network-Manager zu entfernenund den Wicd als
Netzwerk Schnittstelle zu nehemen.

Ich fahre damit seit Jahren gut.

Mit den Network-Manager hatte ich zu Zeiten von Jessie auch schon
Probleme mit verbindungsabrüchen.
Seit dem nutze ich nur noch den Wicd

HTH

Gruß
Manfred

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Richard Kraut-3
In reply to this post by "Jürgen Bausa"
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Montag, den 30.12.2019, 10:17 +0100 schrieb Jürgen Bausa:

> Leider gibt es (noch?) keine Backports zu kernel, Network-Manager und
> wpa_supplicant.
> Sonst könnte man die einfach mal installieren und schauen, ob das etwas
> ändert.

Vom Network-Manager sowie von wpasupplicant gibt es wirklich noch keine
Backports. Aber vom Kernel. Über die Buster-Backports bekommt man z. Zt. den
5.3.9.

- --

MfG Richi

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEERqPC1cUAShrzNBXW+NRy+KEKcZgFAl4KU4IACgkQ+NRy+KEK
cZihqg//WRYZIKRzl9PPCL5RHve3ehva4bOwDn+qqPNzVcp4idur7C0Dz3gsM5Bq
OQ5dJqfLMNHrV4xbRicsRhtHl+xXzWyCAruSZ7RxWZdZ300NS+bqp4FYsZfZe4Wn
waE3LYwyYG2u7CYbq2l3GB1NayJ5iZrf354imnyrYun2SXjGEdYqBxVXzY2Ec8BZ
wpLMKXMaIBq6p0J+ByXNvbcuvXPjm1I3g65Fo7mACpJklkb0WkByTxPGZ/51nzyU
e2tQLdKAd7+CK02w3oBEeRALBg2juraSfGdUjsZcP/+NXK7OCOaTDdi8gvQ3Rb7m
iMc5QrpbhxstzKLJhGbrbFyQHNpin8s5Hd/8LBZSbBU73/yhwNTJiVyiJGVuwNDN
2PdZPvgAsjmsmnB248ENShwLxn/LBQEYv9APr95pWjYb9ZvGKbaYDKjHYOmfjGBE
e6ibh6CBJJzWms3KZsrg1dy9GggfKLYLajKUt8Yji25OP3fnIsBfvrLRoupEIK8K
pgcArbKSxAcBxV8TbFz7HbRwfF/Zn4rPYflEsSc4v6P0Jeb0mbRbpo62OinvETYa
yt5UVhqNHh+qdFv+EDWFsrHTrrYEvK6FeQ34nwTv7+aMqyQxjJtJW7BQ8us6T8ZN
9++t9QLdh0S9SRIX41PwJ08fHUlsBOqIXUVZ4/fl6U6PelffBsg=
=w8IA
-----END PGP SIGNATURE-----

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

"Jürgen Bausa"
In reply to this post by "Jürgen Bausa"
Stimmt, einen kernel Backport gibt es. Den hatte ich übersehen. Hab ihn aber mal probeweise
installiert und der Fehler tritt immer noch auf.

Jürgen

----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Montag, den 30.12.2019, 10:17 +0100 schrieb Jürgen Bausa:

> Leider gibt es (noch?) keine Backports zu kernel, Network-Manager und
> wpa_supplicant.
> Sonst könnte man die einfach mal installieren und schauen, ob das etwas
> ändert.

Vom Network-Manager sowie von wpasupplicant gibt es wirklich noch keine
Backports. Aber vom Kernel. Über die Buster-Backports bekommt man z. Zt. den
5.3.9.

- --

MfG Richi

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Marc Haber-14
In reply to this post by Manfred Gil-5
On Mon, 30 Dec 2019 17:56:06 +0100, Manfred-Gil
<[hidden email]> wrote:
>Versuch doch mal den Network-Manager zu entfernenund den Wicd als
>Netzwerk Schnittstelle zu nehemen.
>
>Ich fahre damit seit Jahren gut.

wicd hatte seit ziemlich genau zehn Jahren kein Major Release mehr. Du
empfiehlst den Umstieg auf ungewartete Software, die kaum jemand mehr
einsetzt. Damit dürfte Jürgen nicht geholfen werden.

For the record: Auf meine Notebooks tut Network-Manager so gut, dass
ich nicht weiß wie ich das Problem von Jürgen debuggen würde.

Grüße
Marc, der auf ein Treiberproblem tippt
--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber         |   " Questions are the         | Mailadresse im Header
Mannheim, Germany  |     Beginning of Wisdom "     |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Marc Haber-14
In reply to this post by "Jürgen Bausa"
On Sun, 29 Dec 2019 20:17:23 +0100, "Jürgen Bausa"
<[hidden email]> wrote:
>Ich betreibe ein Laptop (Xiaomi Air 12) unter Buster AMD64 mit KDE und verwende den Network-Manager.
>Das wlan wird von einer Fritzbox 7530 bereitgestellt (2,4 und 5 GHz mit gleicher ssid, wpa2).
>Seit ich die fritzbox nutze (vorher war es ein TP-Link Router), habe ich folgendes Problem:
>Wird die wlan Verbndung vom Laptop neu initiiert (Neustart oder Aufwachen), dann passiert es manchmal
>(ca.5-10 % der Fälle), dass die Verbindung ganz kurz erstellt wird, dann aber wieder beendet wird und
>auf dem Desktop des Laptops eine Meldung erscheint, das wlan Passwort sei falsch gewesen (was es definitiv
>nicht ist) und ich solle doch jetzt das richtige eingeben. Gebe ich dann das richtige Passwort wieder ein,
>wird die Verbindung problemlos erzeugt. Oder ich klicke das Fenster weg und starte die Verbindung mit dem
>gespeicherten passwort. Auch das geht problemlos.

Wichtig wäre zu wissen, was da für ein WLAN-Chip verbaut ist.

Grüße
Marc
--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber         |   " Questions are the         | Mailadresse im Header
Mannheim, Germany  |     Beginning of Wisdom "     |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

Rolf Muth
In reply to this post by Rolf Muth
Am Sonntag, 29. Dezember 2019, 13:47:48 CET schrieb Rolf Muth:

> Hallo,
>
> Ich habe einen TERRA_MOBILE_1749 Laptop mit Buster, KDE und Network-Manager
> ebenfalls an einer Fritzbox 7530 mit aktiviertem ipv6, auch 2,4 und 5 GHz
> mit gleicher ssid, wpa2. Hier funktioniert alles ganz normal.
>
> Allerdings wird anscheinend auch hier nach dem
> systemctl status network-manager.service die Verbindung kurz unterbrochen:
>
> /var/log/user.log
>
> Dec 29 12:56:35 laptop NetworkManager[834]: <warn>  [1577620595.6901]
> dns-mgr: could not commit DNS changes: resolvconf failed with status 256
> Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6016] dhcp6
> (wlp4s0):   nameserver <ipv6 Adr fritz.box>
> Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6016] dhcp6
> (wlp4s0): state changed unknown -> bound
> Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6056] dhcp6
> (wlp4s0): client pid 10675 exited with status 0
> Dec 29 12:56:36 laptop NetworkManager[834]: <info>  [1577620596.6056] dhcp6
> (wlp4s0): state changed bound -> done
> Dec 29 12:56:51 laptop NetworkManager[834]: <warn>  [1577620611.7928]
> sup-iface[0x55b765fd70b0,wlp4s0]: connection disconnected (reason 33)
Stell doch versuchsweise mal IPv6 in der Fritzbox ab (Internet - Zugangsdaten
- Reiter IPv6).
Der Wlanzugang wird dann bei mir IMHO nicht unterbrrochen...

--
Herzliche Grüße!
Rolf Muth
Meine Adressen dürfen nicht für Werbung verwendet werden!
OpenPGP Public Key:
http://pgp.uni-mainz.de:11371/pks/lookup?op=index&search=0x5544C89A

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Aw: Re: Network-Manager und Fritzbox

"Jürgen Bausa"
In reply to this post by Marc Haber-14
dmesg:
iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208

und lspci:
01:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

Jürgen
 
> Gesendet: Mittwoch, 01. Januar 2020 um 15:09 Uhr
> Von: "Marc Haber" <[hidden email]>
>
> Wichtig wäre zu wissen, was da für ein WLAN-Chip verbaut ist.


Reply | Threaded
Open this post in threaded view
|

Re: Aw: Re: Network-Manager und Fritzbox

Ulf Volmer
On 03.01.20 14:40, "Jürgen Bausa" wrote:
> dmesg:
> iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208

Der Vollständigkeit halber: firmware-iwlwifi ist installiert?

Viele Grüße
Ulf

Reply | Threaded
Open this post in threaded view
|

Re: Network-Manager und Fritzbox

"Jürgen Bausa"
Ja, ist installiert:

jba@lina:~$ apt-cache policy firmware-iwlwifi
firmware-iwlwifi:
  Installiert:           20190114-2
  Installationskandidat: 20190114-2
  Versionstabelle:
     20190717-2~bpo10+1 100
        100 http://ftp.de.debian.org/debian buster-backports/non-free amd64 Packages
 *** 20190114-2 500
        500 http://ftp.de.debian.org/debian buster/non-free amd64 Packages
        100 /var/lib/dpkg/status

Ansonsten funktioniert ja auch alles.

Ich werde aber mal den Backport installieren und schauen, ob das etwas ändert. Bin mir aber
ziemlich sicher, dass es nicht an der Firmware liegt.

Der zweite Rechner, mit dem das Problem auftritt, hat übrigens auch einen Intel Chipsatz.
Allerdings komme ich da momentan nicht dran und kann daher nicht sagen, welcher das genau ist.

Jürgen
 
 

> Gesendet: Freitag, 03. Januar 2020 um 18:09 Uhr
> Von: "Ulf Volmer" <[hidden email]>
> An: [hidden email]
> Betreff: Re: Aw: Re: Network-Manager und Fritzbox
> On 03.01.20 14:40, "Jürgen Bausa" wrote:
>> dmesg:
>> iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208
>
> Der Vollständigkeit halber: firmware-iwlwifi ist installiert?
>
> Viele Grüße
> Ulf

12