Network

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Network

Andrés Benevento

Hola gente, les comento algo que me pasa sobre Debian 8 montado en una virtualización con VirtualBox. Aclaro antes que el host donde tiene que correr es bastante lento.

El punto es que muchas de las veces que arranca Debian no logra tener conectividad. Si lo reinicio varias veces termina conectando, aunque lo que siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.

Les paso el contenido de interfaces:

auto lo
iface lo inet loopback

allow-hotplug eth0
auto eth0
iface eth0 inet static
address 10.10.10.12
netmask 255.255.255.0
network 10.10.10.0
gateway 10.10.10.1

Algunas sugerencia de qué podría estar sucediendo? Desde ya muchas gracias.

Andrés Benevento



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Edwin Caldon

El 12 ago. 2017 11:29 AM, "Andrés Benevento" <[hidden email]> escribió

El punto es que muchas de las veces que arranca Debian no logra tener conectividad. Si lo reinicio varias veces termina conectando, aunque lo que siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.


Y si la interface de red eth0 la dejas como dhcp no static.

Sucede muchas veces que se inicia la máquina virtual, pero uno no se da cuenta si el PC físico está conectado por inhalambrica o cableada, y entonces toca subir la interface en el OS virtualizado de forma manual.

Saludos.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Andrés Benevento

Edwin gracias por tu respuesta. Pensé en dejarle la asignación dinámica por DHCP pero lo ideal sería que tenga IP fija.

Atte.
Andrés Benevento



El 12/8/2017 a las 5:55 p. m., Edwin Caldon escribió:

El 12 ago. 2017 11:29 AM, "Andrés Benevento" <[hidden email]> escribió

El punto es que muchas de las veces que arranca Debian no logra tener conectividad. Si lo reinicio varias veces termina conectando, aunque lo que siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.


Y si la interface de red eth0 la dejas como dhcp no static.

Sucede muchas veces que se inicia la máquina virtual, pero uno no se da cuenta si el PC físico está conectado por inhalambrica o cableada, y entonces toca subir la interface en el OS virtualizado de forma manual.

Saludos.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Felix Perez
El 12 de agosto de 2017, 16:57, Andrés Benevento
<[hidden email]> escribió:
> Edwin gracias por tu respuesta. Pensé en dejarle la asignación dinámica por
> DHCP pero lo ideal sería que tenga IP fija.
>

Ojo con que que el host tenga ip por dhcp y la ip estática entre en
conflicto durante la asignación puede que en algún momento intenten
tener la misma IP




________________________________

>
> El 12/8/2017 a las 5:55 p. m., Edwin Caldon escribió:
>
>
> El 12 ago. 2017 11:29 AM, "Andrés Benevento" <[hidden email]>
> escribió
>
> El punto es que muchas de las veces que arranca Debian no logra tener
> conectividad. Si lo reinicio varias veces termina conectando, aunque lo que
> siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.
>
>
> Y si la interface de red eth0 la dejas como dhcp no static.
>
> Sucede muchas veces que se inicia la máquina virtual, pero uno no se da
> cuenta si el PC físico está conectado por inhalambrica o cableada, y
> entonces toca subir la interface en el OS virtualizado de forma manual.
>
> Saludos.
>
>



--
usuario linux  #274354
normas de la lista:  http://wiki.debian.org/es/NormasLista
como hacer preguntas inteligentes:
http://www.sindominio.net/ayuda/preguntas-inteligentes.html

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Andrés Benevento

Felix si lo he tenido en cuenta. La IP fija está fuera del rango DHCP. Gracias!

Atte.
Andrés Benevento



El 12/8/2017 a las 6:56 p. m., Felix Perez escribió:
El 12 de agosto de 2017, 16:57, Andrés Benevento
[hidden email] escribió:
Edwin gracias por tu respuesta. Pensé en dejarle la asignación dinámica por
DHCP pero lo ideal sería que tenga IP fija.

Ojo con que que el host tenga ip por dhcp y la ip estática entre en
conflicto durante la asignación puede que en algún momento intenten
tener la misma IP




________________________________
El 12/8/2017 a las 5:55 p. m., Edwin Caldon escribió:


El 12 ago. 2017 11:29 AM, "Andrés Benevento" [hidden email]
escribió

El punto es que muchas de las veces que arranca Debian no logra tener
conectividad. Si lo reinicio varias veces termina conectando, aunque lo que
siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.


Y si la interface de red eth0 la dejas como dhcp no static.

Sucede muchas veces que se inicia la máquina virtual, pero uno no se da
cuenta si el PC físico está conectado por inhalambrica o cableada, y
entonces toca subir la interface en el OS virtualizado de forma manual.

Saludos.





Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Felix Perez
El 12 de agosto de 2017, 17:59, Andrés Benevento
<[hidden email]> escribió:
> Felix si lo he tenido en cuenta. La IP fija está fuera del rango DHCP.
> Gracias!
>

Y has "jugado" con las opciones de "conectado a:" en adaptador de red?

> Atte.
> Andrés Benevento
>
> ________________________________
>
> El 12/8/2017 a las 6:56 p. m., Felix Perez escribió:
>
> El 12 de agosto de 2017, 16:57, Andrés Benevento
> <[hidden email]> escribió:
>
> Edwin gracias por tu respuesta. Pensé en dejarle la asignación dinámica por
> DHCP pero lo ideal sería que tenga IP fija.
>
> Ojo con que que el host tenga ip por dhcp y la ip estática entre en
> conflicto durante la asignación puede que en algún momento intenten
> tener la misma IP
>
>
>
>
> ________________________________
>
> El 12/8/2017 a las 5:55 p. m., Edwin Caldon escribió:
>
>
> El 12 ago. 2017 11:29 AM, "Andrés Benevento" <[hidden email]>
> escribió
>
> El punto es que muchas de las veces que arranca Debian no logra tener
> conectividad. Si lo reinicio varias veces termina conectando, aunque lo que
> siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.
>
>
> Y si la interface de red eth0 la dejas como dhcp no static.
>
> Sucede muchas veces que se inicia la máquina virtual, pero uno no se da
> cuenta si el PC físico está conectado por inhalambrica o cableada, y
> entonces toca subir la interface en el OS virtualizado de forma manual.
>
> Saludos.
>
>
>
>
>



--
usuario linux  #274354
normas de la lista:  http://wiki.debian.org/es/NormasLista
como hacer preguntas inteligentes:
http://www.sindominio.net/ayuda/preguntas-inteligentes.html

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Cristian Mitchell
In reply to this post by Andrés Benevento


El 12 de agosto de 2017, 13:29, Andrés Benevento<[hidden email]> escribió:

Hola gente, les comento algo que me pasa sobre Debian 8 montado en una virtualización con VirtualBox. Aclaro antes que el host donde tiene que correr es bastante lento.

El punto es que muchas de las veces que arranca Debian no logra tener conectividad. Si lo reinicio varias veces termina conectando, aunque lo que siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.

Les paso el contenido de interfaces:

auto lo
iface lo inet loopback

allow-hotplug eth0
auto eth0
iface eth0 inet static
address 10.10.10.12
netmask 255.255.255.0
network 10.10.10.0
gateway 10.10.10.1

Algunas sugerencia de qué podría estar sucediendo? Desde ya muchas gracias.

Andrés Benevento




que método usas entre el host y las virtuales
bridge ruteo etc.

por que el problema que estas teniendo viene por ese lado

--
MrIX
Linux user number 412793.
http://counter.li.org/

las grandes obras,
las sueñan los santos locos,
las realizan los luchadores natos,
las aprovechan los felices cuerdo,
y las critican los inútiles crónicos,

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Andrés Benevento

Uso el método puente con el host (bridge). Gracias!

Atte.
Andrés Benevento



El 12/8/2017 a las 9:36 p. m., Cristian Mitchell escribió:


El 12 de agosto de 2017, 13:29, Andrés Benevento<[hidden email]> escribió:

Hola gente, les comento algo que me pasa sobre Debian 8 montado en una virtualización con VirtualBox. Aclaro antes que el host donde tiene que correr es bastante lento.

El punto es que muchas de las veces que arranca Debian no logra tener conectividad. Si lo reinicio varias veces termina conectando, aunque lo que siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.

Les paso el contenido de interfaces:

auto lo
iface lo inet loopback

allow-hotplug eth0
auto eth0
iface eth0 inet static
address 10.10.10.12
netmask 255.255.255.0
network 10.10.10.0
gateway 10.10.10.1

Algunas sugerencia de qué podría estar sucediendo? Desde ya muchas gracias.

Andrés Benevento




que método usas entre el host y las virtuales
bridge ruteo etc.

por que el problema que estas teniendo viene por ese lado

--
MrIX
Linux user number 412793.
http://counter.li.org/

las grandes obras,
las sueñan los santos locos,
las realizan los luchadores natos,
las aprovechan los felices cuerdo,
y las critican los inútiles crónicos,


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Network

Cristian Mitchell


El 13 de agosto de 2017, 09:45, Andrés Benevento<[hidden email]> escribió:

Uso el método puente con el host (bridge). Gracias!

Atte.
Andrés Benevento



El 12/8/2017 a las 9:36 p. m., Cristian Mitchell escribió:


El 12 de agosto de 2017, 13:29, Andrés Benevento<[hidden email]> escribió:

Hola gente, les comento algo que me pasa sobre Debian 8 montado en una virtualización con VirtualBox. Aclaro antes que el host donde tiene que correr es bastante lento.

El punto es que muchas de las veces que arranca Debian no logra tener conectividad. Si lo reinicio varias veces termina conectando, aunque lo que siempre funciona es tirar los comandos: ifdown eth0 y luego ifup eth0.

Les paso el contenido de interfaces:

auto lo
iface lo inet loopback

allow-hotplug eth0
auto eth0
iface eth0 inet static
address 10.10.10.12
netmask 255.255.255.0
network 10.10.10.0
gateway 10.10.10.1

pues aqui el error
si usas bridg la placa de red no es ethx
si no brx la que configuraste en /etc/network/interfaces



 

Algunas sugerencia de qué podría estar sucediendo? Desde ya muchas gracias.

Andrés Benevento




que método usas entre el host y las virtuales
bridge ruteo etc.

por que el problema que estas teniendo viene por ese lado

--
MrIX
Linux user number 412793.
http://counter.li.org/

las grandes obras,
las sueñan los santos locos,
las realizan los luchadores natos,
las aprovechan los felices cuerdo,
y las critican los inútiles crónicos,





--
MrIX
Linux user number 412793.
http://counter.li.org/

las grandes obras,
las sueñan los santos locos,
las realizan los luchadores natos,
las aprovechan los felices cuerdo,
y las critican los inútiles crónicos,

Loading...