OT: opción para instalar libreoffice desde los repositorios

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

OT: opción para instalar libreoffice desde los repositorios

Paulo Riquelme Olivares
Hola lista, tengo una duda, hoy busqué libreoffice en los repositorios y para mi sorpresa ya se encuentra ahí... perdón debí empezar mencionando que uso testing.

Mi duda es que al tratar de instalar libreoffice-core el sistema me dice que hay conflictos pero que a la vez el paquete con que hay conflicto es necesario, me explico:
1° me sale esto en el terminal después de un "aptitude install libreoffice-core"

No se satisfacen las dependencias de los siguientes paquetes:
  libreoffice-common: Entra en conflicto: libtextcat-data pero está instalado 2.2-9.
Las acciones siguientes resolverán estas dependencias

     Eliminar los paquetes siguientes:                  
1)     libtextcat-data                                  

     Dejar las siguientes dependencias sin resolver:    
2)     libreoffice-common recomienda libtextcat-data-utf8

##------Entonces primero tengo que libreoffice-common tiene conflicto con libtexcat-data y segundo libreoffice-common recomienda libtextcat-data-utf8 (paquete que según leí es un paquete virtual que es proporcionado por libtextcat-data) entonces mi consulta si alguien sabe ¿qué sería lo recomendable? eliminar libtextcat-data o la opción 2 de dejar esas dependencias no resueltas?

Si mi duda es muy básica o si está mal planteada se agradecen las críticas constructivas,

muchas gracias,

Paulo

Reply | Threaded
Open this post in threaded view
|

Re: OT: opción para instalar libreoffice desde los repositorios

amatos
El día 8 de abril de 2011 02:09, Paulo Riquelme <[hidden email]> escribió:

> Hola lista, tengo una duda, hoy busqué libreoffice en los repositorios y
> para mi sorpresa ya se encuentra ahí... perdón debí empezar mencionando que
> uso testing.
>
> Mi duda es que al tratar de instalar libreoffice-core el sistema me dice que
> hay conflictos pero que a la vez el paquete con que hay conflicto es
> necesario, me explico:
> 1° me sale esto en el terminal después de un "aptitude install
> libreoffice-core"
>
> No se satisfacen las dependencias de los siguientes paquetes:
>   libreoffice-common: Entra en conflicto: libtextcat-data pero está
> instalado 2.2-9.
> Las acciones siguientes resolverán estas dependencias
>
>      Eliminar los paquetes siguientes:
> 1)     libtextcat-data
>
>      Dejar las siguientes dependencias sin resolver:
> 2)     libreoffice-common recomienda libtextcat-data-utf8

lo que me parece raro es que hable de dependencia y luego diga que el
paquete es "recomendado"
De todas maneras, yo optaría por eliminar 'libtextcat-data' =)
--
Alejandro Matos
http://s3.amazonaws.com/theoatmeal-img/comics/email/4.png


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: http://lists.debian.org/BANLkTi=-Pe3BYspJD5b8QvungLqq3hj4Rw@...

Reply | Threaded
Open this post in threaded view
|

Re: OT: opción para instalar libreoffice desde los repositorios

Tony Palma-2
El Fri, 8 Apr 2011 02:58:23 +0200
Alejandro <[hidden email]> escribió:

> El día 8 de abril de 2011 02:09, Paulo Riquelme <[hidden email]>
> escribió:
> > Hola lista, tengo una duda, hoy busqué libreoffice en los
> > repositorios y para mi sorpresa ya se encuentra ahí... perdón debí
> > empezar mencionando que uso testing.
> >
> > Mi duda es que al tratar de instalar libreoffice-core el sistema me
> > dice que hay conflictos pero que a la vez el paquete con que hay
> > conflicto es necesario, me explico:
> > 1° me sale esto en el terminal después de un "aptitude install
> > libreoffice-core"
> >
> > No se satisfacen las dependencias de los siguientes paquetes:
> >   libreoffice-common: Entra en conflicto: libtextcat-data pero está
> > instalado 2.2-9.
> > Las acciones siguientes resolverán estas dependencias
> >
> >      Eliminar los paquetes siguientes:
> > 1)     libtextcat-data
> >
> >      Dejar las siguientes dependencias sin resolver:
> > 2)     libreoffice-common recomienda libtextcat-data-utf8
>
> lo que me parece raro es que hable de dependencia y luego diga que el
> paquete es "recomendado"
> De todas maneras, yo optaría por eliminar 'libtextcat-data' =)
> --
> Alejandro Matos
> http://s3.amazonaws.com/theoatmeal-img/comics/email/4.png
>
>
Que tal, me llama la atención debido a que:

$ apt-cache show libtextcat-data | grep libtextcat-data-utf8
Replaces: libtextcat-data-utf8, libtextcat0 (<< 2.2-1)
Provides: libtextcat-data-utf8
Conflicts: libtextcat-data-utf8
$ apt-cache showpkg libreoffice-core | grep libtextcat
$ apt-cache show libtextcat-data | grep -i version
Version: 2.2-9

Y también estoy en testing. Te recomendaría como menciona Alejandro,
que remuevas y 'purges' el otro paquete e instales el que provee
(libtextcat-data-utf8)


signature.asc (853 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OT: opción para instalar libreoffice desde los repositorios

JavierDebian
In reply to this post by Paulo Riquelme Olivares
El 07/04/11 21:09, Paulo Riquelme escribió:

> Hola lista, tengo una duda, hoy busqué libreoffice en los repositorios
> y para mi sorpresa ya se encuentra ahí... perdón debí empezar
> mencionando que uso testing.
>
> Mi duda es que al tratar de instalar libreoffice-core el sistema me
> dice que hay conflictos pero que a la vez el paquete con que hay
> conflicto es necesario, me explico:
> 1° me sale esto en el terminal después de un "aptitude install
> libreoffice-core"
>
> No se satisfacen las dependencias de los siguientes paquetes:
>   libreoffice-common: Entra en conflicto: libtextcat-data pero está
> instalado 2.2-9.
> Las acciones siguientes resolverán estas dependencias
>
>      Eliminar los paquetes siguientes:
> 1)     libtextcat-data
>
>      Dejar las siguientes dependencias sin resolver:
> 2)     libreoffice-common recomienda libtextcat-data-utf8
>
> ##------Entonces primero tengo que libreoffice-common tiene conflicto
> con libtexcat-data y segundo libreoffice-common recomienda
> libtextcat-data-utf8 (paquete que según leí es un paquete virtual que
> es proporcionado por libtextcat-data) entonces mi consulta si alguien
> sabe ¿qué sería lo recomendable? eliminar libtextcat-data o la opción
> 2 de dejar esas dependencias no resueltas?
>
> Si mi duda es muy básica o si está mal planteada se agradecen las
> críticas constructivas,
>
> muchas gracias,
>
> Paulo
>
Yo instalé Libre Office apenas estuvo disponible.
Cuando salieron en testing, Debian metió un paquete OpenOffice de
transición que no compatibilizaba mucho.
La solución fue

Limpiar OpenOffce del sistema
# apt-get remove openoffice.org --purge
# apt-get autoremove --purge
$ rmdir ~/.openoffice.org (esto en cada carpeta de usuario)

# apt-get install libreoffice

Y no hubo problemas de ningún tipo, salvo volver a definir mis
plantillas personales y volver a dar de alta los plugins que me nteresan.

JAP




--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: http://lists.debian.org/4D9F38D2.9090309@...