OT: software kmymoney y problema con las dependencias

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OT: software kmymoney y problema con las dependencias

Marcelo Eduardo Giordano
Hola amigos. Tengo debian 9 xfce

y ejecuto lo siguiente

dpkg -i kmymoney_5.0.3-2_amd64.deb

y me da el siguiente error........ Gracias por la ayuda

(Leyendo la base de datos ... 278501 ficheros o directorios instalados
actualmente.)
Preparando para desempaquetar kmymoney_5.0.3-2_amd64.deb ...
Desempaquetando kmymoney (5.0.3-2) sobre (5.0.3-2) ...
dpkg: problemas de dependencias impiden la configuración de kmymoney:
  kmymoney depende de libalkimia5-7 (>= 7.0); sin embargo:
   El paquete `libalkimia5-7' no está instalado.
  kmymoney depende de libgpgmepp6 (>= 1.12.0); sin embargo:
   La versión de `libgpgmepp6:amd64' en el sistema es 1.8.0-3+b2.
  kmymoney depende de libgwengui-qt5-0; sin embargo:
   El paquete `libgwengui-qt5-0' no está instalado.
  kmymoney depende de libical3 (>= 3.0.0); sin embargo:
   El paquete `libical3' no está instalado.
  kmymoney depende de libkchart2 (>= 2.6.0); sin embargo:
   El paquete `libkchart2' no está instalado.
  kmymoney depende de libkf5akonadicore5abi2 (>= 4:18.07.90); sin embargo:
   El paquete `libkf5akonadicore5abi2' no está instalado.
  kmymoney depende de libkf5contacts5 (>= 4:15.07.90); sin embargo:
   La versión de `libkf5contacts5:amd64' en el sistema es 16.04.2-1.
  kmymoney depende de libkf5kiogui5; sin embargo:
   El paquete `libkf5kiogui5' no está instalado.
  kmymoney depende de libkf5webkit5 (>= 4.96.0); sin embargo:
   El paquete `libkf5webkit5' no está instalado.
  kmymoney depende de libofx7; sin embargo:
   El paquete `libofx7' no está instalado.
  kmymoney depende de libqt5core5a (>= 5.11.0~rc1); sin embargo:
   La versión de `libqt5core5a:amd64' en el sistema es 5.7.1+dfsg-3+deb9u1.
  kmymoney depende de libqt5gui5 (>= 5.8.0); sin embargo:
   La versión de `libqt5gui5:amd64' en el sistema es 5.7.1+dfsg-3+deb9u1.
  kmymoney depende de libqt5widgets5 (>= 5.11.0~rc1); sin embargo:
   La versión de `libqt5widgets5:amd64' en el sistema es
5.7.1+dfsg-3+deb9u1.
  kmymoney depende de libsqlcipher0 (>= 1.1.9); sin embargo:
   El paquete `libsqlcipher0' no está instalado.
  kmymoney depende de qtbase-abi-5-11-3; sin embargo:
   El paquete `qtbase-abi-5-11-3' no está instalado.
  kmymoney depende de kmymoney-common (= 5.0.3-2); sin embargo:
   La versión de `kmymoney-common' en el sistema es 4.8.0-2.

Reply | Threaded
Open this post in threaded view
|

Re: OT: software kmymoney y problema con las dependencias

Roberto C. Sánchez-2
On Tue, Mar 12, 2019 at 12:23:59PM -0300, Marcelo Eduardo Giordano wrote:
> Hola amigos. Tengo debian 9 xfce
>
> y ejecuto lo siguiente
>
> dpkg -i kmymoney_5.0.3-2_amd64.deb
>
Parece que intentas instalar una versión de kmymoney que no corresponde
a tu versión de Debian.  La versión actual para Debian 9 stretch es
4.8.0-2 (como está indicado en el error de kmymoney-common al fin de los
errores).

> y me da el siguiente error........ Gracias por la ayuda
>
> (Leyendo la base de datos ... 278501 ficheros o directorios instalados
> actualmente.)
> Preparando para desempaquetar kmymoney_5.0.3-2_amd64.deb ...
> Desempaquetando kmymoney (5.0.3-2) sobre (5.0.3-2) ...
> dpkg: problemas de dependencias impiden la configuración de kmymoney:
>  kmymoney depende de libalkimia5-7 (>= 7.0); sin embargo:
>   El paquete `libalkimia5-7' no está instalado.
>  kmymoney depende de libgpgmepp6 (>= 1.12.0); sin embargo:
>   La versión de `libgpgmepp6:amd64' en el sistema es 1.8.0-3+b2.
>  kmymoney depende de libgwengui-qt5-0; sin embargo:
>   El paquete `libgwengui-qt5-0' no está instalado.
>  kmymoney depende de libical3 (>= 3.0.0); sin embargo:
>   El paquete `libical3' no está instalado.
>  kmymoney depende de libkchart2 (>= 2.6.0); sin embargo:
>   El paquete `libkchart2' no está instalado.
>  kmymoney depende de libkf5akonadicore5abi2 (>= 4:18.07.90); sin embargo:
>   El paquete `libkf5akonadicore5abi2' no está instalado.
>  kmymoney depende de libkf5contacts5 (>= 4:15.07.90); sin embargo:
>   La versión de `libkf5contacts5:amd64' en el sistema es 16.04.2-1.
>  kmymoney depende de libkf5kiogui5; sin embargo:
>   El paquete `libkf5kiogui5' no está instalado.
>  kmymoney depende de libkf5webkit5 (>= 4.96.0); sin embargo:
>   El paquete `libkf5webkit5' no está instalado.
>  kmymoney depende de libofx7; sin embargo:
>   El paquete `libofx7' no está instalado.
>  kmymoney depende de libqt5core5a (>= 5.11.0~rc1); sin embargo:
>   La versión de `libqt5core5a:amd64' en el sistema es 5.7.1+dfsg-3+deb9u1.
>  kmymoney depende de libqt5gui5 (>= 5.8.0); sin embargo:
>   La versión de `libqt5gui5:amd64' en el sistema es 5.7.1+dfsg-3+deb9u1.
>  kmymoney depende de libqt5widgets5 (>= 5.11.0~rc1); sin embargo:
>   La versión de `libqt5widgets5:amd64' en el sistema es 5.7.1+dfsg-3+deb9u1.
>  kmymoney depende de libsqlcipher0 (>= 1.1.9); sin embargo:
>   El paquete `libsqlcipher0' no está instalado.
>  kmymoney depende de qtbase-abi-5-11-3; sin embargo:
>   El paquete `qtbase-abi-5-11-3' no está instalado.
>  kmymoney depende de kmymoney-common (= 5.0.3-2); sin embargo:
>   La versión de `kmymoney-common' en el sistema es 4.8.0-2.
>

Es posible que se pueda instalar kmymoney de buster con pinning:
https://wiki.debian.org/es/AptPreferences

Pero, eso lleva riesgo de causar otros problemas, tal vez problemas
serios que pueden dejar partes de tu sistema inútiles.

Teniendo en cuenta que la versión 5 de kmymoney requiere Qt5, debes
hacer unas de estas cosas:

- confórmate con kmymoney 4.8.0 en stretch
- actualize tu sistemo a Debian 10 buster (el estreno ya viene en pocos
  meses)
- instale a kmymoney 5 de fuentes

Saludos,

-Roberto

--
Roberto C. Sánchez