Problem with nvidia driver and Gnome Backgrounds

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with nvidia driver and Gnome Backgrounds

Johan Kröckel-2
Dear Maintainer,
I am a little bit annoyed of bug #768896 and I am starting to suspect,
that it could be another package which causes the problem.
It seems, that the backgrounds are stored in memory, which is not
powered over suspend and not refreshed after wakeup.
I really want to help with this bug, but I dont know how. Do you have any ideas?

Thanks

Johan

ps: Please cc me, i am not subscribed.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/CABgvyo-rAAaN9+kB22BTWr0+UxWey9+JCQ46KNTUdgb7Zxu0Hg@...

Reply | Threaded
Open this post in threaded view
|

Re: Problem with nvidia driver and Gnome Backgrounds

Paul Wise via nm
On Fri, Dec 5, 2014 at 2:38 PM, Johan Kröckel wrote:

> I am a little bit annoyed of bug #768896 and I am starting to suspect,
> that it could be another package which causes the problem.
> It seems, that the backgrounds are stored in memory, which is not
> powered over suspend and not refreshed after wakeup.
> I really want to help with this bug, but I dont know how. Do you have any ideas?

I'd suggest trying these things:

Try the noveau driver instead of the nvidia one. To switch you will
need to purge the nvidia drivers and reboot (I think).

Try older versions of the kernel and nvidia packages.

http://snapshot.debian.org/package/linux/
http://snapshot.debian.org/package/nvidia-graphics-drivers/

Try the troubleshooting info on the wiki:

https://wiki.debian.org/NvidiaGraphicsDrivers/Troubleshooting

A workaround might be:

Restart gnome-shell after resume; WindowsKey+R, type 'restart'
(without quotes) in the command-box, press Enter.

> ps: Please cc me, i am not subscribed.

Done, no need to CC me though.

--
bye,
pabs

https://wiki.debian.org/PaulWise


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/CAKTje6H9DX5SmxPQ4EnKZ09u97C3QF_YoNeJY5fWirSf8Cb_vw@...

Reply | Threaded
Open this post in threaded view
|

Re: Problem with nvidia driver and Gnome Backgrounds

Johan Kröckel-2
The nouveau driver does not support my graphics adapter but my older
adapter was supported and nouveau is not affected by this bug. I would
be happy to use the os driver.
I will try the troubleshooting things. thanks.

2014-12-05 8:00 GMT+01:00 Paul Wise <[hidden email]>:

> On Fri, Dec 5, 2014 at 2:38 PM, Johan Kröckel wrote:
>
>> I am a little bit annoyed of bug #768896 and I am starting to suspect,
>> that it could be another package which causes the problem.
>> It seems, that the backgrounds are stored in memory, which is not
>> powered over suspend and not refreshed after wakeup.
>> I really want to help with this bug, but I dont know how. Do you have any ideas?
>
> I'd suggest trying these things:
>
> Try the noveau driver instead of the nvidia one. To switch you will
> need to purge the nvidia drivers and reboot (I think).
>
> Try older versions of the kernel and nvidia packages.
>
> http://snapshot.debian.org/package/linux/
> http://snapshot.debian.org/package/nvidia-graphics-drivers/
>
> Try the troubleshooting info on the wiki:
>
> https://wiki.debian.org/NvidiaGraphicsDrivers/Troubleshooting
>
> A workaround might be:
>
> Restart gnome-shell after resume; WindowsKey+R, type 'restart'
> (without quotes) in the command-box, press Enter.
>
>> ps: Please cc me, i am not subscribed.
>
> Done, no need to CC me though.
>
> --
> bye,
> pabs
>
> https://wiki.debian.org/PaulWise


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/CABgvyo9bVc2y3gbmaa206J+tpJ5E+-D4AbJ49YmP69FuYYiP_g@...

Reply | Threaded
Open this post in threaded view
|

Re: Problem with nvidia driver and Gnome Backgrounds

Josselin Mouette
In reply to this post by Johan Kröckel-2
Hi,

Le vendredi 05 décembre 2014 à 07:38 +0100, Johan Kröckel a écrit :
> I am a little bit annoyed of bug #768896 and I am starting to suspect,
> that it could be another package which causes the problem.
> It seems, that the backgrounds are stored in memory, which is not
> powered over suspend and not refreshed after wakeup.
> I really want to help with this bug, but I dont know how. Do you have any ideas?

I have seen the exact same bug on VMware windows when resuming from
suspend with wheezy+nvidia-glx 339.  So this definitely looks like a
nVidia bug which needs to be taken upstream.

--
 .''`.      Josselin Mouette
: :' :
`. `'
  `-


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/1417775156.17676.2.camel@...