Problema com dependências de pacotes

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema com dependências de pacotes

Leonardo S. S. da Rocha
Meus amigos, boa tarde!

recorro a vocês para que me ajudem com esse problema. Um colega
acessou o servidor em produção e instalou pacotes que criaram um
problemão pra mim.  Agora tento resolver as dependências e não estou
conseguindo. Veja o erro:

~# apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos
e 0 não atualizados.
26 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Configurando php7.2-common (7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0) ...
dpkg: erro ao processar o pacote php7.2-common (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
dpkg: problemas com dependências impedem a configuração de php7.2-curl:
php7.2-curl depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-curl (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-curl:
php-curl depende de php7.2-curl; porém:
Pacote php7.2-curl não está configurado ainda.
dpkg: erro ao processar o pacote php-curl (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-mbstring:
php7.2-mbstring depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-mbstring (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-bz2:
php7.2-bz2 depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-bz2 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-mbstring:
php-mbstring depende de php7.2-mbstring; porém:
Pacote php7.2-mbstring não está configurado ainda.
dpkg: erro ao processar o pacote php-mbstring (--configure):

problemas de dependência - deixando desconfigurado

Configurando php5.6-gd (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
dpkg: erro ao processar o pacote php5.6-gd (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
Configurando php7.0-common (7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf) ...
dpkg: erro ao processar o pacote php7.0-common (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
Configurando dbconfig-common (2.0.8) ...
dpkg: erro ao processar o pacote dbconfig-common (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
dpkg: problemas com dependências impedem a configuração de dbconfig-mysql:
dbconfig-mysql depende de dbconfig-common (= 2.0.8); porém:
Pacote dbconfig-common não está configurado ainda.
dpkg: erro ao processar o pacote dbconfig-mysql (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-mysql:
php7.2-mysql depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-mysql (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-xml:
php7.2-xml depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-xml (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-zip:
php7.2-zip depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-zip (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-readline:
php7.0-readline depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-readline (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-php-gettext:
php-php-gettext depende de php-mbstring; porém:
Pacote php-mbstring não está configurado ainda.
Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
dpkg: erro ao processar o pacote php-php-gettext (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-bz2:
php-bz2 depende de php7.2-bz2; porém:
Pacote php7.2-bz2 não está configurado ainda.
dpkg: erro ao processar o pacote php-bz2 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-opcache:
php7.0-opcache depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-opcache (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0:
php7.0 depende de php7.0-common; porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de
libapache2-mod-php7.0:
libapache2-mod-php7.0 depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
libapache2-mod-php7.0 depende de php7.0-opcache; porém:
Pacote php7.0-opcache não está configurado ainda.
dpkg: erro ao processar o pacote libapache2-mod-php7.0 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-cli:
php7.0-cli depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
php7.0-cli depende de php7.0-opcache; porém:
Pacote php7.0-opcache não está configurado ainda.
php7.0-cli depende de php7.0-readline; porém:
Pacote php7.0-readline não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-cli (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-zip:
php-zip depende de php7.2-zip; porém:
Pacote php7.2-zip não está configurado ainda.
dpkg: erro ao processar o pacote php-zip (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-xml:
php-xml depende de php7.2-xml; porém:
Pacote php7.2-xml não está configurado ainda.
dpkg: erro ao processar o pacote php-xml (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de phpmyadmin:
phpmyadmin depende de php-mbstring; porém:
Pacote php-mbstring não está configurado ainda.
Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
phpmyadmin depende de php-xml; porém:
Pacote php-xml não está configurado ainda.
Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
phpmyadmin depende de dbconfig-mysql | dbconfig-no-thanks |
dbconfig-common (<< 2.0.0); porém:
Pacote dbconfig-mysql não está configurado ainda.
Pacote dbconfig-no-thanks não está instalado.
Versão de dbconfig-common no sistema é 2.0.8.
phpmyadmin depende de php-php-gettext | php-gettext (<= 1:7.0); porém:
Pacote php-php-gettext não está configurado ainda.
Pacote php-gettext não está instalado.
dpkg: erro ao processar o pacote phpmyadmin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-json:
php7.0-json depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-json (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-pear:
php-pear depende de php-xml; porém:
Pacote php-xml não está configurado ainda.
Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
dpkg: erro ao processar o pacote php-pear (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-mysql:
php-mysql depende de php7.2-mysql; porém:
Pacote php7.2-mysql não está configurado ainda.
dpkg: erro ao processar o pacote php-mysql (--configure):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para libapache2-mod-php5.6
(5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
Erros foram encontrados durante o processamento de:
php7.2-common
php7.2-curl
php-curl
php7.2-mbstring
php7.2-bz2
php-mbstring
php5.6-gd
php7.0-common
dbconfig-common
dbconfig-mysql
php7.2-mysql
php7.2-xml
php7.2-zip
php7.0-readline
php-php-gettext
php-bz2
php7.0-opcache
php7.0
libapache2-mod-php7.0
php7.0-cli
php-zip
php-xml
phpmyadmin
php7.0-json
php-pear
php-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)

Como podem ver já tentei várias coisas que encontrei na internet mas
não consegui nada. Por exemplo, os seguintes links:

https://ubuntuforum-br.org/index.php?topic=120695.0
https://itsfoss.com/dpkg-returned-an-error-code-1/
https://www.vivaolinux.com.br/dica/apt-E-Sub-process-usrbindpkg-returned-an-error-code-1-Resolvido
https://ubuntuforums.org/showthread.php?t=2376764

E tantas outras coisas. Eu realmente não sei mais o que fazer. Já
desinstalei com purge e ao instalar novamente dá esse problema. Estou
com Debian stretch nesse servidor de produção. Tenho (tinha)
phpmyadmin, mysql, php5.6, php7.0 e php.71, apache2 essas coisas. O
que devo fazer agora? Alguém consegue me ajudar com isso! A cabeça tá
quente já!

Agradeço muito a disponibilidade e peço desculpas pelo tamanho do
texto aqui na lista.

Abraço.

Leonardo Rocha.

Reply | Threaded
Open this post in threaded view
|

Re: Problema com dependências de pacotes

Rodolfo-17
"Já desinstalei com purge e ao instalar novamente"

O que exatamente você desinstalou com purge e o que exatamente você tentou instalar novamente?

Rode o comando # dpkg -C para verificar se existem pacotes quebrados.

Uma boa tentativa é você rodar a instalação/desinstalação com aptitude, o gerenciamento dele é mais robusto.

Abs.

Em qua, 31 de out de 2018 às 12:08, Leonardo S. S. da Rocha <[hidden email]> escreveu:
Meus amigos, boa tarde!

recorro a vocês para que me ajudem com esse problema. Um colega
acessou o servidor em produção e instalou pacotes que criaram um
problemão pra mim.  Agora tento resolver as dependências e não estou
conseguindo. Veja o erro:

~# apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos
e 0 não atualizados.
26 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Configurando php7.2-common (7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0) ...
dpkg: erro ao processar o pacote php7.2-common (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
dpkg: problemas com dependências impedem a configuração de php7.2-curl:
php7.2-curl depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-curl (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-curl:
php-curl depende de php7.2-curl; porém:
Pacote php7.2-curl não está configurado ainda.
dpkg: erro ao processar o pacote php-curl (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-mbstring:
php7.2-mbstring depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-mbstring (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-bz2:
php7.2-bz2 depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-bz2 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-mbstring:
php-mbstring depende de php7.2-mbstring; porém:
Pacote php7.2-mbstring não está configurado ainda.
dpkg: erro ao processar o pacote php-mbstring (--configure):

problemas de dependência - deixando desconfigurado

Configurando php5.6-gd (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
dpkg: erro ao processar o pacote php5.6-gd (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
Configurando php7.0-common (7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf) ...
dpkg: erro ao processar o pacote php7.0-common (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
Configurando dbconfig-common (2.0.8) ...
dpkg: erro ao processar o pacote dbconfig-common (--configure):
sub-processo script post-installation instalado retornou estado de
saída de erro 10
dpkg: problemas com dependências impedem a configuração de dbconfig-mysql:
dbconfig-mysql depende de dbconfig-common (= 2.0.8); porém:
Pacote dbconfig-common não está configurado ainda.
dpkg: erro ao processar o pacote dbconfig-mysql (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-mysql:
php7.2-mysql depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-mysql (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-xml:
php7.2-xml depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-xml (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.2-zip:
php7.2-zip depende de php7.2-common (=
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
Pacote php7.2-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.2-zip (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-readline:
php7.0-readline depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-readline (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-php-gettext:
php-php-gettext depende de php-mbstring; porém:
Pacote php-mbstring não está configurado ainda.
Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
dpkg: erro ao processar o pacote php-php-gettext (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-bz2:
php-bz2 depende de php7.2-bz2; porém:
Pacote php7.2-bz2 não está configurado ainda.
dpkg: erro ao processar o pacote php-bz2 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-opcache:
php7.0-opcache depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-opcache (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0:
php7.0 depende de php7.0-common; porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de
libapache2-mod-php7.0:
libapache2-mod-php7.0 depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
libapache2-mod-php7.0 depende de php7.0-opcache; porém:
Pacote php7.0-opcache não está configurado ainda.
dpkg: erro ao processar o pacote libapache2-mod-php7.0 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-cli:
php7.0-cli depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
php7.0-cli depende de php7.0-opcache; porém:
Pacote php7.0-opcache não está configurado ainda.
php7.0-cli depende de php7.0-readline; porém:
Pacote php7.0-readline não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-cli (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-zip:
php-zip depende de php7.2-zip; porém:
Pacote php7.2-zip não está configurado ainda.
dpkg: erro ao processar o pacote php-zip (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-xml:
php-xml depende de php7.2-xml; porém:
Pacote php7.2-xml não está configurado ainda.
dpkg: erro ao processar o pacote php-xml (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de phpmyadmin:
phpmyadmin depende de php-mbstring; porém:
Pacote php-mbstring não está configurado ainda.
Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
phpmyadmin depende de php-xml; porém:
Pacote php-xml não está configurado ainda.
Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
phpmyadmin depende de dbconfig-mysql | dbconfig-no-thanks |
dbconfig-common (<< 2.0.0); porém:
Pacote dbconfig-mysql não está configurado ainda.
Pacote dbconfig-no-thanks não está instalado.
Versão de dbconfig-common no sistema é 2.0.8.
phpmyadmin depende de php-php-gettext | php-gettext (<= 1:7.0); porém:
Pacote php-php-gettext não está configurado ainda.
Pacote php-gettext não está instalado.
dpkg: erro ao processar o pacote phpmyadmin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php7.0-json:
php7.0-json depende de php7.0-common (=
7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
Pacote php7.0-common não está configurado ainda.
dpkg: erro ao processar o pacote php7.0-json (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-pear:
php-pear depende de php-xml; porém:
Pacote php-xml não está configurado ainda.
Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
dpkg: erro ao processar o pacote php-pear (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-mysql:
php-mysql depende de php7.2-mysql; porém:
Pacote php7.2-mysql não está configurado ainda.
dpkg: erro ao processar o pacote php-mysql (--configure):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para libapache2-mod-php5.6
(5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
Erros foram encontrados durante o processamento de:
php7.2-common
php7.2-curl
php-curl
php7.2-mbstring
php7.2-bz2
php-mbstring
php5.6-gd
php7.0-common
dbconfig-common
dbconfig-mysql
php7.2-mysql
php7.2-xml
php7.2-zip
php7.0-readline
php-php-gettext
php-bz2
php7.0-opcache
php7.0
libapache2-mod-php7.0
php7.0-cli
php-zip
php-xml
phpmyadmin
php7.0-json
php-pear
php-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)

Como podem ver já tentei várias coisas que encontrei na internet mas
não consegui nada. Por exemplo, os seguintes links:

https://ubuntuforum-br.org/index.php?topic=120695.0
https://itsfoss.com/dpkg-returned-an-error-code-1/
https://www.vivaolinux.com.br/dica/apt-E-Sub-process-usrbindpkg-returned-an-error-code-1-Resolvido
https://ubuntuforums.org/showthread.php?t=2376764

E tantas outras coisas. Eu realmente não sei mais o que fazer. Já
desinstalei com purge e ao instalar novamente dá esse problema. Estou
com Debian stretch nesse servidor de produção. Tenho (tinha)
phpmyadmin, mysql, php5.6, php7.0 e php.71, apache2 essas coisas. O
que devo fazer agora? Alguém consegue me ajudar com isso! A cabeça tá
quente já!

Agradeço muito a disponibilidade e peço desculpas pelo tamanho do
texto aqui na lista.

Abraço.

Leonardo Rocha.

Reply | Threaded
Open this post in threaded view
|

Re: Problema com dependências de pacotes

Leonardo S. S. da Rocha
Tudo Rodolfo, removi e tentei instalar:
apache2 e as versões de PHP (5.6, 7.0 e 7.1) que estavam instaladas.

Comandos que utilizei: apt-get remove --purge / apt-get purge /
apt-get remove / apt-get autoremove / apt-get install -f / dpkg
--configure -a e etc. Vou tentar essa do dpkg que me sugere. Posto
aqui!


Obrigado pela ajuda.
Em qua, 31 de out de 2018 às 14:29, Rodolfo <[hidden email]> escreveu:

>
> "Já desinstalei com purge e ao instalar novamente"
>
> O que exatamente você desinstalou com purge e o que exatamente você tentou instalar novamente?
>
> Rode o comando # dpkg -C para verificar se existem pacotes quebrados.
>
> Uma boa tentativa é você rodar a instalação/desinstalação com aptitude, o gerenciamento dele é mais robusto.
>
> Abs.
>
> Em qua, 31 de out de 2018 às 12:08, Leonardo S. S. da Rocha <[hidden email]> escreveu:
>>
>> Meus amigos, boa tarde!
>>
>> recorro a vocês para que me ajudem com esse problema. Um colega
>> acessou o servidor em produção e instalou pacotes que criaram um
>> problemão pra mim.  Agora tento resolver as dependências e não estou
>> conseguindo. Veja o erro:
>>
>> ~# apt-get -f install
>> Lendo listas de pacotes... Pronto
>> Construindo árvore de dependências
>> Lendo informação de estado... Pronto
>> 0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos
>> e 0 não atualizados.
>> 26 pacotes não totalmente instalados ou removidos.
>> Depois desta operação, 0 B adicionais de espaço em disco serão usados.
>> Configurando php7.2-common (7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0) ...
>> dpkg: erro ao processar o pacote php7.2-common (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> dpkg: problemas com dependências impedem a configuração de php7.2-curl:
>> php7.2-curl depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-curl (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-curl:
>> php-curl depende de php7.2-curl; porém:
>> Pacote php7.2-curl não está configurado ainda.
>> dpkg: erro ao processar o pacote php-curl (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-mbstring:
>> php7.2-mbstring depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-mbstring (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-bz2:
>> php7.2-bz2 depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-bz2 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-mbstring:
>> php-mbstring depende de php7.2-mbstring; porém:
>> Pacote php7.2-mbstring não está configurado ainda.
>> dpkg: erro ao processar o pacote php-mbstring (--configure):
>>
>> problemas de dependência - deixando desconfigurado
>>
>> Configurando php5.6-gd (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
>> dpkg: erro ao processar o pacote php5.6-gd (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> Configurando php7.0-common (7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf) ...
>> dpkg: erro ao processar o pacote php7.0-common (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> Configurando dbconfig-common (2.0.8) ...
>> dpkg: erro ao processar o pacote dbconfig-common (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> dpkg: problemas com dependências impedem a configuração de dbconfig-mysql:
>> dbconfig-mysql depende de dbconfig-common (= 2.0.8); porém:
>> Pacote dbconfig-common não está configurado ainda.
>> dpkg: erro ao processar o pacote dbconfig-mysql (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-mysql:
>> php7.2-mysql depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-mysql (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-xml:
>> php7.2-xml depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-xml (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-zip:
>> php7.2-zip depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-zip (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-readline:
>> php7.0-readline depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-readline (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-php-gettext:
>> php-php-gettext depende de php-mbstring; porém:
>> Pacote php-mbstring não está configurado ainda.
>> Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
>> dpkg: erro ao processar o pacote php-php-gettext (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-bz2:
>> php-bz2 depende de php7.2-bz2; porém:
>> Pacote php7.2-bz2 não está configurado ainda.
>> dpkg: erro ao processar o pacote php-bz2 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-opcache:
>> php7.0-opcache depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-opcache (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0:
>> php7.0 depende de php7.0-common; porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de
>> libapache2-mod-php7.0:
>> libapache2-mod-php7.0 depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> libapache2-mod-php7.0 depende de php7.0-opcache; porém:
>> Pacote php7.0-opcache não está configurado ainda.
>> dpkg: erro ao processar o pacote libapache2-mod-php7.0 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-cli:
>> php7.0-cli depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> php7.0-cli depende de php7.0-opcache; porém:
>> Pacote php7.0-opcache não está configurado ainda.
>> php7.0-cli depende de php7.0-readline; porém:
>> Pacote php7.0-readline não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-cli (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-zip:
>> php-zip depende de php7.2-zip; porém:
>> Pacote php7.2-zip não está configurado ainda.
>> dpkg: erro ao processar o pacote php-zip (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-xml:
>> php-xml depende de php7.2-xml; porém:
>> Pacote php7.2-xml não está configurado ainda.
>> dpkg: erro ao processar o pacote php-xml (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de phpmyadmin:
>> phpmyadmin depende de php-mbstring; porém:
>> Pacote php-mbstring não está configurado ainda.
>> Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
>> phpmyadmin depende de php-xml; porém:
>> Pacote php-xml não está configurado ainda.
>> Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
>> phpmyadmin depende de dbconfig-mysql | dbconfig-no-thanks |
>> dbconfig-common (<< 2.0.0); porém:
>> Pacote dbconfig-mysql não está configurado ainda.
>> Pacote dbconfig-no-thanks não está instalado.
>> Versão de dbconfig-common no sistema é 2.0.8.
>> phpmyadmin depende de php-php-gettext | php-gettext (<= 1:7.0); porém:
>> Pacote php-php-gettext não está configurado ainda.
>> Pacote php-gettext não está instalado.
>> dpkg: erro ao processar o pacote phpmyadmin (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-json:
>> php7.0-json depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-json (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-pear:
>> php-pear depende de php-xml; porém:
>> Pacote php-xml não está configurado ainda.
>> Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
>> dpkg: erro ao processar o pacote php-pear (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-mysql:
>> php-mysql depende de php7.2-mysql; porém:
>> Pacote php7.2-mysql não está configurado ainda.
>> dpkg: erro ao processar o pacote php-mysql (--configure):
>> problemas de dependência - deixando desconfigurado
>> A processar 'triggers' para libapache2-mod-php5.6
>> (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
>> Erros foram encontrados durante o processamento de:
>> php7.2-common
>> php7.2-curl
>> php-curl
>> php7.2-mbstring
>> php7.2-bz2
>> php-mbstring
>> php5.6-gd
>> php7.0-common
>> dbconfig-common
>> dbconfig-mysql
>> php7.2-mysql
>> php7.2-xml
>> php7.2-zip
>> php7.0-readline
>> php-php-gettext
>> php-bz2
>> php7.0-opcache
>> php7.0
>> libapache2-mod-php7.0
>> php7.0-cli
>> php-zip
>> php-xml
>> phpmyadmin
>> php7.0-json
>> php-pear
>> php-mysql
>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>
>> Como podem ver já tentei várias coisas que encontrei na internet mas
>> não consegui nada. Por exemplo, os seguintes links:
>>
>> https://ubuntuforum-br.org/index.php?topic=120695.0
>> https://itsfoss.com/dpkg-returned-an-error-code-1/
>> https://www.vivaolinux.com.br/dica/apt-E-Sub-process-usrbindpkg-returned-an-error-code-1-Resolvido
>> https://ubuntuforums.org/showthread.php?t=2376764
>>
>> E tantas outras coisas. Eu realmente não sei mais o que fazer. Já
>> desinstalei com purge e ao instalar novamente dá esse problema. Estou
>> com Debian stretch nesse servidor de produção. Tenho (tinha)
>> phpmyadmin, mysql, php5.6, php7.0 e php.71, apache2 essas coisas. O
>> que devo fazer agora? Alguém consegue me ajudar com isso! A cabeça tá
>> quente já!
>>
>> Agradeço muito a disponibilidade e peço desculpas pelo tamanho do
>> texto aqui na lista.
>>
>> Abraço.
>>
>> Leonardo Rocha.
>>

Reply | Threaded
Open this post in threaded view
|

Re: Problema com dependências de pacotes

Rodolfo-17
Não esquece de usar o aptitude ao invés de apt-get.

Abs.

Em qua, 31 de out de 2018 às 14:04, Leonardo S. S. da Rocha <[hidden email]> escreveu:
Tudo Rodolfo, removi e tentei instalar:
apache2 e as versões de PHP (5.6, 7.0 e 7.1) que estavam instaladas.

Comandos que utilizei: apt-get remove --purge / apt-get purge /
apt-get remove / apt-get autoremove / apt-get install -f / dpkg
--configure -a e etc. Vou tentar essa do dpkg que me sugere. Posto
aqui!


Obrigado pela ajuda.
Em qua, 31 de out de 2018 às 14:29, Rodolfo <[hidden email]> escreveu:
>
> "Já desinstalei com purge e ao instalar novamente"
>
> O que exatamente você desinstalou com purge e o que exatamente você tentou instalar novamente?
>
> Rode o comando # dpkg -C para verificar se existem pacotes quebrados.
>
> Uma boa tentativa é você rodar a instalação/desinstalação com aptitude, o gerenciamento dele é mais robusto.
>
> Abs.
>
> Em qua, 31 de out de 2018 às 12:08, Leonardo S. S. da Rocha <[hidden email]> escreveu:
>>
>> Meus amigos, boa tarde!
>>
>> recorro a vocês para que me ajudem com esse problema. Um colega
>> acessou o servidor em produção e instalou pacotes que criaram um
>> problemão pra mim.  Agora tento resolver as dependências e não estou
>> conseguindo. Veja o erro:
>>
>> ~# apt-get -f install
>> Lendo listas de pacotes... Pronto
>> Construindo árvore de dependências
>> Lendo informação de estado... Pronto
>> 0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos
>> e 0 não atualizados.
>> 26 pacotes não totalmente instalados ou removidos.
>> Depois desta operação, 0 B adicionais de espaço em disco serão usados.
>> Configurando php7.2-common (7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0) ...
>> dpkg: erro ao processar o pacote php7.2-common (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> dpkg: problemas com dependências impedem a configuração de php7.2-curl:
>> php7.2-curl depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-curl (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-curl:
>> php-curl depende de php7.2-curl; porém:
>> Pacote php7.2-curl não está configurado ainda.
>> dpkg: erro ao processar o pacote php-curl (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-mbstring:
>> php7.2-mbstring depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-mbstring (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-bz2:
>> php7.2-bz2 depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-bz2 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-mbstring:
>> php-mbstring depende de php7.2-mbstring; porém:
>> Pacote php7.2-mbstring não está configurado ainda.
>> dpkg: erro ao processar o pacote php-mbstring (--configure):
>>
>> problemas de dependência - deixando desconfigurado
>>
>> Configurando php5.6-gd (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
>> dpkg: erro ao processar o pacote php5.6-gd (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> Configurando php7.0-common (7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf) ...
>> dpkg: erro ao processar o pacote php7.0-common (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> Configurando dbconfig-common (2.0.8) ...
>> dpkg: erro ao processar o pacote dbconfig-common (--configure):
>> sub-processo script post-installation instalado retornou estado de
>> saída de erro 10
>> dpkg: problemas com dependências impedem a configuração de dbconfig-mysql:
>> dbconfig-mysql depende de dbconfig-common (= 2.0.8); porém:
>> Pacote dbconfig-common não está configurado ainda.
>> dpkg: erro ao processar o pacote dbconfig-mysql (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-mysql:
>> php7.2-mysql depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-mysql (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-xml:
>> php7.2-xml depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-xml (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.2-zip:
>> php7.2-zip depende de php7.2-common (=
>> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
>> Pacote php7.2-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.2-zip (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-readline:
>> php7.0-readline depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-readline (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-php-gettext:
>> php-php-gettext depende de php-mbstring; porém:
>> Pacote php-mbstring não está configurado ainda.
>> Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
>> dpkg: erro ao processar o pacote php-php-gettext (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-bz2:
>> php-bz2 depende de php7.2-bz2; porém:
>> Pacote php7.2-bz2 não está configurado ainda.
>> dpkg: erro ao processar o pacote php-bz2 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-opcache:
>> php7.0-opcache depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-opcache (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0:
>> php7.0 depende de php7.0-common; porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de
>> libapache2-mod-php7.0:
>> libapache2-mod-php7.0 depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> libapache2-mod-php7.0 depende de php7.0-opcache; porém:
>> Pacote php7.0-opcache não está configurado ainda.
>> dpkg: erro ao processar o pacote libapache2-mod-php7.0 (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-cli:
>> php7.0-cli depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> php7.0-cli depende de php7.0-opcache; porém:
>> Pacote php7.0-opcache não está configurado ainda.
>> php7.0-cli depende de php7.0-readline; porém:
>> Pacote php7.0-readline não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-cli (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-zip:
>> php-zip depende de php7.2-zip; porém:
>> Pacote php7.2-zip não está configurado ainda.
>> dpkg: erro ao processar o pacote php-zip (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-xml:
>> php-xml depende de php7.2-xml; porém:
>> Pacote php7.2-xml não está configurado ainda.
>> dpkg: erro ao processar o pacote php-xml (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de phpmyadmin:
>> phpmyadmin depende de php-mbstring; porém:
>> Pacote php-mbstring não está configurado ainda.
>> Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
>> phpmyadmin depende de php-xml; porém:
>> Pacote php-xml não está configurado ainda.
>> Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
>> phpmyadmin depende de dbconfig-mysql | dbconfig-no-thanks |
>> dbconfig-common (<< 2.0.0); porém:
>> Pacote dbconfig-mysql não está configurado ainda.
>> Pacote dbconfig-no-thanks não está instalado.
>> Versão de dbconfig-common no sistema é 2.0.8.
>> phpmyadmin depende de php-php-gettext | php-gettext (<= 1:7.0); porém:
>> Pacote php-php-gettext não está configurado ainda.
>> Pacote php-gettext não está instalado.
>> dpkg: erro ao processar o pacote phpmyadmin (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php7.0-json:
>> php7.0-json depende de php7.0-common (=
>> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
>> Pacote php7.0-common não está configurado ainda.
>> dpkg: erro ao processar o pacote php7.0-json (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-pear:
>> php-pear depende de php-xml; porém:
>> Pacote php-xml não está configurado ainda.
>> Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
>> dpkg: erro ao processar o pacote php-pear (--configure):
>> problemas de dependência - deixando desconfigurado
>> dpkg: problemas com dependências impedem a configuração de php-mysql:
>> php-mysql depende de php7.2-mysql; porém:
>> Pacote php7.2-mysql não está configurado ainda.
>> dpkg: erro ao processar o pacote php-mysql (--configure):
>> problemas de dependência - deixando desconfigurado
>> A processar 'triggers' para libapache2-mod-php5.6
>> (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
>> Erros foram encontrados durante o processamento de:
>> php7.2-common
>> php7.2-curl
>> php-curl
>> php7.2-mbstring
>> php7.2-bz2
>> php-mbstring
>> php5.6-gd
>> php7.0-common
>> dbconfig-common
>> dbconfig-mysql
>> php7.2-mysql
>> php7.2-xml
>> php7.2-zip
>> php7.0-readline
>> php-php-gettext
>> php-bz2
>> php7.0-opcache
>> php7.0
>> libapache2-mod-php7.0
>> php7.0-cli
>> php-zip
>> php-xml
>> phpmyadmin
>> php7.0-json
>> php-pear
>> php-mysql
>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>
>> Como podem ver já tentei várias coisas que encontrei na internet mas
>> não consegui nada. Por exemplo, os seguintes links:
>>
>> https://ubuntuforum-br.org/index.php?topic=120695.0
>> https://itsfoss.com/dpkg-returned-an-error-code-1/
>> https://www.vivaolinux.com.br/dica/apt-E-Sub-process-usrbindpkg-returned-an-error-code-1-Resolvido
>> https://ubuntuforums.org/showthread.php?t=2376764
>>
>> E tantas outras coisas. Eu realmente não sei mais o que fazer. Já
>> desinstalei com purge e ao instalar novamente dá esse problema. Estou
>> com Debian stretch nesse servidor de produção. Tenho (tinha)
>> phpmyadmin, mysql, php5.6, php7.0 e php.71, apache2 essas coisas. O
>> que devo fazer agora? Alguém consegue me ajudar com isso! A cabeça tá
>> quente já!
>>
>> Agradeço muito a disponibilidade e peço desculpas pelo tamanho do
>> texto aqui na lista.
>>
>> Abraço.
>>
>> Leonardo Rocha.
>>

Reply | Threaded
Open this post in threaded view
|

Re: Problema com dependências de pacotes

Fred Maranhão
In reply to this post by Leonardo S. S. da Rocha
o que acontece quando você tenta remover o php7.2-curl?

apt purge php7.2-curl


Le mer. 31 oct. 2018 à 15:04, Leonardo S. S. da Rocha
<[hidden email]> a écrit :

>
> Tudo Rodolfo, removi e tentei instalar:
> apache2 e as versões de PHP (5.6, 7.0 e 7.1) que estavam instaladas.
>
> Comandos que utilizei: apt-get remove --purge / apt-get purge /
> apt-get remove / apt-get autoremove / apt-get install -f / dpkg
> --configure -a e etc. Vou tentar essa do dpkg que me sugere. Posto
> aqui!
>
>
> Obrigado pela ajuda.
> Em qua, 31 de out de 2018 às 14:29, Rodolfo <[hidden email]> escreveu:
> >
> > "Já desinstalei com purge e ao instalar novamente"
> >
> > O que exatamente você desinstalou com purge e o que exatamente você tentou instalar novamente?
> >
> > Rode o comando # dpkg -C para verificar se existem pacotes quebrados.
> >
> > Uma boa tentativa é você rodar a instalação/desinstalação com aptitude, o gerenciamento dele é mais robusto.
> >
> > Abs.
> >
> > Em qua, 31 de out de 2018 às 12:08, Leonardo S. S. da Rocha <[hidden email]> escreveu:
> >>
> >> Meus amigos, boa tarde!
> >>
> >> recorro a vocês para que me ajudem com esse problema. Um colega
> >> acessou o servidor em produção e instalou pacotes que criaram um
> >> problemão pra mim.  Agora tento resolver as dependências e não estou
> >> conseguindo. Veja o erro:
> >>
> >> ~# apt-get -f install
> >> Lendo listas de pacotes... Pronto
> >> Construindo árvore de dependências
> >> Lendo informação de estado... Pronto
> >> 0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos
> >> e 0 não atualizados.
> >> 26 pacotes não totalmente instalados ou removidos.
> >> Depois desta operação, 0 B adicionais de espaço em disco serão usados.
> >> Configurando php7.2-common (7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0) ...
> >> dpkg: erro ao processar o pacote php7.2-common (--configure):
> >> sub-processo script post-installation instalado retornou estado de
> >> saída de erro 10
> >> dpkg: problemas com dependências impedem a configuração de php7.2-curl:
> >> php7.2-curl depende de php7.2-common (=
> >> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
> >> Pacote php7.2-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.2-curl (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-curl:
> >> php-curl depende de php7.2-curl; porém:
> >> Pacote php7.2-curl não está configurado ainda.
> >> dpkg: erro ao processar o pacote php-curl (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.2-mbstring:
> >> php7.2-mbstring depende de php7.2-common (=
> >> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
> >> Pacote php7.2-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.2-mbstring (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.2-bz2:
> >> php7.2-bz2 depende de php7.2-common (=
> >> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
> >> Pacote php7.2-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.2-bz2 (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-mbstring:
> >> php-mbstring depende de php7.2-mbstring; porém:
> >> Pacote php7.2-mbstring não está configurado ainda.
> >> dpkg: erro ao processar o pacote php-mbstring (--configure):
> >>
> >> problemas de dependência - deixando desconfigurado
> >>
> >> Configurando php5.6-gd (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
> >> dpkg: erro ao processar o pacote php5.6-gd (--configure):
> >> sub-processo script post-installation instalado retornou estado de
> >> saída de erro 10
> >> Configurando php7.0-common (7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf) ...
> >> dpkg: erro ao processar o pacote php7.0-common (--configure):
> >> sub-processo script post-installation instalado retornou estado de
> >> saída de erro 10
> >> Configurando dbconfig-common (2.0.8) ...
> >> dpkg: erro ao processar o pacote dbconfig-common (--configure):
> >> sub-processo script post-installation instalado retornou estado de
> >> saída de erro 10
> >> dpkg: problemas com dependências impedem a configuração de dbconfig-mysql:
> >> dbconfig-mysql depende de dbconfig-common (= 2.0.8); porém:
> >> Pacote dbconfig-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote dbconfig-mysql (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.2-mysql:
> >> php7.2-mysql depende de php7.2-common (=
> >> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
> >> Pacote php7.2-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.2-mysql (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.2-xml:
> >> php7.2-xml depende de php7.2-common (=
> >> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
> >> Pacote php7.2-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.2-xml (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.2-zip:
> >> php7.2-zip depende de php7.2-common (=
> >> 7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0); porém:
> >> Pacote php7.2-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.2-zip (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.0-readline:
> >> php7.0-readline depende de php7.0-common (=
> >> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
> >> Pacote php7.0-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.0-readline (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-php-gettext:
> >> php-php-gettext depende de php-mbstring; porém:
> >> Pacote php-mbstring não está configurado ainda.
> >> Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
> >> dpkg: erro ao processar o pacote php-php-gettext (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-bz2:
> >> php-bz2 depende de php7.2-bz2; porém:
> >> Pacote php7.2-bz2 não está configurado ainda.
> >> dpkg: erro ao processar o pacote php-bz2 (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.0-opcache:
> >> php7.0-opcache depende de php7.0-common (=
> >> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
> >> Pacote php7.0-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.0-opcache (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.0:
> >> php7.0 depende de php7.0-common; porém:
> >> Pacote php7.0-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.0 (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de
> >> libapache2-mod-php7.0:
> >> libapache2-mod-php7.0 depende de php7.0-common (=
> >> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
> >> Pacote php7.0-common não está configurado ainda.
> >> libapache2-mod-php7.0 depende de php7.0-opcache; porém:
> >> Pacote php7.0-opcache não está configurado ainda.
> >> dpkg: erro ao processar o pacote libapache2-mod-php7.0 (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.0-cli:
> >> php7.0-cli depende de php7.0-common (=
> >> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
> >> Pacote php7.0-common não está configurado ainda.
> >> php7.0-cli depende de php7.0-opcache; porém:
> >> Pacote php7.0-opcache não está configurado ainda.
> >> php7.0-cli depende de php7.0-readline; porém:
> >> Pacote php7.0-readline não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.0-cli (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-zip:
> >> php-zip depende de php7.2-zip; porém:
> >> Pacote php7.2-zip não está configurado ainda.
> >> dpkg: erro ao processar o pacote php-zip (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-xml:
> >> php-xml depende de php7.2-xml; porém:
> >> Pacote php7.2-xml não está configurado ainda.
> >> dpkg: erro ao processar o pacote php-xml (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de phpmyadmin:
> >> phpmyadmin depende de php-mbstring; porém:
> >> Pacote php-mbstring não está configurado ainda.
> >> Pacote php7.2-mbstring, o qual fornece php-mbstring ainda não está configurado.
> >> phpmyadmin depende de php-xml; porém:
> >> Pacote php-xml não está configurado ainda.
> >> Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
> >> phpmyadmin depende de dbconfig-mysql | dbconfig-no-thanks |
> >> dbconfig-common (<< 2.0.0); porém:
> >> Pacote dbconfig-mysql não está configurado ainda.
> >> Pacote dbconfig-no-thanks não está instalado.
> >> Versão de dbconfig-common no sistema é 2.0.8.
> >> phpmyadmin depende de php-php-gettext | php-gettext (<= 1:7.0); porém:
> >> Pacote php-php-gettext não está configurado ainda.
> >> Pacote php-gettext não está instalado.
> >> dpkg: erro ao processar o pacote phpmyadmin (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php7.0-json:
> >> php7.0-json depende de php7.0-common (=
> >> 7.0.32-2+0~20181015120817.7+stretch~1.gbpa6b8cf); porém:
> >> Pacote php7.0-common não está configurado ainda.
> >> dpkg: erro ao processar o pacote php7.0-json (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-pear:
> >> php-pear depende de php-xml; porém:
> >> Pacote php-xml não está configurado ainda.
> >> Pacote php7.2-xml, o qual fornece php-xml ainda não está configurado.
> >> dpkg: erro ao processar o pacote php-pear (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> dpkg: problemas com dependências impedem a configuração de php-mysql:
> >> php-mysql depende de php7.2-mysql; porém:
> >> Pacote php7.2-mysql não está configurado ainda.
> >> dpkg: erro ao processar o pacote php-mysql (--configure):
> >> problemas de dependência - deixando desconfigurado
> >> A processar 'triggers' para libapache2-mod-php5.6
> >> (5.6.38-2+0~20181015120829.6+stretch~1.gbp567807) ...
> >> Erros foram encontrados durante o processamento de:
> >> php7.2-common
> >> php7.2-curl
> >> php-curl
> >> php7.2-mbstring
> >> php7.2-bz2
> >> php-mbstring
> >> php5.6-gd
> >> php7.0-common
> >> dbconfig-common
> >> dbconfig-mysql
> >> php7.2-mysql
> >> php7.2-xml
> >> php7.2-zip
> >> php7.0-readline
> >> php-php-gettext
> >> php-bz2
> >> php7.0-opcache
> >> php7.0
> >> libapache2-mod-php7.0
> >> php7.0-cli
> >> php-zip
> >> php-xml
> >> phpmyadmin
> >> php7.0-json
> >> php-pear
> >> php-mysql
> >> E: Sub-process /usr/bin/dpkg returned an error code (1)
> >>
> >> Como podem ver já tentei várias coisas que encontrei na internet mas
> >> não consegui nada. Por exemplo, os seguintes links:
> >>
> >> https://ubuntuforum-br.org/index.php?topic=120695.0
> >> https://itsfoss.com/dpkg-returned-an-error-code-1/
> >> https://www.vivaolinux.com.br/dica/apt-E-Sub-process-usrbindpkg-returned-an-error-code-1-Resolvido
> >> https://ubuntuforums.org/showthread.php?t=2376764
> >>
> >> E tantas outras coisas. Eu realmente não sei mais o que fazer. Já
> >> desinstalei com purge e ao instalar novamente dá esse problema. Estou
> >> com Debian stretch nesse servidor de produção. Tenho (tinha)
> >> phpmyadmin, mysql, php5.6, php7.0 e php.71, apache2 essas coisas. O
> >> que devo fazer agora? Alguém consegue me ajudar com isso! A cabeça tá
> >> quente já!
> >>
> >> Agradeço muito a disponibilidade e peço desculpas pelo tamanho do
> >> texto aqui na lista.
> >>
> >> Abraço.
> >>
> >> Leonardo Rocha.
> >>
>