Problems since apt-get upgrade

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems since apt-get upgrade

Florian Ludwig
Hello,

since an apt-get upgrade I have several problems with my gnome desktop...

First some applets doesnt work anymore. Sticknotes, systemmonitor and
some else.

Also i the keylayout managment of gnome dosent work. I get this message:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60900000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

The result of this both command:

# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc104", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc104", "us,de", ",nodeadkeys",
"grp:alts_toggle"


# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model =
 overrideSettings = true
 options = []

Florian Ludwig


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems since apt-get upgrade

Ruben Porras-4
Am Sonntag, den 15.01.2006, 20:00 +0100 schrieb Florian Ludwig:

> Error activating XKB configuration.
> It can happen under various circumstances:
> - a bug in libxklavier library
> - a bug in X server (xkbcomp, xmodmap utilities)
> - X server with incompatible libxkbfile implementation
>
> X server version data:
> The X.Org Foundation
> 60900000
>
> If you report this situation as a bug, please include:
> - The result of xprop -root | grep XKB
> - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

I also have this problem, my results are:
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "es", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "es", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [es,us,de    basic]
 model = pc105
 overrideSettings = false
 options = [grp grp:alts_toggle]



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems since apt-get upgrade

vedranf (Bugzilla)
Ruben Porras wrote:

> Am Sonntag, den 15.01.2006, 20:00 +0100 schrieb Florian Ludwig:
>
>>Error activating XKB configuration.
>>It can happen under various circumstances:
>>- a bug in libxklavier library
>>- a bug in X server (xkbcomp, xmodmap utilities)
>>- X server with incompatible libxkbfile implementation
>
>
> I also have this problem, my results are:

Me to.

Happens after starting gnome-settings-daemon.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems since apt-get upgrade

Luis Mondesi
I took a /etc/X11 directory from a computer that worked and diff'ed it
against the same dir on a computer that showed this error and i
couldn't find the reason for this problem.

After i moved /etc/X11 and untar'ed the other dir in its place,
everything worked fine. This ruled out any ~/.Xmodmap file or anything
like that in my $HOME. The problem is with something inside /etc/X11.
Ah, and it's not simply the /etc/X11/xorg.conf file.

Perhaps the answer has to do with xlibs-data, but, I'm not 100% sure.

I think I still have the .diff file around in case somebody wants to
take a look at it. It's certainly a puzzling error.

On 1/18/06, Vedran Furač <[hidden email]> wrote:

> Ruben Porras wrote:
> > Am Sonntag, den 15.01.2006, 20:00 +0100 schrieb Florian Ludwig:
> >
> >>Error activating XKB configuration.
> >>It can happen under various circumstances:
> >>- a bug in libxklavier library
> >>- a bug in X server (xkbcomp, xmodmap utilities)
> >>- X server with incompatible libxkbfile implementation
> >
> >
> > I also have this problem, my results are:
>
> Me to.
>
> Happens after starting gnome-settings-daemon.
>
>
> --
> To UNSUBSCRIBE, email to [hidden email]
> with a subject of "unsubscribe". Trouble? Contact [hidden email]
>
>


--
----)(-----
Luis M
System Administrator
Kiskeyix.org

"We think basically you watch television to turn your brain off, and
you work on your computer when you want to turn your brain on" --
Steve Jobs in an interview for MacWorld Magazine 2004-Feb

No .doc: http://www.fsf.org/philosophy/no-word-attachments.es.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems since apt-get upgrade (partially solved)

Ruben Porras-4
El mié, 18-01-2006 a las 21:15 -0500, Luis M escribió:
> I took a /etc/X11 directory from a computer that worked and diff'ed it
> against the same dir on a computer that showed this error and i
> couldn't find the reason for this problem.
>
> After i moved /etc/X11 and untar'ed the other dir in its place,
> everything worked fine. This ruled out any ~/.Xmodmap file or anything
> like that in my $HOME. The problem is with something inside /etc/X11.
> Ah, and it's not simply the /etc/X11/xorg.conf file.

I disagree with you, in my case, I normally log in with locales for
German. Today I tried with es_ES.UTF-8 and I had no error, so the
problem is whit Gnome.