Problems with keyboard

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems with keyboard

Przemyslaw Wesolek
Dear all,

I'm working on my Debian box both logging at GDM and connecting through
vnc. Until recently everything went smoothly under vnc4server, but when
I switched to tightvncserver I encounter some serious problems with my
keyboard layout.

When connecting via vnc the keyboard is messed up totally. Instead of
"qwert" the echoed characters are something like "c.gvn". No Enter, no
backspace... Under "Keyboard Preferences" the Keyboard model is
"Unknown" and Layout is "US 105-key keyboard (with windows keys)". Any
changes result in nothing better... Also, the dialogs are somewhat
different than when logging through GDM! (e.g. the keyboard layout
picture is missing).

The only solution I found is to delete
~/.gconf/desktop/gnome/peripherials/keyboard key completely. My keyboard
layout settings are gone, but I can work remotely at least.

My layout is set to "pl" in xorg.config. The GNOME layout is also set to
Polish. When the session starts I'm asked whether I want to use X's or
GNOME's settings. Till now I ignored it, but maybe there is something
wrong with it...

I'm working on Debian 'testing'. Can't get back to vnc4server, because
it's no longer in testing. Normal vncserver also has the symptoms above.

Regards,
Przemek


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]