Python_2.7

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Python_2.7

riesdra
Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
apenas com a versão 3.7? Ou esta versão tem dependências que comprometa
o sistema?


Desde já agradeço a atenção de todos.



Reply | Threaded
Open this post in threaded view
|

Re: Python_2.7

Leandro Guimarães Faria Corcete DUTRA-4
Le dimanche 22 mars 2020 à 18:29 -0300, Ricardo Libanio a écrit :
> Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
> pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
> apenas com a versão 3.7? Ou esta versão tem dependências que
> comprometa o sistema?

Depende da versão do Debian.  Creio que, a menos que estejas na
instável, deve ainda haver dependências importantes.  Mas basta testar:
um apt purge python2.7 ou coisa que o valha mostrar-te-á.


--
skype:leandro.gfc.dutra?chat      Yahoo!: ymsgr:sendIM?lgcdutra
+55 (61) 3546 7191              gTalk: xmpp:[hidden email]
+55 (61) 9302 2691        ICQ/AIM: aim:GoIM?screenname=61287803
BRAZIL GMT−3  MSN: msnim:chat?contact=[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Python_2.7

riesdra
Uso a testing, removi aqui reiniciei e esta tudo funcionando, removeu um
monte de coisa do node- nem sei o que é isto, vou deixar assim mesmo,
valeu.

Em 22/03/2020 18:33, Leandro Guimarães Faria Corcete DUTRA escreveu:

> Le dimanche 22 mars 2020 à 18:29 -0300, Ricardo Libanio a écrit :
>> Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
>> pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
>> apenas com a versão 3.7? Ou esta versão tem dependências que
>> comprometa o sistema?
> Depende da versão do Debian.  Creio que, a menos que estejas na
> instável, deve ainda haver dependências importantes.  Mas basta testar:
> um apt purge python2.7 ou coisa que o valha mostrar-te-á.
>
>
> --
> skype:leandro.gfc.dutra?chat      Yahoo!: ymsgr:sendIM?lgcdutra
> +55 (61) 3546 7191              gTalk: xmpp:[hidden email]
> +55 (61) 9302 2691        ICQ/AIM: aim:GoIM?screenname=61287803
> BRAZIL GMT−3  MSN: msnim:chat?contact=[hidden email]
>
>

Reply | Threaded
Open this post in threaded view
|

Re: Python_2.7

osvaldo luciano Santos
Uma sugestão, usando uma interface gráfica como o Synaptic, acesse esse gerenciador, busque o pacote que quer analisar, selecione-o e clique na guia propriedades. Nela você poderá analisar todas as dependências, os dependentes, relações com últimas versões... inclusive todos os arquivos instalados referentes àquele pacote! É uma boa forma de familiarizar-se com o sistema.
att,
Osvaldo

Em dom., 22 de mar. de 2020 às 18:41, Ricardo Libanio <[hidden email]> escreveu:
Uso a testing, removi aqui reiniciei e esta tudo funcionando, removeu um
monte de coisa do node- nem sei o que é isto, vou deixar assim mesmo,
valeu.

Em 22/03/2020 18:33, Leandro Guimarães Faria Corcete DUTRA escreveu:
> Le dimanche 22 mars 2020 à 18:29 -0300, Ricardo Libanio a écrit :
>> Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
>> pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
>> apenas com a versão 3.7? Ou esta versão tem dependências que
>> comprometa o sistema?
> Depende da versão do Debian.  Creio que, a menos que estejas na
> instável, deve ainda haver dependências importantes.  Mas basta testar:
> um apt purge python2.7 ou coisa que o valha mostrar-te-á.
>
>
> --
> skype:leandro.gfc.dutra?chat      Yahoo!: ymsgr:sendIM?lgcdutra
> +55 (61) 3546 7191              gTalk: [hidden email]
> +55 (61) 9302 2691        ICQ/AIM: aim:GoIM?screenname=61287803
> BRAZIL GMT−3  MSN: msnim:chat?contact=[hidden email]
>
>

Reply | Threaded
Open this post in threaded view
|

Re: Python_2.7

riesdra
Removi e por hora tudo normal, se der algum problema reinstalo ele, obrigado.


--
Ricardo Libanio



---- On Dom, 22 mar 2020 20:30:04 -0300 [hidden email] wrote ----

Uma sugestão, usando uma interface gráfica como o Synaptic, acesse esse gerenciador, busque o pacote que quer analisar, selecione-o e clique na guia propriedades. Nela você poderá analisar todas as dependências, os dependentes, relações com últimas versões... inclusive todos os arquivos instalados referentes àquele pacote! É uma boa forma de familiarizar-se com o sistema.
att,
Osvaldo

Em dom., 22 de mar. de 2020 às 18:41, Ricardo Libanio <[hidden email]> escreveu:
Uso a testing, removi aqui reiniciei e esta tudo funcionando, removeu um
monte de coisa do node- nem sei o que é isto, vou deixar assim mesmo,
valeu.

Em 22/03/2020 18:33, Leandro Guimarães Faria Corcete DUTRA escreveu:
> Le dimanche 22 mars 2020 à 18:29 -0300, Ricardo Libanio a écrit :
>> Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
>> pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
>> apenas com a versão 3.7? Ou esta versão tem dependências que
>> comprometa o sistema?
> Depende da versão do Debian.  Creio que, a menos que estejas na
> instável, deve ainda haver dependências importantes.  Mas basta testar:
> um apt purge python2.7 ou coisa que o valha mostrar-te-á.
>
>
> --
> skype:leandro.gfc.dutra?chat      Yahoo!: ymsgr:sendIM?lgcdutra
> +55 (61) 3546 7191              gTalk: [hidden email]
> +55 (61) 9302 2691        ICQ/AIM: aim:GoIM?screenname=61287803
> BRAZIL GMT−3  MSN: msnim:chat?contact=[hidden email]
>
>


Reply | Threaded
Open this post in threaded view
|

Re: Python_2.7

Sinval Júnior-2
In reply to this post by riesdra
Você quer para desenvolver? É altamente recomendavel não mexer no Python do SO. Caso queira outras versão pode intalar em um ambiente sandbox. Usando o recurso de virtual env. Eu uso o pyenv[1] com ele é possível instalar qualuqer versão e sem necessidade do root. Assim não irá comprometer o python do SO.






Ao encaminhar esta mensagem, por favor:
1 - Apague meu endereço eletrônico;
2 - Encaminhe como Cópia Oculta (Cco ou BCc) aos seus destinatários. Dificulte assim a disseminação de vírus, spams e banners.

#=================================================================+
#!/usr/bin/env python
nome = 'Sinval Júnior'
email = 'sinvalju arroba gmail ponto com'
print nome
print email
#==================================================================+


Em dom., 22 de mar. de 2020 às 18:29, Ricardo Libanio <[hidden email]> escreveu:
Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
apenas com a versão 3.7? Ou esta versão tem dependências que comprometa
o sistema?


Desde já agradeço a atenção de todos.



Reply | Threaded
Open this post in threaded view
|

Re: Python_2.7

riesdra
Sim, é para desenvolver estou começando a estudar sobre programação em python.


--
Ricardo Libanio




---- Ativado Qui, 02 abr 2020 23:41:26 -0300 Sinval Júnior <[hidden email]> escreveu ----

Você quer para desenvolver? É altamente recomendavel não mexer no Python do SO. Caso queira outras versão pode intalar em um ambiente sandbox. Usando o recurso de virtual env. Eu uso o pyenv[1] com ele é possível instalar qualuqer versão e sem necessidade do root. Assim não irá comprometer o python do SO.






Ao encaminhar esta mensagem, por favor:
1 - Apague meu endereço eletrônico;
2 - Encaminhe como Cópia Oculta (Cco ou BCc) aos seus destinatários. Dificulte assim a disseminação de vírus, spams e banners.

#=================================================================+
#!/usr/bin/env python
nome = 'Sinval Júnior'
email = 'sinvalju arroba gmail ponto com'
print nome
print email
#==================================================================+


Em dom., 22 de mar. de 2020 às 18:29, Ricardo Libanio <[hidden email]> escreveu:

Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
apenas com a versão 3.7? Ou esta versão tem dependências que comprometa
o sistema?


Desde já agradeço a atenção de todos.





Reply | Threaded
Open this post in threaded view
|

Re: Python_2.7

riesdra
Valeu obrigado.


--
Ricardo Libanio



---- On Sex, 03 abr 2020 12:09:09 -0300 [hidden email] wrote ----

Então é usando o virtualenv mesmo.

Versões mais antigas vc precisa instalar o pacote virtualenv. Versão recentes basta usar [python3 -m venv env] env será um ambiente sandbox. Para ativar basta source env/bin/activate



Ao encaminhar esta mensagem, por favor:
1 - Apague meu endereço eletrônico;
2 - Encaminhe como Cópia Oculta (Cco ou BCc) aos seus destinatários. Dificulte assim a disseminação de vírus, spams e banners.

#=================================================================+
#!/usr/bin/env python
nome = 'Sinval Júnior'
email = 'sinvalju arroba gmail ponto com'
print nome
print email
#==================================================================+


Em sex., 3 de abr. de 2020 às 12:02, riesdra <[hidden email]> escreveu:
Sim, é para desenvolver estou começando a estudar sobre programação em python.


--
Ricardo Libanio




---- Ativado Qui, 02 abr 2020 23:41:26 -0300 Sinval Júnior <[hidden email]> escreveu ----

Você quer para desenvolver? É altamente recomendavel não mexer no Python do SO. Caso queira outras versão pode intalar em um ambiente sandbox. Usando o recurso de virtual env. Eu uso o pyenv[1] com ele é possível instalar qualuqer versão e sem necessidade do root. Assim não irá comprometer o python do SO.






Ao encaminhar esta mensagem, por favor:
1 - Apague meu endereço eletrônico;
2 - Encaminhe como Cópia Oculta (Cco ou BCc) aos seus destinatários. Dificulte assim a disseminação de vírus, spams e banners.

#=================================================================+
#!/usr/bin/env python
nome = 'Sinval Júnior'
email = 'sinvalju arroba gmail ponto com'
print nome
print email
#==================================================================+


Em dom., 22 de mar. de 2020 às 18:29, Ricardo Libanio <[hidden email]> escreveu:

Olá, uso debian aqui no meu note e vejo que ele tem duas versões do
pyton a 2 e a 3. Minha duvida é posso remover a versão 2.7 e ficar
apenas com a versão 3.7? Ou esta versão tem dependências que comprometa
o sistema?


Desde já agradeço a atenção de todos.