Re: Bug#776218: installation-reports: Reportbug needs python-vte, which is not installed in the default installation

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Bug#776218: installation-reports: Reportbug needs python-vte, which is not installed in the default installation

Cyril Brulebois-4
Control: tag -1 - d-i
Control: severity -1 normal

Hi,

and thanks for your report.

Roland Illig <[hidden email]> (2015-01-25):

> Package: installation-reports
> Severity: important
> Tags: d-i
>
> Dear Maintainer,
>
>    * What led up to the situation?
>
> After a fresh Debian installation with GNOME, I started reportbug in order to
> report a bug.
>
>    * What was the outcome of this action?
>
> Reportbug complained that python-vte was not installed and that it would fall
> back to textmode.
>
> Answering the configuration in textmode was not a pleasure, since some
> questions had so many options that I had to scroll up the screen. Also, the
> questions were not separated by an empty line, so that there was no visual clue
> as to where the current question starts.
>
>    * What outcome did you expect instead?
>
> (major) The missing packages should be installed from the beginning. These are
> python-vte and python-gtkspell (which reportbug also wants).
Might be a good idea for some gnome packages to pull those packages?

Adding debian-gtk-gnome@ to cc to gather their view(s). Feel free to
steal the bug report away from installation-reports if appropriate.

Mraw,
KiBi.

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Bug#776218: installation-reports: Reportbug needs python-vte, which is not installed in the default installation

Josselin Mouette
Hi,

Cyril Brulebois <[hidden email]> wrote:
        > (major) The missing packages should be installed from the beginning. These are
        > python-vte and python-gtkspell (which reportbug also wants).
       
        Might be a good idea for some gnome packages to pull those packages?

I’m not sure it’s the right way to do that. These packages are not
maintained upstream and we want to get rid of them, not to add new
dependencies. GNOME in jessie is fully built on GTK3, except for
iceweasel and a couple of other default applications. And most Python
dependencies have been switched to Python 3 as well (except for some
Debian-specific scripts).

--
Joss


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/1422268763.22902.26.camel@dsp0698014

Reply | Threaded
Open this post in threaded view
|

Re: Bug#776218: installation-reports: Reportbug needs python-vte, which is not installed in the default installation

Cyril Brulebois-4
Josselin Mouette <[hidden email]> (2015-01-26):

> Cyril Brulebois <[hidden email]> wrote:
>         > (major) The missing packages should be installed from the beginning. These are
>         > python-vte and python-gtkspell (which reportbug also wants).
>        
>         Might be a good idea for some gnome packages to pull those packages?
>
> I’m not sure it’s the right way to do that. These packages are not
> maintained upstream and we want to get rid of them, not to add new
> dependencies. GNOME in jessie is fully built on GTK3, except for
> iceweasel and a couple of other default applications. And most Python
> dependencies have been switched to Python 3 as well (except for some
> Debian-specific scripts).
I can understand the feeling but what do we do for reportbug then?
It's obviously too late to get it ported to gtk3, so shrug and let
people struggle with its text mode?

Mraw,
KiBi.

signature.asc (836 bytes) Download Attachment