Re: Bug#910009: exim4-config: upgrade fails when trying to execute conffile difference visualizer

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Bug#910009: exim4-config: upgrade fails when trying to execute conffile difference visualizer

Vincent Lefevre-10
Control: reassign -1 dpkg 1.19.1
Control: retitle -1 dpkg execs $PAGER with execvp instead of sh -c, yielding upgrade failure

As a summary, when a pager needs to be invoked (e.g. for the
conffile difference visualizer), one gets an upgrade failure
if $PAGER contains the program name + options, as specified
by POSIX.

On 2018-10-01 14:12:20 +0200, Vincent Lefevre wrote:
> On 2018-10-01 14:08:17 +0200, Vincent Lefevre wrote:
> > A possible bug might be that $PAGER is run as a program name,
> > instead of something like system(), which allows options.
>
> Hmm... I can see in /usr/share/doc/dpkg/changelog.Debian.gz that
> there have been pager-related changes in dpkg 1.19.1 (26 Sep 2018).
> The bug might actually be there.

Indeed, after a quick look at the code (pager_spawn in lib/dpkg/pager.c
and lib/dpkg/command.c code), this seems to be the case.

--
Vincent Lefèvre <[hidden email]> - Web: <https://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <https://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / AriC project (LIP, ENS-Lyon)