Re: Bug#912144: grub2-common: marks kernel update scripts falsely as obsolete conffiles

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Bug#912144: grub2-common: marks kernel update scripts falsely as obsolete conffiles

Colin Watson
On Sun, Oct 28, 2018 at 03:42:16PM +0100, TS wrote:
> since fix for #910959 grub2-common marks kernel update scripts falsely as
> obsolete conffiles.
>
> % dpkg-query -W -f='${Conffiles}\n' | grep 'grub.*obsolete$'
>  /etc/kernel/postrm.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete
>  /etc/kernel/postinst.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete
>
> I tend to rm obsolete conffiles as per definition, which seem to break things here.

Hi debian-dpkg,

I just used Breaks/Replaces here:

  https://salsa.debian.org/grub-team/grub/commit/014ba384bb8ac9869f2ccd2692f8ae05641d5bec

Did I do something wrong, or is this a dpkg bug?

Thanks,

--
Colin Watson                                       [[hidden email]]

Reply | Threaded
Open this post in threaded view
|

Re: Bug#912144: grub2-common: marks kernel update scripts falsely as obsolete conffiles

Sven Joachim
On 2018-10-28 15:03 +0000, Colin Watson wrote:

> On Sun, Oct 28, 2018 at 03:42:16PM +0100, TS wrote:
>> since fix for #910959 grub2-common marks kernel update scripts falsely as
>> obsolete conffiles.
>>
>> % dpkg-query -W -f='${Conffiles}\n' | grep 'grub.*obsolete$'
>>  /etc/kernel/postrm.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete
>>  /etc/kernel/postinst.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete
>>
>> I tend to rm obsolete conffiles as per definition, which seem to break things here.
>
> Hi debian-dpkg,
>
> I just used Breaks/Replaces here:
>
>   https://salsa.debian.org/grub-team/grub/commit/014ba384bb8ac9869f2ccd2692f8ae05641d5bec
>
> Did I do something wrong, or is this a dpkg bug?

The latter I think, namely https://bugs.debian.org/886389.

Cheers,
       Sven

TS
Reply | Threaded
Open this post in threaded view
|

Re: Bug#912144: grub2-common: marks kernel update scripts falsely as obsolete conffiles

TS
Hello,

>>> since fix for #910959 grub2-common marks kernel update scripts falsely as
>>> obsolete conffiles.
>>>
>>> % dpkg-query -W -f='${Conffiles}\n' | grep 'grub.*obsolete$'
>>>  /etc/kernel/postrm.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete
>>>  /etc/kernel/postinst.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete
>>>
>>> I tend to rm obsolete conffiles as per definition, which seem to break things here.
>>
>> Hi debian-dpkg,
>>
>> I just used Breaks/Replaces here:
>>
>>   https://salsa.debian.org/grub-team/grub/commit/014ba384bb8ac9869f2ccd2692f8ae05641d5bec
>>
>> Did I do something wrong, or is this a dpkg bug?
>
> The latter I think, namely https://bugs.debian.org/886389.

since update of today also keyring files are marked as obsolete conffile:

% dpkg-query -W -f='${Conffiles}\n' | grep -E '(grub|archive).*obsolete$'
 /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg
64d549adf06d734bb947d742898d9a19 obsolete
 /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg
a81b62d3b02f6e9781e6639bf6fc050b obsolete
 /etc/kernel/postrm.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete
 /etc/kernel/postinst.d/zz-update-grub 536d9d45e3e547638db3c5d58a925b6c obsolete

https://bugs.debian.org/912144
https://bugs.debian.org/886389


kind regards,

     Thilo

TS
Reply | Threaded
Open this post in threaded view
|

Re: Bug#912144: grub2-common: marks kernel update scripts falsely as obsolete conffiles

TS
TS schrieb/wrote:
> Hello,

> % dpkg-query -W -f='${Conffiles}\n' | grep -E '(grub|archive).*obsolete$'
>  /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg
> 64d549adf06d734bb947d742898d9a19 obsolete
>  /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg
> a81b62d3b02f6e9781e6639bf6fc050b obsolete

sorry for that my fault. Wheezy keys have been removed.
https://bugs.debian.org/901320


kind regards,

     Thilo