Re: Compiling testing/unstable kernels on sarge/stable was: Updated Howto needed

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Compiling testing/unstable kernels on sarge/stable was: Updated Howto needed

Simon Horman-2
On Wed, Nov 02, 2005 at 01:43:27PM +0000, Nick Hill wrote:

> Horms wrote:
> >>Horms,
> >>Thank you for the summary. You have made the versioned patching system
> >>clearer to me. I tried the commands you suggested to build the kernel. I
> >>have had package versioning problems trying to compile etch kernel on
> >>sarge ( gcc (>= 4:4.0) kernel-package (>= 9.008.3) ).
> >
> >
> >I have been having very good luck building 2.6.14-2 with all of the
> >folowing combinations, on sid:
>
> Feedback:
> Horms suggested the following commands;
>
> apt-get source linux-2.6
> cd linux-2.6-X.Y.Z-N
> dpkg-buildpackage -B -us -uc -rfakeroot
>
> When built with:
> Etch: Works OK
> Sarge: Fails as build dependencies are checked and fail with versions of
> gcc and kernel-package. If I disable build dependency checking (-d),
> build fails as the .config is not created.

Nick, these packages are for etch. They are not expected to build
on sarge without modification.

--
Horms


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]