Re: [dpkg] 06/24: debian: Add libncurses-dev as the first Build-Depends alternative

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [dpkg] 06/24: debian: Add libncurses-dev as the first Build-Depends alternative

Sven Joachim
Hi Guillem,

On 2018-05-04 02:49 +0000, Guillem Jover wrote:

> This is an automated email from the git hooks/post-receive script.
>
> guillem pushed a commit to branch master
> in repository dpkg.
>
> commit 114121d649b57bea9236b807d7c57bc918c67723
> Author: Guillem Jover <[hidden email]>
> Date:   Mon Apr 30 01:30:44 2018 +0200
>
>     debian: Add libncurses-dev as the first Build-Depends alternative
>    
>     This is part of the ncurses 6 transition, and the previous packages
>     are now transitional, let's use the current one and leave the old for
>     backwards compatibility.
> ---
>  debian/changelog | 1 +
>  debian/control   | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/debian/changelog b/debian/changelog
> index 88907cf..9dfce80 100644
> --- a/debian/changelog
> +++ b/debian/changelog
> @@ -106,6 +106,7 @@ dpkg (1.19.1) UNRELEASED; urgency=medium
>      - Bump Standards-Version to 4.1.1 (no changes needed).
>      - Add bzip2 and xz-utils to Build-Depends, required by the functional test
>        suite, but shadowed by dpkg-dev from the build system pulling those in.
> +    - Add libncurses-dev as the first Build-Depends alternative.
>    * Test suite:
>      - Skip Dpkg::OpenPGP test if gpg is not present.
>      - Check POD in all perl scripts.
> diff --git a/debian/control b/debian/control
> index 123a8e0..e636673 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -21,7 +21,7 @@ Build-Depends:
>   libbz2-dev,
>   liblzma-dev,
>   libselinux1-dev [linux-any],
> - libncursesw5-dev,
> + libncurses-dev | libncursesw5-dev,

This should be libncurses-dev (>= 6.1+20180210) | libncursesw5-dev
instead.  The old libncurses5-dev package had a Provides: libncurses-dev,
and if somebody builds on a system which has not made the ncurses
transition yet, dselect loses wide character support.

Cheers,
       Sven

Reply | Threaded
Open this post in threaded view
|

Re: [dpkg] 06/24: debian: Add libncurses-dev as the first Build-Depends alternative

Guillem Jover
Hi!

On Fri, 2018-05-04 at 08:01:02 +0200, Sven Joachim wrote:

> On 2018-05-04 02:49 +0000, Guillem Jover wrote:
> > diff --git a/debian/control b/debian/control
> > index 123a8e0..e636673 100644
> > --- a/debian/control
> > +++ b/debian/control
> > @@ -21,7 +21,7 @@ Build-Depends:
> >   libbz2-dev,
> >   liblzma-dev,
> >   libselinux1-dev [linux-any],
> > - libncursesw5-dev,
> > + libncurses-dev | libncursesw5-dev,
>
> This should be libncurses-dev (>= 6.1+20180210) | libncursesw5-dev
> instead.  The old libncurses5-dev package had a Provides: libncurses-dev,
> and if somebody builds on a system which has not made the ncurses
> transition yet, dselect loses wide character support.

Ah right, thanks, will fix this up later today.

Regards,
Guillem