Re: kde error (here is the output)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: kde error (here is the output)

George Adamides-2
Hello again and thank you for the propmt reply! Here's the output
 
george:~#cat /etc/debian_version
3.1

#cat /etc/apt/sources.list
#deb file:///cdrom/ sarge main
george:~# apt-cache policy kdat
kdat:
  Installed: 4:3.5.7-1
  Candidate: 4:3.5.7-1
  Version Table:
 *** 4:3.5.7-1 0
        100 /var/lib/dpkg/status
     4:3.5.5-4 0
        500 http://ftp.fi.debian.org stable/main Packages

I hope this helps.

 
----- Original Message ----
From: Martin Steigerwald <[hidden email]>
To: [hidden email]
Sent: Friday, September 7, 2007 12:21:48 AM
Subject: Re: kde error

Am Donnerstag 06 September 2007 schrieb George Adamides:
> Hello again,

Hi George,

> Well I tried to install the xserver so as to get kde working but I get
> the following message. Can anybody help me clarify what is wrong?
>
> george:/usr/bin# apt-get -f install  xserver-xorg-core
> Reading Package Lists... Done
> Building Dependency Tree... Done
> You might want to run 'apt-get -f install' to correct these:
> The following packages have unmet dependencies:
>   kdat: Depends: kdelibs4c2a (>= 4:3.5.7-1) but it is not going to be
> installed Depends: libc6 (>= 2.5-5) but 2.3.2.ds1-22sarge4 is to be
> installed Depends: libgcc1 (>= 1:4.1.2) but 1:3.4.3-13sarge1 is to be
> installed Depends: libqt3-mt (>= 3:3.3.7) but it is not going to be
> installed Depends: libstdc++6 (>= 4.1.2) but it is not going to be
> installed xserver-xorg-core: Depends: x11-common (>= 1:7.0.0) but it is
> not going to be installed Depends: libc6 (>= 2.3.6-6) but
> 2.3.2.ds1-22sarge4 is to be installed Depends: libfontenc1 but it is
> not going to be installed Depends: libgcc1 (>= 1:4.1.1-12) but
> 1:3.4.3-13sarge1 is to be installed Depends: libxau6 but it is not
> going to be installed Depends: libxdmcp6 but it is not going to be
> installed Depends: libxfont1 but it is not going to be installed
> Depends: xserver-xorg but it is not going to be installed E: Unmet
> dependencies. Try 'apt-get -f install' with no packages (or specify a
> solution).

Where do you have the package kdat from? It seems you are running Debian
Sarge, but try to install kdat from a newer version of Debian (at least
lenny aka testing as only that contains KDE 3.5.7) which needs newer
versions of some packages than you have. I suggest removing that package
completely with aptitude purge kdat, before trying to install the correct
version of the package for Debian Sarge[1]. After removing it, you should
be able to safely install the X server and KDE core stuff by using
aptitude install xserver-xorg kde-core[1].

The kdat package is available for Sarge[2]. Thus on a Debian Sarge a
aptitude install kdat should be able to install it.

Could you please post the output

- cat /etc/debian_version

- cat /etc/apt/sources.list

- apt-cache policy kdat

If you have sarge or oldstable as Debian release in your sources
list, /etc/debian_version shows 3.1 and apt-cache policy shows 4:3.3.2-1
as installable package version, you should be able to install kdat safely
on your system by simply using aptitude install kdat, *after* you have
removed that newer version you tried to install above[1].

In order to enjoy a newer version of kdat and KDE consider upgrading to
Debian Etch.

[1] if aptitude wants to remove some packages cause it thinks they are
unused and you think they are not be careful, if in doubt better use
apt-get then, if interested I can provide a detailed explaination about
that, that explaination should be available somewhere on the Debian
pages, maybe in the wiki, as well

[2] http://packages.debian.org/sarge/kdat

Ciao,
--
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7



Boardwalk for $500? In 2007? Ha!
Play Monopoly Here and Now (it's updated for today's economy) at Yahoo! Games.
Reply | Threaded
Open this post in threaded view
|

Fixing problems with conflicting package versions (was: Re: kde error (here is the output)

Martin Steigerwald
Am Freitag 07 September 2007 schrieb George Adamides:
> Hello again and thank you for the propmt reply! Here's the output

Hello George!

Two things first:

1) Please reply to my message instead of opening a new thread by writing a
new mail.

2) Please use proper quoting: http://learn.to/quote

> george:~#cat /etc/debian_version
> 3.1

You have Debian Sarge. Well at least the base files of it, no guarentee
that all packages are from Debian Sarge tough...

> #cat /etc/apt/sources.list
> #deb file:///cdrom/ sarge main
> deb http://ftp.fi.debian.org/debian/ stable main
> deb-src http://ftp.fi.debian.org/debian/ stable main
> deb http://security.debian.org/ stable/updates main
> deb http://dotdeb.pimpmylinux.org/ stable all
> deb-src http://dotdeb.pimpmylinux.org/ stable all

But since quite some months Etch has been released as stable - thus your
sources.list entries with "stable" do not refer to "sarge", but now
to "etch"! Did you update your system in the meanwhile? Then you may have
a mixture between Sarge and Etch! While it is possible to mix different
versions of Debian, I would not recommend it to a novice.

I recommend explicetily putting sarge or etch into /etc/apt/sources.list,
cause stable will point to a new Debian versions once it gets released.
The next one is lenny.

But see below for detailed suggestions on how to fix your conflicting
package versions.

> george:~# apt-cache policy kdat
> kdat:
>   Installed: 4:3.5.7-1
>   Candidate: 4:3.5.7-1
>   Version Table:
>  *** 4:3.5.7-1 0
>         100 /var/lib/dpkg/status
>      4:3.5.5-4 0
>         500 http://ftp.fi.debian.org stable/main Packages
>
> I hope this helps.
Ok, lets try to make a plan to get it fixed:

1) aptitude purge kdat or if aptitude wants to remove other packages that
you think shouldn't be removed apt-get purge kdat instead

2) You seem to have basefiles of Debian Sarge at least, so replace any
occurence of "stable" in your /etc/apt/sources.list by "sarge" for now.

3) Lets find out whether you have some packages that are newer than sarge.
Install apt-show-versions

aptitude install apt-show-versions

And post the output of:

apt-show-versions | grep "/sarge" | wc -l
apt-show-versions | grep "/etch" | wc -l
apt-show-versions | grep "/lenny" | wc-l
apt-show-versions | grep "/sid" | wc -l

It will show the numbers of installed packages from the different Debian
versions. For a pure Debian Sarge it should be lots of packages for
Sarge, but none for Etch, Lenny or Sid. Then you use "sarge"
in /etc/apt/sources.list. You may upgrade to Etch later - I recommend
this, especially since KDE 3.5.5 is quite an improvement over KDE
3.3.2 ;-). But for now it is enough to use Sarge to get kdat running.

If you already have lots of packages for Etch, I would consider upgrading
to Etch completely to have consistent package versions again. Then you
would use "etch" or "stable" in /etc/apt/sources.list. I recommend Etch,
cause stable will change to Lenny silently, once it is released. You
would need to do an upgrade with aptitude / apt-get upgrade /
dist-upgrade, but read the Debian upgrade notes and be careful if you are
novice with Debian package management. Always check whether the output of
aptitude or apt-get makes sense to you before letting it go.

If you only have a few packages for Etch, you may try to downgrade them.

Well if that mixture of packages work for you, you can even go on with
that, but for a beginning I recommend to you not to run packages from
different Debian versions together.

4) Once you have a Debian system consistent package versions, you can
install KDE, X, kdat as explained before.

Ciao,
--
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7

signature.asc (196 bytes) Download Attachment