Request for newer mesa,llvm packages in stretch backports

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Request for newer mesa,llvm packages in stretch backports

Sanjeev .
with regards to jessie backports of mesa-glx, llvm packages which we
previously had, can we request for newer mesa packages, llvm packages
for strect-, this improve opengl support for newer graphic hardwares.

will it be doable?

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Sylvestre Ledru-6
Hello

As I am alone maintaining the llvm toolchains, I don't have the
bandwidth to do it but I won't object
if anyway wants to step in.

Cheers,
Sylvestre


Le 22/01/2018 à 07:48, Sanjeev a écrit :

> with regards to jessie backports of mesa-glx, llvm packages which we
> previously had, can we request for newer mesa packages, llvm packages
> for strect-, this improve opengl support for newer graphic hardwares.
>
> will it be doable?
>
> _______________________________________________
> Pkg-llvm-team mailing list
> [hidden email]
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-llvm-team

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Andreas Boll
Hi,

2018-01-22 8:32 GMT+01:00 Sylvestre Ledru <[hidden email]>:

> Hello
>
> As I am alone maintaining the llvm toolchains, I don't have the
> bandwidth to do it but I won't object
> if anyway wants to step in.
>
> Cheers,
> Sylvestre
>
>
> Le 22/01/2018 à 07:48, Sanjeev a écrit :
>> with regards to jessie backports of mesa-glx, llvm packages which we
>> previously had, can we request for newer mesa packages, llvm packages
>> for strect-, this improve opengl support for newer graphic hardwares.
>>
>> will it be doable?

We would at least need to maintain backports for:
- llvm-toolchain-5.0
- libdrm
- libclc
- libglvnd
- vulkan
- wayland-protocols
- mesa

If anyone would volunteer to maintain the backport of llvm-toolchain I
would look into maintaining the other packages.
Of course help on the other packages is also welcome.

Thanks,
Andreas

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Jérémy Viès
Hi all,

I'd like to give a help.
I backport for my own the mesa stack and its dependencies.

Until mesa 17.3.2, I had no issue with the following packages, just recompiling the sources from sid:
llvm-toolchain-5.0
libclc
libdrm
wayland-protocols
libglvnd
mesa

But since a few days, at least llvm-toolchain-5.0 needs an updated quilt (0.63-8.2) that does not build out of the box on stretch.
If someone knows what is the quilt update about, I can try to patch debian build of llvm-toolchain to only depend on quilt from stretch.

I dit not tried to backport vulkan as I do not use it for now, but it backported straight forward at jessie time.

Regards,
Jérémy


2018-01-26 11:31 GMT+01:00 Andreas Boll <[hidden email]>:
Hi,

2018-01-22 8:32 GMT+01:00 Sylvestre Ledru <[hidden email]>:
> Hello
>
> As I am alone maintaining the llvm toolchains, I don't have the
> bandwidth to do it but I won't object
> if anyway wants to step in.
>
> Cheers,
> Sylvestre
>
>
> Le 22/01/2018 à 07:48, Sanjeev a écrit :
>> with regards to jessie backports of mesa-glx, llvm packages which we
>> previously had, can we request for newer mesa packages, llvm packages
>> for strect-, this improve opengl support for newer graphic hardwares.
>>
>> will it be doable?

We would at least need to maintain backports for:
- llvm-toolchain-5.0
- libdrm
- libclc
- libglvnd
- vulkan
- wayland-protocols
- mesa

If anyone would volunteer to maintain the backport of llvm-toolchain I
would look into maintaining the other packages.
Of course help on the other packages is also welcome.

Thanks,
Andreas


Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Gianfranco Costamagna via nm
Hello,


>But since a few days, at least llvm-toolchain-5.0 needs an updated quilt (0.63-8.2) that does not build out of the box on stretch.
>If someone knows what is the quilt update about, I can try to patch debian build of llvm-toolchain to only depend on quilt from stretch.
>
>I dit not tried to backport vulkan as I do not use it for now, but it backported straight forward at jessie time.

Regards,
Jérémy



2018-01-26 11:31 GMT+01:00 Andreas Boll <[hidden email]>:

Hi,

>
>2018-01-22 8:32 GMT+01:00 Sylvestre Ledru <[hidden email]>:
>> Hello
>>
>> As I am alone maintaining the llvm toolchains, I don't have the
>> bandwidth to do it but I won't object
>> if anyway wants to step in.
>>
>> Cheers,
>> Sylvestre
>>
>>
>> Le 22/01/2018 à 07:48, Sanjeev a écrit :
>>> with regards to jessie backports of mesa-glx, llvm packages which we
>>> previously had, can we request for newer mesa packages, llvm packages
>>> for strect-, this improve opengl support for newer graphic hardwares.
>>>
>>> will it be doable?
>
>We would at least need to maintain backports for:
>- llvm-toolchain-5.0
>- libdrm
>- libclc
>- libglvnd
>- vulkan
>- wayland-protocols
>- mesa
>
>If anyone would volunteer to maintain the backport of llvm-toolchain I
>would look into maintaining the other packages.
>Of course help on the other packages is also welcome.
>
>Thanks,
>Andreas
>
>

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Gianfranco Costamagna via nm
Hello again
>But since a few days, at least llvm-toolchain-5.0 needs an updated quilt (0.63-8.2) that does not build out of the box on stretch.
>If someone knows what is the quilt update about, I can try to patch debian build of llvm-toolchain to only depend on quilt from stretch.
>
>I dit not tried to backport vulkan as I do not use it for now, but it backported straight forward at jessie time.



quilt_0.63-8.2~bpo9+1.dsc                                                                                                                                                        100% 1977    12.3KB/s   00:00
quilt_0.63-8.2~bpo9+1.debian.tar.xz                                                                                                                                              100%   34KB 112.5KB/s   00:00
quilt-el_0.63-8.2~bpo9+1_all.deb                                                                                                                                                 100% 7354    45.8KB/s   00:00
quilt_0.63-8.2~bpo9+1_all.deb                                                                                                                                                    100%  301KB 348.6KB/s   00:00
quilt_0.63-8.2~bpo9+1_amd64.buildinfo                                                                                                                                            100% 8514    57.4KB/s   00:00
quilt_0.63-8.2~bpo9+1_amd64.changes                                                                                                                                              100% 2751    19.7KB/s   00:00


:)

it will be available in a day or two, somewhat it builds fine with pbuilder and not with sbuild, neither with pbuilder when login into the chroot.
Some test needs reworking there, but the problem seems not a stretch-bpo one, but I can reproduce also in sid
(probably somewhat $HOME should not exist or point to an existing place, don't know)


Anyhow, it is ok I presume now

G.


2018-01-26 11:31 GMT+01:00 Andreas Boll <[hidden email]>:

Hi,

>
>2018-01-22 8:32 GMT+01:00 Sylvestre Ledru <[hidden email]>:
>> Hello
>>
>> As I am alone maintaining the llvm toolchains, I don't have the
>> bandwidth to do it but I won't object
>> if anyway wants to step in.
>>
>> Cheers,
>> Sylvestre
>>
>>
>> Le 22/01/2018 à 07:48, Sanjeev a écrit :
>>> with regards to jessie backports of mesa-glx, llvm packages which we
>>> previously had, can we request for newer mesa packages, llvm packages
>>> for strect-, this improve opengl support for newer graphic hardwares.
>>>
>>> will it be doable?
>
>We would at least need to maintain backports for:
>- llvm-toolchain-5.0
>- libdrm
>- libclc
>- libglvnd
>- vulkan
>- wayland-protocols
>- mesa
>
>If anyone would volunteer to maintain the backport of llvm-toolchain I
>would look into maintaining the other packages.
>Of course help on the other packages is also welcome.
>
>Thanks,
>Andreas
>
>

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Andreas Boll
In reply to this post by Jérémy Viès
Hi,

On Sun, Jan 28, 2018 at 08:37:17PM +0100, Jérémy Viès wrote:
> Hi all,
>
> I'd like to give a help.
> I backport for my own the mesa stack and its dependencies.

Thanks for offering help!

>
> Until mesa 17.3.2, I had no issue with the following packages, just
> recompiling the sources from sid:
> llvm-toolchain-5.0
> libclc
> libdrm
> wayland-protocols
> libglvnd
> mesa
>
> But since a few days, at least llvm-toolchain-5.0 needs an updated quilt
> (0.63-8.2) that does not build out of the box on stretch.
> If someone knows what is the quilt update about, I can try to patch debian
> build of llvm-toolchain to only depend on quilt from stretch.
Yeah, I've bumped the quilt dependency in mesa-17.3.3-1. But it looks like
Gianfranco has already uploaded that quilt version to backports [1]. Thanks
Gianfranco!

>
> I dit not tried to backport vulkan as I do not use it for now, but it
> backported straight forward at jessie time.
>
> Regards,
> Jérémy
>

So the next step would be to find a DD for sponsoring the llvm upload.
The best way for this is to prepare and upload the backport of
llvm-toolchain-5.0 to mentors [2].

For the other packages we want to have the backports to be prepared in
the VCS. See also the branches for jessie-backports. I'll look into this
task.


Thanks,
Andreas

[1] https://ftp-master.debian.org/backports-new.html
[2] https://mentors.debian.net/

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Jérémy Viès
Hi all,

My (first) upload to mentors is online (@ https://mentors.debian.net/package/llvm-toolchain-5.0).
Can someone sponsor me ?

If it is OK, I can start the packaging of other sources and upload them.

Regards,
Jérémy

2018-02-01 10:50 GMT+01:00 Andreas Boll <[hidden email]>:
Hi,

On Sun, Jan 28, 2018 at 08:37:17PM +0100, Jérémy Viès wrote:
> Hi all,
>
> I'd like to give a help.
> I backport for my own the mesa stack and its dependencies.

Thanks for offering help!

>
> Until mesa 17.3.2, I had no issue with the following packages, just
> recompiling the sources from sid:
> llvm-toolchain-5.0
> libclc
> libdrm
> wayland-protocols
> libglvnd
> mesa
>
> But since a few days, at least llvm-toolchain-5.0 needs an updated quilt
> (0.63-8.2) that does not build out of the box on stretch.
> If someone knows what is the quilt update about, I can try to patch debian
> build of llvm-toolchain to only depend on quilt from stretch.

Yeah, I've bumped the quilt dependency in mesa-17.3.3-1. But it looks like
Gianfranco has already uploaded that quilt version to backports [1]. Thanks
Gianfranco!

>
> I dit not tried to backport vulkan as I do not use it for now, but it
> backported straight forward at jessie time.
>
> Regards,
> Jérémy
>

So the next step would be to find a DD for sponsoring the llvm upload.
The best way for this is to prepare and upload the backport of
llvm-toolchain-5.0 to mentors [2].

For the other packages we want to have the backports to be prepared in
the VCS. See also the branches for jessie-backports. I'll look into this
task.


Thanks,
Andreas

[1] https://ftp-master.debian.org/backports-new.html
[2] https://mentors.debian.net/

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Timo Aaltonen-4
On 04.02.2018 21:48, Jérémy Viès wrote:
> Hi all,
>
> My (first) upload to mentors is online
> (@ https://mentors.debian.net/package/llvm-toolchain-5.0).
> Can someone sponsor me ?
>
> If it is OK, I can start the packaging of other sources and upload them.

Hi, I've uploaded llvm now, and also libdrm, wayland-protocols, vulkan
earlier today.


--
t

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Jérémy Viès
Hi,
libclc, libglvnd are already available on mentors. I still need a sponsor...
I will upload mesa in the coming hours.



2018-02-05 11:27 GMT+01:00 Timo Aaltonen <[hidden email]>:
On <a href="tel:04.02.2018%2021" value="+33402201821">04.02.2018 21:48, Jérémy Viès wrote:
> Hi all,
>
> My (first) upload to mentors is online
> (@ https://mentors.debian.net/package/llvm-toolchain-5.0).
> Can someone sponsor me ?
>
> If it is OK, I can start the packaging of other sources and upload them.

Hi, I've uploaded llvm now, and also libdrm, wayland-protocols, vulkan
earlier today.


--
t

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Jérémy Viès
Hi all,

I've uploaded mesa 17.3.5 to mentors, but I still need a sponsor.

Best regards,
Jérémy

2018-02-05 20:05 GMT+01:00 Jérémy Viès <[hidden email]>:
Hi,
libclc, libglvnd are already available on mentors. I still need a sponsor...
I will upload mesa in the coming hours.



2018-02-05 11:27 GMT+01:00 Timo Aaltonen <[hidden email]>:
On <a href="tel:04.02.2018%2021" value="+33402201821" target="_blank">04.02.2018 21:48, Jérémy Viès wrote:
> Hi all,
>
> My (first) upload to mentors is online
> (@ https://mentors.debian.net/package/llvm-toolchain-5.0).
> Can someone sponsor me ?
>
> If it is OK, I can start the packaging of other sources and upload them.

Hi, I've uploaded llvm now, and also libdrm, wayland-protocols, vulkan
earlier today.


--
t


Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Stuart Young
Hi All,

I've been building just the mesa source package locally now against stretch-backports since mesa 17.3.7 and the build process just works.

Since all the build dependencies are now in stretch-backports, what else needs to be done to get mesa into stretch-backports?

I note that Timo (?) created a branch in salsa which contains Jérémy's backport that was submitted to mentors, so that would probably want to be updated to 17.3.9 (which should hopefully hit testing in ~2 days).

One other thing:

Since mesa-18.1.0 is supposedly coming mid-May (according to the release plan from https://lists.freedesktop.org/archives/mesa-dev/2018-April/191388.html ), I decided to see if I could build 18.0.1 source pkg from experimental against stretch-backports.

The only thing that appears to be missing in stretch-backports is libclc-dev (>= 0.2.0+git20180312-1~). Currently stretch-backports has 0.2.0+git20171106-1~bpo9+1. Everything else seems to be there.

-- 
Stuart Young (aka Cefiar)
Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Jérémy Viès
Hi Stuart,

libclc-dev 0.2.0+git20180312-1 is not in testing yet. So I did not tried to build and then upload it to backports.
I will do it ASAP, after it is pushed to testing.

I also tried to push mesa 17.3.9 to backports, but I made a mistake and pushed to the wrong queue :)
I suppose I need to wait it is rejected to try again !

Regards,
Jérémy

2018-04-22 6:19 GMT+02:00 Stuart Young <[hidden email]>:
Hi All,

I've been building just the mesa source package locally now against stretch-backports since mesa 17.3.7 and the build process just works.

Since all the build dependencies are now in stretch-backports, what else needs to be done to get mesa into stretch-backports?

I note that Timo (?) created a branch in salsa which contains Jérémy's backport that was submitted to mentors, so that would probably want to be updated to 17.3.9 (which should hopefully hit testing in ~2 days).

One other thing:

Since mesa-18.1.0 is supposedly coming mid-May (according to the release plan from https://lists.freedesktop.org/archives/mesa-dev/2018-April/191388.html ), I decided to see if I could build 18.0.1 source pkg from experimental against stretch-backports.

The only thing that appears to be missing in stretch-backports is libclc-dev (>= 0.2.0+git20180312-1~). Currently stretch-backports has 0.2.0+git20171106-1~bpo9+1. Everything else seems to be there.

-- 
Stuart Young (aka Cefiar)

Reply | Threaded
Open this post in threaded view
|

Re: Request for newer mesa,llvm packages in stretch backports

Jérémy Viès
In reply to this post by Jérémy Viès
Hi all,

I've uploaded libclc (0.2.0+git20180312-2~bpo9+1) and mesa (18.0.2-2~bpo9+1) to mentors.

I need a sponsor so they are available for every one !

Regards,
Jérémy

2018-02-22 22:22 GMT+01:00 Jérémy Viès <[hidden email]>:
Hi all,

I've uploaded mesa 17.3.5 to mentors, but I still need a sponsor.

Best regards,
Jérémy

2018-02-05 20:05 GMT+01:00 Jérémy Viès <[hidden email]>:
Hi,
libclc, libglvnd are already available on mentors. I still need a sponsor...
I will upload mesa in the coming hours.



2018-02-05 11:27 GMT+01:00 Timo Aaltonen <[hidden email]>:
On <a href="tel:04.02.2018%2021" value="+33402201821" target="_blank">04.02.2018 21:48, Jérémy Viès wrote:
> Hi all,
>
> My (first) upload to mentors is online
> (@ https://mentors.debian.net/package/llvm-toolchain-5.0).
> Can someone sponsor me ?
>
> If it is OK, I can start the packaging of other sources and upload them.

Hi, I've uploaded llvm now, and also libdrm, wayland-protocols, vulkan
earlier today.


--
t