SAMBA problems on Debian 8.8

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

SAMBA problems on Debian 8.8

Hans Kraus
Hi,

yesterday, 14. July, about 9:30 pm my SAMBA shares on Debian simply
stopped working. I did not do anything on the system.

When I now try to connect to them from Windows 8.1 I do not see them
in the "Connect Network Drive" window.

When I enter the address manually I get the error "The connection isn't
accepted from the remote device ...".

All texts are my translations from German, so the will be only
approximately correct.

Any advice for me and what debug info shall I supply?

Kind regards,
Hans

Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

Dejan Jocic
On 15-07-17, Hans Kraus wrote:

> Hi,
>
> yesterday, 14. July, about 9:30 pm my SAMBA shares on Debian simply
> stopped working. I did not do anything on the system.
>
> When I now try to connect to them from Windows 8.1 I do not see them
> in the "Connect Network Drive" window.
>
> When I enter the address manually I get the error "The connection isn't
> accepted from the remote device ...".
>
> All texts are my translations from German, so the will be only
> approximately correct.
>
> Any advice for me and what debug info shall I supply?
>
> Kind regards,
> Hans
>

Samba had 2 security updates, first one had messed up dependencies and
second one solved that. Perhaps you just updated first one and need to
do update/upgrade again to catch up second one?


Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

Ulf Volmer
In reply to this post by Hans Kraus
On 15.07.2017 13:56, Hans Kraus wrote:

> yesterday, 14. July, about 9:30 pm my SAMBA shares on Debian simply
> stopped working. I did not do anything on the system.

There were samba updates for jessie yesterday. First one was broken on
some systems so maybe it will help to do an upgrade again.

> Any advice for me and what debug info shall I supply?

is samba running? If yes, any messages in the log?

best regards
Ulf

Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

Hans Kraus
In reply to this post by Hans Kraus
Am 15.07.2017 um 16:05 schrieb Jason Wittlin-Cohen:

> What does 'dpkg -l | grep samba'  show?
>
> On Sat, Jul 15, 2017 at 10:01 AM, Hans Kraus <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Am 15.07.2017 um 14:48 schrieb Jason Wittlin-Cohen:
>
>         Did you run an apt-get dist-upgrade yesterday?  Debian released
>         updated Samba packages as part of a security update.  However,
>         the updated packages had dependency issues and were quickly
>         replaced by new packages.  If you attempted to run a
>         dist-upgrade with the broken packages, it would have installed
>         samba and samba-core.  Check to see whether your samba packages
>         are still installed.
>
>         On Sat, Jul 15, 2017 at 7:56 AM, Hans Kraus <[hidden email]
>         <mailto:[hidden email]> <mailto:[hidden email]
>         <mailto:[hidden email]>>> wrote:
>
>              Hi,
>
>              yesterday, 14. July, about 9:30 pm my SAMBA shares on
>         Debian simply
>              stopped working. I did not do anything on the system.
>
>              When I now try to connect to them from Windows 8.1 I do not
>         see them
>              in the "Connect Network Drive" window.
>
>              When I enter the address manually I get the error "The
>         connection isn't
>              accepted from the remote device ...".
>
>              All texts are my translations from German, so the will be only
>              approximately correct.
>
>              Any advice for me and what debug info shall I supply?
>
>              Kind regards,
>              Hans
>
>
>     No, definitely not. I do updates/upgrades rather infrequently and I
>     issued (packed in a small script):
>
>     /usr/sbin/update-smart-drivedb
>     apt-get update
>     apt-get -y upgrade
>     apt-get -y autoremove
>
>     only after the error occurred.
>
>     Kind regards,
>     Hans

root@robbe:/var/log/samba# dpkg -l | grep samba
rc  samba 2:4.2.14+dfsg-0+deb8u6               amd64        SMB/CIFS
file, print, and login server for Unix
ii  samba-common 2:4.2.14+dfsg-0+deb8u7               all
common files used by both the Samba server and client
ii  samba-dsdb-modules 2:4.2.14+dfsg-0+deb8u7+b1            amd64
Samba Directory Services Database
ii  samba-libs:amd64 2:4.2.14+dfsg-0+deb8u7+b1            amd64
Samba core libraries
ii  samba-vfs-modules 2:4.2.14+dfsg-0+deb8u7+b1            amd64
Samba Virtual FileSystem plugins
ii  vlc-plugin-samba 2.2.6-1~deb8u1                       amd64
Samba plugin for VLC
root@robbe:/var/log/samba#

Kind regards,
Hans

PS: Sorry for the personal mails.

Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

Hans Kraus
In reply to this post by Ulf Volmer
Am 15.07.2017 um 14:58 schrieb Ulf Volmer:

> On 15.07.2017 13:56, Hans Kraus wrote:
>
>> yesterday, 14. July, about 9:30 pm my SAMBA shares on Debian simply
>> stopped working. I did not do anything on the system.
>
> There were samba updates for jessie yesterday. First one was broken on
> some systems so maybe it will help to do an upgrade again.
>
>> Any advice for me and what debug info shall I supply?
>
> is samba running? If yes, any messages in the log?
>
> best regards
> Ulf
>

Hi, thanks for the help to all.
apt-get upgrade/update installed nothing. Therefore I presume that I
have the latest updates.

I tried to restart the Samba server:
------------------------------------------------------------------------
root@robbe:/var/log/samba# systemctl restart smbd.service
------------------------------------------------------------------------

Querying the status gives:
------------------------------------------------------------------------
root@robbe:/var/log/samba# systemctl status smbd.service
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
    Loaded: loaded (/etc/init.d/smbd)
    Active: active (exited) since Sat 2017-07-15 15:35:43 CEST; 6s ago
   Process: 17381 ExecStop=/etc/init.d/smbd stop (code=exited,
status=0/SUCCESS)
   Process: 17384 ExecStart=/etc/init.d/smbd start (code=exited,
status=0/SUCCESS)

Jul 15 15:35:43 robbe systemd[1]: Starting LSB: start Samba SMB/CIFS
daemon (smbd)...
Jul 15 15:35:43 robbe systemd[1]: Started LSB: start Samba SMB/CIFS
daemon (smbd).
root@robbe:/var/log/samba#
------------------------------------------------------------------------

I don't find in the output of 'ps -elf' anything with samba or smb.

In '/var/log/samba' the latest files are from yesterday, around the time
the error occurred. The log files are (the bigger ones are truncated):

log.nmbd
------------------------------------------------------------------------
...
[2017/07/14 20:49:01.939924,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 20:49:01.940054,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 21:04:01.949910,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 21:04:01.950037,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 21:19:01.963122,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 21:19:01.963239,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 21:34:01.964702,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 21:34:01.964832,  0]
../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
   find_domain_master_name_query_fail:
   Unable to find the Domain Master Browser name KRAUS_ZUHAUSE<1b> for
the workgroup KRAUS_ZUHAUSE.
   Unable to sync browse lists in this workgroup.
[2017/07/14 21:40:44.998819,  0] ../source3/nmbd/nmbd.c:58(terminate)
   Got SIGTERM: going down...
------------------------------------------------------------------------

log.smbd
------------------------------------------------------------------------
[2017/07/14 21:40:46.136827,  0] ../lib/util/pidfile.c:153(pidfile_unlink)
   Failed to delete pidfile /var/run/samba/smbd.pid. Error was No such
file or directory
------------------------------------------------------------------------

log.wb-BUILTIN
------------------------------------------------------------------------
[2017/06/23 11:38:12.736446,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
[2017/07/14 21:40:43.488295,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
------------------------------------------------------------------------

log.wb-ROBBE
------------------------------------------------------------------------
...
[2017/05/26 21:40:56.517196,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
[2017/06/23 11:38:12.736452,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
[2017/07/14 21:40:43.488344,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
------------------------------------------------------------------------

log.winbindd
------------------------------------------------------------------------
[2017/07/14 21:40:43.488300,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=1)
------------------------------------------------------------------------

log.winbindd-idmap
------------------------------------------------------------------------
...
[2017/04/07 21:40:09.510520,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
[2017/05/26 21:40:56.517724,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
[2017/06/23 11:38:12.736476,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
[2017/07/14 21:40:43.488306,  0]
../source3/winbindd/winbindd.c:266(winbindd_sig_term_handler)
   Got sig[15] terminate (is_parent=0)
------------------------------------------------------------------------

Kind regards,
Hans


PS: Sorry for the personal mails.

Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

jwittlincohen
In reply to this post by Hans Kraus
You are running an out-of-date version of samba (2:4.2.14+dfsg-0+deb8u6  vs. 4.2.14+dfsg-0+deb8u7+b1).  In addition, you seem to be missing samba-common-bin,  samba-dsdb-modules, and python-samba, all of which are dependencies of samba.

Try 'sudo apt-get install --reinstall samba'

If that doesn't include install the removed packages, run, 'sudo apt-get install samba-common-bin samba-dsdb-modules python-samba'

On Sat, Jul 15, 2017 at 11:01 AM, Hans Kraus <[hidden email]> wrote:
Am 15.07.2017 um 16:05 schrieb Jason Wittlin-Cohen:
What does 'dpkg -l | grep samba'  show?

On Sat, Jul 15, 2017 at 10:01 AM, Hans Kraus <[hidden email] <mailto:[hidden email]>> wrote:

    Am 15.07.2017 um 14:48 schrieb Jason Wittlin-Cohen:

        Did you run an apt-get dist-upgrade yesterday?  Debian released
        updated Samba packages as part of a security update.  However,
        the updated packages had dependency issues and were quickly
        replaced by new packages.  If you attempted to run a
        dist-upgrade with the broken packages, it would have installed
        samba and samba-core.  Check to see whether your samba packages
        are still installed.

        On Sat, Jul 15, 2017 at 7:56 AM, Hans Kraus <[hidden email]
        <mailto:[hidden email]> <mailto:[hidden email]

        <mailto:[hidden email]>>> wrote:

             Hi,

             yesterday, 14. July, about 9:30 pm my SAMBA shares on
        Debian simply
             stopped working. I did not do anything on the system.

             When I now try to connect to them from Windows 8.1 I do not
        see them
             in the "Connect Network Drive" window.

             When I enter the address manually I get the error "The
        connection isn't
             accepted from the remote device ...".

             All texts are my translations from German, so the will be only
             approximately correct.

             Any advice for me and what debug info shall I supply?

             Kind regards,
             Hans


    No, definitely not. I do updates/upgrades rather infrequently and I
    issued (packed in a small script):

    /usr/sbin/update-smart-drivedb
    apt-get update
    apt-get -y upgrade
    apt-get -y autoremove

    only after the error occurred.

    Kind regards,
    Hans

root@robbe:/var/log/samba# dpkg -l | grep samba
rc  samba 2:4.2.14+dfsg-0+deb8u6               amd64        SMB/CIFS file, print, and login server for Unix
ii  samba-common 2:4.2.14+dfsg-0+deb8u7               all          common files used by both the Samba server and client
ii  samba-dsdb-modules 2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba Directory Services Database
ii  samba-libs:amd64 2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba core libraries
ii  samba-vfs-modules 2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba Virtual FileSystem plugins
ii  vlc-plugin-samba 2.2.6-1~deb8u1                       amd64        Samba plugin for VLC
root@robbe:/var/log/samba#

Kind regards,
Hans


Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

jwittlincohen
BTW, here is what I see when I run dpkg -l | grep samba:

jason@storage-server:~$ dpkg -l | grep samba
ii  python-samba                          2:4.2.14+dfsg-0+deb8u7+b1               amd64        Python bindings for Samba
ii  samba                                 2:4.2.14+dfsg-0+deb8u7+b1               amd64        SMB/CIFS file, print, and login server for Unix
ii  samba-common                          2:4.2.14+dfsg-0+deb8u7                  all          common files used by both the Samba server and client
ii  samba-common-bin                      2:4.2.14+dfsg-0+deb8u7+b1               amd64        Samba common files used by both the server and the client
ii  samba-dbg                             2:4.2.14+dfsg-0+deb8u7+b1               amd64        Samba debugging symbols
ii  samba-doc                             2:4.2.14+dfsg-0+deb8u7                  all          Samba documentation
ii  samba-dsdb-modules                    2:4.2.14+dfsg-0+deb8u7+b1               amd64        Samba Directory Services Database
ii  samba-libs:amd64                      2:4.2.14+dfsg-0+deb8u7+b1               amd64        Samba core libraries
ii  samba-vfs-modules                     2:4.2.14+dfsg-0+deb8u7+b1               amd64        Samba Virtual FileSystem plugins


On Sat, Jul 15, 2017 at 11:09 AM, Jason Wittlin-Cohen <[hidden email]> wrote:
You are running an out-of-date version of samba (2:4.2.14+dfsg-0+deb8u6  vs. 4.2.14+dfsg-0+deb8u7+b1).  In addition, you seem to be missing samba-common-bin,  samba-dsdb-modules, and python-samba, all of which are dependencies of samba.

Try 'sudo apt-get install --reinstall samba'

If that doesn't include install the removed packages, run, 'sudo apt-get install samba-common-bin samba-dsdb-modules python-samba'

On Sat, Jul 15, 2017 at 11:01 AM, Hans Kraus <[hidden email]> wrote:
Am 15.07.2017 um 16:05 schrieb Jason Wittlin-Cohen:
What does 'dpkg -l | grep samba'  show?

On Sat, Jul 15, 2017 at 10:01 AM, Hans Kraus <[hidden email] <mailto:[hidden email]>> wrote:

    Am 15.07.2017 um 14:48 schrieb Jason Wittlin-Cohen:

        Did you run an apt-get dist-upgrade yesterday?  Debian released
        updated Samba packages as part of a security update.  However,
        the updated packages had dependency issues and were quickly
        replaced by new packages.  If you attempted to run a
        dist-upgrade with the broken packages, it would have installed
        samba and samba-core.  Check to see whether your samba packages
        are still installed.

        On Sat, Jul 15, 2017 at 7:56 AM, Hans Kraus <[hidden email]
        <mailto:[hidden email]> <mailto:[hidden email]

        <mailto:[hidden email]>>> wrote:

             Hi,

             yesterday, 14. July, about 9:30 pm my SAMBA shares on
        Debian simply
             stopped working. I did not do anything on the system.

             When I now try to connect to them from Windows 8.1 I do not
        see them
             in the "Connect Network Drive" window.

             When I enter the address manually I get the error "The
        connection isn't
             accepted from the remote device ...".

             All texts are my translations from German, so the will be only
             approximately correct.

             Any advice for me and what debug info shall I supply?

             Kind regards,
             Hans


    No, definitely not. I do updates/upgrades rather infrequently and I
    issued (packed in a small script):

    /usr/sbin/update-smart-drivedb
    apt-get update
    apt-get -y upgrade
    apt-get -y autoremove

    only after the error occurred.

    Kind regards,
    Hans

root@robbe:/var/log/samba# dpkg -l | grep samba
rc  samba 2:4.2.14+dfsg-0+deb8u6               amd64        SMB/CIFS file, print, and login server for Unix
ii  samba-common 2:4.2.14+dfsg-0+deb8u7               all          common files used by both the Samba server and client
ii  samba-dsdb-modules 2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba Directory Services Database
ii  samba-libs:amd64 2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba core libraries
ii  samba-vfs-modules 2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba Virtual FileSystem plugins
ii  vlc-plugin-samba 2.2.6-1~deb8u1                       amd64        Samba plugin for VLC
root@robbe:/var/log/samba#

Kind regards,
Hans



Reply | Threaded
Open this post in threaded view
|

[SOLVED (mostly)] Re: SAMBA problems on Debian 8.8

Hans Kraus
Thanks a lot to all who have helped and/or contemplated my problem.

After:
---------------------------------------------------------------------------
apt-get install --reinstall samba
apt-get install samba-dbg samba-doc
---------------------------------------------------------------------------
and installing the suggested packages too I see:

dpkg -l | grep samba
---------------------------------------------------------------------------
ii  libcrypt-smbhash-perl                                       0.12-4
                             all          generate LM/NT hash of a
password for samba
ii  python-samba
2:4.2.14+dfsg-0+deb8u7+b1            amd64        Python bindings for Samba
ii  samba
2:4.2.14+dfsg-0+deb8u7+b1            amd64        SMB/CIFS file, print,
and login server for Unix
ii  samba-common
2:4.2.14+dfsg-0+deb8u7               all          common files used by
both the Samba server and client
ii  samba-common-bin
2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba common files
used by both the server and the client
ii  samba-dbg
2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba debugging symbols
ii  samba-doc
2:4.2.14+dfsg-0+deb8u7               all          Samba documentation
ii  samba-dsdb-modules
2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba Directory
Services Database
ii  samba-libs:amd64
2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba core libraries
ii  samba-vfs-modules
2:4.2.14+dfsg-0+deb8u7+b1            amd64        Samba Virtual
FileSystem plugins
ii  vlc-plugin-samba
2.2.6-1~deb8u1                       amd64        Samba plugin for VLC
---------------------------------------------------------------------------

systemctl status smbd.service:
---------------------------------------------------------------------------
root@robbe:/etc/samba# systemctl status smbd.service
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
    Loaded: loaded (/etc/init.d/smbd)
    Active: active (running) since Sat 2017-07-15 17:45:27 CEST; 35min ago
   Process: 1906 ExecStop=/etc/init.d/smbd stop (code=exited,
status=0/SUCCESS)
   Process: 1911 ExecStart=/etc/init.d/smbd start (code=exited,
status=0/SUCCESS)
    CGroup: /system.slice/smbd.service
            ├─1920 /usr/sbin/smbd -D
            ├─1923 /usr/sbin/smbd -D
            └─3101 /usr/sbin/smbd -D

Jul 15 17:45:27 robbe smbd[1911]: Starting SMB/CIFS daemon: smbd.
Jul 15 17:45:27 robbe systemd[1]: Started LSB: start Samba SMB/CIFS
daemon (smbd).
Jul 15 17:51:19 robbe smbd[2533]: pam_unix(samba:session): session
opened for user kraush by (uid=0)
Jul 15 17:51:56 robbe smbd[2533]: pam_unix(samba:session): session
closed for user kraush
Jul 15 17:53:57 robbe smbd[2568]: pam_unix(samba:session): session
opened for user kraush by (uid=0)
Jul 15 17:54:19 robbe smbd[2568]: pam_unix(samba:session): session
closed for user kraush
Jul 15 17:54:30 robbe smbd[2573]: pam_unix(samba:session): session
opened for user kraush by (uid=0)
Jul 15 17:54:41 robbe smbd[2573]: pam_unix(samba:session): session
closed for user kraush
Jul 15 17:55:51 robbe smbd[3101]: pam_unix(samba:session): session
opened for user kraush by (uid=0)
Jul 15 18:07:30 robbe smbd[3101]: pam_unix(samba:session): session
closed for user kraush
Jul 15 18:07:30 robbe smbd[3101]: pam_unix(samba:session): session
opened for user kraush by (uid=0)
---------------------------------------------------------------------------

I can now again connect to the shares via the "Connect Network Drive"
window, choosing a drive letter and entering:
\\<fully qualified server name>\<share name>.

I still do not see the Shares (on Windows 8.1) in the "Connect Network
Drive" window in the "Search" part.

Kind regards,
Hans

Am 15.07.2017 um 17:10 schrieb Jason Wittlin-Cohen:

> BTW, here is what I see when I run dpkg -l | grep samba:
>
> jason@storage-server:~$ dpkg -l | grep samba
> ii  python-samba                          2:4.2.14+dfsg-0+deb8u7+b1    
>            amd64        Python bindings for Samba
> ii  samba                                 2:4.2.14+dfsg-0+deb8u7+b1    
>            amd64        SMB/CIFS file, print, and login server for Unix
> ii  samba-common                          2:4.2.14+dfsg-0+deb8u7        
>           all          common files used by both the Samba server and client
> ii  samba-common-bin                      2:4.2.14+dfsg-0+deb8u7+b1    
>            amd64        Samba common files used by both the server and
> the client
> ii  samba-dbg                             2:4.2.14+dfsg-0+deb8u7+b1    
>            amd64        Samba debugging symbols
> ii  samba-doc                             2:4.2.14+dfsg-0+deb8u7        
>           all          Samba documentation
> ii  samba-dsdb-modules                    2:4.2.14+dfsg-0+deb8u7+b1    
>            amd64        Samba Directory Services Database
> ii  samba-libs:amd64                      2:4.2.14+dfsg-0+deb8u7+b1    
>            amd64        Samba core libraries
> ii  samba-vfs-modules                     2:4.2.14+dfsg-0+deb8u7+b1    
>            amd64        Samba Virtual FileSystem plugins
>
>
> On Sat, Jul 15, 2017 at 11:09 AM, Jason Wittlin-Cohen
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     You are running an out-of-date version of samba
>     (2:4.2.14+dfsg-0+deb8u6  vs. 4.2.14+dfsg-0+deb8u7+b1).  In addition,
>     you seem to be missing samba-common-bin,  samba-dsdb-modules, and
>     python-samba, all of which are dependencies of samba.
>
>     Try 'sudo apt-get install --reinstall samba'
>
>     If that doesn't include install the removed packages, run, 'sudo
>     apt-get install samba-common-bin samba-dsdb-modules python-samba'
>
>     On Sat, Jul 15, 2017 at 11:01 AM, Hans Kraus <[hidden email]
>     <mailto:[hidden email]>> wrote:
>
>         Am 15.07.2017 um 16:05 schrieb Jason Wittlin-Cohen:
>
>             What does 'dpkg -l | grep samba'  show?
>
>             On Sat, Jul 15, 2017 at 10:01 AM, Hans Kraus
>             <[hidden email] <mailto:[hidden email]>
>             <mailto:[hidden email] <mailto:[hidden email]>>>
>             wrote:
>
>                  Am 15.07.2017 um 14:48 schrieb Jason Wittlin-Cohen:
>
>                      Did you run an apt-get dist-upgrade yesterday?
>             Debian released
>                      updated Samba packages as part of a security
>             update.  However,
>                      the updated packages had dependency issues and were
>             quickly
>                      replaced by new packages.  If you attempted to run a
>                      dist-upgrade with the broken packages, it would
>             have installed
>                      samba and samba-core.  Check to see whether your
>             samba packages
>                      are still installed.
>
>                      On Sat, Jul 15, 2017 at 7:56 AM, Hans Kraus
>             <[hidden email] <mailto:[hidden email]>
>                      <mailto:[hidden email]
>             <mailto:[hidden email]>> <mailto:[hidden email]
>             <mailto:[hidden email]>
>
>                      <mailto:[hidden email]
>             <mailto:[hidden email]>>>> wrote:
>
>                           Hi,
>
>                           yesterday, 14. July, about 9:30 pm my SAMBA
>             shares on
>                      Debian simply
>                           stopped working. I did not do anything on the
>             system.
>
>                           When I now try to connect to them from Windows
>             8.1 I do not
>                      see them
>                           in the "Connect Network Drive" window.
>
>                           When I enter the address manually I get the
>             error "The
>                      connection isn't
>                           accepted from the remote device ...".
>
>                           All texts are my translations from German, so
>             the will be only
>                           approximately correct.
>
>                           Any advice for me and what debug info shall I
>             supply?
>
>                           Kind regards,
>                           Hans
>
>
>                  No, definitely not. I do updates/upgrades rather
>             infrequently and I
>                  issued (packed in a small script):
>
>                  /usr/sbin/update-smart-drivedb
>                  apt-get update
>                  apt-get -y upgrade
>                  apt-get -y autoremove
>
>                  only after the error occurred.
>
>                  Kind regards,
>                  Hans
>
>
>         root@robbe:/var/log/samba# dpkg -l | grep samba
>         rc  samba 2:4.2.14+dfsg-0+deb8u6               amd64      
>         SMB/CIFS file, print, and login server for Unix
>         ii  samba-common 2:4.2.14+dfsg-0+deb8u7               all      
>            common files used by both the Samba server and client
>         ii  samba-dsdb-modules 2:4.2.14+dfsg-0+deb8u7+b1          
>         amd64        Samba Directory Services Database
>         ii  samba-libs:amd64 2:4.2.14+dfsg-0+deb8u7+b1            amd64
>                Samba core libraries
>         ii  samba-vfs-modules 2:4.2.14+dfsg-0+deb8u7+b1          
>         amd64        Samba Virtual FileSystem plugins
>         ii  vlc-plugin-samba 2.2.6-1~deb8u1                       amd64
>                Samba plugin for VLC
>         root@robbe:/var/log/samba#
>
>         Kind regards,
>         Hans
>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

Marc Shapiro-3
In reply to this post by jwittlincohen
On 07/15/2017 08:09 AM, Jason Wittlin-Cohen wrote:
You are running an out-of-date version of samba (2:4.2.14+dfsg-0+deb8u6  vs. 4.2.14+dfsg-0+deb8u7+b1).  In addition, you seem to be missing samba-common-bin,  samba-dsdb-modules, and python-samba, all of which are dependencies of samba.

Try 'sudo apt-get install --reinstall samba'

If that doesn't include install the removed packages, run, 'sudo apt-get install samba-common-bin samba-dsdb-modules python-samba'

I, too, have been having problems that seem to point to samba.  Note that I am still running Jessie.

If I run 'sudo aptitude update' followed by 'sudo aptitude upgrade' I get the following:

-------------------------------------------------------------------------------------------------------------

The following packages will be upgraded:
  python-samba
The following partially installed packages will be configured:
  samba samba-common-bin
1 packages upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/1,016 kB of archives. After unpacking 0 B will be used.
Do you want to continue? [Y/n/?] y
Traceback (most recent call last):      
  File "/usr/bin/apt-listchanges", line 29, in <module>
    import anydbm
ImportError: No module named 'anydbm'
(Reading database ... 336173 files and directories currently installed.)
Preparing to unpack .../python-samba_2%3a4.2.14+dfsg-0+deb8u7+b1_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: error processing archive /var/cache/apt/archives/python-samba_2%3a4.2.14+dfsg-0+deb8u7+b1_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/python-samba_2%3a4.2.14+dfsg-0+deb8u7+b1_amd64.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)
Failed to perform requested operation on package.  Trying to recover:
dpkg: dependency problems prevent configuration of python-samba:
 python-samba depends on samba-libs (= 2:4.2.14+dfsg-0+deb8u6); however:
  Version of samba-libs:amd64 on system is 2:4.2.14+dfsg-0+deb8u7+b1.

dpkg: error processing package python-samba (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of samba:
 samba depends on python-samba; however:
  Package python-samba is not configured yet.

dpkg: error processing package samba (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of samba-common-bin:
 samba-common-bin depends on python-samba; however:
  Package python-samba is not configured yet.

dpkg: error processing package samba-common-bin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-samba
 samba
 samba-common-bin

-------------------------------------------------------------------------------------------------------------

So far as I can tell, samba only exists on my system because smbclient is suggested by CUPS and since my wife sometime prints from her Windows laptop I want to leave it installed (is this correct?).

Trying to reinstall, or update any of the samba packages just gives me more of the same.  How do I resolve this?

At some point I will want to upgrade from Jessie to Stretch, but I need a clean system before I can attempt that.

Marc
Reply | Threaded
Open this post in threaded view
|

Re: SAMBA problems on Debian 8.8

Frank Miles
In reply to this post by jwittlincohen
On Sat, 15 Jul 2017 17:10:03 +0200, Jason Wittlin-Cohen wrote:

> You are running an out-of-date version of samba (2:4.2.14+dfsg-0+deb8u6
>  vs. 4.2.14+dfsg-0+deb8u7+b1).  In addition, you seem to be missing
> samba-common-bin,  samba-dsdb-modules, and python-samba, all of which are
> dependencies of samba.
>
> Try 'sudo apt-get install --reinstall samba'
>

Thanks, Jason - I had reinstalled samba-libs but not some other apparently
critical part of samba.  The --reinstall fixed it!

   -F

(Not the OP, just another still-running-jessie guy)