(SOLVED) Samba update, apt-listchanges, Pulseaudio, and X not starting

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

(SOLVED) Samba update, apt-listchanges, Pulseaudio, and X not starting

Marc Shapiro-3
I had a whole series of problems that cropped up, one after the other
and trying to deal with them individually seemed virtually impossible.  
However...

The problem with Samba updates and apt-listchanges turned out to be a
PEBKAC issue.  I was working with something in Python that needed Python
3.  I decided to change one of my own scripts to be Python 3
compatible.  Having done this, I thought, "Why don't I just change the
default to Python 3?"  Bad idea.  Apt-listchanges (in Jessie) does not
like Python 3.  Once I set the default back to Python 2.7 all the errors
during "aptitude upgrade" went away. Once I was able to get Jessie fully
up-to-date I made a copy of my partitions, made sure the new partitions
were bootable, and upgraded them the Stretch.  Once I had Stretch
running and properly configured the pulseaudio problems went away and
X11 started working again.

Thanks to everyone who tried to help me sort through any of my many issues.

Note: apt-listchanges in Stretch specifically uses Python 3.


Marc Shapiro