Serveur de son dans un container openvz

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Serveur de son dans un container openvz

Marc JEAN
Bonjour !

Je teste ltsp dans un container openvz, le tout en squeeze i686 à jour ;
plus exactement, dans plusieurs containers, une version simplifiée de
www.ltsp-cluster.org avec un seul container de chaque type ; ça
fonctionne tout seul, sauf le son pulseaudio qui doit passer du serveur
gnome openvz vers le terminal léger.

C'est le serveur de son qui pose problème ; avec un "vrai" serveur ltsp
ça fonctionne en squeeze sans problème ; mais dans un container, même
avec une carte snd_dummy, ça plante au lancement de tout lecteur de son
avec comme seul message "Erreur de bus" en console ; sans doute une
erreur basique de configuration -je suis utilisateur Debian, pas
administrateur ou programmeur-, mais je n'ai absolument rien à me mettre
sous la dent dans les logs.

"pulseaudio -vvvvv" sur le serveur donne : Failed to handle SIGBUS.

Comment avoir un message d'erreur plus précis pour me mettre sur la
voie ? Un howto pas trop technique pour debogguer pulseaudio/ltsp ?

D'avance merci
Marc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers [hidden email]
En cas de soucis, contactez EN ANGLAIS [hidden email]
Archive: http://lists.debian.org/1285235407.15380.43.camel@aps

Reply | Threaded
Open this post in threaded view
|

Résolu: Serveur de son dans un container openvz

Marc JEAN
En fait, le son vient tout seul quand on alloue assez de pages
( paramètre user_beancounter : shmpages )...
Bon week-end à tous !

Le jeudi 23 septembre 2010 à 11:50 +0200, Marc JEAN a écrit :
> Bonjour !
>
> Je teste ltsp dans un container openvz, le tout en squeeze i686 à jour ;
> plus exactement, dans plusieurs containers, une version simplifiée de
> www.ltsp-cluster.org avec un seul container de chaque type ; ça
> fonctionne tout seul, sauf le son pulseaudio qui doit passer du serveur
> gnome openvz vers le terminal léger.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers [hidden email]
En cas de soucis, contactez EN ANGLAIS [hidden email]
Archive: http://lists.debian.org/1285332046.1487.30.camel@aps