Synaptic não abre no GNOME sobre Wayland

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Synaptic não abre no GNOME sobre Wayland

Arles
Prezados,
primeira vez na lista. Meu nome é Arles, usuário GNULinux desde 2004 e usuário Debian desde 2013. Apesar do tempo de trabalho com o sistema sou um usuário sem muitos conhecimentos técnicos.

Fiz uma nova instalação do Debian há uns dias e, agora usando o Testing, estou tentando usar o GNOME sobre Wayland.

Alguns problemas têm surgido, como é comum em toda mudança.

Um deles e que estou meio inseguro de aplicar a solução que encontrei em fóruns pela Rede é que não consigo abrir o Synaptic nem nenhum outro programa que exija autenticação. Abro o programa, a janela de autenticação aparece, forneço a senha, ma a partir dai o programa não abre.

Tentando abrir pelo Terminal, usando o gksu, recebo a seguinte mensagem de erro:

Gtk-Message: Failed to load module "canberra-gtk-module"
/usr/bin/xauth: file /home/xxxx/.Xauthority does not exist /usr/bin/xauth: file /home/xxxx/.Xauthority does not exist gksu-run: gksu/synaptic/26330-0-xxxx_TIME117687914 gksu-run: No protocol specified (synaptic:26348): WARNING: Could not open X display Segmentation fault Encontrei uma solução que me pareceu paliativa que seria rodar o seguinte comando: xhost +si:localuser:root Como não encontrei referências precisas sobre a segurança de adotar tal procedimento, não o adotei em definitivo, fazendo um script rodar na inicialização da seção, por exemplo. Mas, ao rodar o comando numa seção ele fez abrir os programas. Gostaria de, se possível, contar com a ajuda de vocês para me apontar se a solução correta poderia ser esta mesmo e quais os riscos envolvidos. Desde já agradeço. Att,
-- 
*Arles*

PGP Fingerprint: 182C 78D8 F25C 449A 1CB4 3706 5820 9CE8 A1A0 937D


0xA1A0937D.asc (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Synaptic não abre no GNOME sobre Wayland

Antonio Terceiro via nm
On Thu, Apr 20, 2017 at 06:19:05PM -0300, Arles wrote:

> Prezados,
> primeira vez na lista. Meu nome é Arles, usuário GNULinux desde 2004 e
> usuário Debian desde 2013. Apesar do tempo de trabalho com o sistema sou
> um usuário sem muitos conhecimentos técnicos.
>
> Fiz uma nova instalação do Debian há uns dias e, agora usando o Testing,
> estou tentando usar o GNOME sobre Wayland.
>
> Alguns problemas têm surgido, como é comum em toda mudança.
>
> Um deles e que estou meio inseguro de aplicar a solução que encontrei em
> fóruns pela Rede é que não consigo abrir o Synaptic nem nenhum outro
> programa que exija autenticação. Abro o programa, a janela de
> autenticação aparece, forneço a senha, ma a partir dai o programa não abre.
>
> Tentando abrir pelo Terminal, usando o gksu, recebo a seguinte mensagem
> de erro:
>
> Gtk-Message: Failed to load module "canberra-gtk-module"
> /usr/bin/xauth: file /home/xxxx/.Xauthority does not exist
> /usr/bin/xauth: file /home/xxxx/.Xauthority does not exist gksu-run:
> gksu/synaptic/26330-0-xxxx_TIME117687914 gksu-run: No protocol specified
> *(synaptic:26348): WARNING*: Could not open X display Segmentation fault
> Encontrei uma solução que me pareceu paliativa que seria rodar o
> seguinte comando: xhost +si:localuser:rootComo não encontrei referências
> precisas sobre a segurança de adotar tal procedimento, não o adotei em
> definitivo, fazendo um script rodar na inicialização da seção, por
> exemplo. Mas, ao rodar o comando numa seção ele fez abrir os programas.
> Gostaria de, se possível, contar com a ajuda de vocês para me apontar se
> a solução correta poderia ser esta mesmo e quais os riscos
> envolvidos.Desde já agradeço.Att,
isso parece ser exatamente o que está descrito em
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=818366

pelo q eu entendi, tem código no synaptic que assume estar rodando no X
incondicionalmente. estritamente falando, a única solução correta é
consertar o synaptic.

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Synaptic não abre no GNOME sobre Wayland

Arles


Em 22-04-2017 16:48, Antonio Terceiro escreveu:

> On Thu, Apr 20, 2017 at 06:19:05PM -0300, Arles wrote:
>> Prezados,
>> primeira vez na lista. Meu nome é Arles, usuário GNULinux desde 2004 e
>> usuário Debian desde 2013. Apesar do tempo de trabalho com o sistema sou
>> um usuário sem muitos conhecimentos técnicos.
>>
>> Fiz uma nova instalação do Debian há uns dias e, agora usando o Testing,
>> estou tentando usar o GNOME sobre Wayland.
>>
>> Alguns problemas têm surgido, como é comum em toda mudança.
>>
>> Um deles e que estou meio inseguro de aplicar a solução que encontrei em
>> fóruns pela Rede é que não consigo abrir o Synaptic nem nenhum outro
>> programa que exija autenticação. Abro o programa, a janela de
>> autenticação aparece, forneço a senha, ma a partir dai o programa não abre.
>>
>> Tentando abrir pelo Terminal, usando o gksu, recebo a seguinte mensagem
>> de erro:
>>
>> Gtk-Message: Failed to load module "canberra-gtk-module"
>> /usr/bin/xauth: file /home/xxxx/.Xauthority does not exist
>> /usr/bin/xauth: file /home/xxxx/.Xauthority does not exist gksu-run:
>> gksu/synaptic/26330-0-xxxx_TIME117687914 gksu-run: No protocol specified
>> *(synaptic:26348): WARNING*: Could not open X display Segmentation fault
>> Encontrei uma solução que me pareceu paliativa que seria rodar o
>> seguinte comando: xhost +si:localuser:rootComo não encontrei referências
>> precisas sobre a segurança de adotar tal procedimento, não o adotei em
>> definitivo, fazendo um script rodar na inicialização da seção, por
>> exemplo. Mas, ao rodar o comando numa seção ele fez abrir os programas.
>> Gostaria de, se possível, contar com a ajuda de vocês para me apontar se
>> a solução correta poderia ser esta mesmo e quais os riscos
>> envolvidos.Desde já agradeço.Att,
> isso parece ser exatamente o que está descrito em
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=818366
>
> pelo q eu entendi, tem código no synaptic que assume estar rodando no X
> incondicionalmente. estritamente falando, a única solução correta é
> consertar o synaptic.
Opa, Antonio Terceiro, obrigado pela resposta.

Eu penso o mesmo e que ainda existe um caminho de adaptação. Mas percebo
a mesma situação com outros programas. Aqui consegui verificar situação
parecida com o Nautilus e o Gufw.

Estou usando o comando xhost como indicado nesta trilha que você indicou
e que eu já havia acompanhado. Ele funciona, mas não sei ao certo se
devo utilizá-lo pois me parece uma solução que cria um atalho externo ao
Wayland, se não estou enganado. Mas tô usando ele e o coloquei como um
script para inicializar junto com a seção.

Enfim, se houver alguma novidade, por favor, me falem.

Mais uma vez obrigado e forte abraço.



--
*Arles*

PGP Fingerprint: 182C 78D8 F25C 449A 1CB4 3706 5820 9CE8 A1A0 937D


Loading...