Tastaturlayout Problem

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Tastaturlayout Problem

Klaus Becker-2
Moin,

habe gerade auf einem Lappi frisch Buster per netinstall installiert.

Um bestimmte Buchstaben wie z. B. i,o,p,k,l,m zu schreiben, muss ich
dabei auf die Funktionstaste drücken, sonst kommt garnichts oder etwas
ganz anderes raus

/etc/default/keyboard ist ok (ich lebe in Frankreich):

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="latin9"
XKBOPTIONS=""

BACKSPACE="guess"


"dpkg-reconfigure console-setup" und "dpkg-reconfigure console-common"
haben nichts gebracht.

"dpkg-reconfigure console-common" sagt:

"Looking for keymap to install:
mac-usb-fr".

und bricht dann ab. Sowas hab' ich noch nicht gesehen. Wie weiter?

Gruß

Klaus

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem

Ulf Volmer
On 01.04.20 22:21, Klaus Becker wrote:

> habe gerade auf einem Lappi frisch Buster per netinstall installiert.
>
> Um bestimmte Buchstaben wie z. B. i,o,p,k,l,m zu schreiben, muss ich
> dabei auf die Funktionstaste drücken, sonst kommt garnichts oder etwas
> ganz anderes raus

Numlock an?

Viele Grüße
Ulf

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem

Klaus Becker-2


Le 01/04/2020 à 22:34, Ulf Volmer a écrit :

> On 01.04.20 22:21, Klaus Becker wrote:
>
>> habe gerade auf einem Lappi frisch Buster per netinstall installiert.
>>
>> Um bestimmte Buchstaben wie z. B. i,o,p,k,l,m zu schreiben, muss ich
>> dabei auf die Funktionstaste drücken, sonst kommt garnichts oder etwas
>> ganz anderes raus
>
> Numlock an?
>
> Viele Grüße
> Ulf


Hallo Ulf und alle,

hab' ich ausprobiert, daran liegt es nicht.

Heute morgen habe ich den Lappi neu angeworfen, und siehe da, bei der
Anmeldung funktionierte die Tastatur richtig.

Nur als ich dann in XFCE4 war, war es wieder wie vorher, ebenso in TTY.

Habe alles mögliche mit

dpkg-reconfigure console-common/setup/data

versucht, nichts zu machen.

Manche Buchstaben funktionieren so, als sei die Großbuchstaben-Taste
gedrückt, aber nicht alle. Wirklich sonderbar.

LG

Klaus

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem

Klaus Becker-2


Le 02/04/2020 à 09:27, Klaus Becker a écrit :

>
>
> Le 01/04/2020 à 22:34, Ulf Volmer a écrit :
>> On 01.04.20 22:21, Klaus Becker wrote:
>>
>>> habe gerade auf einem Lappi frisch Buster per netinstall installiert.
>>>
>>> Um bestimmte Buchstaben wie z. B. i,o,p,k,l,m zu schreiben, muss ich
>>> dabei auf die Funktionstaste drücken, sonst kommt garnichts oder etwas
>>> ganz anderes raus
>>
>> Numlock an?
>>
>> Viele Grüße
>> Ulf
>
>
> Hallo Ulf und alle,
>
> hab' ich ausprobiert, daran liegt es nicht.
>
> Heute morgen habe ich den Lappi neu angeworfen, und siehe da, bei der
> Anmeldung funktionierte die Tastatur richtig.
>
> Nur als ich dann in XFCE4 war, war es wieder wie vorher, ebenso in TTY.
>
> Habe alles mögliche mit
>
> dpkg-reconfigure console-common/setup/data
>
> versucht, nichts zu machen.
>
> Manche Buchstaben funktionieren so, als sei die Großbuchstaben-Taste
> gedrückt, aber nicht alle. Wirklich sonderbar.
>
> LG
>
> Klaus
>

Ich hab' auch mit den Tastatureinstellungen unter XFCE4 rumgespielt und
getetstet, hat auch nichts gebracht.

Wenn ich keine Lösung finde, installiere ich das System neu, wäre auch
kein Beinbruch.

Klaus

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem

Christian Knoke
Klaus Becker schrieb am 02. Apr um 09:56 Uhr:

> > > > habe gerade auf einem Lappi frisch Buster per netinstall installiert.
> > > >
> > > > Um bestimmte Buchstaben wie z. B. i,o,p,k,l,m zu schreiben, muss ich
> > > > dabei auf die Funktionstaste drücken, sonst kommt garnichts oder etwas
> > > > ganz anderes raus

> > Manche Buchstaben funktionieren so, als sei die Großbuchstaben-Taste
> > gedrückt, aber nicht alle. Wirklich sonderbar.

Auf manchen Laptops können die Funktionen der "Fn" und "STRG" (=Ctrl) Tasten
im BIOS vertauscht werden, teilweise auch mit einer Tastenkombination
umgeschaltet.  Ich meine, neulich etwas gesehen zu haben, dass das auch von
Linux aus geht.

--
http://cknoke.de

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem

Klaus Becker-2


Le 02/04/2020 à 11:03, Christian Knoke a écrit :

> Klaus Becker schrieb am 02. Apr um 09:56 Uhr:
>
>>>>> habe gerade auf einem Lappi frisch Buster per netinstall installiert.
>>>>>
>>>>> Um bestimmte Buchstaben wie z. B. i,o,p,k,l,m zu schreiben, muss ich
>>>>> dabei auf die Funktionstaste drücken, sonst kommt garnichts oder etwas
>>>>> ganz anderes raus
>
>>> Manche Buchstaben funktionieren so, als sei die Großbuchstaben-Taste
>>> gedrückt, aber nicht alle. Wirklich sonderbar.
>
> Auf manchen Laptops können die Funktionen der "Fn" und "STRG" (=Ctrl) Tasten
> im BIOS vertauscht werden, teilweise auch mit einer Tastenkombination
> umgeschaltet.  Ich meine, neulich etwas gesehen zu haben, dass das auch von
> Linux aus geht.
>

Ich hab' nichts dergleichen im BIOS gefunden.

Ich habe aber einen neuen Benutzer angelegt, und mit dem funktionniert
die Tastatur.

Es muss also an den persönlichen XFCE4-Einstellungen liegen. Ich habe
alle versteckten Dateien von einem Desktop-Rechner kopiert, um die
gleichen Einnstellungen leicht wiederzufinden.

Es mÜsste also reichen, die Einstellungen von XFCE4 auf dem Lappi zu
löschen, ich weiß aber nicht, wo die liegen.

Ich habe

rm -rf /home/klaus/.config/xfce4*

ausgeführt, hat aber nichts gebracht. Meine Menüs usw haben sich auch
nicht geändert.

Gruß

Klaus

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem

Marco Möller
Es wurde schon von Ulf Volmer erwähnt: es könnte an der Aktivierung der
Numlock Funktion liegen. In diese Richtung würde ich die Suche nochmal
vertiefen. Als erstes mal in einen Editor gehen, und beobachten was da
genau passiert wenn die genannten Tasten gedrückt werden. Bisher
schriebst Du nur: "sonst kommt gar nichts oder etwas ganz anderes raus".
Was bedeutet das genau? Erzeuge in einem Editor mit den funktionierenden
Tasten mal einige wenige Zeilen mit Buchstabensalat zum Testen und schau
dann nochmal systematisch was dort die Taste "o" zum Beispiel erzeugt.
Wenn es eine Bewegung des Cursors nach oben wäre, dann würde das die
Vermutung auf eine Fehleinstellung der Numlock Funktion perfekt
bestätigen. Sorry, einen wirklich neuen Tipp habe ich sonst nicht.
Gruß, Marco.

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem

Christian Knoke
In reply to this post by Klaus Becker-2
Klaus Becker schrieb am 02. Apr um 12:33 Uhr:

> Ich habe aber einen neuen Benutzer angelegt, und mit dem funktionniert die
> Tastatur.
>
> Es muss also an den persönlichen XFCE4-Einstellungen liegen. Ich habe alle
> versteckten Dateien von einem Desktop-Rechner kopiert, um die gleichen
> Einnstellungen leicht wiederzufinden.
>
> Es mÜsste also reichen, die Einstellungen von XFCE4 auf dem Lappi zu
> löschen, ich weiß aber nicht, wo die liegen.
>
> Ich habe
>
> rm -rf /home/klaus/.config/xfce4*
>
> ausgeführt, hat aber nichts gebracht. Meine Menüs usw haben sich auch nicht
> geändert.

Könnte daran liegen, dass die Dateien am Sitzungsende von XFCE geschrieben
werden. Ggffls XFCE nicht starten und von der Konsole löschen oder woanders
hinschieben.

Sonst würde ich Marcos Tips mal folgen.

Gruß

--
http://cknoke.de

Reply | Threaded
Open this post in threaded view
|

Re: Tastaturlayout Problem [gelöst]

Klaus Becker-2


Le 02/04/2020 à 15:46, Christian Knoke a écrit :

> Klaus Becker schrieb am 02. Apr um 12:33 Uhr:
>
>> Ich habe aber einen neuen Benutzer angelegt, und mit dem funktionniert die
>> Tastatur.
>>
>> Es muss also an den persönlichen XFCE4-Einstellungen liegen. Ich habe alle
>> versteckten Dateien von einem Desktop-Rechner kopiert, um die gleichen
>> Einnstellungen leicht wiederzufinden.
>>
>> Es mÜsste also reichen, die Einstellungen von XFCE4 auf dem Lappi zu
>> löschen, ich weiß aber nicht, wo die liegen.
>>
>> Ich habe
>>
>> rm -rf /home/klaus/.config/xfce4*
>>
>> ausgeführt, hat aber nichts gebracht. Meine Menüs usw haben sich auch nicht
>> geändert.
>
> Könnte daran liegen, dass die Dateien am Sitzungsende von XFCE geschrieben
> werden. Ggffls XFCE nicht starten und von der Konsole löschen oder woanders
> hinschieben.


Hab' ich gemacht und hat geklappt.

Danke für alle Antworten

Klaus

>
> Sonst würde ich Marcos Tips mal folgen.
>
> Gruß
>