Update of ruby-github-linguist

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Update of ruby-github-linguist

Daniel Leidert-2
Hi,

I just wanted to ask, if there are any reasons why ruby-github-linguist should
not be updated to the latest release (7.5.1)? Its only reverse dependency is
gitaly, which is required by gitlab. I don't want to break things. So maybe an
upload to experimental is the best solution here?

Regards, Daniel

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Update of ruby-github-linguist

Utkarsh Gupta

Hey,

On 07/08/19 6:22 am, Daniel Leidert wrote:
Hi,

I just wanted to ask, if there are any reasons why ruby-github-linguist should
not be updated to the latest release (7.5.1)?

From what *I know*, we need gitaly 1.42.5 to support gitlab.
And as per gitaly's Gemfile: 'github-linguist', '~> 6.1'
That should explain why  it was not updated to the latest release.

So maybe an upload to experimental is the best solution here?

I am not sure, but maybe? (Praveen would know better).
But maybe the best solution is to bump github-linguist in the upstream and see how it goes.

Also, just curious to know, what d'you need ruby-github-linguist for?


Best,
Utkarsh

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Update of ruby-github-linguist

Pirate Praveen-3


On 2019, ഓഗസ്റ്റ് 7 7:59:02 AM IST, Utkarsh Gupta <[hidden email]> wrote:

>Hey,
>
>On 07/08/19 6:22 am, Daniel Leidert wrote:
>> Hi,
>>
>> I just wanted to ask, if there are any reasons why
>ruby-github-linguist should
>> not be updated to the latest release (7.5.1)?
>
>From what *I know*, we need gitaly 1.42.5 to support gitlab.
>And as per gitaly's Gemfile:|'github-linguist', '~> 6.1'|
>That should explain why  it was not updated to the latest release.
>
>> So maybe an upload to experimental is the best solution here?
>
>I am not sure, but maybe? (Praveen would know better).
>But maybe the best solution is to bump github-linguist in the upstream
>and see how it goes.
>
>Also, just curious to know, what d'you need ruby-github-linguist for?

We can ask upstream to bump this dependency and try the update with upstream ci. Fork, bump dependency and upstream ci results.

>
>Best,
>Utkarsh

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Reply | Threaded
Open this post in threaded view
|

Re: Update of ruby-github-linguist

Daniel Leidert-2
In reply to this post by Utkarsh Gupta
Am Mittwoch, den 07.08.2019, 07:59 +0530 schrieb Utkarsh Gupta:

> On 07/08/19 6:22 am, Daniel Leidert wrote:
> > Hi,
> >
> > I just wanted to ask, if there are any reasons why ruby-github-linguist
> > should
> > not be updated to the latest release (7.5.1)?
>  
> From what *I know*, we need gitaly 1.42.5 to support gitlab.
> And as per gitaly's Gemfile: 'github-linguist', '~> 6.1'
> That should explain why  it was not updated to the latest release.
Ah. I only checked the gitaly package dependencies, which just state: ruby-
github-linguist (>= 6.1~). The gitaly package dependecies IMHO should be
adjusted to reflect the fact, that upstream chose to use the pessimistic
operator.

> > So maybe an upload to experimental is the best solution here?
>  
> I am not sure, but maybe? (Praveen would know better).
> But maybe the best solution is to bump github-linguist in the upstream and
> see how it goes.
>
> Also, just curious to know, what d'you need ruby-github-linguist for?

Coincidence. When I adjusted the linguist file-type detection for a project on
salsa.d.o yesterday I discovered that our copy of linguist lacks behind
upstream.

My main task atm is to provide an up-to-date jekyll environment with useful
pugins. Maybe you saw my recent uploads (to NEW).

Regards, Daniel

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Update of ruby-github-linguist

Utkarsh Gupta
Hey,

On Wed, Aug 7, 2019 at 5:05 PM Daniel Leidert <[hidden email]> wrote:
> From what *I know*, we need gitaly 1.42.5 to support gitlab.
> And as per gitaly's Gemfile: 'github-linguist', '~> 6.1'
> That should explain why  it was not updated to the latest release.

Ah. I only checked the gitaly package dependencies, which just state: ruby-
github-linguist (>= 6.1~). The gitaly package dependecies IMHO should be
adjusted to reflect the fact, that upstream chose to use the pessimistic
operator.

> Also, just curious to know, what d'you need ruby-github-linguist for?

Coincidence. When I adjusted the linguist file-type detection for a project on
salsa.d.o yesterday I discovered that our copy of linguist lacks behind
upstream.

My main task atm is to provide an up-to-date jekyll environment with useful
pugins. Maybe you saw my recent uploads (to NEW).

Ah!
FWIW, I opened an MR, bumping github-linguist but it looks very unlikely as the CI fails.
Probably more patching needs to be done before we could have 7.5.x in the archive.
Let's wait for what they do with it.


Best,
Utkarsh
Reply | Threaded
Open this post in threaded view
|

Re: Update of ruby-github-linguist

Pirate Praveen-3
In reply to this post by Daniel Leidert-2


On 2019, ഓഗസ്റ്റ് 7 5:05:03 PM IST, Daniel Leidert <[hidden email]> wrote:
>Ah. I only checked the gitaly package dependencies, which just state:
>ruby-
>github-linguist (>= 6.1~). The gitaly package dependecies IMHO should
>be
>adjusted to reflect the fact, that upstream chose to use the
>pessimistic
>operator.

That would be just extra work for us. Instead we just have to follow SemVer and assume major versions break compatibility.
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.