Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Sebastian Niehaus-2
Hallo,

ich habe schon wieder ein Problem mit einem Upgrade, diesmal von Jessie
auf Stretch.

"apt-get update" lief ohne Probleme durch, beim dist-upgrade kam
folgendes, was ich nicht einordnen oder lösen kann.


Vielen Dank für Tipps...


Sebastian

root@ceramic:/home/niehaus# apt-get   dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Einige Pakete konnten
nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libkf5screen-bin : Beschädigt: kscreen (< 4:5.8) aber 1.0.2.1-1 soll
installiert werden
 libkf5screen7 : Beschädigt: kscreen (< 4:5.8) aber 1.0.2.1-1 soll
installiert werden
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve
hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht
worden sein.
root@ceramic:/home/niehaus# ^C
root@ceramic:/home/niehaus#

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Hilmar Preuße
Am 16.08.2019 um 11:07 teilte Sebastian Niehaus mit:

Moin,

> root@ceramic:/home/niehaus# apt-get   dist-upgrade
> Paketlisten werden gelesen... Fertig
> Abhängigkeitsbaum wird aufgebaut.
> Statusinformationen werden eingelesen.... Fertig
> Paketaktualisierung (Upgrade) wird berechnet... Einige Pakete konnten
> nicht installiert werden. Das kann bedeuten, dass
> Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
> Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
> nicht erstellt wurden oder Incoming noch nicht verlassen haben.
> Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
>
> Die folgenden Pakete haben unerfüllte Abhängigkeiten:
>  libkf5screen-bin : Beschädigt: kscreen (< 4:5.8) aber 1.0.2.1-1 soll
> installiert werden
>  libkf5screen7 : Beschädigt: kscreen (< 4:5.8) aber 1.0.2.1-1 soll
> installiert werden
> E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve
> hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht
> worden sein.
> root@ceramic:/home/niehaus# ^C
> root@ceramic:/home/niehaus#
>
Hast Du das mit dem hold mal geprüft? In stretch ist kscreen auf Version
5.8.5, darum wundert mich etwas, wieso er die 1.0.2 installieren will.

Was sagt "apt-cache policy kscreen"?

H.
--
sigfault
#206401 http://counter.li.org


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Sebastian Niehaus-2
Hallo,

Am 16.08.19 um 11:12 schrieb Hilmar Preuße:
> Am 16.08.2019 um 11:07 teilte Sebastian Niehaus mit:


> Hast Du das mit dem hold mal geprüft?

Ehrlich gesagt weiß ich nicht wie

> In stretch ist kscreen auf Version
> 5.8.5, darum wundert mich etwas, wieso er die 1.0.2 installieren will.
>
> Was sagt "apt-cache policy kscreen"?
root@ceramic:/home/niehaus# apt-cache policy kscreen
kscreen:
  Installiert:           1.0.2.1-1
  Installationskandidat: 4:5.8.5-2
  Versionstabelle:
     4:5.8.5-2 0
        500 tor+http://vwakviie2ienjx6t.onion/debian/ stretch/main amd64
Packages
 *** 1.0.2.1-1 0
        100 /var/lib/dpkg/status
root@ceramic:/home/niehaus#



Vielen Dank für Deine stete Hilfe ..


Sebastian

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Hilmar Preuße

Am 16.08.2019 um 11:37 teilte Sebastian Niehaus mit:
> Am 16.08.19 um 11:12 schrieb Hilmar Preuße:

Moin

>> Hast Du das mit dem hold mal geprüft?
>
> Ehrlich gesagt weiß ich nicht wie
>
dpkg --get-selections |grep -i hold

>> In stretch ist kscreen auf Version
>> 5.8.5, darum wundert mich etwas, wieso er die 1.0.2 installieren will.
>>
>> Was sagt "apt-cache policy kscreen"?
> root@ceramic:/home/niehaus# apt-cache policy kscreen
> kscreen:
>   Installiert:           1.0.2.1-1
>   Installationskandidat: 4:5.8.5-2
>   Versionstabelle:
>      4:5.8.5-2 0
>         500 tor+http://vwakviie2ienjx6t.onion/debian/ stretch/main amd64
> Packages
>  *** 1.0.2.1-1 0
>         100 /var/lib/dpkg/status
> root@ceramic:/home/niehaus#
>
Sieht erstmal gut aus. ich hätte jetzt aber erwartet, daß er die
Kandidaten auch installiert.

H.
--
sigfault
#206401 http://counter.li.org


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Sebastian Niehaus-2
Am 16.08.19 um 12:17 schrieb Hilmar Preuße:
>
> Am 16.08.2019 um 11:37 teilte Sebastian Niehaus mit:
>> Am 16.08.19 um 11:12 schrieb Hilmar Preuße:

>>> Hast Du das mit dem hold mal geprüft?
>> Ehrlich gesagt weiß ich nicht wie
>>
> dpkg --get-selections |grep -i hold
Ah, okay. Da wird nichts angezeigt.


>>> In stretch ist kscreen auf Version
>>> 5.8.5, darum wundert mich etwas, wieso er die 1.0.2 installieren will.
>>>
>>> Was sagt "apt-cache policy kscreen"?
>> root@ceramic:/home/niehaus# apt-cache policy kscreen
>> kscreen:
>>   Installiert:           1.0.2.1-1
>>   Installationskandidat: 4:5.8.5-2
>>   Versionstabelle:
>>      4:5.8.5-2 0
>>         500 tor+http://vwakviie2ienjx6t.onion/debian/ stretch/main amd64
>> Packages
>>  *** 1.0.2.1-1 0
>>         100 /var/lib/dpkg/status
>> root@ceramic:/home/niehaus#
>>
> Sieht erstmal gut aus. ich hätte jetzt aber erwartet, daß er die
> Kandidaten auch installiert.
Ich habe mal kscreen deinstalliert. Mal sehen, ob es dann weitergeht  ...


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Elimar Riesebieter
In reply to this post by Sebastian Niehaus-2
* Sebastian Niehaus <[hidden email]> [2019-08-16 11:37 +0200]:

> Hallo,
>
> Am 16.08.19 um 11:12 schrieb Hilmar Preuße:
> > Am 16.08.2019 um 11:07 teilte Sebastian Niehaus mit:
>
>
> > Hast Du das mit dem hold mal geprüft?
>
> Ehrlich gesagt weiß ich nicht wie
>
> > In stretch ist kscreen auf Version
> > 5.8.5, darum wundert mich etwas, wieso er die 1.0.2 installieren will.
> >
> > Was sagt "apt-cache policy kscreen"?
> root@ceramic:/home/niehaus# apt-cache policy kscreen
> kscreen:
>   Installiert:           1.0.2.1-1
>   Installationskandidat: 4:5.8.5-2
>   Versionstabelle:
>      4:5.8.5-2 0
>         500 tor+http://vwakviie2ienjx6t.onion/debian/ stretch/main amd64

Was ist tor+http://vwakviie2ienjx6t.onion/debian/ ?

Wie sieht Deine sources.list aus?

Elimar
--
  Excellent day for drinking heavily.
  Spike the office water cooler;-)

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Elimar Riesebieter
* Elimar Riesebieter <[hidden email]> [2019-08-16 13:57 +0200]:

> * Sebastian Niehaus <[hidden email]> [2019-08-16 11:37 +0200]:
>
> > Hallo,
> >
> > Am 16.08.19 um 11:12 schrieb Hilmar Preuße:
> > > Am 16.08.2019 um 11:07 teilte Sebastian Niehaus mit:
> >
> >
> > > Hast Du das mit dem hold mal geprüft?
> >
> > Ehrlich gesagt weiß ich nicht wie
> >
> > > In stretch ist kscreen auf Version
> > > 5.8.5, darum wundert mich etwas, wieso er die 1.0.2 installieren will.
> > >
> > > Was sagt "apt-cache policy kscreen"?
> > root@ceramic:/home/niehaus# apt-cache policy kscreen
> > kscreen:
> >   Installiert:           1.0.2.1-1
> >   Installationskandidat: 4:5.8.5-2
> >   Versionstabelle:
> >      4:5.8.5-2 0
> >         500 tor+http://vwakviie2ienjx6t.onion/debian/ stretch/main amd64
>
> Was ist tor+http://vwakviie2ienjx6t.onion/debian/ ?
>
> Wie sieht Deine sources.list aus?

Bei installiertem apt-transport-tor sollte

deb  tor+http://vwakviie2ienjx6t.onion/debian          stretch            main
deb  tor+http://vwakviie2ienjx6t.onion/debian          stretch-updates    main
deb  tor+http://sgvtcaew4bxjd7ln.onion/debian-security stretch/updates    main

wohl genügen.

Elimar
--
  "Talking much about oneself can also
   be a means to conceal oneself."
         -Friedrich Nietzsche

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Martin Klaiber
In reply to this post by Sebastian Niehaus-2
Sebastian Niehaus <[hidden email]> wrote:

> Die folgenden Pakete haben unerfüllte Abhängigkeiten:
>  libkf5screen-bin : Beschädigt: kscreen (< 4:5.8) aber 1.0.2.1-1 soll
> installiert werden

Was heißt "Beschädigt"?

Diese deutschen Übersetzungen bei Fehlermeldungen sind IMHO Schrott.
Lass Dir die Ausgabe auf Englisch anzeigen und wirf sie bei google
ein. So mache ich es und in der Regel erhält man brauchbare Lösungen.

HTH, Martin

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade-Problem: "libkf5screen-bin : Beschädigt: kscreen ..."

Sebastian Niehaus-2
In reply to this post by Elimar Riesebieter
Am 16.08.19 um 14:20 schrieb Elimar Riesebieter:
> * Elimar Riesebieter <[hidden email]> [2019-08-16 13:57 +0200]:
>> Was ist tor+http://vwakviie2ienjx6t.onion/debian/ ?
>>
>> Wie sieht Deine sources.list aus?



deb     tor+http://vwakviie2ienjx6t.onion/debian/ stretch main non-free
contrib
deb-src tor+http://vwakviie2ienjx6t.onion/debian/ stretch main non-free
contrib
######################################################################
#
# Security
#
######################################################################

deb  tor+http://sgvtcaew4bxjd7ln.onion/debian-security stretch/updates
  main
deb  tor+http://sgvtcaew4bxjd7ln.onion/ stretch/updates main contrib
non-free



> Bei installiertem apt-transport-tor sollte
> [...]
> wohl genügen.


Sollte eigentlich passen.

Off topic: kann man Thunderbird eigentlich abschnittsweise den
zeilenweisen Umbruch verbieten :-\


Naja, ich bin mit Deinstallation von kscreen jetzt ersteinmal
weitergekommen. Der Rechner rödelt noch - älteres Semester und wenn
Stretch geschafft ist soll es direkt weiter zu Buster gehen ...

Sebastian