WSJT-X out of date

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

WSJT-X out of date

Christopher J
Greetings,

Firstly, thanks for your work supporting the ham/debian community.

I've noticed that WSJT-X is very out of date, currently v 1.1 is packaged, with v1.4rc available.
It would be great to get this updated!

--
Thanks,
Christopher M0YNG
Reply | Threaded
Open this post in threaded view
|

Re: WSJT-X out of date

Iain R. Learmonth-2
Hi Christopher,

I've CC'd you as I'm not sure if you're subscribed to the list, let me know
if you are and I can remove the CC for future mails.

On Fri, Mar 13, 2015 at 09:56:18PM +0000, Christopher J wrote:
>    I've noticed that WSJT-X is very out of date, currently v 1.1 is
>    packaged, with v1.4rc available.
>    It would be great to get this updated!

Yep, we are aware of this and we're currently working on a new package (I
belive it's KI7MT doing this). The reason it hasn't been uploaded yet is
that Debian is currently in a freeze which means that new packages will just
sit in unstable and not migrate to testing. Once jessie has been released,
we will start uploading and we have quite a few updates on their way for
other packages too.

Thanks,
Iain.

--
e: [hidden email]            w: iain.learmonth.me
x: [hidden email]     t: EPVPN 2105
c: 2M0STB                  g: IO87we
p: 1F72 607C 5FF2 CCD5 3F01 600D 56FF 9EA4 E984 6C49

attachment0 (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: WSJT-X out of date

KI7MT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Hi Ian,

FWIW, there are several items that still need to be addressed, aside
from the fact Jessie is frozen.

Long story short, the package (source code) now includes a fork of
Hamlib v1.2.15 in addition to the WSWJT-X source code. It also
requires an additional package to install the non-FOSS KVASD decoder,
which is no longer part of WSJT-X ( as a package ).

I've create 2x PPA's that will install both the KVASD decoder and a
much more resent version of WSJT-X, both of which are following the
development branch of WSJT-X. I've tested this on Jessie, but not
extensively.

- ----------------------------------------

TO ADD THE PPAs and PERFORM INSTALLATION:
* Open a terminal (Ctrl+Alt+T)
* sudo add-apt-repository ppa:ki7mt/kvasd-installer
* -->  Accept the PGP Key
* sudo add-apt-repository ppa:ki7mt/wsjtx-dev
* -->  Accept the PGP Key
* sudo apt-get update

INSTALL and RUN KVASD Installer
* Open a terminal (Ctrl+Alt+T) if you closed it.
* sudo apt-get install kvasd-installer
* When complete, type: kvasd-installer
* At the main Menu, Select "Install decoder", follow the prompts.
* After install, test the decoder or just exit kvasd-installer

WSJT-X INSTALL and RUN

NOTE: The new WSJT-X package *does not / will not* overwrite any user
v1.1 files installed from the repository. However, you should
uninstall the repo version first as there will be a links to the
original wsjtx binary, just to be safe.

* Open a terminal (Ctrl+Alt+T) if you closed it.
* sudo apt-get install wsjtx-dev
* Use Search: Search for wsjtx, then click the icon.
* To run from the command line, type: wsjtx

That should do it. From that point forward, updates are performed
normally with: sudo apt-get update && sudo apt-get upgrade.

- ----------------------------------------

For those a little more ambitious, there is also a Linux SDK called (
JTSDK ) that will build the appropriate Hamlib3 version, and either
the current Release candidate (RC4) or the latest Development Branch v1.5.

If anyone is interested in testing the JTSDK for Debian/UBuntu, I can
post instructions, it's fairly straight forward. The SDK also builds
WSJT and WSPR.


73's
Greg, KI7MT


On 03/13/2015 05:26 PM, Iain R. Learmonth wrote:

> Hi Christopher,
>
> I've CC'd you as I'm not sure if you're subscribed to the list, let
> me know if you are and I can remove the CC for future mails.
>
> On Fri, Mar 13, 2015 at 09:56:18PM +0000, Christopher J wrote:
>> I've noticed that WSJT-X is very out of date, currently v 1.1 is
>> packaged, with v1.4rc available. It would be great to get this
>> updated!
>
> Yep, we are aware of this and we're currently working on a new
> package (I belive it's KI7MT doing this). The reason it hasn't been
> uploaded yet is that Debian is currently in a freeze which means
> that new packages will just sit in unstable and not migrate to
> testing. Once jessie has been released, we will start uploading and
> we have quite a few updates on their way for other packages too.
>
> Thanks, Iain.
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJVA7xvAAoJEBjA9rcNovmR0x0P+gL+A61+cTB2hhr8ahFOH3vi
OW0cjRAt7TC9Nu9BP4PnIYaZAhJCgI9rGFXUxu5RLeQ5+DGrwrH18dvBvNEoIzQ2
zxcAHmOMrDgYcmP1cSSEG53IaW9ORp4EQ9oV/pem/Uex8wKElerYja5MBHO7vMqQ
+z7mCnU3uHit5ld1GByJ398BWVX79czLLPW17BW84xk1v1KtnRDSUxIGAwFbsKPQ
XvBQ4Cai+1yPNnd5LcYmD022OFLzdkLUuVbflY3tjGdzCVv/MaEorzv9ElG9x+k8
hd8GJU54zc+xXIbfZakC5bOQAdaRwQm/GRaQnRn1pJL4TiRsWNwYCUbnNfK+y1s2
Vy+Z8WjH5qZd0rPwIbBoJUU814vvk0SPZ3vczL7gid3Tba9NoRvvOchlGAUfLqFQ
aQnZdlRk0v/W18NRpNz+wYM1ZjEpKmuGK5+np6SD+y4M9IBdXSXMZSHGbDwUrtel
oNc/dngHrGeb5m3KamDzzvQ5wdXiNYmQy0a3xZaYEzAiJXQvqe7ETj4FUxTEeOnd
hfV/pUPCoMoDEc8aLB0tYSY2gXx8otJjH5nsChoIiyavBOuAReiN8GteyGk+WZtp
701H3vgZDhrQR57LZls6Lnd1iZ4j/FeUa7y9VUEhUictPP9GNXbKk21fi9QYpoid
F+kcrX70SHpN/KrIoEZn
=1KQD
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/5503BC8B.2070908@...

Reply | Threaded
Open this post in threaded view
|

Re: WSJT-X out of date

Christopher J
Greg,

Thanks for the info.
I've added the PPAs, but maybe I missed something?

W: Failed to fetch http://ppa.launchpad.net/ki7mt/kvasd-installer/ubuntu/dists/jessie/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ki7mt/wsjtx-dev/ubuntu/dists/jessie/main/binary-i386/Packages  404  Not Found

On 14 March 2015 at 04:43, KI7MT <[hidden email]> wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Hi Ian,

FWIW, there are several items that still need to be addressed, aside
from the fact Jessie is frozen.

Long story short, the package (source code) now includes a fork of
Hamlib v1.2.15 in addition to the WSWJT-X source code. It also
requires an additional package to install the non-FOSS KVASD decoder,
which is no longer part of WSJT-X ( as a package ).

I've create 2x PPA's that will install both the KVASD decoder and a
much more resent version of WSJT-X, both of which are following the
development branch of WSJT-X. I've tested this on Jessie, but not
extensively.

- ----------------------------------------

TO ADD THE PPAs and PERFORM INSTALLATION:
* Open a terminal (Ctrl+Alt+T)
* sudo add-apt-repository ppa:ki7mt/kvasd-installer
* -->  Accept the PGP Key
* sudo add-apt-repository ppa:ki7mt/wsjtx-dev
* -->  Accept the PGP Key
* sudo apt-get update

INSTALL and RUN KVASD Installer
* Open a terminal (Ctrl+Alt+T) if you closed it.
* sudo apt-get install kvasd-installer
* When complete, type: kvasd-installer
* At the main Menu, Select "Install decoder", follow the prompts.
* After install, test the decoder or just exit kvasd-installer

WSJT-X INSTALL and RUN

NOTE: The new WSJT-X package *does not / will not* overwrite any user
v1.1 files installed from the repository. However, you should
uninstall the repo version first as there will be a links to the
original wsjtx binary, just to be safe.

* Open a terminal (Ctrl+Alt+T) if you closed it.
* sudo apt-get install wsjtx-dev
* Use Search: Search for wsjtx, then click the icon.
* To run from the command line, type: wsjtx

That should do it. From that point forward, updates are performed
normally with: sudo apt-get update && sudo apt-get upgrade.

- ----------------------------------------

For those a little more ambitious, there is also a Linux SDK called (
JTSDK ) that will build the appropriate Hamlib3 version, and either
the current Release candidate (RC4) or the latest Development Branch v1.5.

If anyone is interested in testing the JTSDK for Debian/UBuntu, I can
post instructions, it's fairly straight forward. The SDK also builds
WSJT and WSPR.


73's
Greg, KI7MT


On 03/13/2015 05:26 PM, Iain R. Learmonth wrote:
> Hi Christopher,
>
> I've CC'd you as I'm not sure if you're subscribed to the list, let
> me know if you are and I can remove the CC for future mails.
>
> On Fri, Mar 13, 2015 at 09:56:18PM +0000, Christopher J wrote:
>> I've noticed that WSJT-X is very out of date, currently v 1.1 is
>> packaged, with v1.4rc available. It would be great to get this
>> updated!
>
> Yep, we are aware of this and we're currently working on a new
> package (I belive it's KI7MT doing this). The reason it hasn't been
> uploaded yet is that Debian is currently in a freeze which means
> that new packages will just sit in unstable and not migrate to
> testing. Once jessie has been released, we will start uploading and
> we have quite a few updates on their way for other packages too.
>
> Thanks, Iain.
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJVA7xvAAoJEBjA9rcNovmR0x0P+gL+A61+cTB2hhr8ahFOH3vi
OW0cjRAt7TC9Nu9BP4PnIYaZAhJCgI9rGFXUxu5RLeQ5+DGrwrH18dvBvNEoIzQ2
zxcAHmOMrDgYcmP1cSSEG53IaW9ORp4EQ9oV/pem/Uex8wKElerYja5MBHO7vMqQ
+z7mCnU3uHit5ld1GByJ398BWVX79czLLPW17BW84xk1v1KtnRDSUxIGAwFbsKPQ
XvBQ4Cai+1yPNnd5LcYmD022OFLzdkLUuVbflY3tjGdzCVv/MaEorzv9ElG9x+k8
hd8GJU54zc+xXIbfZakC5bOQAdaRwQm/GRaQnRn1pJL4TiRsWNwYCUbnNfK+y1s2
Vy+Z8WjH5qZd0rPwIbBoJUU814vvk0SPZ3vczL7gid3Tba9NoRvvOchlGAUfLqFQ
aQnZdlRk0v/W18NRpNz+wYM1ZjEpKmuGK5+np6SD+y4M9IBdXSXMZSHGbDwUrtel
oNc/dngHrGeb5m3KamDzzvQ5wdXiNYmQy0a3xZaYEzAiJXQvqe7ETj4FUxTEeOnd
hfV/pUPCoMoDEc8aLB0tYSY2gXx8otJjH5nsChoIiyavBOuAReiN8GteyGk+WZtp
701H3vgZDhrQR57LZls6Lnd1iZ4j/FeUa7y9VUEhUictPP9GNXbKk21fi9QYpoid
F+kcrX70SHpN/KrIoEZn
=1KQD
-----END PGP SIGNATURE-----



--
Thanks,
Christopher M0YNG
Reply | Threaded
Open this post in threaded view
|

Re: WSJT-X out of date

KI7MT
Hi Christopher,

Sorry, this was an oversight on my part. When using Jessie, after adding
the PPA's, you need to edit the source lists to point to the correct URLS.

Look in /etc/apt/sources.d/

for: ki7mt-kvasd-installer-trusty.list
and: ki7mt-wsjtx-dev-trusty.list

Edit both those files and change jessie to trusty.

Then; sudo apt-get update

and try to install from there. That should change the PPA URL's from:

http://ppa.launchpad.net/ki7mt/kvasd-installer/ubuntu/dists/jessie/main/binary-i386/Packages

to

http://ppa.launchpad.net/ki7mt/kvasd-installer/ubuntu/dists/trusty/main/binary-i386/Packages

If that doesn't work (it did for me), I can build the .deb files for
Jessie and Sid, then post them on the JTSDK site at sourceforge. You
could then use Gdebi to install them.

73's
Greg, KI7MT


On 03/17/2015 03:40 PM, Christopher J wrote:

> Greg,
>
> Thanks for the info.
> I've added the PPAs, but maybe I missed something?
>
> W: Failed to fetch
> http://ppa.launchpad.net/ki7mt/kvasd-installer/ubuntu/dists/jessie/main/binary-i386/Packages
> 404  Not Found
>
> W: Failed to fetch
> http://ppa.launchpad.net/ki7mt/wsjtx-dev/ubuntu/dists/jessie/main/binary-i386/Packages
> 404  Not Found
>
> On 14 March 2015 at 04:43, KI7MT <[hidden email]> wrote:
>
> Hi Ian,
>
> FWIW, there are several items that still need to be addressed, aside
> from the fact Jessie is frozen.
>
> Long story short, the package (source code) now includes a fork of
> Hamlib v1.2.15 in addition to the WSWJT-X source code. It also
> requires an additional package to install the non-FOSS KVASD decoder,
> which is no longer part of WSJT-X ( as a package ).
>
> I've create 2x PPA's that will install both the KVASD decoder and a
> much more resent version of WSJT-X, both of which are following the
> development branch of WSJT-X. I've tested this on Jessie, but not
> extensively.
>
> ----------------------------------------
>
> TO ADD THE PPAs and PERFORM INSTALLATION:
> * Open a terminal (Ctrl+Alt+T)
> * sudo add-apt-repository ppa:ki7mt/kvasd-installer
> * -->  Accept the PGP Key
> * sudo add-apt-repository ppa:ki7mt/wsjtx-dev
> * -->  Accept the PGP Key
> * sudo apt-get update
>
> INSTALL and RUN KVASD Installer
> * Open a terminal (Ctrl+Alt+T) if you closed it.
> * sudo apt-get install kvasd-installer
> * When complete, type: kvasd-installer
> * At the main Menu, Select "Install decoder", follow the prompts.
> * After install, test the decoder or just exit kvasd-installer
>
> WSJT-X INSTALL and RUN
>
> NOTE: The new WSJT-X package *does not / will not* overwrite any user
> v1.1 files installed from the repository. However, you should
> uninstall the repo version first as there will be a links to the
> original wsjtx binary, just to be safe.
>
> * Open a terminal (Ctrl+Alt+T) if you closed it.
> * sudo apt-get install wsjtx-dev
> * Use Search: Search for wsjtx, then click the icon.
> * To run from the command line, type: wsjtx
>
> That should do it. From that point forward, updates are performed
> normally with: sudo apt-get update && sudo apt-get upgrade.
>
> ----------------------------------------
>
> For those a little more ambitious, there is also a Linux SDK called (
> JTSDK ) that will build the appropriate Hamlib3 version, and either
> the current Release candidate (RC4) or the latest Development Branch v1.5.
>
> If anyone is interested in testing the JTSDK for Debian/UBuntu, I can
> post instructions, it's fairly straight forward. The SDK also builds
> WSJT and WSPR.
>
>
> 73's
> Greg, KI7MT
>
>
> On 03/13/2015 05:26 PM, Iain R. Learmonth wrote:
>>>> Hi Christopher,
>>>>
>>>> I've CC'd you as I'm not sure if you're subscribed to the list, let
>>>> me know if you are and I can remove the CC for future mails.
>>>>
>>>> On Fri, Mar 13, 2015 at 09:56:18PM +0000, Christopher J wrote:
>>>>> I've noticed that WSJT-X is very out of date, currently v 1.1 is
>>>>> packaged, with v1.4rc available. It would be great to get this
>>>>> updated!
>>>>
>>>> Yep, we are aware of this and we're currently working on a new
>>>> package (I belive it's KI7MT doing this). The reason it hasn't been
>>>> uploaded yet is that Debian is currently in a freeze which means
>>>> that new packages will just sit in unstable and not migrate to
>>>> testing. Once jessie has been released, we will start uploading and
>>>> we have quite a few updates on their way for other packages too.
>>>>
>>>> Thanks, Iain.
>>>>
>>
>
>
>


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/5508C448.5040500@...

Reply | Threaded
Open this post in threaded view
|

Re: WSJT-X out of date

Iain R. Learmonth-2
Hi,

On Tue, Mar 17, 2015 at 06:18:16PM -0600, KI7MT wrote:
> If that doesn't work (it did for me), I can build the .deb files for
> Jessie and Sid, then post them on the JTSDK site at sourceforge. You
> could then use Gdebi to install them.

These are packages me and others at the hackerspace would like to play with
at some point, we just haven't got round to it yet. I don't see wsjt-x in
our git, but I could pull the source package from the PPA, build it for
jessie and stick it up on:

  http://shiftout.net/~irl/

This is a repo I use for deploying packages to my friends for testing before
uploading to Debian.

Thanks,
Iain.

--
e: [hidden email]            w: iain.learmonth.me
x: [hidden email]     t: EPVPN 2105
c: 2M0STB                  g: IO87we
p: 1F72 607C 5FF2 CCD5 3F01 600D 56FF 9EA4 E984 6C49

attachment0 (836 bytes) Download Attachment