Wine sobre "buster"

classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|

Wine sobre "buster"

JavierDebian
Buenas tardes.


¿Alguien ha podido instalar Wine sobre Debian 10 "buster" amd64?


=====================
Si instalo de los propios repositorios, muero en

# apt install --install-recommends wine
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine64
Paquetes sugeridos:
   ttf-mscorefonts-installer q4wine winbind winetricks playonlinux
wine-binfmt wine64-preloader
Paquetes recomendados:
   wine32
Se instalarán los siguientes paquetes NUEVOS:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine wine64
0 actualizados, 7 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 26,6 MB de archivos.
Se utilizarán 237 MB de espacio de disco adicional después de esta
operación.
¿Desea continuar? [S/n]
Des:1 https://debian.unnoba.edu.ar/debian buster/main amd64 fonts-wine
all 4.0-2 [226 kB]
Des:2 https://debian.unnoba.edu.ar/debian buster/main amd64 libcapi20-3
amd64 1:3.27-3 [28,5 kB]
Des:3 https://debian.unnoba.edu.ar/debian buster/main amd64 libosmesa6
amd64 18.3.6-2+deb10u1 [2.243 kB]
Des:4 https://debian.unnoba.edu.ar/debian buster/main amd64 libvkd3d1
amd64 1.1-3 [125 kB]
Des:5 https://debian.unnoba.edu.ar/debian buster/main amd64 libwine
amd64 4.0-2 [23,6 MB]
Des:6 https://debian.unnoba.edu.ar/debian buster/main amd64 wine64 amd64
4.0-2 [286 kB]
Des:7 https://debian.unnoba.edu.ar/debian buster/main amd64 wine all
4.0-2 [134 kB]
Descargados 26,6 MB en 5s (5.539 kB/s)
Seleccionando el paquete fonts-wine previamente no seleccionado.
(Leyendo la base de datos ... 307836 ficheros o directorios instalados
actualmente.)
Preparando para desempaquetar .../0-fonts-wine_4.0-2_all.deb ...
Desempaquetando fonts-wine (4.0-2) ...
Seleccionando el paquete libcapi20-3:amd64 previamente no seleccionado.
Preparando para desempaquetar .../1-libcapi20-3_1%3a3.27-3_amd64.deb ...
Desempaquetando libcapi20-3:amd64 (1:3.27-3) ...
Seleccionando el paquete libosmesa6:amd64 previamente no seleccionado.
Preparando para desempaquetar
.../2-libosmesa6_18.3.6-2+deb10u1_amd64.deb ...
Desempaquetando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Seleccionando el paquete libvkd3d1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../3-libvkd3d1_1.1-3_amd64.deb ...
Desempaquetando libvkd3d1:amd64 (1.1-3) ...
Seleccionando el paquete libwine:amd64 previamente no seleccionado.
Preparando para desempaquetar .../4-libwine_4.0-2_amd64.deb ...
Desempaquetando libwine:amd64 (4.0-2) ...
Seleccionando el paquete wine64 previamente no seleccionado.
Preparando para desempaquetar .../5-wine64_4.0-2_amd64.deb ...
Desempaquetando wine64 (4.0-2) ...
Seleccionando el paquete wine previamente no seleccionado.
Preparando para desempaquetar .../6-wine_4.0-2_all.deb ...
Desempaquetando wine (4.0-2) ...
Configurando libcapi20-3:amd64 (1:3.27-3) ...
Configurando libvkd3d1:amd64 (1.1-3) ...
Configurando fonts-wine (4.0-2) ...
Configurando libwine:amd64 (4.0-2) ...
Configurando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Configurando wine64 (4.0-2) ...
Configurando wine (4.0-2) ...
Procesando disparadores para libc-bin (2.29-10) ...
Procesando disparadores para man-db (2.8.5-2) ...
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Procesando disparadores para wine (4.0-2) ...

$ wine DiskInfo64.exe
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first.  as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"

# dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
Obj:1 http://security.debian.org buster/updates InRelease
(...)
Descargados 8.667 kB en 4s (2.199 kB/s)
Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
                Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================
Si instalo de https://wiki.winehq.org/Debian

# apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  winehq-stable : Depende: wine-stable (= 5.0.0~buster) pero no va a
instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================


¿Alguien no ha muerto en el intento y tiene la "receta"?

Gracias.

JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

JavierDebian


El 14/5/20 a las 15:49, Marcos Ariel Di Lauro escribió:

>>
>> =====================
>> Si instalo de https://wiki.winehq.org/Debian
>>
>> # apt install --install-recommends winehq-stable
>> Leyendo lista de paquetes... Hecho
>> Creando árbol de dependencias
>> Leyendo la información de estado... Hecho
>> No se pudieron instalar algunos paquetes. Esto puede significar que
>> usted pidió una situación imposible o, si está usando la distribución
>> inestable, que algunos paquetes necesarios aún no se han creado o se
>> han sacado de «Incoming».
>> La siguiente información puede ayudar a resolver la situación:
>>
>> Los siguientes paquetes tienen dependencias incumplidas:
>>  winehq-stable : Depende: wine-stable (= 5.0.0~buster) pero no va a
>> instalarse
>> E: No se pudieron corregir los problemas, usted ha retenido paquetes
>> rotos.
>>
>>
>> =====================
>>
 > Yo lo instalo de la forma que te explica la pagina de Wine.
 >


No pude, como indiqué.
¿Alguna idea?

JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Camaleón
In reply to this post by JavierDebian
El 2020-05-14 a las 15:31 -0300, JavierDebian escribió:

(...)

> # dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
> Obj:1 http://security.debian.org buster/updates InRelease
> (...)
> Descargados 8.667 kB en 4s (2.199 kB/s)
> Leyendo lista de paquetes... Hecho
> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias
> Leyendo la información de estado... Hecho
> No se pudieron instalar algunos paquetes. Esto puede significar que
> usted pidió una situación imposible o, si está usando la distribución
> inestable, que algunos paquetes necesarios aún no se han creado o se
> han sacado de «Incoming».
> La siguiente información puede ayudar a resolver la situación:
>
> Los siguientes paquetes tienen dependencias incumplidas:
>  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
>                Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
> E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

***
How to install wine32 in Debian 9?
<https://unix.stackexchange.com/questions/538998/how-to-install-wine32-in-debian-9>

Also works in Debian 10 – Levin Apr 14 at 8:57
^^^^^^^^^^^^^^^^^^^^^^^
***

Saludos,

--
Camaleón

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Galvatorix Torixgalva
In reply to this post by JavierDebian
Hola,

yo he instalado varias veces wine. En mi caso lo resumo en una palabra: decepcionante.

Si lo que buscas es ejecutar un software que no sea un videojuego para windows, busca un sofware que sea lo mas similar en linux.

Si lo que buscas es ejecutar un videojuego para windows, ponte windows en un disco duro aparte.

Hasta donde yo lo he probado, wine es como decir "quiero pero no termino de poder". Yo me encontre con problemas de configuracion, y las pocas veces he pe podido el rendimiento era muy deficiente.

Que conste que wine me parece un software que tiene un objetivo muy intreresante: poder ejecutar software de windows en linux.

El problema que le veo es que muchas cosas piden maquina real. De hecho te puedes encontrar en la web de wine un amplio listado de software (incluyendo videojuegos) para windows que funciona en linux usando wine. Mi conclusion es que en wine funcionara lo que funcione, y en caso de funcionar sera de la manera en que funcione.

Un saludo





Libre de virus. www.avg.com

On Thu, May 14, 2020 at 7:32 PM JavierDebian <[hidden email]> wrote:
Buenas tardes.


¿Alguien ha podido instalar Wine sobre Debian 10 "buster" amd64?


=====================
Si instalo de los propios repositorios, muero en

# apt install --install-recommends wine
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine64
Paquetes sugeridos:
   ttf-mscorefonts-installer q4wine winbind winetricks playonlinux
wine-binfmt wine64-preloader
Paquetes recomendados:
   wine32
Se instalarán los siguientes paquetes NUEVOS:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine wine64
0 actualizados, 7 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 26,6 MB de archivos.
Se utilizarán 237 MB de espacio de disco adicional después de esta
operación.
¿Desea continuar? [S/n]
Des:1 https://debian.unnoba.edu.ar/debian buster/main amd64 fonts-wine
all 4.0-2 [226 kB]
Des:2 https://debian.unnoba.edu.ar/debian buster/main amd64 libcapi20-3
amd64 1:3.27-3 [28,5 kB]
Des:3 https://debian.unnoba.edu.ar/debian buster/main amd64 libosmesa6
amd64 18.3.6-2+deb10u1 [2.243 kB]
Des:4 https://debian.unnoba.edu.ar/debian buster/main amd64 libvkd3d1
amd64 1.1-3 [125 kB]
Des:5 https://debian.unnoba.edu.ar/debian buster/main amd64 libwine
amd64 4.0-2 [23,6 MB]
Des:6 https://debian.unnoba.edu.ar/debian buster/main amd64 wine64 amd64
4.0-2 [286 kB]
Des:7 https://debian.unnoba.edu.ar/debian buster/main amd64 wine all
4.0-2 [134 kB]
Descargados 26,6 MB en 5s (5.539 kB/s)
Seleccionando el paquete fonts-wine previamente no seleccionado.
(Leyendo la base de datos ... 307836 ficheros o directorios instalados
actualmente.)
Preparando para desempaquetar .../0-fonts-wine_4.0-2_all.deb ...
Desempaquetando fonts-wine (4.0-2) ...
Seleccionando el paquete libcapi20-3:amd64 previamente no seleccionado.
Preparando para desempaquetar .../1-libcapi20-3_1%3a3.27-3_amd64.deb ...
Desempaquetando libcapi20-3:amd64 (1:3.27-3) ...
Seleccionando el paquete libosmesa6:amd64 previamente no seleccionado.
Preparando para desempaquetar
.../2-libosmesa6_18.3.6-2+deb10u1_amd64.deb ...
Desempaquetando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Seleccionando el paquete libvkd3d1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../3-libvkd3d1_1.1-3_amd64.deb ...
Desempaquetando libvkd3d1:amd64 (1.1-3) ...
Seleccionando el paquete libwine:amd64 previamente no seleccionado.
Preparando para desempaquetar .../4-libwine_4.0-2_amd64.deb ...
Desempaquetando libwine:amd64 (4.0-2) ...
Seleccionando el paquete wine64 previamente no seleccionado.
Preparando para desempaquetar .../5-wine64_4.0-2_amd64.deb ...
Desempaquetando wine64 (4.0-2) ...
Seleccionando el paquete wine previamente no seleccionado.
Preparando para desempaquetar .../6-wine_4.0-2_all.deb ...
Desempaquetando wine (4.0-2) ...
Configurando libcapi20-3:amd64 (1:3.27-3) ...
Configurando libvkd3d1:amd64 (1.1-3) ...
Configurando fonts-wine (4.0-2) ...
Configurando libwine:amd64 (4.0-2) ...
Configurando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Configurando wine64 (4.0-2) ...
Configurando wine (4.0-2) ...
Procesando disparadores para libc-bin (2.29-10) ...
Procesando disparadores para man-db (2.8.5-2) ...
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Procesando disparadores para wine (4.0-2) ...

$ wine DiskInfo64.exe
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first.  as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"

# dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
Obj:1 http://security.debian.org buster/updates InRelease
(...)
Descargados 8.667 kB en 4s (2.199 kB/s)
Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
                Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================
Si instalo de https://wiki.winehq.org/Debian

# apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  winehq-stable : Depende: wine-stable (= 5.0.0~buster) pero no va a
instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================


¿Alguien no ha muerto en el intento y tiene la "receta"?

Gracias.

JAP



--
Profesor de informática en Tutellus


Libre de virus. www.avg.com
Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

JavierDebian
El 15/5/20 a las 04:19, Galvatorix Torixgalva escribió:

> On Thu, May 14, 2020 at 7:32 PM JavierDebian
> <[hidden email] <mailto:[hidden email]>>
> wrote:
>
>     Buenas tardes.
>
>
>     ¿Alguien ha podido instalar Wine sobre Debian 10 "buster" amd64?
>
>
>     =====================
>     Si instalo de los propios repositorios, muero en
>
>     # apt install --install-recommends wine
>     Leyendo lista de paquetes... Hecho
>     Creando árbol de dependencias
>     Leyendo la información de estado... Hecho
>     Se instalarán los siguientes paquetes adicionales:
>         fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine64
>     Paquetes sugeridos:
>         ttf-mscorefonts-installer q4wine winbind winetricks playonlinux
>     wine-binfmt wine64-preloader
>     Paquetes recomendados:
>         wine32
>     Se instalarán los siguientes paquetes NUEVOS:
>         fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine wine64
>     0 actualizados, 7 nuevos se instalarán, 0 para eliminar y 0 no
>     actualizados.
>     Se necesita descargar 26,6 MB de archivos.
>     Se utilizarán 237 MB de espacio de disco adicional después de esta
>     operación.
>     ¿Desea continuar? [S/n]
>     Des:1 https://debian.unnoba.edu.ar/debian buster/main amd64 fonts-wine
>     all 4.0-2 [226 kB]
>     Des:2 https://debian.unnoba.edu.ar/debian buster/main amd64 libcapi20-3
>     amd64 1:3.27-3 [28,5 kB]
>     Des:3 https://debian.unnoba.edu.ar/debian buster/main amd64 libosmesa6
>     amd64 18.3.6-2+deb10u1 [2.243 kB]
>     Des:4 https://debian.unnoba.edu.ar/debian buster/main amd64 libvkd3d1
>     amd64 1.1-3 [125 kB]
>     Des:5 https://debian.unnoba.edu.ar/debian buster/main amd64 libwine
>     amd64 4.0-2 [23,6 MB]
>     Des:6 https://debian.unnoba.edu.ar/debian buster/main amd64 wine64
>     amd64
>     4.0-2 [286 kB]
>     Des:7 https://debian.unnoba.edu.ar/debian buster/main amd64 wine all
>     4.0-2 [134 kB]
>     Descargados 26,6 MB en 5s (5.539 kB/s)
>     Seleccionando el paquete fonts-wine previamente no seleccionado.
>     (Leyendo la base de datos ... 307836 ficheros o directorios instalados
>     actualmente.)
>     Preparando para desempaquetar .../0-fonts-wine_4.0-2_all.deb ...
>     Desempaquetando fonts-wine (4.0-2) ...
>     Seleccionando el paquete libcapi20-3:amd64 previamente no seleccionado.
>     Preparando para desempaquetar .../1-libcapi20-3_1%3a3.27-3_amd64.deb ...
>     Desempaquetando libcapi20-3:amd64 (1:3.27-3) ...
>     Seleccionando el paquete libosmesa6:amd64 previamente no seleccionado.
>     Preparando para desempaquetar
>     .../2-libosmesa6_18.3.6-2+deb10u1_amd64.deb ...
>     Desempaquetando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
>     Seleccionando el paquete libvkd3d1:amd64 previamente no seleccionado.
>     Preparando para desempaquetar .../3-libvkd3d1_1.1-3_amd64.deb ...
>     Desempaquetando libvkd3d1:amd64 (1.1-3) ...
>     Seleccionando el paquete libwine:amd64 previamente no seleccionado.
>     Preparando para desempaquetar .../4-libwine_4.0-2_amd64.deb ...
>     Desempaquetando libwine:amd64 (4.0-2) ...
>     Seleccionando el paquete wine64 previamente no seleccionado.
>     Preparando para desempaquetar .../5-wine64_4.0-2_amd64.deb ...
>     Desempaquetando wine64 (4.0-2) ...
>     Seleccionando el paquete wine previamente no seleccionado.
>     Preparando para desempaquetar .../6-wine_4.0-2_all.deb ...
>     Desempaquetando wine (4.0-2) ...
>     Configurando libcapi20-3:amd64 (1:3.27-3) ...
>     Configurando libvkd3d1:amd64 (1.1-3) ...
>     Configurando fonts-wine (4.0-2) ...
>     Configurando libwine:amd64 (4.0-2) ...
>     Configurando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
>     Configurando wine64 (4.0-2) ...
>     Configurando wine (4.0-2) ...
>     Procesando disparadores para libc-bin (2.29-10) ...
>     Procesando disparadores para man-db (2.8.5-2) ...
>     Procesando disparadores para hicolor-icon-theme (0.17-2) ...
>     Procesando disparadores para wine (4.0-2) ...
>
>     $ wine DiskInfo64.exe
>     it looks like wine32 is missing, you should install it.
>     multiarch needs to be enabled first.  as root, please
>     execute "dpkg --add-architecture i386 && apt-get update &&
>     apt-get install wine32"
>
>     # dpkg --add-architecture i386 && apt-get update && > apt-get
>     install wine32
>     Obj:1 http://security.debian.org buster/updates InRelease
>     (...)
>     Descargados 8.667 kB en 4s (2.199 kB/s)
>     Leyendo lista de paquetes... Hecho
>     Leyendo lista de paquetes... Hecho
>     Creando árbol de dependencias
>     Leyendo la información de estado... Hecho
>     No se pudieron instalar algunos paquetes. Esto puede significar que
>     usted pidió una situación imposible o, si está usando la distribución
>     inestable, que algunos paquetes necesarios aún no se han creado o se
>     han sacado de «Incoming».
>     La siguiente información puede ayudar a resolver la situación:
>
>     Los siguientes paquetes tienen dependencias incumplidas:
>        wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
>                      Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
>     E: No se pudieron corregir los problemas, usted ha retenido paquetes
>     rotos.
>
>
>     =====================
>     Si instalo de https://wiki.winehq.org/Debian
>
>     # apt install --install-recommends winehq-stable
>     Leyendo lista de paquetes... Hecho
>     Creando árbol de dependencias
>     Leyendo la información de estado... Hecho
>     No se pudieron instalar algunos paquetes. Esto puede significar que
>     usted pidió una situación imposible o, si está usando la distribución
>     inestable, que algunos paquetes necesarios aún no se han creado o se
>     han sacado de «Incoming».
>     La siguiente información puede ayudar a resolver la situación:
>
>     Los siguientes paquetes tienen dependencias incumplidas:
>        winehq-stable : Depende: wine-stable (= 5.0.0~buster) pero no va a
>     instalarse
>     E: No se pudieron corregir los problemas, usted ha retenido paquetes
>     rotos.
>
>
>     =====================
>
>
>     ¿Alguien no ha muerto en el intento y tiene la "receta"?
>
>     Gracias.
>
>     JAP
>
>
>
> --
> Profesor de informática en Tutellus
>
> Tutellus https://www.tutellus.com/perfil/230494/rafael-navarro
>
>
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
> Libre de virus. www.avg.com
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
>
>
> <#m_6916365579139901897_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

 > Hola,
 >
 > yo he instalado varias veces wine. En mi caso lo resumo en una palabra:
 > decepcionante.
 >
 > Si lo que buscas es ejecutar un software que no sea un videojuego para
 > windows, busca un sofware que sea lo mas similar en linux.
 >
 > Si lo que buscas es ejecutar un videojuego para windows, ponte windows
 > en un disco duro aparte.
 >
 > Hasta donde yo lo he probado, wine es como decir "quiero pero no termino
 > de poder". Yo me encontre con problemas de configuracion, y las pocas
 > veces he pe podido el rendimiento era muy deficiente.
 >
 > Que conste que wine me parece un software que tiene un objetivo muy
 > intreresante: poder ejecutar software de windows en linux.
 >
 > El problema que le veo es que muchas cosas piden maquina real. De hecho
 > te puedes encontrar en la web de wine un amplio listado de software
 > (incluyendo videojuegos) para windows que funciona en linux usando wine.
 > Mi conclusion es que en wine funcionara lo que funcione, y en caso de
 > funcionar sera de la manera en que funcione.
 >
 > Un saludo
 >
 >
 >
 >
 >
 >
<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>

 > Libre de virus. www.avg.com
 >
<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>

 >
 >
 >
<#m_6916365579139901897_m_2538962966342891844_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
 >


Estimado, gracias por tu aporte.
En líneas generales, lo que me dices, ya lo tengo en claro; uso Debian
desde hace 15 años.
Pero desde los equipos multinúcleo multihilo, suelo usar máquinas
virtuales para correr los programas de Windows, tanto qemu como VirtualBox.
El tema es que ahora, con este tema de la pandemia y la cuarentena, he
rescatado un viejo amd64 de doble núcleo y apenas 4GB de RAM, por lo que
usar una virtual no está en la posibilidad sin afectar tremendamente el
rendimiento.
Pero como necesito correr una estupidez bajo Windows, intenté volver a WINE.
Y me he roto la cabeza en Buster; no puedo instalarlo; hace ya tiempo
que no lo hacía, calculo que desde Squeezy.
Por eso pregunto: ¿Alguien lo ha podido instalar en Buster?

Gracias

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

JavierDebian
In reply to this post by Camaleón


El 15/5/20 a las 03:57, Camaleón escribió:

> El 2020-05-14 a las 15:31 -0300, JavierDebian escribió:
>
> (...)
>
>> # dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
>> Obj:1 http://security.debian.org buster/updates InRelease
>> (...)
>> Descargados 8.667 kB en 4s (2.199 kB/s)
>> Leyendo lista de paquetes... Hecho
>> Leyendo lista de paquetes... Hecho
>> Creando árbol de dependencias
>> Leyendo la información de estado... Hecho
>> No se pudieron instalar algunos paquetes. Esto puede significar que
>> usted pidió una situación imposible o, si está usando la distribución
>> inestable, que algunos paquetes necesarios aún no se han creado o se
>> han sacado de «Incoming».
>> La siguiente información puede ayudar a resolver la situación:
>>
>> Los siguientes paquetes tienen dependencias incumplidas:
>>   wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
>>                 Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
>> E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
>
> ***
> How to install wine32 in Debian 9?
> <https://unix.stackexchange.com/questions/538998/how-to-install-wine32-in-debian-9>
>
> Also works in Debian 10 – Levin Apr 14 at 8:57
> ^^^^^^^^^^^^^^^^^^^^^^^
> ***
>
> Saludos,
>

Eso ya lo había intentado; la salida va al pie.
También hubo otro tutorial que seguí, y pretendía cargarse todo el
sistema, reemplazando casi todo de amd64 a i386.

# apt install \
 >       wine \
 >       wine32 \
 >       wine64 \
 >       libwine \
 >       libwine:i386 \
 >       fonts-wine
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
fonts-wine ya está en su versión más reciente (4.0-2).
fijado fonts-wine como instalado manualmente.
libwine ya está en su versión más reciente (4.0-2).
fijado libwine como instalado manualmente.
wine ya está en su versión más reciente (4.0-2).
wine64 ya está en su versión más reciente (4.0-2).
fijado wine64 como instalado manualmente.
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  libwine:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
                 Depende: libfontconfig1:i386 (>= 2.12.6) pero no va a
instalarse
                 Depende: libfreetype6:i386 (>= 2.6.2) pero no va a
instalarse
                 Depende: libncurses6:i386 (>= 6) pero no va a instalarse
                 Depende: libtinfo6:i386 (>= 6) pero no va a instalarse
                 Depende: libasound2:i386 (>= 1.0.16)
                 Depende: libglib2.0-0:i386 (>= 2.12.0) pero no va a
instalarse
                 Depende: libgphoto2-6:i386 (>= 2.5.10) pero no va a
instalarse
                 Depende: libgphoto2-port12:i386 (>= 2.5.10) pero no va
a instalarse
                 Depende: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0)
pero no va a instalarse
                 Depende: libgstreamer1.0-0:i386 (>= 1.4.0) pero no va a
instalarse
                 Depende: liblcms2-2:i386 (>= 2.2+git20110628) pero no
va a instalarse
                 Depende: libldap-2.4-2:i386 (>= 2.4.7) pero no va a
instalarse
                 Depende: libmpg123-0:i386 (>= 1.13.7) pero no va a
instalarse
                 Depende: libopenal1:i386 (>= 1.14) pero no va a instalarse
                 Depende: libpcap0.8:i386 (>= 0.9.8) pero no va a instalarse
                 Depende: libpulse0:i386 (>= 0.99.1) pero no va a instalarse
                 Depende: libudev1:i386 (>= 183) pero no va a instalarse
                 Depende: libvkd3d1:i386 (>= 1.0) pero no va a instalarse
                 Depende: libx11-6:i386 pero no va a instalarse
                 Depende: libxext6:i386 pero no va a instalarse
                 Depende: libxml2:i386 (>= 2.9.0) pero no va a instalarse
                 Depende: ocl-icd-libopencl1:i386 pero no va a instalarse o
                          libopencl1:i386
                 Depende: zlib1g:i386 (>= 1:1.1.4) pero no va a instalarse
                 Recomienda: libcapi20-3:i386 pero no va a instalarse
                 Recomienda: libcups2:i386 (>= 1.4.0) pero no va a
instalarse
                 Recomienda: libdbus-1-3:i386 (>= 1.9.14) pero no va a
instalarse
                 Recomienda: libgl1:i386 pero no va a instalarse
                 Recomienda: libglu1-mesa:i386 pero no va a instalarse o
                             libglu1:i386
                 Recomienda: libgnutls30:i386 (>= 3.6.5) pero no va a
instalarse
                 Recomienda: libgsm1:i386 (>= 1.0.18) pero no va a
instalarse
                 Recomienda: libgssapi-krb5-2:i386 (>= 1.6.dfsg.2) pero
no va a instalarse
                 Recomienda: libjpeg62-turbo:i386 (>= 1.3.1) pero no va
a instalarse
                 Recomienda: libkrb5-3:i386 (>= 1.6.dfsg.2) pero no va a
instalarse
                 Recomienda: libodbc1:i386 (>= 2.3.1) pero no va a
instalarse
                 Recomienda: libosmesa6:i386 (>= 10.2~) pero no va a
instalarse
                 Recomienda: libpng16-16:i386 (>= 1.6.2-1) pero no va a
instalarse
                 Recomienda: libsdl2-2.0-0:i386 (>= 2.0.9) pero no va a
instalarse
                 Recomienda: libtiff5:i386 (>= 4.0.3) pero no va a
instalarse
                 Recomienda: libv4l-0:i386 (>= 0.5.0) pero no va a
instalarse
                 Recomienda: libvulkan1:i386 pero no va a instalarse
                 Recomienda: libxcomposite1:i386 (>= 1:0.3-1) pero no va
a instalarse
                 Recomienda: libxcursor1:i386 (> 1.1.2) pero no va a
instalarse
                 Recomienda: libxfixes3:i386 pero no va a instalarse
                 Recomienda: libxi6:i386 pero no va a instalarse
                 Recomienda: libxinerama1:i386 pero no va a instalarse
                 Recomienda: libxrandr2:i386 pero no va a instalarse
                 Recomienda: libxrender1:i386 pero no va a instalarse
                 Recomienda: libxslt1.1:i386 (>= 1.1.25) pero no va a
instalarse
                 Recomienda: libxxf86vm1:i386 pero no va a instalarse
                 Recomienda: libgl1-mesa-dri:i386 pero no va a instalarse
                 Recomienda: libasound2-plugins:i386 pero no va a instalarse
  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

juan carlos rebate todriguez
In reply to this post by JavierDebian
Quizá sea bobo lo que digo pero wine no ocupa 200 megas y pico sino 800, ese error da sino añades la arquitectura i386 a apt

El jue., 14 may. 2020 20:32, JavierDebian <[hidden email]> escribió:
Buenas tardes.


¿Alguien ha podido instalar Wine sobre Debian 10 "buster" amd64?


=====================
Si instalo de los propios repositorios, muero en

# apt install --install-recommends wine
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine64
Paquetes sugeridos:
   ttf-mscorefonts-installer q4wine winbind winetricks playonlinux
wine-binfmt wine64-preloader
Paquetes recomendados:
   wine32
Se instalarán los siguientes paquetes NUEVOS:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine wine64
0 actualizados, 7 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 26,6 MB de archivos.
Se utilizarán 237 MB de espacio de disco adicional después de esta
operación.
¿Desea continuar? [S/n]
Des:1 https://debian.unnoba.edu.ar/debian buster/main amd64 fonts-wine
all 4.0-2 [226 kB]
Des:2 https://debian.unnoba.edu.ar/debian buster/main amd64 libcapi20-3
amd64 1:3.27-3 [28,5 kB]
Des:3 https://debian.unnoba.edu.ar/debian buster/main amd64 libosmesa6
amd64 18.3.6-2+deb10u1 [2.243 kB]
Des:4 https://debian.unnoba.edu.ar/debian buster/main amd64 libvkd3d1
amd64 1.1-3 [125 kB]
Des:5 https://debian.unnoba.edu.ar/debian buster/main amd64 libwine
amd64 4.0-2 [23,6 MB]
Des:6 https://debian.unnoba.edu.ar/debian buster/main amd64 wine64 amd64
4.0-2 [286 kB]
Des:7 https://debian.unnoba.edu.ar/debian buster/main amd64 wine all
4.0-2 [134 kB]
Descargados 26,6 MB en 5s (5.539 kB/s)
Seleccionando el paquete fonts-wine previamente no seleccionado.
(Leyendo la base de datos ... 307836 ficheros o directorios instalados
actualmente.)
Preparando para desempaquetar .../0-fonts-wine_4.0-2_all.deb ...
Desempaquetando fonts-wine (4.0-2) ...
Seleccionando el paquete libcapi20-3:amd64 previamente no seleccionado.
Preparando para desempaquetar .../1-libcapi20-3_1%3a3.27-3_amd64.deb ...
Desempaquetando libcapi20-3:amd64 (1:3.27-3) ...
Seleccionando el paquete libosmesa6:amd64 previamente no seleccionado.
Preparando para desempaquetar
.../2-libosmesa6_18.3.6-2+deb10u1_amd64.deb ...
Desempaquetando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Seleccionando el paquete libvkd3d1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../3-libvkd3d1_1.1-3_amd64.deb ...
Desempaquetando libvkd3d1:amd64 (1.1-3) ...
Seleccionando el paquete libwine:amd64 previamente no seleccionado.
Preparando para desempaquetar .../4-libwine_4.0-2_amd64.deb ...
Desempaquetando libwine:amd64 (4.0-2) ...
Seleccionando el paquete wine64 previamente no seleccionado.
Preparando para desempaquetar .../5-wine64_4.0-2_amd64.deb ...
Desempaquetando wine64 (4.0-2) ...
Seleccionando el paquete wine previamente no seleccionado.
Preparando para desempaquetar .../6-wine_4.0-2_all.deb ...
Desempaquetando wine (4.0-2) ...
Configurando libcapi20-3:amd64 (1:3.27-3) ...
Configurando libvkd3d1:amd64 (1.1-3) ...
Configurando fonts-wine (4.0-2) ...
Configurando libwine:amd64 (4.0-2) ...
Configurando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Configurando wine64 (4.0-2) ...
Configurando wine (4.0-2) ...
Procesando disparadores para libc-bin (2.29-10) ...
Procesando disparadores para man-db (2.8.5-2) ...
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Procesando disparadores para wine (4.0-2) ...

$ wine DiskInfo64.exe
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first.  as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"

# dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
Obj:1 http://security.debian.org buster/updates InRelease
(...)
Descargados 8.667 kB en 4s (2.199 kB/s)
Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
                Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================
Si instalo de https://wiki.winehq.org/Debian

# apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  winehq-stable : Depende: wine-stable (= 5.0.0~buster) pero no va a
instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================


¿Alguien no ha muerto en el intento y tiene la "receta"?

Gracias.

JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Camaleón
In reply to this post by JavierDebian
El 2020-05-15 a las 13:42 -0300, JavierDebian escribió:

> El 15/5/20 a las 03:57, Camaleón escribió:
> > El 2020-05-14 a las 15:31 -0300, JavierDebian escribió:
> >
> > (...)
> >
> > > # dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
> > > Obj:1 http://security.debian.org buster/updates InRelease
> > > (...)
> > > Descargados 8.667 kB en 4s (2.199 kB/s)
> > > Leyendo lista de paquetes... Hecho
> > > Leyendo lista de paquetes... Hecho
> > > Creando árbol de dependencias
> > > Leyendo la información de estado... Hecho
> > > No se pudieron instalar algunos paquetes. Esto puede significar que
> > > usted pidió una situación imposible o, si está usando la distribución
> > > inestable, que algunos paquetes necesarios aún no se han creado o se
> > > han sacado de «Incoming».
> > > La siguiente información puede ayudar a resolver la situación:
> > >
> > > Los siguientes paquetes tienen dependencias incumplidas:
> > >   wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
> > >                 Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
> > > E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
> >
> > ***
> > How to install wine32 in Debian 9?
> > <https://unix.stackexchange.com/questions/538998/how-to-install-wine32-in-debian-9>
> >
> > Also works in Debian 10 – Levin Apr 14 at 8:57
> > ^^^^^^^^^^^^^^^^^^^^^^^
> > ***
> >
> > Saludos,
> >
>
> Eso ya lo había intentado; la salida va al pie.
> También hubo otro tutorial que seguí, y pretendía cargarse todo el sistema,
> reemplazando casi todo de amd64 a i386.
>
> # apt install \
> >       wine \
> >       wine32 \
> >       wine64 \
> >       libwine \
> >       libwine:i386 \
> >       fonts-wine

(...)

Salida de:

1.
dpkg --print-architecture

2.
dpkg --add-architecture i386 && apt update
apt install \
      wine \
      wine32 \
      wine64 \
      libwine \
      libwine:i386 \
      fonts-wine

3.
apt-get install libc6:i386
apt-get install libwine:i386

Saludos,

--
Camaleón

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Emerson Gonzalez
Galvatorix tiene mas razón que un santo
Todos los buenos deseos de los linuxeros no alcanzan, wine es un parche grotesco que no sirve para nada, yo si que lo digo con todas las letras
Y linux, haces lo que puedes hacer con linux, y nada mas, comparar es imposible

El vie., 15 de may. de 2020 a la(s) 20:27, Camaleón ([hidden email]) escribió:
El 2020-05-15 a las 13:42 -0300, JavierDebian escribió:

> El 15/5/20 a las 03:57, Camaleón escribió:
> > El 2020-05-14 a las 15:31 -0300, JavierDebian escribió:
> >
> > (...)
> >
> > > # dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
> > > Obj:1 http://security.debian.org buster/updates InRelease
> > > (...)
> > > Descargados 8.667 kB en 4s (2.199 kB/s)
> > > Leyendo lista de paquetes... Hecho
> > > Leyendo lista de paquetes... Hecho
> > > Creando árbol de dependencias
> > > Leyendo la información de estado... Hecho
> > > No se pudieron instalar algunos paquetes. Esto puede significar que
> > > usted pidió una situación imposible o, si está usando la distribución
> > > inestable, que algunos paquetes necesarios aún no se han creado o se
> > > han sacado de «Incoming».
> > > La siguiente información puede ayudar a resolver la situación:
> > >
> > > Los siguientes paquetes tienen dependencias incumplidas:
> > >   wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
> > >                 Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
> > > E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
> >
> > ***
> > How to install wine32 in Debian 9?
> > <https://unix.stackexchange.com/questions/538998/how-to-install-wine32-in-debian-9>
> >
> > Also works in Debian 10 – Levin Apr 14 at 8:57
> > ^^^^^^^^^^^^^^^^^^^^^^^
> > ***
> >
> > Saludos,
> >
>
> Eso ya lo había intentado; la salida va al pie.
> También hubo otro tutorial que seguí, y pretendía cargarse todo el sistema,
> reemplazando casi todo de amd64 a i386.
>
> # apt install \
> >       wine \
> >       wine32 \
> >       wine64 \
> >       libwine \
> >       libwine:i386 \
> >       fonts-wine

(...)

Salida de:

1.
dpkg --print-architecture

2.
dpkg --add-architecture i386 && apt update
apt install \
      wine \
      wine32 \
      wine64 \
      libwine \
      libwine:i386 \
      fonts-wine

3.
apt-get install libc6:i386
apt-get install libwine:i386

Saludos,

--
Camaleón

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

JavierDebian
In reply to this post by Camaleón


El 15/5/20 a las 15:26, Camaleón escribió:

> Salida de:
>
> 1.
> dpkg --print-architecture
>
> 2.
> dpkg --add-architecture i386 && apt update
> apt install \
>        wine \
>        wine32 \
>        wine64 \
>        libwine \
>        libwine:i386 \
>        fonts-wine
>
> 3.
> apt-get install libc6:i386
> apt-get install libwine:i386
>
> Saludos,


# dpkg --print-architecture
amd64

# dpkg --add-architecture i386 && apt update
Obj:1 http://dl.google.com/linux/chrome/deb stable InRelease
Obj:2 http://security.debian.org buster/updates InRelease
Ign:3 http://dl.google.com/linux/earth/deb stable InRelease
Obj:4 https://debian.unnoba.edu.ar/debian buster InRelease
Obj:5 https://debian.unnoba.edu.ar/debian buster-updates InRelease
Obj:6 http://dl.google.com/linux/earth/deb stable Release
Obj:7 https://debian.unnoba.edu.ar/debian buster-proposed-updates InRelease
Obj:8 https://debian.unnoba.edu.ar/debian buster-backports InRelease
Des:10 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease [2.464 B]
Obj:11 https://repo.skype.com/deb stable InRelease
Obj:12 https://www.deb-multimedia.org buster InRelease
Descargados 2.464 B en 2s (1.235 B/s)
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se puede actualizar 1 paquete. Ejecute «apt list --upgradable» para verlo.

# apt install \
 >       wine \
 >       wine32 \
 >       wine64 \
 >       libwine \
 >       libwine:i386 \
 >       fonts-wine
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
fonts-wine ya está en su versión más reciente (4.0-2).
fijado fonts-wine como instalado manualmente.
libwine ya está en su versión más reciente (4.0-2).
fijado libwine como instalado manualmente.
wine ya está en su versión más reciente (4.0-2).
wine64 ya está en su versión más reciente (4.0-2).
fijado wine64 como instalado manualmente.
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  libwine:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
                 Depende: libfontconfig1:i386 (>= 2.12.6) pero no va a
instalarse
                 Depende: libfreetype6:i386 (>= 2.6.2) pero no va a
instalarse
                 Depende: libncurses6:i386 (>= 6) pero no va a instalarse
                 Depende: libtinfo6:i386 (>= 6) pero no va a instalarse
                 Depende: libasound2:i386 (>= 1.0.16)
                 Depende: libglib2.0-0:i386 (>= 2.12.0) pero no va a
instalarse
                 Depende: libgphoto2-6:i386 (>= 2.5.10) pero no va a
instalarse
                 Depende: libgphoto2-port12:i386 (>= 2.5.10) pero no va
a instalarse
                 Depende: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0)
pero no va a instalarse
                 Depende: libgstreamer1.0-0:i386 (>= 1.4.0) pero no va a
instalarse
                 Depende: liblcms2-2:i386 (>= 2.2+git20110628) pero no
va a instalarse
                 Depende: libldap-2.4-2:i386 (>= 2.4.7) pero no va a
instalarse
                 Depende: libmpg123-0:i386 (>= 1.13.7) pero no va a
instalarse
                 Depende: libopenal1:i386 (>= 1.14) pero no va a instalarse
                 Depende: libpcap0.8:i386 (>= 0.9.8) pero no va a instalarse
                 Depende: libpulse0:i386 (>= 0.99.1) pero no va a instalarse
                 Depende: libudev1:i386 (>= 183) pero no va a instalarse
                 Depende: libvkd3d1:i386 (>= 1.0) pero no va a instalarse
                 Depende: libx11-6:i386 pero no va a instalarse
                 Depende: libxext6:i386 pero no va a instalarse
                 Depende: libxml2:i386 (>= 2.9.0) pero no va a instalarse
                 Depende: ocl-icd-libopencl1:i386 pero no va a instalarse o
                          libopencl1:i386
                 Depende: zlib1g:i386 (>= 1:1.1.4) pero no va a instalarse
                 Recomienda: libcapi20-3:i386 pero no va a instalarse
                 Recomienda: libcups2:i386 (>= 1.4.0) pero no va a
instalarse
                 Recomienda: libdbus-1-3:i386 (>= 1.9.14) pero no va a
instalarse
                 Recomienda: libgl1:i386 pero no va a instalarse
                 Recomienda: libglu1-mesa:i386 pero no va a instalarse o
                             libglu1:i386
                 Recomienda: libgnutls30:i386 (>= 3.6.5) pero no va a
instalarse
                 Recomienda: libgsm1:i386 (>= 1.0.18) pero no va a
instalarse
                 Recomienda: libgssapi-krb5-2:i386 (>= 1.6.dfsg.2) pero
no va a instalarse
                 Recomienda: libjpeg62-turbo:i386 (>= 1.3.1) pero no va
a instalarse
                 Recomienda: libkrb5-3:i386 (>= 1.6.dfsg.2) pero no va a
instalarse
                 Recomienda: libodbc1:i386 (>= 2.3.1) pero no va a
instalarse
                 Recomienda: libosmesa6:i386 (>= 10.2~) pero no va a
instalarse
                 Recomienda: libpng16-16:i386 (>= 1.6.2-1) pero no va a
instalarse
                 Recomienda: libsdl2-2.0-0:i386 (>= 2.0.9) pero no va a
instalarse
                 Recomienda: libtiff5:i386 (>= 4.0.3) pero no va a
instalarse
                 Recomienda: libv4l-0:i386 (>= 0.5.0) pero no va a
instalarse
                 Recomienda: libvulkan1:i386 pero no va a instalarse
                 Recomienda: libxcomposite1:i386 (>= 1:0.3-1) pero no va
a instalarse
                 Recomienda: libxcursor1:i386 (> 1.1.2) pero no va a
instalarse
                 Recomienda: libxfixes3:i386 pero no va a instalarse
                 Recomienda: libxi6:i386 pero no va a instalarse
                 Recomienda: libxinerama1:i386 pero no va a instalarse
                 Recomienda: libxrandr2:i386 pero no va a instalarse
                 Recomienda: libxrender1:i386 pero no va a instalarse
                 Recomienda: libxslt1.1:i386 (>= 1.1.25) pero no va a
instalarse
                 Recomienda: libxxf86vm1:i386 pero no va a instalarse
                 Recomienda: libgl1-mesa-dri:i386 pero no va a instalarse
                 Recomienda: libasound2-plugins:i386 pero no va a instalarse
  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


# apt-get install libc6:i386 libwine:i386
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  libwine:i386 : Depende: libfontconfig1:i386 (>= 2.12.6) pero no va a
instalarse
                 Depende: libgphoto2-6:i386 (>= 2.5.10) pero no va a
instalarse
                 Recomienda: libcups2:i386 (>= 1.4.0) pero no va a
instalarse
                 Recomienda: libgl1:i386 pero no va a instalarse
                 Recomienda: libglu1-mesa:i386 pero no va a instalarse o
                             libglu1:i386
                 Recomienda: libgssapi-krb5-2:i386 (>= 1.6.dfsg.2) pero
no va a instalarse
                 Recomienda: libkrb5-3:i386 (>= 1.6.dfsg.2) pero no va a
instalarse
                 Recomienda: libosmesa6:i386 (>= 10.2~) pero no va a
instalarse
                 Recomienda: libxslt1.1:i386 (>= 1.1.25) pero no va a
instalarse
                 Recomienda: libgl1-mesa-dri:i386 pero no va a instalarse
                 Recomienda: libasound2-plugins:i386 pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.



Como verás, no voy ni para atrás ni para adelante.
Estoy corriendo un buster con un entorno LXQt para alivianar el equipo.

El sources.list es

deb http://security.debian.org/ buster/updates main contrib non-free
deb https://www.deb-multimedia.org buster main non-free
# UNNOBA
deb https://debian.unnoba.edu.ar/debian/ buster main contrib non-free
deb https://debian.unnoba.edu.ar/debian/ buster-updates main contrib
non-free
deb https://debian.unnoba.edu.ar/debian/ buster-proposed-updates main
contrib non-free
deb https://debian.unnoba.edu.ar/debian/ buster-backports main contrib
non-free


JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Camaleón
El 2020-05-15 a las 21:08 -0300, JavierDebian escribió:

> El 15/5/20 a las 15:26, Camaleón escribió:
> > Salida de:
> >
> > 1.
> > dpkg --print-architecture
> >
> > 2.
> > dpkg --add-architecture i386 && apt update
> > apt install \
> >        wine \
> >        wine32 \
> >        wine64 \
> >        libwine \
> >        libwine:i386 \
> >        fonts-wine
> >
> > 3.
> > apt-get install libc6:i386
> > apt-get install libwine:i386
> >
> > Saludos,
>
>
> # dpkg --print-architecture
> amd64

¿!

dpkg --add-architecture i386
apt-get update
dpkg --print-architecture

> # dpkg --add-architecture i386 && apt update

(...)

> Se puede actualizar 1 paquete. Ejecute «apt list --upgradable» para verlo.

apt list --ugradable
 
> # apt install \
> >       wine \
> >       wine32 \
> >       wine64 \
> >       libwine \
> >       libwine:i386 \
> >       fonts-wine

(...)

>  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
> E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
>
>
> # apt-get install libc6:i386 libwine:i386

(...)

> Los siguientes paquetes tienen dependencias incumplidas:
>  libwine:i386 : Depende: libfontconfig1:i386 (>= 2.12.6) pero no va a
> instalarse
>                 Depende: libgphoto2-6:i386 (>= 2.5.10) pero no va a
> instalarse

(...)

> E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
>
>
>
> Como verás, no voy ni para atrás ni para adelante.
> Estoy corriendo un buster con un entorno LXQt para alivianar el equipo.

Lo único que me queda claro es que APT no quiere instalar paquetes de una
arquictura distinta de la que tienes definida, y que sólo es la de 64
bits (amd64).

Según la wiki de Debian¹, para que el sistema multiarquitectura funcione
tanto dpkg como apt tienen que estar «sincronizados», es decir,
configurados para las arquitecturas que quieras usar, en este caso
amd64 e i386.

>
> El sources.list es
>
> deb http://security.debian.org/ buster/updates main contrib non-free
> deb https://www.deb-multimedia.org buster main non-free
> # UNNOBA
> deb https://debian.unnoba.edu.ar/debian/ buster main contrib non-free
> deb https://debian.unnoba.edu.ar/debian/ buster-updates main contrib
> non-free
> deb https://debian.unnoba.edu.ar/debian/ buster-proposed-updates main
> contrib non-free
> deb https://debian.unnoba.edu.ar/debian/ buster-backports main contrib
> non-free

Para este caso, comenta todos los repos que no sean Debian (Google Chrome, multimedia,
skype), es decir, deja sólo:

deb http://security.debian.org/ buster/updates main contrib non-free
deb https://debian.unnoba.edu.ar/debian/ buster main contrib non-free

Asegúrate de que has añadido la arquitectura (i386) a dpkg y apt (para
que ambos puedan instalar los paquetes sin problemas), actualiza los repos (apt-get update) y no instales
los paquetes recomendados (apt-get install wine32 --no-install-recommends).

¹https://wiki.debian.org/Multiarch/HOWTO

Saludos,

--
Camaleón

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

JavierDebian


El 16/5/20 a las 04:32, Camaleón escribió:
> dpkg --print-architecture

Curioso.
Tampoco sources.list se modifica.
Voy a indagar allí, y agregar a mano [arch=amd64,i386]


JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

JavierDebian
In reply to this post by Camaleón


El 16/5/20 a las 04:32, Camaleón escribió:

> El 2020-05-15 a las 21:08 -0300, JavierDebian escribió:
>
>> El 15/5/20 a las 15:26, Camaleón escribió:
>>> Salida de:
>>>
>>> 1.
>>> dpkg --print-architecture
>>>
>>> 2.
>>> dpkg --add-architecture i386 && apt update
>>> apt install \
>>>         wine \
>>>         wine32 \
>>>         wine64 \
>>>         libwine \
>>>         libwine:i386 \
>>>         fonts-wine
>>>
>>> 3.
>>> apt-get install libc6:i386
>>> apt-get install libwine:i386
>>>
>>> Saludos,
>>
>>
>> # dpkg --print-architecture
>> amd64
>
> ¿!
>
> dpkg --add-architecture i386
> apt-get update
> dpkg --print-architecture
>
>> # dpkg --add-architecture i386 && apt update
>
> (...)
>
>> Se puede actualizar 1 paquete. Ejecute «apt list --upgradable» para verlo.
>
> apt list --ugradable
>  
>> # apt install \
>>>        wine \
>>>        wine32 \
>>>        wine64 \
>>>        libwine \
>>>        libwine:i386 \
>>>        fonts-wine
>
> (...)
>
>>   wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
>> E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
>>
>>
>> # apt-get install libc6:i386 libwine:i386
>
> (...)
>
>> Los siguientes paquetes tienen dependencias incumplidas:
>>   libwine:i386 : Depende: libfontconfig1:i386 (>= 2.12.6) pero no va a
>> instalarse
>>                  Depende: libgphoto2-6:i386 (>= 2.5.10) pero no va a
>> instalarse
>
> (...)
>
>> E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
>>
>>
>>
>> Como verás, no voy ni para atrás ni para adelante.
>> Estoy corriendo un buster con un entorno LXQt para alivianar el equipo.
>
> Lo único que me queda claro es que APT no quiere instalar paquetes de una
> arquictura distinta de la que tienes definida, y que sólo es la de 64
> bits (amd64).
>
> Según la wiki de Debian¹, para que el sistema multiarquitectura funcione
> tanto dpkg como apt tienen que estar «sincronizados», es decir,
> configurados para las arquitecturas que quieras usar, en este caso
> amd64 e i386.
>
>>
>> El sources.list es
>>
>> deb http://security.debian.org/ buster/updates main contrib non-free
>> deb https://www.deb-multimedia.org buster main non-free
>> # UNNOBA
>> deb https://debian.unnoba.edu.ar/debian/ buster main contrib non-free
>> deb https://debian.unnoba.edu.ar/debian/ buster-updates main contrib
>> non-free
>> deb https://debian.unnoba.edu.ar/debian/ buster-proposed-updates main
>> contrib non-free
>> deb https://debian.unnoba.edu.ar/debian/ buster-backports main contrib
>> non-free
>
> Para este caso, comenta todos los repos que no sean Debian (Google Chrome, multimedia,
> skype), es decir, deja sólo:
>
> deb http://security.debian.org/ buster/updates main contrib non-free
> deb https://debian.unnoba.edu.ar/debian/ buster main contrib non-free
>
> Asegúrate de que has añadido la arquitectura (i386) a dpkg y apt (para
> que ambos puedan instalar los paquetes sin problemas), actualiza los repos (apt-get update) y no instales
> los paquetes recomendados (apt-get install wine32 --no-install-recommends).
>
> ¹https://wiki.debian.org/Multiarch/HOWTO
>
> Saludos,
>



Se niega ostensiblemente. Me rindo.


root@bbar:~# dpkg --add-architecture i386

root@bbar:~# apt update
Obj:1 http://security.debian.org buster/updates InRelease
Obj:2 https://debian.unnoba.edu.ar/debian buster InRelease
Ign:3 http://dl.google.com/linux/earth/deb stable InRelease
Obj:4 https://debian.unnoba.edu.ar/debian buster-updates InRelease
Obj:5 https://debian.unnoba.edu.ar/debian buster-proposed-updates InRelease
Obj:6 https://debian.unnoba.edu.ar/debian buster-backports InRelease
Obj:7 https://www.deb-multimedia.org buster InRelease
Descargados 2.464 B en 2s (1.369 B/s)
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Todos los paquetes están actualizados.

root@bbar:~# dpkg --print-architecture
amd64

root@bbar:~# dpkg --print-foreign-architectures
i386

root@bbar:~# apt install  wine32 --no-install-recommends
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
                Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

walter salazar
In reply to this post by JavierDebian
Hola . Tuve muchos problemas con varios programas en debian 10. No usé wine todavia, peor muchos de esos problemas tenian que ver con wayland. Muchos se me solucionaron al usar el escritorio clasico, trata de usar el escritorio tradicional, Tengo que instalar un programa que se ejecuta solo en win asi que mas adelante andaré siguiendo tu huella.

El sáb., 16 may. 2020 a las 13:17, JavierDebian (<[hidden email]>) escribió:


El 16/5/20 a las 04:32, Camaleón escribió:
> dpkg --print-architecture

Curioso.
Tampoco sources.list se modifica.
Voy a indagar allí, y agregar a mano [arch=amd64,i386]


JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Alejandro Gutiérrez
Has probado con aptitude  en lugar de apt o apt-get?

El sáb, 16 de mayo de 2020 14:24, walter salazar <[hidden email]> escribió:
Hola . Tuve muchos problemas con varios programas en debian 10. No usé wine todavia, peor muchos de esos problemas tenian que ver con wayland. Muchos se me solucionaron al usar el escritorio clasico, trata de usar el escritorio tradicional, Tengo que instalar un programa que se ejecuta solo en win asi que mas adelante andaré siguiendo tu huella.

El sáb., 16 may. 2020 a las 13:17, JavierDebian (<[hidden email]>) escribió:


El 16/5/20 a las 04:32, Camaleón escribió:
> dpkg --print-architecture

Curioso.
Tampoco sources.list se modifica.
Voy a indagar allí, y agregar a mano [arch=amd64,i386]


JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Alejandro Gutiérrez
In reply to this post by JavierDebian
Prueba usando aptitude  en lugar de apt

El jue., 14 de mayo de 2020 15:32, JavierDebian <[hidden email]> escribió:
Buenas tardes.


¿Alguien ha podido instalar Wine sobre Debian 10 "buster" amd64?


=====================
Si instalo de los propios repositorios, muero en

# apt install --install-recommends wine
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine64
Paquetes sugeridos:
   ttf-mscorefonts-installer q4wine winbind winetricks playonlinux
wine-binfmt wine64-preloader
Paquetes recomendados:
   wine32
Se instalarán los siguientes paquetes NUEVOS:
   fonts-wine libcapi20-3 libosmesa6 libvkd3d1 libwine wine wine64
0 actualizados, 7 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 26,6 MB de archivos.
Se utilizarán 237 MB de espacio de disco adicional después de esta
operación.
¿Desea continuar? [S/n]
Des:1 https://debian.unnoba.edu.ar/debian buster/main amd64 fonts-wine
all 4.0-2 [226 kB]
Des:2 https://debian.unnoba.edu.ar/debian buster/main amd64 libcapi20-3
amd64 1:3.27-3 [28,5 kB]
Des:3 https://debian.unnoba.edu.ar/debian buster/main amd64 libosmesa6
amd64 18.3.6-2+deb10u1 [2.243 kB]
Des:4 https://debian.unnoba.edu.ar/debian buster/main amd64 libvkd3d1
amd64 1.1-3 [125 kB]
Des:5 https://debian.unnoba.edu.ar/debian buster/main amd64 libwine
amd64 4.0-2 [23,6 MB]
Des:6 https://debian.unnoba.edu.ar/debian buster/main amd64 wine64 amd64
4.0-2 [286 kB]
Des:7 https://debian.unnoba.edu.ar/debian buster/main amd64 wine all
4.0-2 [134 kB]
Descargados 26,6 MB en 5s (5.539 kB/s)
Seleccionando el paquete fonts-wine previamente no seleccionado.
(Leyendo la base de datos ... 307836 ficheros o directorios instalados
actualmente.)
Preparando para desempaquetar .../0-fonts-wine_4.0-2_all.deb ...
Desempaquetando fonts-wine (4.0-2) ...
Seleccionando el paquete libcapi20-3:amd64 previamente no seleccionado.
Preparando para desempaquetar .../1-libcapi20-3_1%3a3.27-3_amd64.deb ...
Desempaquetando libcapi20-3:amd64 (1:3.27-3) ...
Seleccionando el paquete libosmesa6:amd64 previamente no seleccionado.
Preparando para desempaquetar
.../2-libosmesa6_18.3.6-2+deb10u1_amd64.deb ...
Desempaquetando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Seleccionando el paquete libvkd3d1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../3-libvkd3d1_1.1-3_amd64.deb ...
Desempaquetando libvkd3d1:amd64 (1.1-3) ...
Seleccionando el paquete libwine:amd64 previamente no seleccionado.
Preparando para desempaquetar .../4-libwine_4.0-2_amd64.deb ...
Desempaquetando libwine:amd64 (4.0-2) ...
Seleccionando el paquete wine64 previamente no seleccionado.
Preparando para desempaquetar .../5-wine64_4.0-2_amd64.deb ...
Desempaquetando wine64 (4.0-2) ...
Seleccionando el paquete wine previamente no seleccionado.
Preparando para desempaquetar .../6-wine_4.0-2_all.deb ...
Desempaquetando wine (4.0-2) ...
Configurando libcapi20-3:amd64 (1:3.27-3) ...
Configurando libvkd3d1:amd64 (1.1-3) ...
Configurando fonts-wine (4.0-2) ...
Configurando libwine:amd64 (4.0-2) ...
Configurando libosmesa6:amd64 (18.3.6-2+deb10u1) ...
Configurando wine64 (4.0-2) ...
Configurando wine (4.0-2) ...
Procesando disparadores para libc-bin (2.29-10) ...
Procesando disparadores para man-db (2.8.5-2) ...
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Procesando disparadores para wine (4.0-2) ...

$ wine DiskInfo64.exe
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first.  as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"

# dpkg --add-architecture i386 && apt-get update && > apt-get install wine32
Obj:1 http://security.debian.org buster/updates InRelease
(...)
Descargados 8.667 kB en 4s (2.199 kB/s)
Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
                Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================
Si instalo de https://wiki.winehq.org/Debian

# apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
  winehq-stable : Depende: wine-stable (= 5.0.0~buster) pero no va a
instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


=====================


¿Alguien no ha muerto en el intento y tiene la "receta"?

Gracias.

JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster"

Camaleón
In reply to this post by JavierDebian
El 2020-05-16 a las 14:23 -0300, JavierDebian escribió:
>
> El 16/5/20 a las 04:32, Camaleón escribió:

(...)

> > >
> > > # dpkg --print-architecture
> > > amd64
> >
> > ¿!
> >

(...)

> > > E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
> > >
> > >
> > >
> > > Como verás, no voy ni para atrás ni para adelante.
> > > Estoy corriendo un buster con un entorno LXQt para alivianar el equipo.
> >
> > Lo único que me queda claro es que APT no quiere instalar paquetes de una
> > arquictura distinta de la que tienes definida, y que sólo es la de 64
> > bits (amd64).
> >
> > Según la wiki de Debian¹, para que el sistema multiarquitectura funcione
> > tanto dpkg como apt tienen que estar «sincronizados», es decir,
> > configurados para las arquitecturas que quieras usar, en este caso
> > amd64 e i386.
> >

(...)

>
>
> Se niega ostensiblemente. Me rindo.
>
>
> root@bbar:~# dpkg --add-architecture i386
>
> root@bbar:~# apt update
> Obj:1 http://security.debian.org buster/updates InRelease
> Obj:2 https://debian.unnoba.edu.ar/debian buster InRelease
> Ign:3 http://dl.google.com/linux/earth/deb stable InRelease
> Obj:4 https://debian.unnoba.edu.ar/debian buster-updates InRelease
> Obj:5 https://debian.unnoba.edu.ar/debian buster-proposed-updates InRelease
> Obj:6 https://debian.unnoba.edu.ar/debian buster-backports InRelease
> Obj:7 https://www.deb-multimedia.org buster InRelease
> Descargados 2.464 B en 2s (1.369 B/s)
> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias
> Leyendo la información de estado... Hecho
> Todos los paquetes están actualizados.
>
> root@bbar:~# dpkg --print-architecture
> amd64
>
> root@bbar:~# dpkg --print-foreign-architectures
> i386

Según la wiki de Debian, la salida parece correcta, por lo que vamos a
dar por hecho que tienes configurado el sistema correctamente para
trabajar con múltiples arquitecturas:

****
There is a current machine architecture, as printed by dpkg
--print-architecture. It is built-in to the currently installed dpkg
package.

(...)

Other available architectures are shown by dpkg
--print-foreign-architectures. dpkg will manage packages for these
architectures as well as the machine architecture.
***

Verifica con:

cat /var/lib/dpkg/arch

> root@bbar:~# apt install  wine32 --no-install-recommends
> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias
> Leyendo la información de estado... Hecho
> No se pudieron instalar algunos paquetes. Esto puede significar que
> usted pidió una situación imposible o, si está usando la distribución
> inestable, que algunos paquetes necesarios aún no se han creado o se
> han sacado de «Incoming».
> La siguiente información puede ayudar a resolver la situación:
>
> Los siguientes paquetes tienen dependencias incumplidas:
>  wine32:i386 : Depende: libc6:i386 (>= 2.28) pero no va a instalarse
>                Depende: libwine:i386 (= 4.0-2) pero no va a instalarse
> E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Vamos a tratar el problema como lo haríamos con cualquier otro paquete
de 64 bits que tiene una dependencia que le impide instalarse.

apt-get -f install

Y si tampoco devuelve nada útil, prueba con «aptitude» como te han
recomendado:

aptitude why-not libc6:i386

Me da la impresión de que hay dependencias en cascada incumplidas para esos
paquetes y por eso rechaza instalarlos.

Tras añadir la arquitectura i386, además refrescar los paquete con
«apt-get update» prueba con «apt-get dist-upgrade» (cuidado con la
salida y con la respuesta) y después «apt-get install wine32».

Saludos,

--
Camaleón

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster" - [¿SOLUCIONADO?]

JavierDebian
In reply to this post by JavierDebian


El 14/5/20 a las 15:31, JavierDebian escribió:
> Buenas tardes.
>
>
> ¿Alguien ha podido instalar Wine sobre Debian 10 "buster" amd64?
>


Luego de batallar varios días, he llegado a la siguiente conclusión:

No se puede instalar wine en un sistema que esté "retocado" con
repositorios "especiales".

Es decir, mis repositorios normales incluyen los siguientes:

debian/ buster main contrib non-free
debian/ buster-updates main contrib non-free
debian/ buster-proposed-updates main contrib non-free
debian/ buster-backports main contrib non-free
security.debian.org/ buster/updates main contrib non-free
www.deb-multimedia.org buster main non-free

Esto, a lo largo del tiempo ha ido instalando paquetes, que al instalar
WINE generan problemas de dependencias, sobre todo en lo que hace a
multimedia y algunas cosas de "backports".

¿Cómo lo infiero?

Hice en una máquina virtual una instalación limpia, y probé con sólo
instalar el sistema desde debian/ buster main contrib non-free.
Se instaló sin inconvenientes.

Por lo que en la máquina donde necesito WINE, hice una instalación
limpia (otra razón más por la cual siempre mantener particiones
separadas para /home)
Hacerlo desde un DVD lleva poco más de una hora, que es mucho menos
tiempo de lo he gastado hasta ahora,

Ahora funciona.
Luego de ello, agregué los otros repositorios; ya anda de tiro.

La punta del hilo estaba en https://wiki.debian.org/Wine

"But if you install Wine from another suite (e.g. Debian Backports or
Unstable) then some newly needed i386 packages might have another
version, and you face broken dependencies. To solve this install the
i386 package from the same suite as the already installed amd64 package
(e.g. "sudo apt install libpulse0:i386/testing"), and then continue to
install Wine. "

Si bien no tengo "pinning" hecho en el sistema, es evidente que hay
problemas.

Muchas gracias.

JAP

Reply | Threaded
Open this post in threaded view
|

Re: Wine sobre "buster" - [¿SOLUCIONADO?]

Felix Perez
El dom., 17 de may. de 2020 a la(s) 12:30, JavierDebian
([hidden email]) escribió:

>
>
>
> El 14/5/20 a las 15:31, JavierDebian escribió:
> > Buenas tardes.
> >
> >
> > ¿Alguien ha podido instalar Wine sobre Debian 10 "buster" amd64?
> >
>
>
> Luego de batallar varios días, he llegado a la siguiente conclusión:
>
> No se puede instalar wine en un sistema que esté "retocado" con
> repositorios "especiales".
>
> Es decir, mis repositorios normales incluyen los siguientes:
>
> debian/ buster main contrib non-free
> debian/ buster-updates main contrib non-free
> debian/ buster-proposed-updates main contrib non-free
> debian/ buster-backports main contrib non-free
> security.debian.org/ buster/updates main contrib non-free
> www.deb-multimedia.org buster main non-free
>
> Esto, a lo largo del tiempo ha ido instalando paquetes, que al instalar
> WINE generan problemas de dependencias, sobre todo en lo que hace a
> multimedia y algunas cosas de "backports".
>
> ¿Cómo lo infiero?
>
> Hice en una máquina virtual una instalación limpia, y probé con sólo
> instalar el sistema desde debian/ buster main contrib non-free.
> Se instaló sin inconvenientes.
>
> Por lo que en la máquina donde necesito WINE, hice una instalación
> limpia (otra razón más por la cual siempre mantener particiones
> separadas para /home)
> Hacerlo desde un DVD lleva poco más de una hora, que es mucho menos
> tiempo de lo he gastado hasta ahora,
>
> Ahora funciona.
> Luego de ello, agregué los otros repositorios; ya anda de tiro.
>
> La punta del hilo estaba en https://wiki.debian.org/Wine
>
> "But if you install Wine from another suite (e.g. Debian Backports or
> Unstable) then some newly needed i386 packages might have another
> version, and you face broken dependencies. To solve this install the
> i386 package from the same suite as the already installed amd64 package
> (e.g. "sudo apt install libpulse0:i386/testing"), and then continue to
> install Wine. "
>
> Si bien no tengo "pinning" hecho en el sistema, es evidente que hay
> problemas.
>
> Muchas gracias.
>
> JAP
>
Muchas gracias Javier.
Saludos.

--
usuario linux  #274354
normas de la lista:  http://wiki.debian.org/es/NormasLista
como hacer preguntas inteligentes:
http://www.sindominio.net/ayuda/preguntas-inteligentes.html