XOrg.conf avec une ATI Mobility Radeon X600

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

XOrg.conf avec une ATI Mobility Radeon X600

David BERCOT
Bonjour,

Bon, avant de régler mon problème Compiz, il faudrait d'abord que ma
carte graphique marche correctement. Et là, ce n'est pas le cas ;-)

J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de passer
2 heures à faire plein d'essais : drivers de base, drivers proprio ATI
(v8.42.3 téléchargé depuis chez eux), drivers fglrx, sans succès !!!
Je fais des modifications dans la section "Module", etc..., etc...,
sans résultat. J'ai toujours :
glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting
LIBGL_DEBUG=verbose)

Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
secondes ?

Merci d'avance.

David.

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: XOrg.conf avec une ATI Mobility Radeon X600

hugues larrive
David BERCOT a écrit :

> Bonjour,
>
> Bon, avant de régler mon problème Compiz, il faudrait d'abord que ma
> carte graphique marche correctement. Et là, ce n'est pas le cas ;-)
>
> J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de passer
> 2 heures à faire plein d'essais : drivers de base, drivers proprio ATI
> (v8.42.3 téléchargé depuis chez eux), drivers fglrx, sans succès !!!
> Je fais des modifications dans la section "Module", etc..., etc...,
> sans résultat. J'ai toujours :
> glxinfo | grep direct
> direct rendering: No (If you want to find out why, try setting
> LIBGL_DEBUG=verbose)
>
> Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
> secondes ?
>
> Merci d'avance.
>
> David.
>  
Chez moi ça fonctionne en dual-screen avec une Radeon RV100 et driver
libre (jamais réussi avec le proprio).
Pour les détails concernant la configuration du driver : man radeon
Voilà mon xorg.conf si tu veux t'en inspirer (pas très propre vu que
j'avais pas réussi du premier coup et qu'une fois que ça fonctionne...) :

Section "Files"
    FontPath    "/usr/share/fonts/X11/misc"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc"
    FontPath    "/usr/share/fonts/X11/cyrillic"
    FontPath    "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/Type1"
    FontPath    "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath    "/usr/share/fonts/X11/100dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath    "/usr/share/fonts/X11/75dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load    "i2c"
    Load    "bitmap"
    Load    "ddc"
    Load    "dbe"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "type1"
    Load    "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "Device"
    Identifier    "ATI head 1"
    Driver        "radeon"
    BusID        "PCI:1:0:0"
    #ChipID 0x5159
    VideoRAM 32768
    Screen 0
    Option "DPMS" "true"
    Option "BusType" "AGP"
    Option "AGPMode" "4"
    Option "AGPSize" "64"
    Option "AGPFastWrite" "true"
    Option "DDCMode" "true"
    Option "DynamicClocks" "true"
    Option "XaaNoOffscreenPixmaps"
    Option "AccelMethod" "XAA"
    Option "ColorTiling" "true"
    Option "BufferSize" "2"
    Option "RingSize" "8"
    Option "EnablePageFlip" "true"
    Option "DynamicClocks" "on"
    Option "mtrr" "on"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "EnableDepthMoves" "true"
    Option "RenderAccel" "true"
    Option "BackingStore" "true"


# Dual head config
Option "MonitorLayout" "CRT, CRT2"
Option "MergedFB" "true"
Option "CRT2Position" "RightOf"
Option "MergedXineramaCRT2IsScreen0" "False"
#Option "MergedXinerama" "true"
Option "MetaModes" "1024x768-1024x768"

EndSection
Section "Monitor"
    Identifier    "Moniteur gauche"
    Option        "DPMS"
    HorizSync    30-70
    VertRefresh    50-160
    ModeLine "1024x768"      78.75 1024 1040 1136 1312  768  769  772
800 +hsync +vsync
EndSection

Section "Screen"
    Identifier    "Ecran gauche"
    Device        "ATI head 1"
    Monitor        "Moniteur gauche"
    DefaultDepth    24
    SubSection "Display"
        Depth        24
        Modes        "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    #Option "Xinerama" "true"
    Option "AIGLX" "true"
    Screen "Ecran gauche" 0 0
    #Screen "Ecran droit" RightOf "Ecran gauche"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "DRI"
    Mode    0666
EndSection

Section "Extensions"
        Option "Composite" "true"
EndSection



J'utilise compiz 0.3.6-1 sous etch car avec la version 0.2.2 les
fenêtres se maximisaient sur les 2 écrans...
@+


signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: XOrg.conf avec une ATI Mobility Radeon X600

Fabrice Regnier
In reply to this post by David BERCOT
salut,

fabricer@FR-PORT:~$ lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility
X700 (PCIE)

fabricer@FR-PORT:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X700
OpenGL version string: 2.0.6747 (8.40.4)

fabricer@FR-PORT:~$ dpkg -al| grep fglrx
ii  fglrx-control 8.40.4-2
ii  fglrx-driver 8.40.4-2
ii  fglrx-driver-dev 8.40.4-2
ii  fglrx-kernel-2.6.22-2-686
ii  fglrx-kernel-src

construction du module fglrx avec module-assistant

fabricer@FR-PORT:~$ cat /etc/X11/xorg.conf
Section "ServerLayout"
         Identifier     "Default Layout"
         Screen         "Default Screen" 0 0
         InputDevice    "Generic Keyboard"
         InputDevice    "Configured Mouse"
         InputDevice    "Synaptics Touchpad"
EndSection

Section "ServerFlags"
         Option      "AIGLX" "off"
EndSection

Section "InputDevice"
         Identifier  "Generic Keyboard"
         Driver      "kbd"
         Option      "CoreKeyboard"
         Option      "XkbRules" "xorg"
         Option      "XkbModel" "pc105"
         Option      "XkbLayout" "fr"
EndSection

Section "InputDevice"
         Identifier  "Configured Mouse"
         Driver      "mouse"
         Option      "CorePointer"
         Option      "Device" "/dev/input/mice"
         Option      "Protocol" "ImPS/2"
EndSection

Section "InputDevice"
         Identifier  "Synaptics Touchpad"
         Driver      "synaptics"
         Option      "SendCoreEvents" "true"
         Option      "Device" "/dev/psaux"
         Option      "Protocol" "auto-dev"
         Option      "HorizScrollDelta" "0"
EndSection

Section "Monitor"
         Identifier   "Écran générique"
         HorizSync    30.0 - 70.0
         VertRefresh  50.0 - 160.0
         Option      "DPMS"
EndSection

Section "Device"
         Identifier  "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
         Driver      "fglrx"
         Option      "TVFormat" "PAL-N"
         BusID       "PCI:1:0:0"
EndSection

Section "Screen"
         Identifier "Default Screen"
         Device     "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
         Monitor    "Écran générique"
         DefaultDepth     24
         SubSection "Display"
                 Modes    "1280x800" "800x600"
         EndSubSection
EndSection

Section "DRI"
         Mode         0666
EndSection

Section "Extensions"
         Option      "Composite" "Disable"
         Option      "RENDER" "Enable"
EndSection


fabricer@FR-PORT:~$ glxinfo | grep direct
direct rendering: Yes

euh quoi d'autre ?

Si je me rappelle bien, pour faire tourner compiz, il faut utiliser le
driver libre plutôt que fglrx.

En espèrant que ça aide ;)

a+

f.


David BERCOT wrote:

> Bonjour,
>
> Bon, avant de régler mon problème Compiz, il faudrait d'abord que ma
> carte graphique marche correctement. Et là, ce n'est pas le cas ;-)
>
> J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de passer
> 2 heures à faire plein d'essais : drivers de base, drivers proprio ATI
> (v8.42.3 téléchargé depuis chez eux), drivers fglrx, sans succès !!!
> Je fais des modifications dans la section "Module", etc..., etc...,
> sans résultat. J'ai toujours :
> glxinfo | grep direct
> direct rendering: No (If you want to find out why, try setting
> LIBGL_DEBUG=verbose)
>
> Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
> secondes ?
>
> Merci d'avance.
>
> David.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench   
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Compiz fusion avec ATI & XOrg.conf avec une ATI Mobility Radeon X600

David BERCOT
Bonjour,

Merci aussi aux autres pour leurs suggestions ;-)
3 jours dessus et toujours pas de résultat !!!

En gros, j'ai maintenant à peu près la même version que toi sans :
> Section "ServerFlags"
>          Option      "AIGLX" "off"
> EndSection

OK. Ca, ça marche aussi :
> fabricer@FR-PORT:~$ glxinfo | grep direct
> direct rendering: Yes
>
> Si je me rappelle bien, pour faire tourner compiz, il faut utiliser
> le driver libre plutôt que fglrx.

Ben je ne sais pas, mais là, je n'y arrive vraiment pas...
Quand je lance fusion-icon, je n'ai pas de titre de fenêtre (bien que
j'ai coché l'option "décoration des fenêtres), et si je lance un compiz
--replace en ligne de commande, j'ai un joli :
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Même en rajoutant
Option          "AllowGLXWithComposite" "true"
ça ne change rien...

Bref, je commence vraiment à me demander si ça peut marcher
correctement sur ma machine...

J'ai mis un Ubuntu sur un autre poste (avec une NVidia 6600 je crois),
et Compiz tourne aux petits oignons...

Allez, je vais me coucher et peut être attendre (sauf si quelqu'un a
une super idée ;-))).

Encore merci.

David.

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: XOrg.conf avec une ATI Mobility Radeon X600

Guillaume Coeugnet
In reply to this post by Fabrice Regnier
J'ai la même carte que toi, une X600.

Je n'ai pas de soucis apparent pour installer les drivers proprio. J'utilise
la méthode suivante :
- enlever tous les packages fglrx existant (s'ils existent) et faire un
updatedb puis un locate fglrx pour enlever tous fichiers non désirés et qui
resteraient.
- downloader le binaire des drivers proprio et le lancer avec l'option
--buildpkg Debian/Sid (pour compiz, mieux vaut être en Sid). Il faut
récupérer les derniers drivers qui gèrent (enfin) maintenant l'AIGLX
(8.43.2). Les benchs sont mitigés mais j'essaies moi même de le tester. Je
vais y revenir plus tard.
- installer les paquets générés
- faire un "m-a clean fglrx", un "m-a prepare", un "m-a auto-install fglrx"
- lancer aticonfig avec les options adéquats
- rebooter X et çà devrait aller. Dans le cas contraire, mettre une copie de
ton Xorg.0.log. Tu devrait avoir un DRI à yes et un beau fgl_glxgears qui
tourne(nt)

La config du Xorg donnée est très bien, j'ai en Xorg.conf pour un
dual-screen si tu le souhaites.

Pour compiz, problème. Lors de ma dernière mise à jour, j'avais un problème
avec kde et kdeinit qui ne voulaient plus démarrer. Un "dist-upgrade" hier
m'a fait retrouver un kde opérationnel. Mais, compiz-fusion (dépôt
tuxfamilly) ne veut pas s'installer à cause d'une libwnck18 (de tête) qui
n'existe plus dans Lenny (remplacé par la libwnck20). Cette lib est utilisée
par emerald qui est utilisée par compiz-fusion.
Maintenant, je n'ai pas essayé le compiz des dépots debian. Ce n'est pas
compiz-fusion mais il marchera peut-être mieux.

Voilà !

> -----Message d'origine-----
> De : [hidden email] [mailto:[hidden email]] De la
> part de fabrice régnier
> Envoyé : samedi 3 novembre 2007 15:11
> À : [hidden email]
> Objet : Re: XOrg.conf avec une ATI Mobility Radeon X600
>
> salut,
>
> fabricer@FR-PORT:~$ lspci | grep ATI
> 01:00.0 VGA compatible controller: ATI Technologies Inc
> Radeon Mobility X700 (PCIE)
>
> fabricer@FR-PORT:~$ fglrxinfo
> display: :0.0  screen: 0
> OpenGL vendor string: ATI Technologies Inc.
> OpenGL renderer string: ATI MOBILITY RADEON X700 OpenGL
> version string: 2.0.6747 (8.40.4)
>
> fabricer@FR-PORT:~$ dpkg -al| grep fglrx ii  fglrx-control
> 8.40.4-2 ii  fglrx-driver 8.40.4-2 ii  fglrx-driver-dev
> 8.40.4-2 ii  fglrx-kernel-2.6.22-2-686 ii  fglrx-kernel-src
>
> construction du module fglrx avec module-assistant
>
> fabricer@FR-PORT:~$ cat /etc/X11/xorg.conf Section "ServerLayout"
>          Identifier     "Default Layout"
>          Screen         "Default Screen" 0 0
>          InputDevice    "Generic Keyboard"
>          InputDevice    "Configured Mouse"
>          InputDevice    "Synaptics Touchpad"
> EndSection
>
> Section "ServerFlags"
>          Option      "AIGLX" "off"
> EndSection
>
> Section "InputDevice"
>          Identifier  "Generic Keyboard"
>          Driver      "kbd"
>          Option      "CoreKeyboard"
>          Option      "XkbRules" "xorg"
>          Option      "XkbModel" "pc105"
>          Option      "XkbLayout" "fr"
> EndSection
>
> Section "InputDevice"
>          Identifier  "Configured Mouse"
>          Driver      "mouse"
>          Option      "CorePointer"
>          Option      "Device" "/dev/input/mice"
>          Option      "Protocol" "ImPS/2"
> EndSection
>
> Section "InputDevice"
>          Identifier  "Synaptics Touchpad"
>          Driver      "synaptics"
>          Option      "SendCoreEvents" "true"
>          Option      "Device" "/dev/psaux"
>          Option      "Protocol" "auto-dev"
>          Option      "HorizScrollDelta" "0"
> EndSection
>
> Section "Monitor"
>          Identifier   "Écran générique"
>          HorizSync    30.0 - 70.0
>          VertRefresh  50.0 - 160.0
>          Option      "DPMS"
> EndSection
>
> Section "Device"
>          Identifier  "ATI Technologies Inc Radeon Mobility
> X700 (PCIE)"
>          Driver      "fglrx"
>          Option      "TVFormat" "PAL-N"
>          BusID       "PCI:1:0:0"
> EndSection
>
> Section "Screen"
>          Identifier "Default Screen"
>          Device     "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
>          Monitor    "Écran générique"
>          DefaultDepth     24
>          SubSection "Display"
>                  Modes    "1280x800" "800x600"
>          EndSubSection
> EndSection
>
> Section "DRI"
>          Mode         0666
> EndSection
>
> Section "Extensions"
>          Option      "Composite" "Disable"
>          Option      "RENDER" "Enable"
> EndSection
>
>
> fabricer@FR-PORT:~$ glxinfo | grep direct direct rendering: Yes
>
> euh quoi d'autre ?
>
> Si je me rappelle bien, pour faire tourner compiz, il faut
> utiliser le driver libre plutôt que fglrx.
>
> En espèrant que ça aide ;)
>
> a+
>
> f.
>
>
> David BERCOT wrote:
> > Bonjour,
> >
> > Bon, avant de régler mon problème Compiz, il faudrait
> d'abord que ma
> > carte graphique marche correctement. Et là, ce n'est pas le cas ;-)
> >
> > J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de
> > passer
> > 2 heures à faire plein d'essais : drivers de base, drivers
> proprio ATI
> > (v8.42.3 téléchargé depuis chez eux), drivers fglrx, sans succès !!!
> > Je fais des modifications dans la section "Module", etc..., etc...,
> > sans résultat. J'ai toujours :
> > glxinfo | grep direct
> > direct rendering: No (If you want to find out why, try setting
> > LIBGL_DEBUG=verbose)
> >
> > Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
> > secondes ?
> >
> > Merci d'avance.
> >
> > David.
>
>
> --
> Lisez la FAQ de la liste avant de poser une question :
> http://wiki.debian.net/?DebianFrench   
> Vous pouvez aussi ajouter le mot ``spam'' dans vos champs
> "From" et "Reply-To:"
>
> To UNSUBSCRIBE, email to [hidden email]
> with a subject of "unsubscribe". Trouble? Contact
> [hidden email]
>
>

Reply | Threaded
Open this post in threaded view
|

Compiz : j'attends d'être en NVidia [Re: XOrg.conf avec une ATI Mobility Radeon X600]

David BERCOT
Bonjour,

Finalement, tout roule aussi correctement avec les drivers proprio.
J'ai bien l'accélération activée... Maintenant, pour Compiz, je
n'arrive vraiment à rien (même s'il est installé).

Je viens rapidement de mettre Ubuntu sur mon portable (en dual boot, à
la place de XP), et ça ne donne rien de plus. Visiblement, avec ATI,
c'est pas trop ça...

Tant pis, je vais rester en mode "pas d'effet de la mort" ;-)

Merci.

David.

Le Mon, 5 Nov 2007 09:44:16 +0100,
"Guillaume Coeugnet" <[hidden email]> a écrit :

> J'ai la même carte que toi, une X600.
>
> Je n'ai pas de soucis apparent pour installer les drivers proprio.
> J'utilise la méthode suivante :
> - enlever tous les packages fglrx existant (s'ils existent) et faire
> un updatedb puis un locate fglrx pour enlever tous fichiers non
> désirés et qui resteraient.
> - downloader le binaire des drivers proprio et le lancer avec l'option
> --buildpkg Debian/Sid (pour compiz, mieux vaut être en Sid). Il faut
> récupérer les derniers drivers qui gèrent (enfin) maintenant l'AIGLX
> (8.43.2). Les benchs sont mitigés mais j'essaies moi même de le
> tester. Je vais y revenir plus tard.
> - installer les paquets générés
> - faire un "m-a clean fglrx", un "m-a prepare", un "m-a auto-install
> fglrx"
> - lancer aticonfig avec les options adéquats
> - rebooter X et çà devrait aller. Dans le cas contraire, mettre une
> copie de ton Xorg.0.log. Tu devrait avoir un DRI à yes et un beau
> fgl_glxgears qui tourne(nt)
>
> La config du Xorg donnée est très bien, j'ai en Xorg.conf pour un
> dual-screen si tu le souhaites.
>
> Pour compiz, problème. Lors de ma dernière mise à jour, j'avais un
> problème avec kde et kdeinit qui ne voulaient plus démarrer. Un
> "dist-upgrade" hier m'a fait retrouver un kde opérationnel. Mais,
> compiz-fusion (dépôt tuxfamilly) ne veut pas s'installer à cause
> d'une libwnck18 (de tête) qui n'existe plus dans Lenny (remplacé par
> la libwnck20). Cette lib est utilisée par emerald qui est utilisée
> par compiz-fusion. Maintenant, je n'ai pas essayé le compiz des
> dépots debian. Ce n'est pas compiz-fusion mais il marchera peut-être
> mieux.
>
> Voilà !
>
> > -----Message d'origine-----
> > De : [hidden email] [mailto:[hidden email]] De la
> > part de fabrice régnier
> > Envoyé : samedi 3 novembre 2007 15:11
> > À : [hidden email]
> > Objet : Re: XOrg.conf avec une ATI Mobility Radeon X600
> >
> > salut,
> >
> > fabricer@FR-PORT:~$ lspci | grep ATI
> > 01:00.0 VGA compatible controller: ATI Technologies Inc
> > Radeon Mobility X700 (PCIE)
> >
> > fabricer@FR-PORT:~$ fglrxinfo
> > display: :0.0  screen: 0
> > OpenGL vendor string: ATI Technologies Inc.
> > OpenGL renderer string: ATI MOBILITY RADEON X700 OpenGL
> > version string: 2.0.6747 (8.40.4)
> >
> > fabricer@FR-PORT:~$ dpkg -al| grep fglrx ii  fglrx-control
> > 8.40.4-2 ii  fglrx-driver 8.40.4-2 ii  fglrx-driver-dev
> > 8.40.4-2 ii  fglrx-kernel-2.6.22-2-686 ii  fglrx-kernel-src
> >
> > construction du module fglrx avec module-assistant
> >
> > fabricer@FR-PORT:~$ cat /etc/X11/xorg.conf Section "ServerLayout"
> >          Identifier     "Default Layout"
> >          Screen         "Default Screen" 0 0
> >          InputDevice    "Generic Keyboard"
> >          InputDevice    "Configured Mouse"
> >          InputDevice    "Synaptics Touchpad"
> > EndSection
> >
> > Section "ServerFlags"
> >          Option      "AIGLX" "off"
> > EndSection
> >
> > Section "InputDevice"
> >          Identifier  "Generic Keyboard"
> >          Driver      "kbd"
> >          Option      "CoreKeyboard"
> >          Option      "XkbRules" "xorg"
> >          Option      "XkbModel" "pc105"
> >          Option      "XkbLayout" "fr"
> > EndSection
> >
> > Section "InputDevice"
> >          Identifier  "Configured Mouse"
> >          Driver      "mouse"
> >          Option      "CorePointer"
> >          Option      "Device" "/dev/input/mice"
> >          Option      "Protocol" "ImPS/2"
> > EndSection
> >
> > Section "InputDevice"
> >          Identifier  "Synaptics Touchpad"
> >          Driver      "synaptics"
> >          Option      "SendCoreEvents" "true"
> >          Option      "Device" "/dev/psaux"
> >          Option      "Protocol" "auto-dev"
> >          Option      "HorizScrollDelta" "0"
> > EndSection
> >
> > Section "Monitor"
> >          Identifier   "Écran générique"
> >          HorizSync    30.0 - 70.0
> >          VertRefresh  50.0 - 160.0
> >          Option      "DPMS"
> > EndSection
> >
> > Section "Device"
> >          Identifier  "ATI Technologies Inc Radeon Mobility
> > X700 (PCIE)"
> >          Driver      "fglrx"
> >          Option      "TVFormat" "PAL-N"
> >          BusID       "PCI:1:0:0"
> > EndSection
> >
> > Section "Screen"
> >          Identifier "Default Screen"
> >          Device     "ATI Technologies Inc Radeon Mobility X700
> > (PCIE)" Monitor    "Écran générique"
> >          DefaultDepth     24
> >          SubSection "Display"
> >                  Modes    "1280x800" "800x600"
> >          EndSubSection
> > EndSection
> >
> > Section "DRI"
> >          Mode         0666
> > EndSection
> >
> > Section "Extensions"
> >          Option      "Composite" "Disable"
> >          Option      "RENDER" "Enable"
> > EndSection
> >
> >
> > fabricer@FR-PORT:~$ glxinfo | grep direct direct rendering: Yes
> >
> > euh quoi d'autre ?
> >
> > Si je me rappelle bien, pour faire tourner compiz, il faut
> > utiliser le driver libre plutôt que fglrx.
> >
> > En espèrant que ça aide ;)
> >
> > a+
> >
> > f.
> >
> >
> > David BERCOT wrote:
> > > Bonjour,
> > >
> > > Bon, avant de régler mon problème Compiz, il faudrait
> > d'abord que ma
> > > carte graphique marche correctement. Et là, ce n'est pas le
> > > cas ;-)
> > >
> > > J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de
> > > passer
> > > 2 heures à faire plein d'essais : drivers de base, drivers
> > proprio ATI
> > > (v8.42.3 téléchargé depuis chez eux), drivers fglrx, sans
> > > succès !!! Je fais des modifications dans la section "Module",
> > > etc..., etc..., sans résultat. J'ai toujours :
> > > glxinfo | grep direct
> > > direct rendering: No (If you want to find out why, try setting
> > > LIBGL_DEBUG=verbose)
> > >
> > > Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
> > > secondes ?
> > >
> > > Merci d'avance.
> > >
> > > David.
> >
> >
> > --
> > Lisez la FAQ de la liste avant de poser une question :
> > http://wiki.debian.net/?DebianFrench   
> > Vous pouvez aussi ajouter le mot ``spam'' dans vos champs
> > "From" et "Reply-To:"
> >
> > To UNSUBSCRIBE, email to [hidden email]
> > with a subject of "unsubscribe". Trouble? Contact
> > [hidden email]
> >
> >
>
>

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Compiz : j'attends d'être en NVidia [Re: XOrg.conf avec une ATI Mobility Radeon X600]

Geoffroy Youri-2
David BERCOT a écrit :
> Bonjour,
>
> Finalement, tout roule aussi correctement avec les drivers proprio.
> J'ai bien l'accélération activée... Maintenant, pour Compiz, je
> n'arrive vraiment à rien (même s'il est installé).
>
> Je viens rapidement de mettre Ubuntu sur mon portable (en dual boot, à
> la place de XP), et ça ne donne rien de plus. Visiblement, avec ATI,
> c'est pas trop ça...
Il me semble que fglrx ne gère pas AIGLX qui est nécessaire pour faire
tourner compiz. Ceci dit cela vient de changer récemment et la nouvelle
version de fglrx sur sid (v8.42) supporte désormais AIGLX [0]

> Tant pis, je vais rester en mode "pas d'effet de la mort" ;-)

Tu vas donc pouvoir épater les collègues :)

geoffroy

[0]
http://packages.debian.org/changelogs/pool/non-free/f/fglrx-driver/fglrx-driver_8.42.3-2/changelog#versionversion8.42.3-1


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench   
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Compiz : j'attends d'être en NVidia [Re: XOrg.conf avec une ATI Mobility Radeon X600]

Guillaume Coeugnet
Hello,

Hier soir, je me suis relancé dans ma quête de compiz et c'est aux environs
de 2h que ce dernier a "fonctionné". Je n'ai pas eu trop de problème pour en
arriver là.

Partant du fait que les derniers drivers propriétaires étaient bien
installés, il m'a fallu activer l'AIGLX et le Composite dans le xorg.conf.
Un redémarrage et un coup d'œil dans le Xorg.0.log m'ont apprit que l'AIGLX
était actif.
J'ai alors corrigé mon erreur dans le référencement du dépôt de tuxfamily
pour le faire pointer sur sid et non lenny (d'où mon problème avec la lib
libwnck18 qui n'existe plus dans sid). L'installation de compiz-fusion a pu
se faire.
J'ai constaté une erreur lors du démarrage de ce dernier ($ compiz.real
--replace) concernant du GLX non dispo. J'ai appris sur un forum que les
drivers ATI fonctionnaient mal avec xserver-xorg-core à la version 1.4. J'ai
downgradé ce package en 1.3 et après un démarrage de "compiz fusion icon",
tout a roulé.

Bilan, c'est amusant mais pas encore très stable ... Par moment des menus
contectuels s'affichent vides, la barre des tâches cafouillent lorsque l'on
joue trop avec les changements de bureaux virtuels. Il y a de nombreux lags,
on ne voit par moment que la fin de certains effets. Par contre, j'aime bien
la neige sur le bureau à l'approche de Noël :)

Je suis donc arrivé à mes fins, çà fonctionne mais avec pas mal de
difficultés, il faut espérer que çà changera avec la future version du
driver ATI. Je souhaites voir mainant s'il est possible de faire du compiz
avec un dual screen ...


> -----Message d'origine-----
> De : geoffroy [mailto:[hidden email]]
> Envoyé : mardi 6 novembre 2007 18:08
> À : debian-user-french
> Objet : Re: Compiz : j'attends d'être en NVidia [Re:
> XOrg.conf avec une ATI Mobility Radeon X600]
>
> David BERCOT a écrit :
> > Bonjour,
> >
> > Finalement, tout roule aussi correctement avec les drivers proprio.
> > J'ai bien l'accélération activée... Maintenant, pour Compiz, je
> > n'arrive vraiment à rien (même s'il est installé).
> >
> > Je viens rapidement de mettre Ubuntu sur mon portable (en
> dual boot, à
> > la place de XP), et ça ne donne rien de plus. Visiblement,
> avec ATI,
> > c'est pas trop ça...
> Il me semble que fglrx ne gère pas AIGLX qui est nécessaire
> pour faire tourner compiz. Ceci dit cela vient de changer
> récemment et la nouvelle version de fglrx sur sid (v8.42)
> supporte désormais AIGLX [0]
>
> > Tant pis, je vais rester en mode "pas d'effet de la mort" ;-)
>
> Tu vas donc pouvoir épater les collègues :)
>
> geoffroy
>
> [0]
> http://packages.debian.org/changelogs/pool/non-free/f/fglrx-dr
iver/fglrx-driver_8.42.3-2/changelog#versionversion8.42.3-1

>
>
> --
> Lisez la FAQ de la liste avant de poser une question :
> http://wiki.debian.net/?DebianFrench   
> Vous pouvez aussi ajouter le mot ``spam'' dans vos champs
> "From" et "Reply-To:"
>
> To UNSUBSCRIBE, email to [hidden email]
> with a subject of "unsubscribe". Trouble? Contact
> [hidden email]
>
>