Xorg crash nach Upgrade Stretch -> Buster

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Xorg crash nach Upgrade Stretch -> Buster

Dirk Neumann-3
Liebe Debian-Benutzer,

nach dem Upgrade von Stretch auf Buster kommt es bei mir vor, dass xorg
hin und wieder abstürzt. In der Xorg.0.log finde ich dann:

[  1479.482] (EE) glamor0: GL error: GL_OUT_OF_MEMORY in glTexSubImage
[  1479.483] (WW) glamor: Failed to allocate 6x6 FBO due to GL_OUT_OF_MEMORY.
[  1479.483] (WW) glamor: Expect reduced performance.
[  1479.483] (EE)
[  1479.483] (EE) Backtrace:
[  1479.493] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x55c90ab212c9]
[  1479.494] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x50) [0x7f9d3496a77f]
[  1479.494] (EE) 2: /usr/lib/xorg/modules/libglamoregl.so (glamor_get_pixmap_texture+0x7d) [0x7f9d338ea47d]
[  1479.494] (EE) 3: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x7c18) [0x7f9d338fcbc8]
[  1479.495] (EE) 4: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x804c) [0x7f9d338fd36c]
[  1479.495] (EE) 5: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x865e) [0x7f9d338fdb0e]
[  1479.496] (EE) 6: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0xa6a6) [0x7f9d33901806]
[  1479.496] (EE) 7: /usr/lib/xorg/Xorg (DamageRegionAppend+0x6af) [0x55c90aaa35af]
[  1479.496] (EE) 8: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x1157e) [0x7f9d3390fc9e]
[  1479.496] (EE) 9: /usr/lib/xorg/Xorg (AddTraps+0x41a5) [0x55c90aa9bec5]
[  1479.497] (EE) 10: /usr/lib/xorg/Xorg (SendErrorToClient+0x35e) [0x55c90a9c29ce]
[  1479.497] (EE) 11: /usr/lib/xorg/Xorg (InitFonts+0x3b6) [0x55c90a9c6956]
[  1479.497] (EE) 12: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xeb) [0x7f9d347b409b]
[  1479.498] (EE) 13: /usr/lib/xorg/Xorg (_start+0x2a) [0x55c90a9b067a]
[  1479.498] (EE)
[  1479.498] (EE) Segmentation fault at address 0x0
[  1479.498] (EE)
Fatal server error:
[  1479.498] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  1479.498] (EE)
[  1479.498] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  1479.498] (EE) Please also check the log file at "/home/dirk/.local/share/xorg/Xorg.0.log" for additional information.
[  1479.498] (EE)
[  1479.498] (II) AIGLX: Suspending AIGLX clients for VT switch
[  1479.507] (EE) Server terminated with error (1). Closing log file.

Die erste Zeile lässt mich schließen, dass ein Speicherbereich zu knapp bemessen ist.
Kann ich das irgendwo konfigurieren?
Ich starte X von der Textconsole mittels startx.
Als Grafiktreiber wird nouveau verwendet


Viele Grüße,

Dirk.

Reply | Threaded
Open this post in threaded view
|

Re: Xorg crash nach Upgrade Stretch -> Buster

Sven Joachim
Am 07.01.2020 um 17:10 schrieb Dirk Neumann:

> Liebe Debian-Benutzer,
>
> nach dem Upgrade von Stretch auf Buster kommt es bei mir vor, dass xorg
> hin und wieder abstürzt. In der Xorg.0.log finde ich dann:
>
> [  1479.482] (EE) glamor0: GL error: GL_OUT_OF_MEMORY in glTexSubImage
> [  1479.483] (WW) glamor: Failed to allocate 6x6 FBO due to GL_OUT_OF_MEMORY.
> [  1479.483] (WW) glamor: Expect reduced performance.
> [  1479.483] (EE)
> [  1479.483] (EE) Backtrace:
> [  1479.493] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x55c90ab212c9]
> [  1479.494] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x50) [0x7f9d3496a77f]
> [  1479.494] (EE) 2: /usr/lib/xorg/modules/libglamoregl.so (glamor_get_pixmap_texture+0x7d) [0x7f9d338ea47d]
> [  1479.494] (EE) 3: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x7c18) [0x7f9d338fcbc8]
> [  1479.495] (EE) 4: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x804c) [0x7f9d338fd36c]
> [  1479.495] (EE) 5: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x865e) [0x7f9d338fdb0e]
> [  1479.496] (EE) 6: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0xa6a6) [0x7f9d33901806]
> [  1479.496] (EE) 7: /usr/lib/xorg/Xorg (DamageRegionAppend+0x6af) [0x55c90aaa35af]
> [  1479.496] (EE) 8: /usr/lib/xorg/modules/libglamoregl.so (glamor_create_gc+0x1157e) [0x7f9d3390fc9e]
> [  1479.496] (EE) 9: /usr/lib/xorg/Xorg (AddTraps+0x41a5) [0x55c90aa9bec5]
> [  1479.497] (EE) 10: /usr/lib/xorg/Xorg (SendErrorToClient+0x35e) [0x55c90a9c29ce]
> [  1479.497] (EE) 11: /usr/lib/xorg/Xorg (InitFonts+0x3b6) [0x55c90a9c6956]
> [  1479.497] (EE) 12: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xeb) [0x7f9d347b409b]
> [  1479.498] (EE) 13: /usr/lib/xorg/Xorg (_start+0x2a) [0x55c90a9b067a]
> [  1479.498] (EE)
> [  1479.498] (EE) Segmentation fault at address 0x0
> [  1479.498] (EE)
> Fatal server error:
> [  1479.498] (EE) Caught signal 11 (Segmentation fault). Server aborting
> [  1479.498] (EE)
> [  1479.498] (EE)
> Please consult the The X.Org Foundation support
>          at http://wiki.x.org
>  for help.
> [  1479.498] (EE) Please also check the log file at "/home/dirk/.local/share/xorg/Xorg.0.log" for additional information.
> [  1479.498] (EE)
> [  1479.498] (II) AIGLX: Suspending AIGLX clients for VT switch
> [  1479.507] (EE) Server terminated with error (1). Closing log file.
>
> Die erste Zeile lässt mich schließen, dass ein Speicherbereich zu knapp bemessen ist.

Nee, das ist ein Speicherleck.  Siehe zum Beispiel:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943893
https://bugs.freedesktop.org/show_bug.cgi?id=110714

> Kann ich das irgendwo konfigurieren?
> Ich starte X von der Textconsole mittels startx.
> Als Grafiktreiber wird nouveau verwendet

Versuch es mal mit dieser /etc/X11/xorg.conf:

--8<---------------cut here---------------start------------->8---
Section "Device"
        Identifier "n"
        Driver "nouveau"
EndSection
--8<---------------cut here---------------end--------------->8---

Der X-Server in Buster verwendet standardmäßig den modesetting-Treiber
für Nvidiakarten, das ist ein aus Fedora stammender zweifelhafter Patch.
Die obige xorg.conf sorgt dafür, dass stattdessen wieder nouveau zum
Zuge kommt, nach meiner Erfahrung funktioniert der besser.

Viel Glück,
Sven

Reply | Threaded
Open this post in threaded view
|

Re: [solved] Xorg crash nach Upgrade Stretch -> Buster

Dirk Neumann-3
On Tue, 07 Jan 2020 20:40:08 +0100
Sven Joachim <[hidden email]> wrote:

> Versuch es mal mit dieser /etc/X11/xorg.conf:
>
> --8<---------------cut here---------------start------------->8---
> Section "Device"
> Identifier "n"
> Driver "nouveau"
> EndSection
> --8<---------------cut here---------------end--------------->8---

Vielen Dank! Ich hab das jetzt einen Tag so laufen gelassen. Es ist
kein Absturz mehr aufgetreten.


Gruß,

Dirk Neumann