apache2.sevice

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

apache2.sevice

linus.reinholz
Hallo Liste,
Ich habe mir ein Webinterface mit Apache2 eingerichtet, nur seit neusten kann ich Apache2 nicht mehr mit "systemctl start apache2" starten. Hat jemand von euch eine Ahnung woran das liegen kann.
Bei "systemctl status apache2" kommt folgender Output:
● apache2.service - The Apache HTTP Server
     Loaded: loaded (/lib/systemd/system/apache2.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Tue 2020-03-24 16:45:40 CET; 34s ago
    Process: 6835 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
Grüße Linus

Reply | Threaded
Open this post in threaded view
|

Re: apache2.sevice

S. Kremer
Hi,

versuche mal folgendes:

sudo systemctl enable apache2 oder nur systemctl enable apache2

anschließend

sudo service apache2 start oder nur service apache2 start

started apache dann?


--- Original Nachricht ---
Betreff: apache2.sevice
Von: [hidden email]
An: "[hidden email]" <[hidden email]>
Datum: 24-03-2020 16:50



Hallo Liste,
Ich habe mir ein Webinterface mit Apache2 eingerichtet, nur seit neusten kann ich Apache2 nicht mehr mit "systemctl start apache2" starten. Hat jemand von euch eine Ahnung woran das liegen kann.
Bei "systemctl status apache2" kommt folgender Output:
● apache2.service - The Apache HTTP Server
     Loaded: loaded (/lib/systemd/system/apache2.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Tue 2020-03-24 16:45:40 CET; 34s ago
    Process: 6835 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
Grüße Linus


logo_ik.png (11K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: apache2.sevice

Harald Weidner
In reply to this post by linus.reinholz
Hallo,


> Ich habe mir ein Webinterface mit Apache2 eingerichtet, nur seit neusten
> kann ich Apache2 nicht mehr mit "systemctl start apache2" starten. Hat
> jemand von euch eine Ahnung woran das liegen kann.

Vermutlich an einem Fehler in den Konfigurationsdateien?

> Bei "systemctl status apache2" kommt folgender Output:
>
> > ● apache2.service - The Apache HTTP Server
> >      Loaded: loaded (/lib/systemd/system/apache2.service; disabled; vendor preset: disabled)
> >      Active: failed (Result: exit-code) since Tue 2020-03-24 16:45:40 CET; 34s ago
> >        Docs: https://httpd.apache.org/docs/2.4/
> >     Process: 6835 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

Wenn der Apache wenigstens halbwegs sauber konfiguriert ist, solltest du im
Error-Log (Default: /var/log/apache2/error.log) eine Fehlermeldung finden.

Manchmal ist auch ein "journalctl -xu apache2.service" hilfreich.

Gruß, Harald

Reply | Threaded
Open this post in threaded view
|

Re: apache2.sevice

Sven Hartge-5
Harald Weidner <[hidden email]> wrote:

>> Ich habe mir ein Webinterface mit Apache2 eingerichtet, nur seit neusten
>> kann ich Apache2 nicht mehr mit "systemctl start apache2" starten. Hat
>> jemand von euch eine Ahnung woran das liegen kann.

> Vermutlich an einem Fehler in den Konfigurationsdateien?

>> Bei "systemctl status apache2" kommt folgender Output:
>>
>>> ● apache2.service - The Apache HTTP Server
>>>      Loaded: loaded (/lib/systemd/system/apache2.service; disabled; vendor preset: disabled)
>>>      Active: failed (Result: exit-code) since Tue 2020-03-24 16:45:40 CET; 34s ago
>>>        Docs: https://httpd.apache.org/docs/2.4/
>>>     Process: 6835 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

> Wenn der Apache wenigstens halbwegs sauber konfiguriert ist, solltest du im
> Error-Log (Default: /var/log/apache2/error.log) eine Fehlermeldung finden.

> Manchmal ist auch ein "journalctl -xu apache2.service" hilfreich.

Und "apachectl configtest".

S!

--
Sigmentation fault. Core dumped.