auto unlock fails

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

auto unlock fails

Walter Valenti
Package: libpam-kwallet5
Version: 5.14.3-1

Architecture: amd64

Hi,
on Debian testing (buster) the unlock of kwallet5 via pam fails.
I use lightdm as display manager.

I've added in /etc/pam.d/lightdm
auth  optional pam_kwallet5.so
session optional pam_kwallet5.so auto_start

After login there is in the logs:
on ~/.xsession-errors
2019/01/17 10:57:10 socat[3205] E connect(5, AF=1 "/run/user/1000/kwallet5.socket", 32): Connection refused
I've tried to exec /usr/share/libpam-kwallet-common/pam_kwallet_init and i obtain the same error.

on /var/log/syslog
Jan 17 09:57:17 valx lightdm: pam_kwallet5: final socket path: /run/user/1000/kwallet5.socket
Jan 17 09:57:17 valx lightdm: pam_kwallet5-kwalletd: Couldn't listen in socket

I've tried to add my user in lightdm group but doesn't work.
uid=1000(walter) gid=1000(walter) gruppi=1000(walter),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),108(netdev),111(lightdm)

Thanks