bin NMUs for the 8 evolution-data-server package name changes

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

bin NMUs for the 8 evolution-data-server package name changes

Loïc Minier
        Hi,

 evolution-data-server is unstable changes a total of 8 package names:

 old name/SONAME                new name/SONAME
 ===============                ===============
 libcamel1.2-8                  libcamel1.2-10
 libebook1.2-5                  libebook1.2-9
 libecal1.2-6                   libecal1.2-7
 libedata-cal1.2-5              libedata-cal1.2-6
 libedataserver1.2-7            libedataserver1.2-9
 libedataserverui1.2-6          libedataserverui1.2-8
 libegroupwise1.2-10            libegroupwise1.2-13
 libexchange-storage1.2-1       libexchange-storage1.2-3

 Could you please bin NMU the following source/version couples
 dep-waiting on the listed binaires:
 - contact-lookup-applet/0.15-1:
        libebook1.2-9, libedataserver1.2-9
 - contacts/0.5-1:
        libebook1.2-9
 - dates/0.4.1-1:
        libecal1.2-7, libedataserver1.2-9
 - deskbar-applet/2.14.2-4.2:
        libebook1.2-9, libedataserver1.2-9
 - ekiga/2.0.3-6:
        libebook1.2-9, libedataserver1.2-9
 - evolution-exchange/2.6.3.dfsg-1:
        libcamel1.2-10, libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
        libedataserver1.2-9, libedataserverui1.2-8,
        libexchange-storage1.2-3
 - evolution-jescs/2.6.4-2:
        libcamel1.2-10, libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
        libedataserver1.2-9, libedataserverui1.2-8
 - evolution-sharp/0.11.1-3:
        libebook1.2-9, libecal1.2-7, libedataserver1.2-9
 - evolution-webcal/2.6.0-1:
        libecal1.2-7, libedataserver1.2-9
 - galago-eds-feed/0.5.0-3:
        libebook1.2-9, libedataserver1.2-9
 - glabels/2.1.3-1:
        libebook1.2-9
 - gnome-panel/2.18.1-1:
        libebook1.2-9, libecal1.2-7, libedataserver1.2-9,
        libedataserverui1.2-8
 - hdate-applet/0.15.6-5:
        libecal1.2-7, libedataserver1.2-9
 - libopensync-plugin-evolution2/0.19-1:
        libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
        libedataserver1.2-9
 - librevolution-ruby/0.5-6:
        libebook1.2-9, libecal1.2-7, libedataserver1.2-9
 - mail-notification/4.0.dfsg.1-1:
        libedataserver1.2-9
 - multisync/0.82-8:
        libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
        libedataserver1.2-9
 - tasks/0.4-1:
        libecal1.2-7


 Have fun!  :-P

--
Loïc Minier


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: bin NMUs for the 8 evolution-data-server package name changes

Loïc Minier
 So, I didn't think the Evo team would so quickly prepare the other
 three Evo modules, here are 3 updates:

On Wed, Apr 25, 2007, Loïc Minier wrote:
>  - evolution-exchange/2.6.3.dfsg-1:
>         libcamel1.2-10, libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
>         libedataserver1.2-9, libedataserverui1.2-8,
>         libexchange-storage1.2-3

 This should now be evolution-exchange/2.10.1-1 instead, the build-deps
 are not requiring the transitionned build-deps.

>  - evolution-jescs/2.6.4-2:
>         libcamel1.2-10, libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
>         libedataserver1.2-9, libedataserverui1.2-8

 bin NMU not needed any more: new upstream uploaded with sufficient
 build-deps.

>  - evolution-webcal/2.6.0-1:
>         libecal1.2-7, libedataserver1.2-9

 This should now be evolution-webcal/2.10.0-1 instead, the build-deps
 are not requiring the transitionned build-deps.

 Sorry for these inconveniences.

--
Loïc Minier


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: bin NMUs for the 8 evolution-data-server package name changes

Steve Langasek
In reply to this post by Loïc Minier
On Wed, Apr 25, 2007 at 10:19:38PM +0200, Loïc Minier wrote:
>  evolution-data-server is unstable changes a total of 8 package names:

>  old name/SONAME                new name/SONAME
>  ===============                ===============
>  libcamel1.2-8                  libcamel1.2-10
>  libebook1.2-5                  libebook1.2-9
>  libecal1.2-6                   libecal1.2-7
>  libedata-cal1.2-5              libedata-cal1.2-6
>  libedataserver1.2-7            libedataserver1.2-9
>  libedataserverui1.2-6          libedataserverui1.2-8
>  libegroupwise1.2-10            libegroupwise1.2-13
>  libexchange-storage1.2-1       libexchange-storage1.2-3

>  Could you please bin NMU the following source/version couples
>  dep-waiting on the listed binaires:

BinNMUs scheduled for all relevant reverse-dependencies.  FWIW, it appears
the new version of 'bug-buddy' depends on libebook without a versioned
build-dep, so I've added it to the list.


>  - contact-lookup-applet/0.15-1:
>         libebook1.2-9, libedataserver1.2-9
>  - contacts/0.5-1:
>         libebook1.2-9

0.5-2 was uploaded with a versioned build-dep

>  - dates/0.4.1-1:
>         libecal1.2-7, libedataserver1.2-9

0.4.1-2 was uploaded with a versioned build-dep

>  - deskbar-applet/2.14.2-4.2:
>         libebook1.2-9, libedataserver1.2-9
>  - ekiga/2.0.3-6:
>         libebook1.2-9, libedataserver1.2-9
>  - evolution-exchange/2.6.3.dfsg-1:
>         libcamel1.2-10, libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
>         libedataserver1.2-9, libedataserverui1.2-8,
>         libexchange-storage1.2-3
>  - evolution-jescs/2.6.4-2:
>         libcamel1.2-10, libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
>         libedataserver1.2-9, libedataserverui1.2-8
>  - evolution-sharp/0.11.1-3:
>         libebook1.2-9, libecal1.2-7, libedataserver1.2-9
>  - evolution-webcal/2.6.0-1:
>         libecal1.2-7, libedataserver1.2-9
>  - galago-eds-feed/0.5.0-3:
>         libebook1.2-9, libedataserver1.2-9

source package name is eds-feed

>  - glabels/2.1.3-1:
>         libebook1.2-9
>  - gnome-panel/2.18.1-1:
>         libebook1.2-9, libecal1.2-7, libedataserver1.2-9,
>         libedataserverui1.2-8
>  - hdate-applet/0.15.6-5:
>         libecal1.2-7, libedataserver1.2-9
>  - libopensync-plugin-evolution2/0.19-1:
>         libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
>         libedataserver1.2-9
>  - librevolution-ruby/0.5-6:
>         libebook1.2-9, libecal1.2-7, libedataserver1.2-9
>  - mail-notification/4.0.dfsg.1-1:
>         libedataserver1.2-9
>  - multisync/0.82-8:
>         libebook1.2-9, libecal1.2-7, libedata-cal1.2-6,
>         libedataserver1.2-9
>  - tasks/0.4-1:
>         libecal1.2-7

Cheers,
--
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
[hidden email]                                   http://www.debian.org/


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]