(deb-cat) Programari Java amb Firefox 60

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

(deb-cat) Programari Java amb Firefox 60

Narcis Garcia-3
Les administracions públiques d'arreu comencen a integrar bastant les
gestions telemàtiques amb certificat digital, DNI electrònic, etc.
En el cas de les administracions a Catalunya (començant per la
Generalitat), el què més fan és externalitzar el desenvolupament de tot
això a empreses que se solen enfocar a Java, i que no solen contemplar
una altra plataforma que no sigui Microsoft Windows.

Sorprenent és que l'únic sistema operatiu (que jo sàpiga) que
desenvolupa i distribueix la Generalitat és el Linkat, amb la qual cosa
hi ha una gegantina contradicció amb l'exclusió dels usuaris de
programari lliure.

Al gra: Des de M.Firefox 52 que els connectors de tipus «NPAPI» ja no
són suportats, entre els quals hi ha el icedtea-plugin
Als repositoris (main) de Debian estable hi ha l'anomalia de què entren
les noves versions de programari Mozilla, amb la qual cosa també entren
els nous problemes com aquest: que ja anem pel Firefox 60 i aquest no
admet el icedtea-plugin del mateix repositori.

Algú coneix la solució?

Gràcies.

--


__________
I'm using this express-made address because personal addresses aren't
masked enough at this mail public archive. Public archive administrator
should fix this against automated addresses collectors.

Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Jordi Funollet Pujol-2
Crec que el Firefox ESR (Extended Support Release) encara té habilitats els NPAPI.

https://www.mozilla.org/en-US/firefox/organizations/

--
Jordi Funollet Pujol
http://www.linkedin.com/in/jordifunollet

On Mon, Oct 22, 2018, at 3:16 PM, Narcis Garcia wrote:

> Les administracions públiques d'arreu comencen a integrar bastant les
> gestions telemàtiques amb certificat digital, DNI electrònic, etc.
> En el cas de les administracions a Catalunya (començant per la
> Generalitat), el què més fan és externalitzar el desenvolupament de tot
> això a empreses que se solen enfocar a Java, i que no solen contemplar
> una altra plataforma que no sigui Microsoft Windows.
>
> Sorprenent és que l'únic sistema operatiu (que jo sàpiga) que
> desenvolupa i distribueix la Generalitat és el Linkat, amb la qual cosa
> hi ha una gegantina contradicció amb l'exclusió dels usuaris de
> programari lliure.
>
> Al gra: Des de M.Firefox 52 que els connectors de tipus «NPAPI» ja no
> són suportats, entre els quals hi ha el icedtea-plugin
> Als repositoris (main) de Debian estable hi ha l'anomalia de què entren
> les noves versions de programari Mozilla, amb la qual cosa també entren
> els nous problemes com aquest: que ja anem pel Firefox 60 i aquest no
> admet el icedtea-plugin del mateix repositori.
>
> Algú coneix la solució?
>
> Gràcies.
>
> --
>
>
> __________
> I'm using this express-made address because personal addresses aren't
> masked enough at this mail public archive. Public archive administrator
> should fix this against automated addresses collectors.
>

Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Alex Muntada-2
In reply to this post by Narcis Garcia-3
Hola Narcis,

> Als repositoris (main) de Debian estable hi ha l'anomalia de què entren
> les noves versions de programari Mozilla, amb la qual cosa també entren
> els nous problemes com aquest: que ja anem pel Firefox 60 i aquest no
> admet el icedtea-plugin del mateix repositori.
>
> Algú coneix la solució?

Jo he aconseguit sortir-me'n algun cop descarregant el fitxer
amb extensió .jnlp i executant-lo després des del terminal
amb javaws. Això em permet obrir consoles remotes amb IPMI i
DRAC encara que el navegador no suporti el plugin, per exemple.

Salut,
Alex

--
  ⢀⣴⠾⠻⢶⣦⠀
  ⣾⠁⢠⠒⠀⣿⡁  Alex Muntada <[hidden email]>
  ⢿⡄⠘⠷⠚⠋   Debian Developer - log.alexm.org
  ⠈⠳⣄⠀⠀⠀⠀


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Narcis Garcia-3
In reply to this post by Jordi Funollet Pujol-2
Mozilla ja va anunciar la fi del NPAPI:
https://support.mozilla.org/en-US/kb/npapi-plugins

Tot i això, concretament a la versió 52 (i no posteriors) encara es pot
rehabilitar la compatibilitat amb l'opció plugin.load_flash_only=false

Per aquests casos en què les subcontractes de les administracions
públiques demanen Java, utilitzaré Icecat versió 52 (que es pot
instal·lar amb els paquets de Trisquel), i així puc admetre les
(indegudes) actualitzacions de M.Firefox.

Imagino que tot això es resoldria si els desenvolupadors del
icedtea-plugin adaptessin el projecte a la nova interfície interna de
complements de Mozilla.

__________
I'm using this express-made address because personal addresses aren't
masked enough at this mail public archive. Public archive administrator
should fix this against automated addresses collectors.
El 22/10/18 a les 15:44, Jordi Funollet ha escrit:

> Crec que el Firefox ESR (Extended Support Release) encara té habilitats els NPAPI.
>
> https://www.mozilla.org/en-US/firefox/organizations/
>
> --
> Jordi Funollet Pujol
> http://www.linkedin.com/in/jordifunollet
>
> On Mon, Oct 22, 2018, at 3:16 PM, Narcis Garcia wrote:
>> Les administracions públiques d'arreu comencen a integrar bastant les
>> gestions telemàtiques amb certificat digital, DNI electrònic, etc.
>> En el cas de les administracions a Catalunya (començant per la
>> Generalitat), el què més fan és externalitzar el desenvolupament de tot
>> això a empreses que se solen enfocar a Java, i que no solen contemplar
>> una altra plataforma que no sigui Microsoft Windows.
>>
>> Sorprenent és que l'únic sistema operatiu (que jo sàpiga) que
>> desenvolupa i distribueix la Generalitat és el Linkat, amb la qual cosa
>> hi ha una gegantina contradicció amb l'exclusió dels usuaris de
>> programari lliure.
>>
>> Al gra: Des de M.Firefox 52 que els connectors de tipus «NPAPI» ja no
>> són suportats, entre els quals hi ha el icedtea-plugin
>> Als repositoris (main) de Debian estable hi ha l'anomalia de què entren
>> les noves versions de programari Mozilla, amb la qual cosa també entren
>> els nous problemes com aquest: que ja anem pel Firefox 60 i aquest no
>> admet el icedtea-plugin del mateix repositori.
>>
>> Algú coneix la solució?
>>
>> Gràcies.
>>
>> --
>>
>>
>> __________
>> I'm using this express-made address because personal addresses aren't
>> masked enough at this mail public archive. Public archive administrator
>> should fix this against automated addresses collectors.
>>
>

Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Jordi Mallach
El dc. 24 de 10 de 2018 a les 09:59 +0200, en/na Narcis Garcia va
escriure:
> Per aquests casos en què les subcontractes de les administracions
> públiques demanen Java, utilitzaré Icecat versió 52 (que es pot
> instal·lar amb els paquets de Trisquel), i així puc admetre les
> (indegudes) actualitzacions de M.Firefox.

Indegudes?!

Per què indegudes? Quina és l'alternativa?

--
Jordi Mallach Pérez  -- Debian developer  https://www.debian.org/
[hidden email]    [hidden email]  https://www.sindominio.net/
GnuPG public key information available at https://oskuro.net/


Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Narcis Garcia-3
__________
I'm using this express-made address because personal addresses aren't
masked enough at this mail public archive. Public archive administrator
should fix this against automated addresses collectors.
El 30/10/18 a les 10:18, Jordi Mallach ha escrit:

> El dc. 24 de 10 de 2018 a les 09:59 +0200, en/na Narcis Garcia va
> escriure:
>> Per aquests casos en què les subcontractes de les administracions
>> públiques demanen Java, utilitzaré Icecat versió 52 (que es pot
>> instal·lar amb els paquets de Trisquel), i així puc admetre les
>> (indegudes) actualitzacions de M.Firefox.
>
> Indegudes?!
>
> Per què indegudes? Quina és l'alternativa?
>

Les crec indegudes perquè precisament provoquen el problema que es volia
evitar creant una distribució estable amb el sistema de versions de Debian.
Com és que LibreOffice segueix a la versió 5 als repositoris de la
Debian 9 (stable)? I el paquet de controladors d'impressora HPLIP?
Jo sempre he entès que aquesta política de manteniment de versions del
programari fa que la versió estable de Debian quasi mai no empitjori,
sinó que sempre millori, ja que no s'introdueixen noves incoherències
entre paquets, com és el cas.

«L'alternativa», que en realitat és la normalitat, és que les noves
versions de programari vagin a la propera versió de Debian i, si les
persones que fan paquets ho veuen convenient, que les introdueixin al
repositori «backports» que està pensat per disposar a la versió actual
excepcionalment de programari de properes versions.

Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Joan
Suposo que l'equilibri és complicat... En el món web, com que les coses
evolucionen tant ràpid, les versions antigues d'un navegador de fa 2
anys de vegades portaven problemes (jo n'havia patit alguns). Però com
que sempre pots tenir el Chrome, etc. si no era amb un, feies amb
l'altre...

Diria que el canvi Debian el va fer aprofitant les versions ESR de la
pròpia Mozilla, no? Vaja, buscant aprofitar la feina que feia Mozilla a
nivell de seguretat, i acompassar-se a ella...

El que no sé és si hi ha alternatives a usar el Firefox ESR, com fora
usar el Firefox "congelat". Potser una seria usar algun dels navegadors
que es basen molt en Firefox, com els de TOR i d'altres...

Però el que tu comentes, de congelar la versió de Firefox i si algú vol
les novetats, tirar de backports, doncs també era una bona opció,
potser algo menys estable perquè obligues a obrir el sistema a
backports, que mai serà tant estable com sense... I la pega afegida,
potser, de que els mantenidors del paquet de Firefox a Debian s'hagin de
currar les sol·lucions als forats de seguretat, sense aprofitar la
feina de Mozilla amb les ESR.

Joan Cervan

El Tue, 30 Oct 2018 10:31:47 +0100
Narcis Garcia <[hidden email]> va escriure:

> __________
> I'm using this express-made address because personal addresses aren't
> masked enough at this mail public archive. Public archive
> administrator should fix this against automated addresses collectors.
> El 30/10/18 a les 10:18, Jordi Mallach ha escrit:
> > El dc. 24 de 10 de 2018 a les 09:59 +0200, en/na Narcis Garcia va
> > escriure:  
> >> Per aquests casos en què les subcontractes de les administracions
> >> públiques demanen Java, utilitzaré Icecat versió 52 (que es pot
> >> instal·lar amb els paquets de Trisquel), i així puc admetre les
> >> (indegudes) actualitzacions de M.Firefox.  
> >
> > Indegudes?!
> >
> > Per què indegudes? Quina és l'alternativa?
> >  
>
> Les crec indegudes perquè precisament provoquen el problema que es
> volia evitar creant una distribució estable amb el sistema de
> versions de Debian. Com és que LibreOffice segueix a la versió 5 als
> repositoris de la Debian 9 (stable)? I el paquet de controladors
> d'impressora HPLIP? Jo sempre he entès que aquesta política de
> manteniment de versions del programari fa que la versió estable de
> Debian quasi mai no empitjori, sinó que sempre millori, ja que no
> s'introdueixen noves incoherències entre paquets, com és el cas.
>
> «L'alternativa», que en realitat és la normalitat, és que les noves
> versions de programari vagin a la propera versió de Debian i, si les
> persones que fan paquets ho veuen convenient, que les introdueixin al
> repositori «backports» que està pensat per disposar a la versió actual
> excepcionalment de programari de properes versions.
>



--
Joan Cervan i Andreu
http://personal.calbasi.net

"El meu paper no és transformar el món ni l'home sinó, potser, el de
ser útil, des del meu lloc, als pocs valors sense els quals un món no
val la pena viure'l" A. Camus

i pels que teniu fe:
"Déu no és la Veritat, la Veritat és Déu"
Gandhi

Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Jordi Mallach
Hola,

El dt. 30 de 10 de 2018 a les 12:26 +0100, en/na Joan va escriure:
> Però el que tu comentes, de congelar la versió de Firefox i si algú
> vol
> les novetats, tirar de backports, doncs també era una bona opció,
> potser algo menys estable perquè obligues a obrir el sistema a
> backports, que mai serà tant estable com sense... I la pega afegida,
> potser, de que els mantenidors del paquet de Firefox a Debian s'hagin
> de
> currar les sol·lucions als forats de seguretat, sense aprofitar la
> feina de Mozilla amb les ESR.

Joan ha donat en el clau: durant un temps, l'equip de seguretat
intentava fer backports, un a un, dels pedaços que resolien les
vulnerabilitats, però això era com feina per a 2 persones a temps
complet. Un navegador i els seus motors de renderització i de JS no són
precisament el programari més simple que hi ha a l'arxiu de Debian.
Senzillament no era possible. La única cosa raonable és seguir les
versions ESR de Firefox, o directament no donar suport de seguretat als
navegadores que s'inclouen amb Debian.

Si em donen a triar entre una versió insegura del programa que emprem
tots més sovint i a totes hores o sacrificar els applets de Java, jo ho
tinc clar.

--
Jordi Mallach Pérez  -- Debian developer  https://www.debian.org/
[hidden email]    [hidden email]  https://www.sindominio.net/
GnuPG public key information available at https://oskuro.net/


Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Joan
Per cert, el que no sé, perquè només us he llegit en diagonal allò dels
applets de java, és si aquests, per la nova versió de Firefox a Debian
estable, podrien incloure's via backports, per exemple... O potser fins
i tot s'instal·len manualment...

Fins ara,

Joan

El Wed, 31 Oct 2018 10:09:03 +0100
Jordi Mallach <[hidden email]> va escriure:

> Hola,
>
> El dt. 30 de 10 de 2018 a les 12:26 +0100, en/na Joan va escriure:
> > Però el que tu comentes, de congelar la versió de Firefox i si algú
> > vol
> > les novetats, tirar de backports, doncs també era una bona opció,
> > potser algo menys estable perquè obligues a obrir el sistema a
> > backports, que mai serà tant estable com sense... I la pega afegida,
> > potser, de que els mantenidors del paquet de Firefox a Debian
> > s'hagin de
> > currar les sol·lucions als forats de seguretat, sense aprofitar la
> > feina de Mozilla amb les ESR.  
>
> Joan ha donat en el clau: durant un temps, l'equip de seguretat
> intentava fer backports, un a un, dels pedaços que resolien les
> vulnerabilitats, però això era com feina per a 2 persones a temps
> complet. Un navegador i els seus motors de renderització i de JS no
> són precisament el programari més simple que hi ha a l'arxiu de
> Debian. Senzillament no era possible. La única cosa raonable és
> seguir les versions ESR de Firefox, o directament no donar suport de
> seguretat als navegadores que s'inclouen amb Debian.
>
> Si em donen a triar entre una versió insegura del programa que emprem
> tots més sovint i a totes hores o sacrificar els applets de Java, jo
> ho tinc clar.
>



--
Joan Cervan i Andreu
http://personal.calbasi.net

"El meu paper no és transformar el món ni l'home sinó, potser, el de
ser útil, des del meu lloc, als pocs valors sense els quals un món no
val la pena viure'l" A. Camus

i pels que teniu fe:
"Déu no és la Veritat, la Veritat és Déu"
Gandhi

Reply | Threaded
Open this post in threaded view
|

Re: (deb-cat) Programari Java amb Firefox 60

Joan
In reply to this post by Narcis Garcia-3
Per cert, el que no sé, perquè només us he llegit en diagonal allò dels
applets de java, és si aquests, per la nova versió de Firefox a Debian
estable, podrien incloure's via backports, per exemple... O potser fins
i tot s'instal·len manualment...

Fins ara,

Joan Cervan

El Wed, 31 Oct 2018 10:09:03 +0100
Jordi Mallach <[hidden email]> va escriure:

> Hola,
>
> El dt. 30 de 10 de 2018 a les 12:26 +0100, en/na Joan va escriure:  
> > Però el que tu comentes, de congelar la versió de Firefox i si algú
> > vol
> > les novetats, tirar de backports, doncs també era una bona opció,
> > potser algo menys estable perquè obligues a obrir el sistema a
> > backports, que mai serà tant estable com sense... I la pega afegida,
> > potser, de que els mantenidors del paquet de Firefox a Debian
> > s'hagin de
> > currar les sol·lucions als forats de seguretat, sense aprofitar la
> > feina de Mozilla amb les ESR.    
>
> Joan ha donat en el clau: durant un temps, l'equip de seguretat
> intentava fer backports, un a un, dels pedaços que resolien les
> vulnerabilitats, però això era com feina per a 2 persones a temps
> complet. Un navegador i els seus motors de renderització i de JS no
> són precisament el programari més simple que hi ha a l'arxiu de
> Debian. Senzillament no era possible. La única cosa raonable és
> seguir les versions ESR de Firefox, o directament no donar suport de
> seguretat als navegadores que s'inclouen amb Debian.
>
> Si em donen a triar entre una versió insegura del programa que emprem
> tots més sovint i a totes hores o sacrificar els applets de Java, jo
> ho tinc clar.
>  

--
Joan Cervan i Andreu
http://personal.calbasi.net

"El meu paper no és transformar el món ni l'home sinó, potser, el de
ser útil, des del meu lloc, als pocs valors sense els quals un món no
val la pena viure'l" A. Camus

i pels que teniu fe:
"Déu no és la Veritat, la Veritat és Déu"
Gandhi

Per cert, el que no sé, perquè només us he llegit en diagonal allò dels
applets de java, és si aquests, per la nova versió de Firefox a Debian
estable, podrien incloure's via backports, per exemple... O potser fins
i tot s'instal·len manualment...

Fins ara,

Joan

El Wed, 31 Oct 2018 10:09:03 +0100
Jordi Mallach <[hidden email]> va escriure:

> Hola,
>
> El dt. 30 de 10 de 2018 a les 12:26 +0100, en/na Joan va escriure:
> > Però el que tu comentes, de congelar la versió de Firefox i si algú
> > vol
> > les novetats, tirar de backports, doncs també era una bona opció,
> > potser algo menys estable perquè obligues a obrir el sistema a
> > backports, que mai serà tant estable com sense... I la pega afegida,
> > potser, de que els mantenidors del paquet de Firefox a Debian
> > s'hagin de
> > currar les sol·lucions als forats de seguretat, sense aprofitar la
> > feina de Mozilla amb les ESR.  
>
> Joan ha donat en el clau: durant un temps, l'equip de seguretat
> intentava fer backports, un a un, dels pedaços que resolien les
> vulnerabilitats, però això era com feina per a 2 persones a temps
> complet. Un navegador i els seus motors de renderització i de JS no
> són precisament el programari més simple que hi ha a l'arxiu de
> Debian. Senzillament no era possible. La única cosa raonable és
> seguir les versions ESR de Firefox, o directament no donar suport de
> seguretat als navegadores que s'inclouen amb Debian.
>
> Si em donen a triar entre una versió insegura del programa que emprem
> tots més sovint i a totes hores o sacrificar els applets de Java, jo
> ho tinc clar.
>


--
Joan Cervan i Andreu
http://personal.calbasi.net

"El meu paper no és transformar el món ni l'home sinó, potser, el de
ser útil, des del meu lloc, als pocs valors sense els quals un món no
val la pena viure'l" A. Camus

i pels que teniu fe:
"Déu no és la Veritat, la Veritat és Déu"
Gandhi

attachment0 (423 bytes) Download Attachment