debian CD issue / error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

debian CD issue / error

Mike Hosken-2
Hi Team,

I'm trying to make install CD media for buster HPPA.

I have compiled the debian-installer and installed it with no issues.

I have made changes to easybuild and CONF to suit.
when trying to build I'm getting this error. can anyone explain why so I
can fix it.

uname -a Linux atlantis 4.19.0-5-parisc64-smp #1 SMP Debian 4.19.37-3
(2019-05-15) parisc64 GNU/Linux

its this error

Can't open Packages file
/tmp/buster/CD1/dists/buster/main/binary-hppa/Packages : No such file or
directory


below is a grab from the terminal.

any help would be fantastic

Mike Hosken

Running sort_deps to sort packages for hppa:
   Generating dependency tree with apt-cache depends...
   Adding standard, required, important and base packages first
   S/R/I/B packages take 0 bytes
   Adding the rest of the requested packages
   Now up to 0 bytes
   COMPLETE=1; add all remaining packages
Done: processed/sorted 0 packages, total size 0 bytes.
if [ ""x = "yes"x ] ; then \
         /srv/d-i/debian-cd/tools/grab_source_list /tmp/buster /tmp/apt
/tmp/buster/list /tmp/buster/packages; \
else \
         /srv/d-i/debian-cd/tools/merge_package_lists /tmp/buster
/tmp/apt "hppa" /tmp/buster/packages; \
fi
if [ ""x = "yes"x ] ; then \
         grep ^source /tmp/buster/packages > /tmp/buster/packages.source;
\
fi
/srv/d-i/debian-cd/tools/make_disc_trees.pl /srv/d-i/debian-cd
/srv/debian /tmp buster "hppa" "xorriso" "-as mkisofs -r
-checksum_algorithm_iso md5,sha1 -jigdo-min-file-size 1024
-jigdo-exclude 'README*' -jigdo-exclude /doc/ -jigdo-exclude /md5sum.txt
-jigdo-exclude /.disk/ -jigdo-exclude /pics/ -jigdo-exclude 'Release*'
-jigdo-exclude 'Packages*' -jigdo-exclude 'Sources*' -jigdo-force-md5
/pool/"
xorriso 1.5.0 : RockRidge filesystem manipulator, libburnia project.

xorriso -version says:
xorriso 1.5.0
ISO 9660 Rock Ridge filesystem manipulator and CD/DVD/BD burn program
Copyright (C) 2017, Thomas Schmitt <[hidden email]>, libburnia
project.
xorriso version   :  1.5.0
Version timestamp :  2018.09.15.133001
Build timestamp   :  -none-given-
libisofs   in use :  1.5.0  (min. 1.5.0)
libjte     in use :  1.0.0  (min. 1.0.0)
libburn    in use :  1.5.0  (min. 1.5.0)
libburn OS adapter:  internal GNU/Linux SG_IO adapter sg-linux
libisoburn in use :  1.5.0  (min. 1.5.0)
Provided under GNU GPL version 3 or later, due to libreadline license.
There is NO WARRANTY, to the extent permitted by law.

Reading in package information for hppa:
   Done: Read details of 0 packages for hppa
WARNING: no translated descriptions found for buster/main
WARNING: no translated descriptions found for buster/contrib
WARNING: no translated descriptions found for buster/non-free
Starting to lay out packages into images:
   Checking base is installable for hppa
Can't open Packages file
/tmp/buster/CD1/dists/buster/main/binary-hppa/Packages : No such file or
directory
make: *** [Makefile:478: image-trees] Error 2
root@atlantis:/srv/d-i/debian-cd#

CONF.sh (25K) Download Attachment
easy-build.sh (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: debian CD issue / error

Steve McIntyre
Hi Mike,

On Wed, Jun 12, 2019 at 12:58:43AM +1200, [hidden email] wrote:

>
>I'm trying to make install CD media for buster HPPA.
>
>I have compiled the debian-installer and installed it with no issues.
>
>I have made changes to easybuild and CONF to suit.
>when trying to build I'm getting this error. can anyone explain why so I can
>fix it.
>
>uname -a Linux atlantis 4.19.0-5-parisc64-smp #1 SMP Debian 4.19.37-3
>(2019-05-15) parisc64 GNU/Linux
>
>its this error
>
>Can't open Packages file
>/tmp/buster/CD1/dists/buster/main/binary-hppa/Packages : No such file or
>directory

OK, that's coming out of tools/make_disc_trees.pl. It's complaining
about a missing Packages file that should have been generated earlier
from other bits of the debian-cd run. I'm guessing something else must
have failed earlier, but it's not clear. Could you log the whole run
and share that, please? Maybe run inside "script", that's often
easiest.

--
Steve McIntyre, Cambridge, UK.                                [hidden email]
"... the premise [is] that privacy is about hiding a wrong. It's not.
 Privacy is an inherent human right, and a requirement for maintaining
 the human condition with dignity and respect."
  -- Bruce Schneier

Reply | Threaded
Open this post in threaded view
|

Re: debian CD issue / error

Mike Hosken-2

Hi Steve,

running easy-build throws out a kernel error twice.

Not sure what it means but would suspect it's the issue.

- - - - - - - - - - - - Live Console - - - - - - - - - - - -
[  794.184456]
[  794.184547] do_page_fault() command='apt-get' type=15
address=0x2f7c5204 in libapt-pkg.so.5.0.2[f7fcf000+204000]
[  794.184547] trap #15: Data TLB miss fault, vm_start = 0x007a2000,
vm_end = 0x00847000
[  794.572158]
[  794.572249] do_page_fault() command='apt-get' type=15
address=0x2f7c5204 in libapt-pkg.so.5.0.2[f7fcf000+204000]
[  794.572249] trap #15: Data TLB miss fault, vm_start = 0x007d0000,
vm_end = 0x00875000


Mike




On 2019-06-12 02:08, Steve McIntyre wrote:

> Hi Mike,
>
> On Wed, Jun 12, 2019 at 12:58:43AM +1200, [hidden email] wrote:
>>
>> I'm trying to make install CD media for buster HPPA.
>>
>> I have compiled the debian-installer and installed it with no issues.
>>
>> I have made changes to easybuild and CONF to suit.
>> when trying to build I'm getting this error. can anyone explain why so
>> I can
>> fix it.
>>
>> uname -a Linux atlantis 4.19.0-5-parisc64-smp #1 SMP Debian 4.19.37-3
>> (2019-05-15) parisc64 GNU/Linux
>>
>> its this error
>>
>> Can't open Packages file
>> /tmp/buster/CD1/dists/buster/main/binary-hppa/Packages : No such file
>> or
>> directory
>
> OK, that's coming out of tools/make_disc_trees.pl. It's complaining
> about a missing Packages file that should have been generated earlier
> from other bits of the debian-cd run. I'm guessing something else must
> have failed earlier, but it's not clear. Could you log the whole run
> and share that, please? Maybe run inside "script", that's often
> easiest.

Reply | Threaded
Open this post in threaded view
|

Re: debian CD issue / error

Steve McIntyre
On Wed, Jun 12, 2019 at 08:05:52PM +1200, [hidden email] wrote:

>
>Hi Steve,
>
>running easy-build throws out a kernel error twice.
>
>Not sure what it means but would suspect it's the issue.
>
>- - - - - - - - - - - - Live Console - - - - - - - - - - - -
>[  794.184456]
>[  794.184547] do_page_fault() command='apt-get' type=15 address=0x2f7c5204
>in libapt-pkg.so.5.0.2[f7fcf000+204000]
>[  794.184547] trap #15: Data TLB miss fault, vm_start = 0x007a2000, vm_end =
>0x00847000
>[  794.572158]
>[  794.572249] do_page_fault() command='apt-get' type=15 address=0x2f7c5204
>in libapt-pkg.so.5.0.2[f7fcf000+204000]
>[  794.572249] trap #15: Data TLB miss fault, vm_start = 0x007d0000, vm_end =
>0x00875000

Could be, yes. :-( Sorry, no idea of what's happening there...

--
Steve McIntyre, Cambridge, UK.                                [hidden email]
Is there anybody out there?

Reply | Threaded
Open this post in threaded view
|

Re: debian CD issue / error

Steve McIntyre
On Fri, Jun 14, 2019 at 09:03:08PM +1200, [hidden email] wrote:

>Hi Steve,
>
>I have found the error, it complains about unmet dependencies on every
>package -see output log.
>
>I have checked the mirror and it works as expected for instance
>
>from log
>
> bsdutils : PreDepends: libc6 (>= 2.28) but it is not installable
>            PreDepends: libsystemd0 but it is not installable
>
>from mirror
>
>root@atlantis:/srv/d-i/debian-cd-3.1.23# apt-get --simulate install libc6
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>libc6 is already the newest version (2.28-10).
>0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>root@atlantis:/srv/d-i/debian-cd-3.1.23#
>
>So my question is how do i change the expected dependencies in debian-cd??

Hmmm, that's really odd. Can you debootstrap OK from this mirror?
debian-cd is just reporting directly what apt is telling it about the
package metadata in the archive you're using.

AFAIK Adrian is building hppa images OK (in CC); I don't think he
needs any particularly special config.

--
Steve McIntyre, Cambridge, UK.                                [hidden email]
Google-bait:       http://www.debian.org/CD/free-linux-cd
  Debian does NOT ship free CDs. Please do NOT contact the mailing
  lists asking us to send them to you.