debian-installer boot-menu: F10 not working

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

debian-installer boot-menu: F10 not working

Holger Wansing-4
Hi,

I noticed that (on amd64) the F10 key in the help screens has no function.
The F10 page is however used (for copyrights and warranty hints).

Apparently this has been the case for many years (if not forever).

Any objections against this fix?


diff --git a/build/boot/x86/prompt.cfg b/build/boot/x86/prompt.cfg
index 5ee6b2780..aefae6fdb 100644
--- a/build/boot/x86/prompt.cfg
+++ b/build/boot/x86/prompt.cfg
@@ -13,4 +13,4 @@ f6 ${SYSDIR}f6.txt
 f7 ${SYSDIR}f7.txt
 f8 ${SYSDIR}f8.txt
 f9 ${SYSDIR}f9.txt
-f0 ${SYSDIR}f10.txt
+f10 ${SYSDIR}f10.txt



It works fine here, when building a netboot image locally.

Holger


--
Holger Wansing <[hidden email]>
PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076

Reply | Threaded
Open this post in threaded view
|

Re: debian-installer boot-menu: F10 not working

Holger Wansing-4
Hi,

Holger Wansing <[hidden email]> wrote:
> Hi,
>
> I noticed that (on amd64) the F10 key in the help screens has no function.
> The F10 page is however used (for copyrights and warranty hints).
>
> Apparently this has been the case for many years (if not forever).
>
> Any objections against this fix?

Ok, so I will commit this shortly.

Holger


>
> diff --git a/build/boot/x86/prompt.cfg b/build/boot/x86/prompt.cfg
> index 5ee6b2780..aefae6fdb 100644
> --- a/build/boot/x86/prompt.cfg
> +++ b/build/boot/x86/prompt.cfg
> @@ -13,4 +13,4 @@ f6 ${SYSDIR}f6.txt
>  f7 ${SYSDIR}f7.txt
>  f8 ${SYSDIR}f8.txt
>  f9 ${SYSDIR}f9.txt
> -f0 ${SYSDIR}f10.txt
> +f10 ${SYSDIR}f10.txt
>
>
>
> It works fine here, when building a netboot image locally.
>
> Holger
>
>
> --
> Holger Wansing <[hidden email]>
> PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076
>


--
Holger Wansing <[hidden email]>
PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076

Reply | Threaded
Open this post in threaded view
|

Re: debian-installer boot-menu: F10 not working

Holger Wansing-4
Hi,

Holger Wansing <[hidden email]> wrote:

> Hi,
>
> Holger Wansing <[hidden email]> wrote:
> > Hi,
> >
> > I noticed that (on amd64) the F10 key in the help screens has no function.
> > The F10 page is however used (for copyrights and warranty hints).
> >
> > Apparently this has been the case for many years (if not forever).
> >
> > Any objections against this fix?
>
> Ok, so I will commit this shortly.
>
> Holger

Done.


> >
> > diff --git a/build/boot/x86/prompt.cfg b/build/boot/x86/prompt.cfg
> > index 5ee6b2780..aefae6fdb 100644
> > --- a/build/boot/x86/prompt.cfg
> > +++ b/build/boot/x86/prompt.cfg
> > @@ -13,4 +13,4 @@ f6 ${SYSDIR}f6.txt
> >  f7 ${SYSDIR}f7.txt
> >  f8 ${SYSDIR}f8.txt
> >  f9 ${SYSDIR}f9.txt
> > -f0 ${SYSDIR}f10.txt
> > +f10 ${SYSDIR}f10.txt
> >
> >
> >
> > It works fine here, when building a netboot image locally.
> >
> > Holger
> >
> >
> > --
> > Holger Wansing <[hidden email]>
> > PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076
> >
>
>
> --
> Holger Wansing <[hidden email]>
> PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076
>


--
Holger Wansing <[hidden email]>
PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076