gimp in crash

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

gimp in crash

Franco Peci
Venerd?? ho fatto l'aggiornamento (uso testing con Xfce come DE) e Gimp
va in crash.
Ecco qui sotto parte del messaggio che ricevo quando provo ad apro
un'immagine.
Da una rapida ricerca mi sembra sia stato gi?? segnalato tale problema
forse legato alla libreria GEGL.
Fra parentesi anche ad esportare con writer di Libreoffice una pagina
come jpg, le immagini appaiono dei rettangoli neri. Non so se anche
questo sia dovuto a qualche libreria difettosa.
Devo solo attendere nuovi aggiornamenti che risolvono il presunto bug, o
posso fare qualcosa?

Grazie per eventuali risposte.
Ciao
Franco


GNU Image Manipulation Program version 2.10.8
git-describe: GIMP_2_10_6-294-ga967e8d2c2
C compiler:
 ?????? Using built-in specs.
 ?????? COLLECT_GCC=gcc
 ?????? COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper
 ?????? OFFLOAD_TARGET_NAMES=nvptx-none:hsa
 ?????? OFFLOAD_TARGET_DEFAULT=1
 ?????? Target: x86_64-linux-gnu
 ?????? Configured with: ../src/configure -v --with-pkgversion='Debian
9.2.1-6' --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs
--enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,gm2
--prefix=/usr --with-gcc-major-version-only --program-suffix=-9
--program-prefix=x86_64-linux-gnu- --enable-shared
--enable-linker-build-id --libexecdir=/usr/lib
--without-included-gettext --enable-threads=posix --libdir=/usr/lib
--enable-nls --enable-bootstrap --enable-clocale=gnu
--enable-libstdcxx-debug --enable-libstdcxx-time=yes
--with-default-libstdcxx-abi=new --enable-gnu-unique-object
--disable-vtable-verify --enable-plugin --enable-default-pie
--with-system-zlib --with-target-system-zlib=auto --enable-multiarch
--disable-werror --with-arch-32=i686 --with-abi=m64
--with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic
--enable-offload-targets=nvptx-none,hsa --without-cuda-driver
--enable-checking=release --build=x86_64-linux-gnu
--host=x86_64-linux-gnu --target=x86_64-linux-gnu
 ?????? Thread model: posix
 ?????? gcc version 9.2.1 20190827 (Debian 9.2.1-6)

using GEGL version 0.4.12 (compiled against version 0.4.14)
using GLib version 2.60.6 (compiled against version 2.60.6)
using GdkPixbuf version 2.38.1 (compiled against version 2.38.1)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.42.3 (compiled against version 1.42.3)
using Fontconfig version 2.13.1 (compiled against version 2.13.1)
using Cairo version 1.16.0 (compiled against version 1.16.0)

```
 > fatal error: Errore di segmentazione

Reply | Threaded
Open this post in threaded view
|

Re: gimp in crash

liste DOT girarsi AT posteo DOT eu
Il 15/09/19 15:27, Franco Peci ha scritto:

> Venerd?? ho fatto l'aggiornamento (uso testing con Xfce come DE) e Gimp
> va in crash.
> Ecco qui sotto parte del messaggio che ricevo quando provo ad apro
> un'immagine.
> Da una rapida ricerca mi sembra sia stato gi?? segnalato tale problema
> forse legato alla libreria GEGL.
> Fra parentesi anche ad esportare con writer di Libreoffice una pagina
> come jpg, le immagini appaiono dei rettangoli neri. Non so se anche
> questo sia dovuto a qualche libreria difettosa.
> Devo solo attendere nuovi aggiornamenti che risolvono il presunto bug, o
> posso fare qualcosa?
>
> Grazie per eventuali risposte.
> Ciao
> Franco
>
>

io ho la versione 2.10.8, ed anch'io uso testing, prova a controllare se
c'è la nuova versione aggiornando dai repo unstable.


--
_|_|_|_|_|_|_|_|_|_
|_|_|_|_|_|_|_|_|_|_|
Simone Girardelli

Reply | Threaded
Open this post in threaded view
|

Re: gimp in crash

Davide Prina
In reply to this post by Franco Peci
On 15/09/19 15:27, Franco Peci wrote:
> Venerd?? ho fatto l'aggiornamento (uso testing con Xfce come DE) e Gimp
> va in crash.

$ gimp &
GIMP-Errore: Unable to run plug-in "plugin-uncrop.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-uncrop.py)

Fallita l'esecuzione di un processo figlio “python” (File o directory
non esistente)

gimp: LibGimpBase-ATTENZIONE: gimp: gimp_wire_read(): error
gimp: LibGimpBase-ATTENZIONE: gimp: gimp_wire_read(): error
GIMP-Errore: Unable to run plug-in "plugin-resynth-enlarge.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-resynth-enlarge.py)
[...]

quindi sembra che ci siano problemi ben prima... appena apri gimp ha dei
problemi con python. Stanno facendo la transazione da python 2.7 a
python 3 e probabilmente in testing è arrivato qualcosa di non completo.

> Ecco qui sotto parte del messaggio che ricevo quando provo ad apro
> un'immagine.

Il crash lo hai prima di aprire l'immagine. Se fai apri nuova immagine e
poi attendi, senza selezionare nessuna immagine, avrai un crash.

Quindi:
* visto che hai visto il bug segnalato, puoi aggiungere anche la tua
esperienza negativa (indica anche a noi il numero del bug che hai trovato)
* puoi attendere che si risolva, se non ti è indispensabile l'uso di gimp
* se ti serve gimp, allora puoi pescare le versioni vecchie dei
pacchetti che hai aggiornato venerdì qui (leggi le istruzioni come fare
per pescare i pacchetti presenti ad un dato giorno):
https://snapshot.debian.org/

Ciao
Davide

--
Dizionari: http://linguistico.sourceforge.net/wiki
I didn't use Microsoft machines when I was in my operational phase,
because I couldn't trust them.
Not because I knew that there was a particular back door or anything
like that, but because I couldn't be sure.
Edward Snowden

Reply | Threaded
Open this post in threaded view
|

Re: gimp in crash

Walter Valenti
>On 15/09/19 15:27, Franco Peci wrote:
>> Venerd?? ho fatto l'aggiornamento (uso testing con Xfce come DE) e Gimp
>> va in crash.

>$ gimp &
>GIMP-Errore: Unable to run plug-in "plugin-uncrop.py"
>(/usr/lib/gimp/2.0/plug-ins/plugin-uncrop.py)

>Fallita l'esecuzione di un processo figlio “python” (File o directory
>non esistente)

Ciao,
uso anche io testing e gimp si avvia senza errori.
/usr/lib/gimp/2.0/plug-ins/plugin-uncrop.py non è installato sulla  macchina,
Si trova nel pacchetto "gimp-plugin-registry"

Prova a disinstallare il pacchetto e vedi se gimp ti si 
avvia.





Reply | Threaded
Open this post in threaded view
|

Re: gimp in crash

Davide Prina
In reply to this post by Franco Peci
On 15/09/19 15:27, Franco Peci wrote:
> Venerd?? ho fatto l'aggiornamento (uso testing con Xfce come DE) e Gimp
> va in crash.

> Da una rapida ricerca mi sembra sia stato gi?? segnalato tale problema
> forse legato alla libreria GEGL.

infatti il problema è proprio di quelle librerie, come riportato in
diversi bug report[¹]
gimp è stato compilato in Sid con una versione maggiore di quelle
librerie, rispetto alla versione presente in testing.

Per risolvere il problema basta prendere la versione delle librerie da
Sid e installarle quelle, se sono ancora presenti.

Dai bug report bisogna prendere il pacchetto libgegl-0.4-0, se ancora
presente, altrimenti si può prendere da snapshot[²]

Ciao
Davide

[¹]
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=939754
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=939768

[²]
https://snapshot.debian.org/

--
Dizionari: http://linguistico.sourceforge.net/wiki
What happened in 2013 couldn't have happened without free software
(He credited free software for his ability to help disclose the U.S.
government's far-reaching surveillance projects).
Edward Snowden


Reply | Threaded
Open this post in threaded view
|

Re: gimp in crash

peterpunk
In reply to this post by Franco Peci
On Sun, 15 Sep 2019 15:27:53 +0200 Franco wrote:

> Venerd?? ho fatto l'aggiornamento (uso testing con Xfce come DE) e
> Gimp va in crash.
>

Gli aggiornamenti di oggi correggono il bug.

peterpunk
--

  ,= ,-_-. =.
 ((_/)o o(\_))
  `-'(. .)`-'
      \_/     printf("Mai un giorno senza una riga\n");

Reply | Threaded
Open this post in threaded view
|

Re: gimp in crash

Franco Peci
Confermo che ora Gimp ?? tornato a funzionare.
Grazie a tutti quelli che hanno risposto e anche a coloro che lavorano
per Debian.

Ciao
Franco



Il 18/09/19 10:54, peterpunk ha scritto:
> On Sun, 15 Sep 2019 15:27:53 +0200 Franco wrote:
>
>> Venerd?? ho fatto l'aggiornamento (uso testing con Xfce come DE) e
>> Gimp va in crash.
>>
> Gli aggiornamenti di oggi correggono il bug.
>
> peterpunk

Reply | Threaded
Open this post in threaded view
|

Re: gimp in crash

Piviul-2
Il 18/09/19 14:39, Franco Peci ha scritto:
> Confermo che ora Gimp ?? tornato a funzionare.
> Grazie a tutti quelli che hanno risposto e anche a coloro che lavorano
> per Debian.
mi associo ai ringraziamenti estendendoli a tutti coloro che attivamente
si prodigano a rendere il software libero sempre migliore.

Piviul

Reply | Threaded
Open this post in threaded view
|

Blender in crash

andrea biancalana-2
In reply to this post by peterpunk
Mi dicono che, un po' come capitava con gimp qualche giorno, blender non si avvia piu' su una testing aggiornata:

sapete se e' un problema noto che sara' presumibilmente presto risolto?

Oggi non ho potuto ancora approfondire per altri impegni (ma proprio nel pomeriggio serviva blender per un corso a scuola...) pero' ho visto che la stessa versione 2.80 di blender su un altro sistema testing meno aggiornato funziona

Grazie

Reply | Threaded
Open this post in threaded view
|

Re: Blender in crash

Davide Prina
On 23/09/19 21:34, andrea biancalana wrote:
> blender non si avvia piu' su una testing aggiornata:

quando si ha un problema del genere bisogna provare a fare almeno i
seguenti passi:

1) far partire l'applicazione da terminale. In questo modo si può avere
un messaggio di errore che permette di capire cosa c'è che non va

$ blender &

ed in effetti stampa un po' di errori:

         Received X11 Error:
        error code:   167
        request code: 151
        minor code:   34
        error text:   GLXBadFBConfig
[...]
Warning: Could not find a matching GPU name. Things may not behave as
expected.
Detected OpenGL configuration:
Vendor: X.Org
Renderer: AMD RV730 (DRM 2.50.0 / 5.2.9-dp-20190826, LLVM 8.0.1)
Received X11 Error:
        error code:   8
        request code: 151
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
[...]

poi sembra non avviarsi, almeno come faceva un bel po' di mesi fa...
l'ultima volta che l'ho usato.

Se però sei paziente si avvia. Anche se sembra poco usabile perché
lentissimo (io ho un PC un po' vecchiotto, circa 11 anni)
Probabilmente con le nuove versioni tenta di usare la GPU della scheda
video e a me non la rileva, però sembrano esserci altri errori con X11

2) vedere nei log
in questo caso dovrebbe bastare
/var/log/syslog

Si può eseguire il comando
$ tail -f /var/log/syslog
prima di far partire il programma al punto 1, in modo da vedere a video
gli errori che produce

e anche qui io ho un bel po' di messaggi di errore del kernel relativi
alla scheda video.

3) vedere se ci sono bug aperti sul problema

$ querybts blender

> sapete se e' un problema noto che sara' presumibilmente presto risolto?

nel mio caso sembra che il problema sia la mia scheda video non
completamente supportata o non più completamente supportata.

Prova anche tu a fare questi semplici passi e vedi se capisci dove
risiede il problema.

Ciao
Davide

--
Dizionari: http://linguistico.sourceforge.net/wiki
Fate una prova di guida ... e tenetevi la macchina!:
http://linguistico.sf.net/wiki/doku.php?id=usaooo2
Non autorizzo la memorizzazione del mio indirizzo su outlook

Reply | Threaded
Open this post in threaded view
|

Re: Blender in crash

andrea biancalana-2
il giorno Tue, 24 Sep 2019 20:07:55 +0200  Davide Prina <[hidden email]> ha scritto:

> On 23/09/19 21:34, andrea biancalana wrote:
> > blender non si avvia piu' su una testing aggiornata:  
>
> quando si ha un problema del genere bisogna provare a fare almeno i
> seguenti passi:
>
> 1) far partire l'applicazione da terminale. In questo modo si può avere
> un messaggio di errore che permette di capire cosa c'è che non va
>
> $ blender &
>
> ed in effetti stampa un po' di errori:
>
>          Received X11 Error:
> error code:   167
> request code: 151
> minor code:   34
> error text:   GLXBadFBConfig
> [...]
> Warning: Could not find a matching GPU name. Things may not behave as
> expected.
> Detected OpenGL configuration:
> Vendor: X.Org
> Renderer: AMD RV730 (DRM 2.50.0 / 5.2.9-dp-20190826, LLVM 8.0.1)
> Received X11 Error:
> error code:   8
> request code: 151
> minor code:   34
> error text:   BadMatch (invalid parameter attributes)
> [...]
>
> poi sembra non avviarsi, almeno come faceva un bel po' di mesi fa...
> l'ultima volta che l'ho usato.

Si, si: grazie.
Il bug e' gia' stato segnalato il primo settembre ma non e' ancora stato risolto: questa in fondo e' la cosa che trovo piu' strana.
 

> Se però sei paziente si avvia.

no: in questo caso va inesorabilmente in crash.
Mi risulta che il problema sia solo su testing i386: su sistemi testing amd64 funziona.

>
> e anche qui io ho un bel po' di messaggi di errore del kernel relativi
> alla scheda video.

mi sembra che l'errore definitivo sia
BLI_assert failed: /build/blender-MRodtJ/blender-2.80+dfsg/source/blender/editors/space_outliner/outliner_draw.c:1032

esattamente come hanno gia' segnalato il primo settembre.

Grazie