kdelibs4-dev on sid?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

kdelibs4-dev on sid?

alan.ezust (Bugzilla)
I'm having a terrible difficulty installing kdelibs4-dev in sid - is
it a broken package?

Reply | Threaded
Open this post in threaded view
|

Re: kdelibs4-dev on sid?

alan.ezust (Bugzilla)
let me qualify that - now that I've removed kdebase and I still can't
install it.
The following packages have unmet dependencies:
  kdelibs4-dev: Depends: libarts1-dev (>= 1.4.2) but it is not going
to be installed

ROOT@lazarus]# apt-get install libarts1-dev kdelibs4-dev
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libarts1-dev: Depends: libarts1c2a (= 1.4.3-2) but it is not going
to be installed
E: Broken packages

Reply | Threaded
Open this post in threaded view
|

Re: kdelibs4-dev on sid?

Sune Vuorela-2
On 2005-11-26, Alan Ezust <[hidden email]> wrote:
> The following packages have unmet dependencies:
>   libarts1-dev: Depends: libarts1c2a (= 1.4.3-2) but it is not going
> to be installed

Yes - sid is starting to break heavily - and in some weeks, it will be
back up running ;)

/Sune


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: kdelibs4-dev on sid?

Martin Steigerwald
In reply to this post by alan.ezust (Bugzilla)
Am Samstag 26 November 2005 07:30 schrieb Alan Ezust:

> ROOT@lazarus]# apt-get install libarts1-dev kdelibs4-dev
> Reading package lists... Done
> Building dependency tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>   libarts1-dev: Depends: libarts1c2a (= 1.4.3-2) but it is not going
> to be installed
> E: Broken packages

Hello Alan,

there seems to be another library transition. This time between KDE 3.4.2
and KDE 3.4.3 related libraries.

As sid does not contain the complete KDE 3.4.3 distribution and all KDE
related packages that are important to me compiled with those new
libraries, I am going to leave those new library packages uninstalled for
a while.

I am a bit puzzled about this, cause I thought there would be *one* C++
ABI transition and not two of them. Seems I have missed something.

IMHO those transitions are quite time consuming for developers,
betatesters and users and would like that they won't happen that often.

Regards,
--
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: kdelibs4-dev on sid?

Martin Steigerwald
In reply to this post by alan.ezust (Bugzilla)
Am Samstag 26 November 2005 07:30 schrieb Alan Ezust:

> The following packages have unmet dependencies:
>   libarts1-dev: Depends: libarts1c2a (= 1.4.3-2) but it is not going
> to be installed
> E: Broken packages

Hello again,

here is the necessary piece of information

-------------------------------------------------------------------------
From:  Christopher Martin <[hidden email]>
To:  [hidden email], [hidden email]
Date:  16.11.2005 20:48

[...]

THE ROAD AHEAD
==============

Unfortunately, a necessary change to Debian's GCC configuration [1], that
was just uploaded, breaks binary compatibility for many C++ libraries and
the applications that use them, forcing them to be renamed, as in, for
instance, libfoo7c2 --> libfoo7c2a. KDE is affected by this change. Once
the updated toolchain is in place for all architectures, and all libraries
that arts and kdelibs build-depend on are also transitioned (could be a
while...), then we will upload a transitioned KDE 3.4.3 to Sid (unstable).
KDE 3.5.0 will likely then move into experimental. Only once KDE 3.4.3 has
moved into Etch (testing), will KDE 3.5 be uploaded to unstable, however.

[...]
-------------------------------------------------------------------------

So this time at least it doesn't seem to be the GCC developers causing
that transition ;-).

Regards,
--
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]