libbonoboui: Prepared version 2.14.0-0.1 for upload to unstable

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

libbonoboui: Prepared version 2.14.0-0.1 for upload to unstable

"Øystein Gisnås"
I've modified the 2.10.1-2 package scripts to fit the 2.14.0 release of
libbonoboui.

Applied changes from 2.10.1-2 are:
  * debian/watch:
    - updated version to 2.14
  * debian/patches:
    - 32_implicit-pointer.patch: dropped; applied upstream
  * debian/control.in:
    - improved package descriptions
    - removed duplicate dependency libxml2-dev (Closes: #356889)
      Thanks to Stefan Huehner.
    - Updated dependencies according to configure script
  * debian/rules:
    - added -V argument to dh_makeshlibs (Closes: #317904)
    - removed cdbs simple-patchsys dependency
  * debian/shlibs.local:
    - removed file and moved intended functionality to debian/rules

I've run the package through lintian/linda. They still report warnings
and errors (about missing manpage), but less problems than the previous
version. I've also successfully run the package through pbuilder, but
have not done any smoketesting. Two 2.14 libraries are needed to build
the package - libgnome and libbonobo, of which the last is already in
unstable.

Cheers,
Øystein Gisnås


libbonoboui_2.14.0-0.1.diff.gz (7K) Download Attachment
signature.asc (198 bytes) Download Attachment