libgtk version related

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

libgtk version related

Vibhav Sharma
Hi,

I'm using debian unstable and developing on eclipse.

Coming across the following problem.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=159840

as you can see, the suggestion I have gotten is to test against latest
version
of gtk+.

which happens to be 2.10.6

but debian unstable has

libgtk1.2 : 1.2.10-18
libgtk2.0-0 : 2.8.20-2

(which of these indicate gtk+ version)
as the latest available.

so 2 questions

* when can we expect 2.10.6
and
if I want to test against that now, .... how can I go about it without
breaking
package management on my system.

any pointers/links would be much appreciated.

thanks in advance,

Vibhav Sharma

P.S. : Please CC any replies to me <[hidden email]>, I haven't
subscribed to the list.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: libgtk version related

Josselin Mouette
Le mercredi 11 octobre 2006 à 15:37 +0530, Vibhav Sharma a écrit :

> Hi,
>
> I'm using debian unstable and developing on eclipse.
>
> Coming across the following problem.
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=159840
>
> as you can see, the suggestion I have gotten is to test against latest
> version
> of gtk+.
>
> which happens to be 2.10.6

This is utterly wrong. If the software works on Fedora core 5 which has
gtk+ 2.8.15, there's no reason why it would be necessary to upgrade to
2.10.

You can also try with previous versions of gtk+ you will find on
snapshot.debian.net.

> * when can we expect 2.10.6
> and
> if I want to test against that now, .... how can I go about it without
> breaking
> package management on my system.

GTK+ 2.10.6 is currently available in the experimental repository.
--
 .''`.           Josselin Mouette        /\./\
: :' :           [hidden email]
`. `'                        [hidden email]
   `-  Debian GNU/Linux -- The power of freedom

Reply | Threaded
Open this post in threaded view
|

Re: libgtk version related

Vibhav Sharma
Josselin Mouette wrote:

> Le mercredi 11 octobre 2006 à 15:37 +0530, Vibhav Sharma a écrit :
>  
>> Hi,
>>
>> I'm using debian unstable and developing on eclipse.
>>
>> Coming across the following problem.
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=159840
>>
>> as you can see, the suggestion I have gotten is to test against latest
>> version
>> of gtk+.
>>
>> which happens to be 2.10.6
>>    
>
> This is utterly wrong. If the software works on Fedora core 5 which has
> gtk+ 2.8.15, there's no reason why it would be necessary to upgrade to
> 2.10.
>
> You can also try with previous versions of gtk+ you will find on
> snapshot.debian.net.
>
>  
actually, I'm sorry I did not make myself more clear ... FC5
installation was updated and running
gtk+  1:2.10.5
gtk2   2.8.15
>> * when can we expect 2.10.6
>> and
>> if I want to test against that now, .... how can I go about it without
>> breaking
>> package management on my system.
>>    
>
> GTK+ 2.10.6 is currently available in the experimental repository.
>  

I'll try that ...


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: libgtk version related

Vibhav Sharma
In reply to this post by Josselin Mouette

>> * when can we expect 2.10.6
>> and
>> if I want to test against that now, .... how can I go about it without
>> breaking
>> package management on my system.
>>    
>
> GTK+ 2.10.6 is currently available in the experimental repository.
>  

update ....

the experimental package conflict with 'libgnomeui' and thus basically
says it wants to uninstall
all gnome .... not funny .... :(

any workaround?
what might happen if I force install ignoring dependencies/conflicts.


Vibhav


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: libgtk version related

Josselin Mouette
Le jeudi 12 octobre 2006 à 14:35 +0530, Vibhav Sharma a écrit :
> > GTK+ 2.10.6 is currently available in the experimental repository.
> >  
> update ....
>
> the experimental package conflict with 'libgnomeui' and thus basically
> says it wants to uninstall
> all gnome .... not funny .... :(

As the modules ABI changed in GTK+ 2.10, you have to update libgnomeui,
gtk2-engines, and a few other packages as well, from the experimental
repository.
--
 .''`.           Josselin Mouette        /\./\
: :' :           [hidden email]
`. `'                        [hidden email]
   `-  Debian GNU/Linux -- The power of freedom