lintian warnings from man pages due to too long lines

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

lintian warnings from man pages due to too long lines

Guillem Jover
Hi!

This has been going on for a while now, and even though I did ask Sven
about it on IRC some time ago, I cannot find any previous mention to
Helge (sorry if I did but forgot!). There are these following lintian
warnings emitted:

  W: dpkg-dev: manpage-has-errors-from-man usr/share/man/de/man1/dpkg-architecture.1.gz 276: warning [p 5, 4.5i]: cannot adjust line
  W: dselect: manpage-has-errors-from-man usr/share/man/de/man1/dselect.1.gz 83: warning [p 1, 10.2i, div 'an-div', 0.0i]: cannot adjust line
  W: dselect: manpage-has-errors-from-man usr/share/man/fr/man1/dselect.1.gz 81: warning [p 1, 10.0i, div 'an-div', 0.0i]: cannot adjust line

Could we do something about the dpkg-dev German translation that triggers
this, or even the English original if there's some way to reword it so
that it does not make the translation hard to fix?

I think the dselect one could be fixed by moving the --colour as an
alias below the --color one, but I've not tried that yet.

Thanks,
Guillem

Reply | Threaded
Open this post in threaded view
|

Re: lintian warnings from man pages due to too long lines

Helge Kreutzmann-2
Hello Guillem,
On Sun, Sep 01, 2019 at 12:03:16AM +0200, Guillem Jover wrote:

> This has been going on for a while now, and even though I did ask Sven
> about it on IRC some time ago, I cannot find any previous mention to
> Helge (sorry if I did but forgot!). There are these following lintian
> warnings emitted:
>
>   W: dpkg-dev: manpage-has-errors-from-man usr/share/man/de/man1/dpkg-architecture.1.gz 276: warning [p 5, 4.5i]: cannot adjust line
>   W: dselect: manpage-has-errors-from-man usr/share/man/de/man1/dselect.1.gz 83: warning [p 1, 10.2i, div 'an-div', 0.0i]: cannot adjust line
>   W: dselect: manpage-has-errors-from-man usr/share/man/fr/man1/dselect.1.gz 81: warning [p 1, 10.0i, div 'an-div', 0.0i]: cannot adjust line
>
> Could we do something about the dpkg-dev German translation that triggers
> this, or even the English original if there's some way to reword it so
> that it does not make the translation hard to fix?
These issues, if issues at all, are very minor. IMHO you could simply
ignore them. I looked both at the source and at the rendered version of
the translated dpkg-architecture.1, and everything is as expected.
(Though I don't have an 80 column terminal at hand).

In the worst case the translated strings visually appear a little
rugged, e.g. by lines beeing too long.

> I think the dselect one could be fixed by moving the --colour as an
> alias below the --color one, but I've not tried that yet.

I don't think it is worth the effort trying to "fix" these by
rewording the orignal. Both the orginal as well as the translation
have a reason to be as they are (the content matters), so changing the
content (original string or translation) to fix a possible and very
minor visual glitch is IMHO not the right path. Also this can occur
again and again, as the original strings are updated.

In my opinion this could be sovled programmatically, but this would be a
lot of effort. (La)TeX does it, but the algorithm is not trivial,
though it might be easier for fixed fonts.

But again, IMHO this is really not worth the effort.

Greetings

            Helge

--
      Dr. Helge Kreutzmann                     [hidden email]
           Dipl.-Phys.                   http://www.helgefjell.de/debian.php
        64bit GNU powered                     gpg signed mail preferred
           Help keep free software "libre": http://www.ffii.de/

signature.asc (849 bytes) Download Attachment