paquet libgmic1 cassé

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

paquet libgmic1 cassé

Kohler Gerard

bonjour,

système : Debian Bullseye

suite à une mise à jour je ne peux plus utiliser gmic avec Gimp,

le paquet libgmic1 est cassé et je ne peux pas l'enlever ni le réinstaller

lorsque je fais :

# apt-get install gim-gmic

voici la réponse :

 Les paquets suivants contiennent des dépendances non satisfaites :
 gimp-gmic : Dépend: libgmic1 (= 2.4.5-1.1) mais ne sera pas installé
 E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


si je fais :

# dpkg --force all --purge libgmic1

voici la réponse :

dpkg: avertissement: requête ignorée : suppression de libgmic1, qui n'est pas installé


une idée pour s'en sortir ?

merci de votre aide

gerard

Reply | Threaded
Open this post in threaded view
|

Re: paquet libgmic1 cassé

Étienne Mollier
Kohler Gerard, on 2020-03-29 21:03:50 +0200:

> système : Debian Bullseye
>
> suite à une mise à jour je ne peux plus utiliser gmic avec Gimp,
>
> le paquet libgmic1 est cassé et je ne peux pas l'enlever ni le réinstaller
>
> lorsque je fais :
>
> /# apt-get install gim-gmic/
>
> voici la réponse :
>
> / Les paquets suivants contiennent des dépendances non satisfaites :
>  gimp-gmic : Dépend: libgmic1 (= 2.4.5-1.1) mais ne sera pas installé
>  E: Impossible de corriger les problèmes, des paquets défectueux sont en
> mode « garder en l'état »./
Bonsoir,

Apparemment le paquet libgmic1 est marqué « on hold » / « garder
en l'état ».

Est-ce que ceci aiderait à débloquer la situation :

        # apt-mark unhold libgmic1

Amicalement,
--
Étienne Mollier <[hidden email]>
Fingerprint:  5ab1 4edf 63bb ccff 8b54  2fa9 59da 56fe fff3 882d
Et Hip, Hip, Hip, Hourra !   Pour le personnel infirmier !   \o/

signature.asc (673 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: paquet libgmic1 cassé

Kohler Gerard

bon cela semble assez compliqué :

# apt-mark unhold libgmic1
libgmic1 était déjà marqué comme non figé.


# dpkg -i libgmic1_2.4.5-1.1_amd64.deb
(Lecture de la base de données... 637714 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de libgmic1_2.4.5-1.1_amd64.deb ...
Dépaquetage de libgmic1:amd64 (2.4.5-1.1) sur (2.4.5-1.1) ...
dpkg: des problèmes de dépendances empêchent la configuration de libgmic1:amd64 :
 libgmic1:amd64 dépend de libopencv-videoio4.2 (>= 4.2.0+dfsg) ; cependant :
  Le paquet libopencv-videoio4.2 n'est pas installé.

dpkg: erreur de traitement du paquet libgmic1:amd64 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.30-2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 libgmic1:amd64

lorsque j'essaie d'installer libopencv-videoio4.2 :

# apt-get install libopencv-videoio4.2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libopencv-videoio4.2 : Dépend: libopencv-imgcodecs4.2 (= 4.2.0+dfsg-5+b2) mais ne sera pas installé
                        Dépend: libopencv-imgproc4.2 (>= 4.2.0+dfsg) mais ne sera pas installé

# apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gir1.2-gnomekeyring-1.0 libfuse3-3 libpython-all-dev libre2-5 python-all python-all-dev python-crypto python-entrypoints python-keyring
  python-keyrings.alt python-wheel python-xdg
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libgmic1
0 mis à jour, 0 nouvellement installés, 1 à enlever et 21 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 7 144 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 637714 fichiers et répertoires déjà installés.)
Suppression de libgmic1:amd64 (2.4.5-1.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.30-2) ...


# apt autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  gir1.2-gnomekeyring-1.0 libfuse3-3 libpython-all-dev libre2-5 python-all python-all-dev python-crypto python-entrypoints python-keyring
  python-keyrings.alt python-wheel python-xdg
0 mis à jour, 0 nouvellement installés, 12 à enlever et 21 non mis à jour.
Après cette opération, 2 870 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 637710 fichiers et répertoires déjà installés.)
Suppression de gir1.2-gnomekeyring-1.0 (3.12.0-1+b2) ...
Suppression de libfuse3-3:amd64 (3.9.0-2) ...
Suppression de python-all-dev (2.7.17-2) ...
Suppression de libpython-all-dev:amd64 (2.7.17-2) ...
Suppression de libre2-5:amd64 (20200101+dfsg-1) ...
Suppression de python-all (2.7.17-2) ...
Suppression de python-keyrings.alt (3.2.0-1) ...
Suppression de python-crypto (2.6.1-13) ...
Suppression de python-keyring (18.0.1-2) ...
Suppression de python-entrypoints (0.3-2) ...
Suppression de python-wheel (0.33.6-2) ...
Suppression de python-xdg (0.26-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.30-2) ...


et cela continue sans cesse, libgmic1 ne s'enlève jamais,

j'avoue ne pas comprendre

si j'utilise synaptic, il me dit que le paquet gmic est cassé et à la ligne de commande ça tourne en rond


Gerard







Reply | Threaded
Open this post in threaded view
|

Re: paquet libgmic1 cassé

Kohler Gerard
Le 31/03/2020 à 21:12, Kohler Gerard a écrit :

bon cela semble assez compliqué :

# apt-mark unhold libgmic1
libgmic1 était déjà marqué comme non figé.


# dpkg -i libgmic1_2.4.5-1.1_amd64.deb
(Lecture de la base de données... 637714 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de libgmic1_2.4.5-1.1_amd64.deb ...
Dépaquetage de libgmic1:amd64 (2.4.5-1.1) sur (2.4.5-1.1) ...
dpkg: des problèmes de dépendances empêchent la configuration de libgmic1:amd64 :
 libgmic1:amd64 dépend de libopencv-videoio4.2 (>= 4.2.0+dfsg) ; cependant :
  Le paquet libopencv-videoio4.2 n'est pas installé.

dpkg: erreur de traitement du paquet libgmic1:amd64 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.30-2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 libgmic1:amd64

lorsque j'essaie d'installer libopencv-videoio4.2 :

# apt-get install libopencv-videoio4.2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libopencv-videoio4.2 : Dépend: libopencv-imgcodecs4.2 (= 4.2.0+dfsg-5+b2) mais ne sera pas installé
                        Dépend: libopencv-imgproc4.2 (>= 4.2.0+dfsg) mais ne sera pas installé

# apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gir1.2-gnomekeyring-1.0 libfuse3-3 libpython-all-dev libre2-5 python-all python-all-dev python-crypto python-entrypoints python-keyring
  python-keyrings.alt python-wheel python-xdg
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libgmic1
0 mis à jour, 0 nouvellement installés, 1 à enlever et 21 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 7 144 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 637714 fichiers et répertoires déjà installés.)
Suppression de libgmic1:amd64 (2.4.5-1.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.30-2) ...


# apt autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  gir1.2-gnomekeyring-1.0 libfuse3-3 libpython-all-dev libre2-5 python-all python-all-dev python-crypto python-entrypoints python-keyring
  python-keyrings.alt python-wheel python-xdg
0 mis à jour, 0 nouvellement installés, 12 à enlever et 21 non mis à jour.
Après cette opération, 2 870 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 637710 fichiers et répertoires déjà installés.)
Suppression de gir1.2-gnomekeyring-1.0 (3.12.0-1+b2) ...
Suppression de libfuse3-3:amd64 (3.9.0-2) ...
Suppression de python-all-dev (2.7.17-2) ...
Suppression de libpython-all-dev:amd64 (2.7.17-2) ...
Suppression de libre2-5:amd64 (20200101+dfsg-1) ...
Suppression de python-all (2.7.17-2) ...
Suppression de python-keyrings.alt (3.2.0-1) ...
Suppression de python-crypto (2.6.1-13) ...
Suppression de python-keyring (18.0.1-2) ...
Suppression de python-entrypoints (0.3-2) ...
Suppression de python-wheel (0.33.6-2) ...
Suppression de python-xdg (0.26-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.30-2) ...


et cela continue sans cesse, libgmic1 ne s'enlève jamais,

j'avoue ne pas comprendre

si j'utilise synaptic, il me dit que le paquet gmic est cassé et à la ligne de commande ça tourne en rond


Gerard







bon j'ai trouvé !

en fait il y avait une vieille version de freecad qui traînait sans avoir été totalement purgée lors d'une mise à jour, avec des dépendances relous,

bon apparemment tout est rentré dans l'ordre,

merci de votre aide

Gerard


Reply | Threaded
Open this post in threaded view
|

Re: paquet libgmic1 cassé

Étienne Mollier
Kohler Gerard, on 2020-03-31 21:23:33 +0200:

> bon j'ai trouvé !
>
> en fait il y avait une vieille version de freecad qui traînait sans avoir
> été totalement purgée lors d'une mise à jour, avec des dépendances relous,
>
> bon apparemment tout est rentré dans l'ordre,
>
> merci de votre aide
>
> Gerard
Bonjour,

En toute honnêteté, j'ai observé le même problème que vous hier
soir, et la correction ce soir, à une journée de décalage.

Le paquet gimp-gmic dépend de libgdal26.  La précédente version
du paquet libgdal26 dépendait de libhdf5-103 et de libnetcdf15.
Or, libnetcdf15 dépend de libhdf5-103-1 qui entrait en conflit
avec libhdf5-103.

La nouvelle version de libgdal26 dépend désormais de
libhdf5-103-1, ce qui corrige le problème d'installation de
gimp-gmic.

Désolé de ne pas avoir répondu plus tôt,
Amicalement,
--
Étienne Mollier <[hidden email]>
Fingerprint:  5ab1 4edf 63bb ccff 8b54  2fa9 59da 56fe fff3 882d
Et Hip, Hip, Hip, Hourra !   Pour le personnel infirmier !   \o/

signature.asc (673 bytes) Download Attachment