phonon-backend-gstreamer-common has been kept back

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

phonon-backend-gstreamer-common has been kept back

Miguel A. Vallejo
Hi

I noticed that phonon-backend-gstreamer-common have been keep back
since several weeks ago in Sid. If I try to update it manually apt
wants to remove the entire KDE.

Did I miss something?

Thanks in advance

Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Diederik de Haas-2
On dinsdag 12 november 2019 20:47:19 CET Miguel A. Vallejo wrote:
> I noticed that phonon-backend-gstreamer-common have been keep back
> since several weeks ago in Sid. If I try to update it manually apt
> wants to remove the entire KDE.

I don't have that problem on my Sid box.
Can you share the output/result of
"aptitude safe-upgrade phonon-backend-gstreamer-common" ?
and if it's any different also from "full-upgrade"?

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Miguel A. Vallejo
Hi

> I don't have that problem on my Sid box.
> Can you share the output/result of
> "aptitude safe-upgrade phonon-backend-gstreamer-common" ?

Here it is:

~# aptitude safe-upgrade phonon-backend-gstreamer-common
Resolving dependencies...
The following packages have been kept back:
 phonon-backend-gstreamer-common{a}
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

> and if it's any different also from "full-upgrade"?

Yes, quite different:

~# aptitude full-upgrade phonon-backend-gstreamer-common
The following packages will be REMOVED:
 phonon-backend-gstreamer-common{u}
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 38.9 kB will be freed.
The following packages have unmet dependencies:
phonon-backend-gstreamer : Depends: phonon-backend-gstreamer-common (=
4:4.9.1-1) but it is not going to be installed
The following actions will resolve these dependencies:

    Remove the following packages:
1)     jovie [4:16.08.0-1+b1 (now)]
2)     kde-runtime [4:17.08.3-2.1 (now)]
3)     kopete [4:17.08.3-2.1 (now)]
4)     phonon [4:4.10.3-2 (now)]
5)     phonon-backend-gstreamer [4:4.9.1-1 (now)]

    Leave the following dependencies unresolved:
6)     kdelibs5-plugins recommends kde-runtime
7)     libkopete4 recommends kopete (= 4:17.08.3-2.1)



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

    Keep the following packages at their current version:
1)     phonon-backend-gstreamer-common [4:4.9.1-1 (now)]



Accept this solution? [Y/n/q/?] n

*** No more solutions available ***


And this is the apt output:

~# apt install phonon-backend-gstreamer-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
 espeak-ng-data festival festival-freebsoft-utils festlex-cmu
festlex-poslex festvox-kallpc16k icoutils kate-data katepart
kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools
kmouth libattica0.4 libbctoolbox1 libbzrtp0 libdbusmenu-qt2
libdotconf0 libespeak-ng1 libestools2.5 libgadu3 libgpgme++2v5
libilmbase23 libkabc4 libkactivities6 libkatepartinterfaces4
libkcmutils4 libkde3support4 libkdeclarative5 libkdesu5 libkdeui5
libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkio5
libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4 libkmime4
libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkopete4
libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkpty4
libkresources4 libkrosscore4 libktexteditor4 libmeanwhile1
libmediastreamer-base10 libmediastreamer-voip10 libntrack-qt4-1
libntrack0 libopenexr23 libortp13 libotr5 libpcaudio0 libphonon4
libplasma3 libpolkit-qt-1-1 libqca2 libqca2-plugins libqimageblitz4
libqjson0 libqt4-opengl libqt4-qt3support libqtwebkit4 libsolid4
libsonic0 libspeechd2 libthreadweaver4 libutempter0
ntrack-module-libnl-0 oxygen-icon-theme plasma-scriptengine-javascript
sound-icons speech-dispatcher speech-dispatcher-audio-plugins
speech-dispatcher-espeak-ng speech-dispatcher-festival
Use 'apt autoremove' to remove them.
Suggested packages:
 phonon-backend-gstreamer phonon4qt5-backend-gstreamer
The following packages will be REMOVED:
 jovie kde-runtime kopete phonon phonon-backend-gstreamer
The following packages will be upgraded:
 phonon-backend-gstreamer-common
1 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
Need to get 13.9 kB of archives.
After this operation, 32.2 MB disk space will be freed.
Do you want to continue? [Y/n]

I hope all these info helps

Thank you.

Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Luigi Toscano
Miguel A. Vallejo ha scritto:

> Hi
>
>> I don't have that problem on my Sid box.
>> Can you share the output/result of
>> "aptitude safe-upgrade phonon-backend-gstreamer-common" ?
>
> Here it is:
>
> ~# aptitude safe-upgrade phonon-backend-gstreamer-common
> Resolving dependencies...
> The following packages have been kept back:
>  phonon-backend-gstreamer-common{a}
> No packages will be installed, upgraded, or removed.
> 0 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
> Need to get 0 B of archives. After unpacking 0 B will be used.
>
>> and if it's any different also from "full-upgrade"?
>
> Yes, quite different:
>
> ~# aptitude full-upgrade phonon-backend-gstreamer-common
> The following packages will be REMOVED:
>  phonon-backend-gstreamer-common{u}
> 0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> Need to get 0 B of archives. After unpacking 38.9 kB will be freed.
> The following packages have unmet dependencies:
> phonon-backend-gstreamer : Depends: phonon-backend-gstreamer-common (=
> 4:4.9.1-1) but it is not going to be installed
> The following actions will resolve these dependencies:
>
>     Remove the following packages:
> 1)     jovie [4:16.08.0-1+b1 (now)]
> 2)     kde-runtime [4:17.08.3-2.1 (now)]
> 3)     kopete [4:17.08.3-2.1 (now)]
> 4)     phonon [4:4.10.3-2 (now)]
> 5)     phonon-backend-gstreamer [4:4.9.1-1 (now)]
>
>     Leave the following dependencies unresolved:
> 6)     kdelibs5-plugins recommends kde-runtime
> 7)     libkopete4 recommends kopete (= 4:17.08.3-2.1)
>

It simply removes the remaining Qt 4 applications.

Try to install phonon-backend-vlc, and then upgrade.

--
Luigi

Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Helge Reimer
In reply to this post by Diederik de Haas-2
Am Dienstag, 12. November 2019, 22:38:40 CET schrieb Diederik de Haas:
> On dinsdag 12 november 2019 20:47:19 CET Miguel A. Vallejo wrote:
> > I noticed that phonon-backend-gstreamer-common have been keep back
> > since several weeks ago in Sid. If I try to update it manually apt
> > wants to remove the entire KDE.

Same issue here.

> I don't have that problem on my Sid box.
> Can you share the output/result of
> "aptitude safe-upgrade phonon-backend-gstreamer-common" ?
> and if it's any different also from "full-upgrade"?

In my case the output of "aptitude safe-upgrade phonon-backend-gstreamer-
common" is:

phonon-backend-gstreamer-common{a}
Die folgenden Pakete werden ENTFERNT:
  guile-2.2-libs{u} libgtkglext1{u} libkf5kdegames7{u} libtss2-udev{u} linux-
compiler-gcc-8-x86{u} linux-headers-5.2.0-3-amd64{u} linux-headers-5.2.0-3-
common{u} linux-kbuild-5.2{u} python3-icu{u}
0 Pakete aktualisiert, 0 zusätzlich installiert, 9 werden entfernt und 2 nicht
aktualisiert.

"aptitude full-upgrade" says:

Die folgenden Pakete werden ENTFERNT:              
  guile-2.2-libs{u} libgtkglext1{u} libkf5kdegames7{u} libtss2-udev{u} linux-
compiler-gcc-8-x86{u} linux-headers-5.2.0-3-amd64{u} linux-headers-5.2.0-3-
common{u} linux-kbuild-5.2{u} python3-icu{u}
Die folgenden Pakete werden aktualisiert:
  phonon-backend-gstreamer-common phonon4qt5-backend-gstreamer
2 Pakete aktualisiert, 0 zusätzlich installiert, 9 werden entfernt und 0 nicht
aktualisiert.
147 kB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden
106 MB frei werden.
Die folgenden Pakete haben verletzte Abhängigkeiten:
 phonon-backend-gstreamer : Hängt ab von: phonon-backend-gstreamer-common (=
4:4.9.1-1) but 4:4.10.0-1 is to be installed
Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Entfernen der folgenden Pakete:                        
1)     kaccessible [4:17.08.3-1 (now)]                      
2)     kde-runtime [4:17.08.3-2.1 (now)]                    
3)     phonon [4:4.10.3-2 (now)]                            
4)     phonon-backend-gstreamer [4:4.9.1-1 (now)]          

     Leave the following dependencies unresolved:          
5)     kdeaccessibility empfiehlt kaccessible (>= 4:17.08.3)
6)     kdelibs5-plugins empfiehlt kde-runtime

--
Gruß
Helge


Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Miguel A. Vallejo
In reply to this post by Luigi Toscano
> Try to install phonon-backend-vlc, and then upgrade.

It's already installed

Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Luigi Toscano
Miguel A. Vallejo ha scritto:
>> Try to install phonon-backend-vlc, and then upgrade.
>
> It's already installed
>

What if you manually do:

apt-get install phonon-backend-gstreamer-common phonon phonon-backend-vlc
?


In any case it's just removing a few Qt4 applications and libraries, which you
don't need anyway (apart maybe from kopete).

Ciao
--
Luigi

Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Miguel A. Vallejo
> What if you manually do:
>
> apt-get install phonon-backend-gstreamer-common phonon phonon-backend-vlc
> ?

~# apt-get install phonon-backend-gstreamer-common phonon
phonon4qt5-backend-vlc
Reading package lists... Done
Building dependency tree
Reading state information... Done
phonon4qt5-backend-vlc is already the newest version (0.11.1-1).
phonon is already the newest version (4:4.10.3-2).
phonon set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 phonon-backend-gstreamer : Depends: phonon-backend-gstreamer-common
(= 4:4.9.1-1) but 4:4.10.0-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.


> In any case it's just removing a few Qt4 applications and libraries, which you
> don't need anyway (apart maybe from kopete).

Removed Kopete and some programs, but still there are problems:



apt-get install phonon-backend-gstreamer-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
 espeak-ng-data festival festival-freebsoft-utils festlex-cmu
festlex-poslex festvox-kallpc16k icoutils kate-data katepart
kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools
kmouth libattica0.4 libdbusmenu-qt2 libdotconf0 libespeak-ng1
libestools2.5 libgpgme++2v5 libilmbase23 libkactivities6
libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5
libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4
libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4
libkrosscore4 libktexteditor4 libntrack-qt4-1 libntrack0 libopenexr23
libpcaudio0 libphonon4 libplasma3 libpolkit-qt-1-1 libqca2
libqca2-plugins libqt4-opengl libqt4-qt3support libqtwebkit4 libsolid4
libsonic0 libspeechd2 libthreadweaver4 libutempter0
ntrack-module-libnl-0 oxygen-icon-theme plasma-scriptengine-javascript
sound-icons speech-dispatcher speech-dispatcher-audio-plugins
speech-dispatcher-espeak-ng speech-dispatcher-festival
Use 'apt autoremove' to remove them.
Suggested packages:
 phonon-backend-gstreamer phonon4qt5-backend-gstreamer
The following packages will be REMOVED:
 jovie kde-runtime phonon phonon-backend-gstreamer
The following packages will be upgraded:
 phonon-backend-gstreamer-common
1 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
Need to get 13.9 kB of archives.
After this operation, 12.2 MB disk space will be freed.
Do you want to continue? [Y/n]


He wants to remove kde-runtime and phonon itself.

Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Diederik de Haas-2
In reply to this post by Miguel A. Vallejo
On dinsdag 12 november 2019 23:18:36 CET Miguel A. Vallejo wrote:

> The following packages have unmet dependencies:
> phonon-backend-gstreamer : Depends: phonon-backend-gstreamer-common (=
> 4:4.9.1-1) but it is not going to be installed
> The following actions will resolve these dependencies:
>
>     Remove the following packages:
> 1)     jovie [4:16.08.0-1+b1 (now)]
> 2)     kde-runtime [4:17.08.3-2.1 (now)]
> 3)     kopete [4:17.08.3-2.1 (now)]
> 4)     phonon [4:4.10.3-2 (now)]
> 5)     phonon-backend-gstreamer [4:4.9.1-1 (now)]
>
>     Leave the following dependencies unresolved:
> 6)     kdelibs5-plugins recommends kde-runtime
> 7)     libkopete4 recommends kopete (= 4:17.08.3-2.1)
As Luigi already indicated, you have old cruft (QT4) installed and you should
get rid of them.
The easiest way is to say Yes to the above suggestion.
And then install phonon4qt5-backend-gstreamer, which will then also upgrade
phonon-backend-gstreamer-common

HTH

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Diederik de Haas-2
On dinsdag 12 november 2019 23:42:35 CET Diederik de Haas wrote:
> As Luigi already indicated, you have old cruft (QT4) installed and you
> should get rid of them.
> The easiest way is to say Yes to the above suggestion.
> And then install phonon4qt5-backend-gstreamer, which will then also upgrade
> phonon-backend-gstreamer-common

And I forgot the most important part:
do it with aptitude!

As you noticed, apt/apt-get is not so smart and happily removes your whole
system. Aptitude has a powerful dependency resolver and you've just witnessed
that.

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Diederik de Haas-2
In reply to this post by Miguel A. Vallejo
On dinsdag 12 november 2019 23:18:36 CET Miguel A. Vallejo wrote:

> The following packages were automatically installed and are no longer
> required: espeak-ng-data festival festival-freebsoft-utils festlex-cmu
> festlex-poslex festvox-kallpc16k icoutils kate-data katepart
> kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools
> kmouth libattica0.4 libbctoolbox1 libbzrtp0 libdbusmenu-qt2
> libdotconf0 libespeak-ng1 libestools2.5 libgadu3 libgpgme++2v5
> libilmbase23 libkabc4 libkactivities6 libkatepartinterfaces4
> libkcmutils4 libkde3support4 libkdeclarative5 libkdesu5 libkdeui5
> libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkio5
> libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4 libkmime4
> libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkopete4
> libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkpty4
> libkresources4 libkrosscore4 libktexteditor4 libmeanwhile1
> libmediastreamer-base10 libmediastreamer-voip10 libntrack-qt4-1
> libntrack0 libopenexr23 libortp13 libotr5 libpcaudio0 libphonon4
> libplasma3 libpolkit-qt-1-1 libqca2 libqca2-plugins libqimageblitz4
> libqjson0 libqt4-opengl libqt4-qt3support libqtwebkit4 libsolid4
> libsonic0 libspeechd2 libthreadweaver4 libutempter0
> ntrack-module-libnl-0 oxygen-icon-theme plasma-scriptengine-javascript
> sound-icons speech-dispatcher speech-dispatcher-audio-plugins
> speech-dispatcher-espeak-ng speech-dispatcher-festival
> Use 'apt autoremove' to remove them.
I always get very suspicious when I see such a large list, but it looks like
you have quite a lot of cruft on your system.
I don't know if "Debian Package Tracker" is a Web Shortcuts which is part of a
normal installation or if I have added it manually myself.
The "Shortcut URL:" is "https://tracker.debian.org/pkg/\{@}"

Using that, you can easily select each package name and then look it up in
"tracker.debian.org" and see what the status is. If you see "Removed <version>
from unstable" and/or "<package> REMOVED from testing", then you should get
rid of it in most cases.
This will take some time, but IMO is time well spend.


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Miguel A. Vallejo
Well, removed Kopete, some QT4 libs and KDE broke. Fortunately I was
able to restore it with some few apt-get install/remove

Everything seems to work now. I didn't realize the problem was QT4.

Thank you!

Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Helge Reimer
In reply to this post by Miguel A. Vallejo
Am Dienstag, 12. November 2019, 23:18:36 CET schrieb Miguel A. Vallejo:

>     Remove the following packages:
> 1)     jovie [4:16.08.0-1+b1 (now)]
> 2)     kde-runtime [4:17.08.3-2.1 (now)]
> 3)     kopete [4:17.08.3-2.1 (now)]
> 4)     phonon [4:4.10.3-2 (now)]
> 5)     phonon-backend-gstreamer [4:4.9.1-1 (now)]

In my case kaccessible, kde-runtime, phonon-backend-gstreamer and phonon has
been removed. There is no more installation canditate available anymore.

phonon-backend-gstreamer-common phonon4qt5-backend-gstreamer has been upgraded
and everything is fine again.


--
Gruß
Helge


Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Martin Steigerwald
In reply to this post by Miguel A. Vallejo
Miguel A. Vallejo - 13.11.19, 00:21:04 CET:
> Well, removed Kopete, some QT4 libs and KDE broke. Fortunately I was
> able to restore it with some few apt-get install/remove
>
> Everything seems to work now. I didn't realize the problem was QT4.

In case you need kopete, you can try to install the version from
experimental. Here it is co-installable with the latest phonon in Debian
Sid as of today.

But interestingly enough, kopete only appears to be available in
experimental anyway:

% LANG=en apt policy kopete
kopete:
  Installed: 4:18.08.3-1
  Candidate: 4:18.08.3-1
  Version table:
 *** 4:18.08.3-1 200
        200 http://ftp.de.debian.org/debian experimental/main amd64
Packages
        100 /var/lib/dpkg/status

Currently I do not really have an idea where KDE project is heading with
instant messaging. KDE Telepathy does not appear to receive any
development anymore. And as for Kopete… I do not hear much as well. At
the same time kaidan is not yet ready.

But regarding Jabber clients it is a mess on Linux anyway, if you ask
me.

Thanks,
--
Martin


Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Andrey Rahmatullin-3
In reply to this post by Diederik de Haas-2
On Wed, Nov 13, 2019 at 12:01:51AM +0100, Diederik de Haas wrote:
> I don't know if "Debian Package Tracker" is a Web Shortcuts which is part of a
> normal installation or if I have added it manually myself.
> The "Shortcut URL:" is "https://tracker.debian.org/pkg/\{@}"
>
> Using that, you can easily select each package name and then look it up in
> "tracker.debian.org" and see what the status is. If you see "Removed <version>
> from unstable" and/or "<package> REMOVED from testing", then you should get
> rid of it in most cases.
Just use apt-show-versions, filtering by "No available version in archive".

--
WBR, wRAR

signature.asc (911 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: phonon-backend-gstreamer-common has been kept back

Diederik de Haas-2
On woensdag 13 november 2019 11:39:08 CET Andrey Rahmatullin wrote:

> On Wed, Nov 13, 2019 at 12:01:51AM +0100, Diederik de Haas wrote:
> > I don't know if "Debian Package Tracker" is a Web Shortcuts which is part
> > of a normal installation or if I have added it manually myself.
> > The "Shortcut URL:" is "https://tracker.debian.org/pkg/\{@}"
> >
> > Using that, you can easily select each package name and then look it up in
> > "tracker.debian.org" and see what the status is. If you see "Removed
> > <version> from unstable" and/or "<package> REMOVED from testing", then
> > you should get rid of it in most cases.
>
> Just use apt-show-versions, filtering by "No available version in archive".
That's indeed useful to quickly identify the cruft :)

Still, it doesn't show even close the amount of information that I get through
tracker.d.o. (I've become a big fan of t.d.o)

https://tracker.debian.org/pkg/kopete shows me the following:
Versions that are present in o-o-stable, oldstable, stable, experimental (thus
not in testing or sid). In the 'news' section I can click on the link
"Removed 4:17.08.3-2.1 from unstable" which tells me:
------------------- Reason -------------------
RoQA; Obsolete libs - Qt4
----------------------------------------------
and a link to https://bugs.debian.org/935659 and that bug tells me:
"The current unstable version is Qt4.  There is a Qt5 version in
experimental, but the maintainer has not yet concluded it's appropriate
to include in a future release.  Once the Qt5 version is ready, it can
be uploaded to unstable to re-introduce the package.  In the meantime,
it doesn't make sense to block further progress on removing Qt4."

So now I know that kopete was removed because its using Qt4 and that that is
apparently (and rightfully) considered obsolete. If you do the t.d.o thing a
number of times you'd likely/rightfully concluded that all Qt4 apps/libs are
removed from the unstable/testing archives. You can/should conclude that maybe
you ought to remove those as well.
In the case of kopete you'd have also learned that there is a version in
experimental which uses Qt5 and that the maintainer currently thinks it is
unsuitable to end up in a next stable release. This could change in the future
and you could decide for yourself to help with that by installing the version
from experimental anyway and reporting bugs if you encounter them. Ofc all the
caveats of experimental applies and also the warning by the maintainer in this
specific case. In any case, you have enough info to make an informed decision.


signature.asc (849 bytes) Download Attachment