sid dist-upgrade has hosed gnome :(

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

sid dist-upgrade has hosed gnome :(

Tom Cook
Hi all,

I recently (last week) did a dist-upgrade on a sid system and had heaps of trouble from it.  The worst was that udev didn't work right, so I didn't get most devices, but that's now fixed.  But now...

gdm does not start correctly.  Xorg starts fine, and shows the grey-brown background thingy it always does, with the black cross mouse pointer (which can move) but gdm never appears.  xdm works fine, but gdm does nothing.  I have tried this both with gdmgreeter and gdmlogin.

When I login with xdm, the keyboard does not work - or rather doesn't work very much.  Keystrokes don't get through to some applications.  The WM (metacity) seems to get the events OK, because I can switch desktops, alt-tab between windows, close windows using keyboard shortcuts etc, but applications seem to miss many keystrokes.  For instance, when I start gnome-terminal nothing I type appears at the command prompt, and I can't access the menus using keyboard shortcuts.  The keyboard does work in nautilus, except for when the focus is in the location bar, and then it doesn't work. 1.1.4 does seem to work OK.

I have tried moving .gconf, .gconfd, .gnome, .gnome2, .gnome-desktop out of the way, but that made no difference.

Another problem I'm having is that when I click on the Applications menu, the content appears for a very brief moment (< 0.2 seconds) and then goes again.  This is making it hard to check which applications receive events and which don't.

Lastly, geda seems to crash whenever I choose New or Open from the Project menu.

Does anyone have any hints on tracking these down?